Haz una pregunta
  Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

16/08/2007 #1


conexion del cny70 con un schmitt trigger
hola a todos, tengo un problema, a la hora de conectar mi sensor CNY70 al Schmitt trigger (HCF40106B) me sale +5v en la salida todo el tiempo, parece que no detecta la pequeña señal del CNY70.


aqui les adjunto la imagen de mi conexion, espero me den su opinion.
(elegi esta configuracion porque pense que era muy sencilla pero ya veo que no )
17/08/2007 #2


es normal que siempre el cny70 te de un voltaje muy bajo menor a 1v???
17/08/2007 #3


Su salida es un transistor. Cuando conduce tiene la caida Vce (ver datashett) cuando es infinito teorico.

Saludos
18/08/2007 #4


Disculpa mi ignorancia, pero no entiendo muy bien que es lo que me quieres decir.
Debo conectar un transistor? O_o
18/08/2007 #5
Moderador general

Avatar de Fogonazo

Intenta aumentando la resistencia de 47 KOms a 220 KOms.

El Nombre te habla de la caida interna del foto-transistor en saturacion (Refleccion maxima= Conduccion plena) y su resistencia en el modo corte (Oscuridad total).

Recuerda que la refleccion se produce a muy corta distancia y una mejor o peor reflectividad te cambia la tension de salida.

¿ Por que en tu esquema figuran 2 optos ?
19/08/2007 #6


mira yo estoy haciendo un proyecto final para el colegio , que es un robot autónomo, y estoy utilizando los sensores cny70, y encontre un circuito en internet que funciona perfectamente.

saludos y suerte... espero que te sirva, yo lo probe y anda a la perfección.

http://www.x-robotics.com/sensores.htm
19/08/2007 #7


El que envia el promotor del hilo tambien funciona y es mucho más económico.
27/10/2007 #8


Hola Amigos Del Foro,
Yo Utilizo Esos Sensores Pero Con Las Resistencias Al Lado Positivo Y La Linea Que Sale Del Colector A La Resistencia De 47k La Envio A Un Inversor 74LS14 Y De Ahy La Paso A La Pata Del Pic, Usualmente Que Utilizo Es El 16F84A.

Utilizo El 7414 Para Codificar Los Pulsos Bajos Y Altos.

Si No Saben Como Conectarlo, Aunque Lo Dudo Estas Son Las Patas.
Imágenes Adjuntas
Tipo de Archivo: jpg cny70_147.jpg (28,9 KB (Kilobytes), 3180 visitas)
29/10/2007 #9


Gracias por la explicacion.
04/11/2007 #10


cx
ke buenas respuestas
12/04/2008 #11


Hacer cambio
Veo su explicacion y le logro entender, pero quisiera saber si se puede aplicar igual con un QRD1114, por que yo ya no pude conseguir CNY70, esa es mi duda, ojala alguien me pudiera responder, gracias
02/05/2008 #12

Avatar de 20deoctubre

Muchicimas gracias Alejo GS tu conexión del sensor me resulto completamente exitosa.
03/05/2008 #13

Avatar de 20deoctubre

Bueno en principio totalmente exitosa. Lo que paso fue que con la pura salida del sensor si me daba el nivel logico bajo y el alto para la configuración que utilice.
El problema vino cuando quise conectarle una carga como un led para probarlo, no funciono :( . El voltaje que le llegaba al led variaba entre dos y un volt (ningun nivel logico comun) y el LED nunca encendio ni se apago. Me paso igual al intentar conectarlo al 74HC14 y pues supongo que pasara lo mismo si lo conecto a la GAL22V10 que planeo utilizar para el control de los motores (hasta con un cablesillo comun el voltaje se me cayo hasta 2 volts)
Ojala alguien se apiade de mi y me ayude... desde ya gracias
16/07/2009 #14


la impedancia del 74LS14 es muy baja, no funciona muy bien y tiene mucho ruido es mejor usar un lm358 como comparador
17/07/2009 #15


yo he usado 7414s con un arreglo similar al mostrado, sin embargo, como se menciona tambien antes, es más facil conectar el opto a tierra y a la entrada que usar el opto como el lado positivo.

Una forma de darse idea de si funciona o no, es medir el voltaje en la el punto medio entre el opto y la resistencia tapando el opto y luego iluminandolo con una lampara (no se preocupen, las resistencias dan tambien luz "inflaroja"), se debe registrar una caida de voltaje en algúna condicion, y hay que ver si el cambio de voltaje es suficiente para que marque un valor fijo en el integrado que alimentan, si no mal recuerdo, un 7414 necesita voltajes superiores a los 3 volts para tomarlo como un 1 y voltajes menores a 1.4 como un 0, cualquier cosa intermedia puede dar cualquier resultado, lo que no es bueno.
19/08/2009 #16


Pwm necesario?
buenas amigos miren emprendo la asaña de un seguidor de linea, y pues mi duda surge si con la configuracion que uds mencionar y enviado pulsos detectables para el pic, no es necesario la etapa pwm en el codigo del pic, o si es necesario y alguien tiene una para el control de la velocidad de motores agradeceria su ayuda....
21/08/2009 #17


no entendi lo que quieres.
el PWM se suele usar para controlar la velocidad de un motor, si tienes un sensor infrarojo como el CNY 70 no necesitas darle un tren de pulsos, un par de resistencias y listo, tu sensor produce una señal que puede ser interpretada por el PIC.
El PIC se me hace un tanto exagerado para un seguidor de linea, puedes hacerlo con un L293D (control de motores) y un 7414
para procesar las señales, el 7414 es un inversor schmitt trigger, lo que hace que no tartamudee.
21/08/2009 #18


karl dijo:
no entendi lo que quieres.
el PWM se suele usar para controlar la velocidad de un motor, si tienes un sensor infrarojo como el CNY 70 no necesitas darle un tren de pulsos, un par de resistencias y listo, tu sensor produce una señal que puede ser interpretada por el PIC.
El PIC se me hace un tanto exagerado para un seguidor de linea, puedes hacerlo con un L293D (control de motores) y un 7414
para procesar las señales, el 7414 es un inversor schmitt trigger, lo que hace que no tartamudee.
amigo gracias por tu respuesta, pero es que es obligacion usar el pic en este proyecto, y pues ahorita lo que tengo es que de la salida de mi sensor lo mando a un puerto del pic(uso 2 sensores), y el control de motores con el l293d, pero en los pines 1,2 que es respecto al control del primer motor que le conectaria? porque ahi tengo entendido que es donde recibe la señal pwm.....pero si no la quiero usar que conectaria? y el 7414 es para que siga una velocidad constante vrdd? y el 7414 ese si no entiendo donde lo conectaria? a la salida de mis sensores he visto una configuracion pero nose si a eso te refieres....
03/06/2010 #19

Avatar de oberol26

Respuesta: conexion del cny70 con un schmitt trigger
Alejo GS dijo: Ver Mensaje
Hola Amigos Del Foro,
Yo Utilizo Esos Sensores Pero Con Las Resistencias Al Lado Positivo Y La Linea Que Sale Del Colector A La Resistencia De 47k La Envio A Un Inversor 74LS14 Y De Ahy La Paso A La Pata Del Pic, Usualmente Que Utilizo Es El 16F84A.

Utilizo El 7414 Para Codificar Los Pulsos Bajos Y Altos.

Si No Saben Como Conectarlo, Aunque Lo Dudo Estas Son Las Patas.
Me haz salvado la existencia! ja! estuve luchando X poder configurarlo y aki halle la respuesta GRACIAS!! si te conociera te invitaba unas chelas! jajaa!
21/01/2012 #20

Avatar de Barrero0717

Hola a todos..
tengo un problema con la utilizacion de este sensor con el 74LS14...
Se supone que con valores menores que 1.4V, el 74LS14 reconoce eso como un 0, y cuando utilizo el sensor CNY70 alcanza a llegar 0.8V a la entrada del inversor pero a su salida siguen habiendo 0V...
He mirado el integrado y esta en perfecto estado porque me funciona con un fotodiodo receptor infrarrojo...

Cual puede ser el problema???
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Robótica, Domótica y Mecatrónica

La electrónica Aplicada a la Robótica y sus técnicas de interface.

Cerrar
Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.