Haz una pregunta
  Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

14/02/2011 #1


Control de camara PTZ Pelco-D/P
Buenas personal,

Estoy implementando un sistema de control mediante protocolo Pelco-D o Pelco-P, el modelo de la camara es el siguiente "eneo edmc-2221".

El sistema final constaría de una interfaz de usuario (PC), una ARM M3 para hacer el sistema de control y por ultimo la camara.

El sistema de prueba actual consta de mi portatil y un cable convertidor USB->RS-485 conectando la camara y el PC.

Bien, aqui esta mi gran problema, configuro los switch de la camara para pelco-d con Baud Rate de 9600. Enciendo la camara, hace la calibración sola, una vez que la camara termina con la calibración, comienzo a enviar las tramas con las acciones, desde un programa hecho en visual c++ 6.0, con la misma configuración que la camara. Aqui esta el gran problema, no siempre hace las acciones, es mas casi nunca hace las acciones, por ejemplo, le mando las acciones una cada segundo, y de cada 20 acciones que le envio solo hace 5. Y cuando configuro para Pelco-P quizas mejora un poco mas. Pero necesito que la camara reaccione a todas las acciones que le envie, para poder tener el control correcto.

Entonces, que es lo que sucede?? las tramas estan correctamente enviadas. Necesito enviar primero alguna trama de inicialización para que la camara reaccione a todas mis acciones. O puedo enviar las acciones directamente sin inicializar nada??

Muchisimas gracias por su atencion,,

Saludos desde Porto,
14/02/2011 #2

Avatar de Unikfriend

Hi Butxes...

Supongo que cuando utilizas el joystick funciona bien,
y si te conectas por el RS232 sin utilizar el RS485 funciona?

pudiera ser problema del USB, intenta utilizando un PC que cuenta con puerto serial.

Saludos.
14/02/2011 #3


Unikfriend dijo: Ver Mensaje
Hi Butxes...

Supongo que cuando utilizas el joystick funciona bien,
y si te conectas por el RS232 sin utilizar el RS485 funciona?

pudiera ser problema del USB, intenta utilizando un PC que cuenta con puerto serial.

Saludos.
Hola,

Lo primero muchas gracias por la respuesta, se agradece mucho.

Lo segundo, con el joystick funciona bien, pero el problema del joystick esq solo funciona con protocolo fastrax-II, entones tengo q cambiar los switch de la camara a fastrax-II y funciona correctamente. Pero el joystick no funciona en otro protocolo, y cuando cambio todas las configuraciones a Pelco-d o Pelco-p y uso mi programa u otros la camara no reacciona ante todos los envios, solo algunas veces.

Esta camara funciona con RS-485 por lo tanto la señal debe ser diferencial, y RS-232 no me vale. Por ahora no dispongo de ordenador con puerto serial.

Si se te ocurre o a alguien se le ocurre alguna solucion, por favor indicarla

Muchisimas gracias por su atención,,
15/02/2011 #4

Avatar de Unikfriend

Hi,
cuando utilizas el software que viene con la camara conectado por USB y RS485,
la puedes comunicar sin ningun problema?
20/02/2011 #5


Unikfriend dijo: Ver Mensaje
Hi,
cuando utilizas el software que viene con la camara conectado por USB y RS485,
la puedes comunicar sin ningun problema?

Buenas,,

Muchas gracias por tu interes,

Cuando utilizo el software bajado oficial de pelco-d/p y con otro software llamado PTZ-Controller, hace practicamente lo mismo, de todas las acciones enviadas muy pocas son ejecutadas.

Entonces mi pregunta es la siguiente, una vez conectada la camara y despues de hacer la calibracion ella sola automaticamente, tengo q enviarle alguna trama en especial para que trabaje?? o ya deberia funcionar las acciones de left, right, up, down, etc, enviando solo la trama de las acciones???

Saludos Urko
20/02/2011 #6

Avatar de Kebra

Butxes dijo: Ver Mensaje
Buenas,,

Muchas gracias por tu interes,

Cuando utilizo el software bajado oficial de pelco-d/p y con otro software llamado PTZ-Controller, hace practicamente lo mismo, de todas las acciones enviadas muy pocas son ejecutadas.

Entonces mi pregunta es la siguiente, una vez conectada la camara y despues de hacer la calibracion ella sola automaticamente, tengo q enviarle alguna trama en especial para que trabaje?? o ya deberia funcionar las acciones de left, right, up, down, etc, enviando solo la trama de las acciones???

Saludos Urko
Tenés una placa GV-NET como para salir de dudas? Digo, capaz que la cámara está funcionando mal, o el ID de la cámara no sea el correcto. Podés cambiarle el protocolo a la cámara?
A mi me pasó con unos domos LG 903 y una Geo 800 que no andaba ni por casualidad, hasta que me di cuenta que el ID 0 que viene por defecto en el domo, en la Geo no existía, arrancaba en 1, y tuve que cambiarle el ID. Es una tontería, pero estuve renegando dos días hasta que me dí cuenta.
21/02/2011 #7


Kebra dijo: Ver Mensaje
Tenés una placa GV-NET como para salir de dudas? Digo, capaz que la cámara está funcionando mal, o el ID de la cámara no sea el correcto. Podés cambiarle el protocolo a la cámara?
A mi me pasó con unos domos LG 903 y una Geo 800 que no andaba ni por casualidad, hasta que me di cuenta que el ID 0 que viene por defecto en el domo, en la Geo no existía, arrancaba en 1, y tuve que cambiarle el ID. Es una tontería, pero estuve renegando dos días hasta que me dí cuenta.
Buenas,

Pues no tengo una placa GV-NET. Despuues las configuraciones de la camara esta bien puesta, ademas si la camara no estaria bien configurada nunca realizaria ninguna accion, o realizaria cosas al azar, pero ese no es mi problema. mi problema es q no siempre realiza las acciones, y me gustaria saber si con los protocolos pelco hay que mandar alguna trama primero antes de enviar alguna accion. He estao mirando en internet y parece q no es necesaria, que solo con enviar las tramas de las acciones es suficiente,,

Muchas gracias por vuestra atencion,,,
25/04/2011 #8


hi dude, te recomiendo que bajes el programa 232-analyzer , solo para que pruebes la camara, si la camara funciona correctamente con este programa desde el puerto USB-RS485 entonces es algun problema con tu programa, puede ser en la inicializacion yo hice un control para una camara PTZ pelco D 2400BR.. y tube problemas con la comunicacion, 1ero hay que mandar las tramas desde el valor menos significativo hasta el mas significativo, incluyendo la direccion de la camara.. es posible que no estes mandando el byte de inicializacion para cada trama que es XFF... bueno, primero prueba con el 232-analizer si te funciona vuelvo y te repito es problema en como estas mandando los datos , si me mandas el codigo es posible que pueda ayudarte mejor,.. saludos

actualmente estoy haciendo una camara autotracking que va a seguir un objeto que se mueva con un color especifico... lo estoy haciendo el ubunto, ya hice el codigo de tracking espacial en el plano imagen , solo me falta mandarle los comandos a la camara para que se mueva en una u otra direccion, mi problema es, que nose como mandar datos seriales en ubuntu :s he buscado informacion pero no he logrado mandar la primera trama por el puerto serial (USB-RS485) ... SI ALGUIEN sabe como mandar datos seriales y me lo facilite please ayudenme..
25/04/2011 #9


Buenas Aldo,

El programa 232-analyzer y el PTZ-controller, ya los he utilizado pero no me funcionan correctamente.
27/04/2011 #10


saludos butxes,
esta la posibilidad de que tu camara tenga problemas (aunque lo dudo) entre al datasheet de la camara y en
"Serial interfaces" dice RS-485, 9600Baud, 63 camera ID adresses selectable.
Besides the keyboard control via the eneo EDC-KBD(M)
series, the control via matrix, switchers and keyboards
with Pelco P&D protocol is possible.

intenta variando esos switches, aunque me imagino que ya lo hiciste, si no , no se , quisiera ayudarte, pero no se que mas se me ocurre...
http://www.sourcesecurity.com/techni...edmc-2221.html
27/04/2011 #11


Muchas gracias por la respuesta, pero me parece q ni asi,,,
29/07/2012 #12


Butxes dijo: Ver Mensaje
Buenas personal,

Estoy implementando un sistema de control mediante protocolo Pelco-D o Pelco-P, el modelo de la camara es el siguiente "eneo edmc-2221".

El sistema final constaría de una interfaz de usuario (PC), una ARM M3 para hacer el sistema de control y por ultimo la camara.

El sistema de prueba actual consta de mi portatil y un cable convertidor USB->RS-485 conectando la camara y el PC.

Bien, aqui esta mi gran problema, configuro los switch de la camara para pelco-d con Baud Rate de 9600. Enciendo la camara, hace la calibración sola, una vez que la camara termina con la calibración, comienzo a enviar las tramas con las acciones, desde un programa hecho en visual c++ 6.0, con la misma configuración que la camara. Aqui esta el gran problema, no siempre hace las acciones, es mas casi nunca hace las acciones, por ejemplo, le mando las acciones una cada segundo, y de cada 20 acciones que le envio solo hace 5. Y cuando configuro para Pelco-P quizas mejora un poco mas. Pero necesito que la camara reaccione a todas las acciones que le envie, para poder tener el control correcto.

Entonces, que es lo que sucede?? las tramas estan correctamente enviadas. Necesito enviar primero alguna trama de inicialización para que la camara reaccione a todas mis acciones. O puedo enviar las acciones directamente sin inicializar nada??

Muchisimas gracias por su atencion,,

Saludos desde Porto,
Hola, probaste bajando la velocidad de transmicion a 2400 baudios?
01/08/2012 #13

Avatar de Kebra

Probá poner la velocidad en 2400, es la que usamos siempre para lo equipos...
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Robótica, Domótica y Mecatrónica

La electrónica Aplicada a la Robótica y sus técnicas de interface.

Cerrar
Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.