Haz una pregunta
  Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

29/04/2011 #1

Avatar de Mitzi

control de un rele de 5v con un pic
hola que tal..tengo una duda estoy desarrollando un proyecto el cual explico de algunos de mis conocimientos que tengo:
VOY A CONTROLAR 2 motores con cambio bidireccional..para ello decidi utilizar el driver l293b y para controlar el motor en algun sentido tiene 4 salidas..2 para cada motor que tengo que poner a negativo para que gire hacia una direccion y quiero controlarlos a determinado tiempo..para ello estoy ocupando el pic16f627 pero me dijeron que conectara un rele a la salida del pic pero no me da la salida del pin del pic los 5v que requiere el rele asi que quisiera una ayuda del esquema de este..e visto que ponen un transistor pero como lo conecto????porque = veo que no conectan el comun o no se muy bien,, el rele es de 5v y tiene 5 pines con las dos bobinas .el comun y los contactos na Y nO ENTONCES COMO LO CONECTO PARA QUE MI CONTACTO ABIERTO SALGA A LA SALIDA DEL DRIVER???????
14/05/2011 #2

Avatar de Mitzi

hola de nuevo pues espero que si puedan ayudarme con este tema ya avance en esto y pues ya funciona el rele con el pic pero la cuestion es que como no se mucho de pics no se que precauciones debo de tener ya que se m han quemado ya 2.....la razon es que pongo que ative el rele a determinado tiempo pero se traba ya conectandolo con el driver...no se porque y despues falla fatalmente....como le puedo hacer????

al rele le e conectado un transistor y un diodo para la bobina pero talvez fallla esto ya que no se desactiva o eso creo ....alguien sabe porque ..se los agradeceria gracias
14/05/2011 #3

Avatar de johncaro12

podrias poner un esquema de tus intentos fallidos, para tratar de ver cual ha sido el problema?
14/05/2011 #4

Avatar de pandacba

el rele tiene el diodo de protección en paralleo? segundo nunca atacar elementos de potencia deirectamente por las salidad de los puertos siempre se hace una interface, ya sea con un opto, o con un transisor, en tu caso la mejor solución es un trnasitor que comande la bobina de relay con lo cual tenes la ventaja de que no neceista alimentarse con 5V si no con 12, es un error tomar la alimentación de los 5V del micro y encima no poner un diodo, ya que alli se genera picos de hasta 50 volts, y el micro QEPD!!
14/05/2011 #5




Mira espero que te sirva
En ese proyecto usamos el relevador para una etapa de potencia, prendimos una licuadora con un pic :P

Saludos
14/05/2011 #6

Avatar de pandacba

A eso me referia, perfecto! pero es recomendable que la tensión del relay se tome antes del regulador para no causara ruido ni perturbaciones al mciro
14/05/2011 #7

Avatar de Mitzi

ok muchas gracias me a servido de mucho y me funciona bien......en cuanto a este problema funciona sin problema con el pic........ je pero creo que ahora eh cometido un error con mi pic ya que despues de hacer las pruebas funcionaba bien pero al querer programarle otra cosa ya no se pudo y me salio un mensaje de que fallo la direccion de la memoria 0x00000 o algo asi ..............y de lo demas muchas gracias por el aporte ...la falla estaba en el diodo que no cumplia con su funcion como tal pero ahora esta mejor ...despues de reponer mi pic y ver lo que fallo pondre el esquema de lo que hice muchas gracias =)=)

DarkSunL dijo: Ver Mensaje


Mira espero que te sirva
En ese proyecto usamos el relevador para una etapa de potencia, prendimos una licuadora con un pic :P

Saludos
gracias gracias me a servido de mucho

solo que yo utilice el transistor bc337, resistencia de 1k
14/05/2011 #8


Que bueno que te funcionó
Y es algo extraño lo del diodo...
Me ha funcionado bien, tanto en el pic como en un integrado, solo una vez conecté el diodo al revés y fundí un led pero no pasó de ahí jaja
Saludos
15/05/2011 #9

Avatar de Mitzi

DarkSunL dijo: Ver Mensaje
Que bueno que te funcionó
Y es algo extraño lo del diodo...
Me ha funcionado bien, tanto en el pic como en un integrado, solo una vez conecté el diodo al revés y fundí un led pero no pasó de ahí jaja
Saludos
si fue extraño pero cuando se lo cambie por uno que es 1N0007 mm algo asi funciono bien

supongo que no lo conecte de manera adecuada a la primera
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Robótica, Domótica y Mecatrónica

La electrónica Aplicada a la Robótica y sus técnicas de interface.

Cerrar
Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.