Haz una pregunta
  Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

11/10/2008 #1


Dspics cuadratura de encoder
Programe la qei en ensamblador, sin embargo el poscnt solo cuenta a bajas velocidades y al subir la velocidad lo detecta como un ruido y detiene la cuenta, ya probe cambiar los filtros por unos mas bajos y no funciona nada, alguien conoce el problema?
11/10/2008 #2

Avatar de Ardogan

Fijate en la hoja de datos cual es la frecuencia máxima que admite para los canales del encoder, puede ser que estés pasado (frecuencia pulsos encoder> frecuencia máxima admitida por los pines de entrada del pic). De ser así, probá cambiando la resolución de decodificación (si lo tenés a 4X bajalo a 2X o a 1X), vas a perder resolución pero en una de esas anda.
Creo que la frecuencia admitida por el dspic estaba en función de su frecuencia de trabajo, podrías probar aumentando la frecuencia de trabajo a ver que pasa.
Saludos
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Robótica, Domótica y Mecatrónica

La electrónica Aplicada a la Robótica y sus técnicas de interface.

Cerrar
Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.