Haz una pregunta
  Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

28/11/2013 #1


Motor a pasos con L297 y TIP41C
Hola, Buenas noches.

Verán estoy en un proyecto donde me he dado a la tarea de mover un motor a pasos unipolar que consume 3A a 24V, he visto varios circuitos y he armado el de un L297 con un L298 y lo probé con un motor unipolar de bajo amperaje y funciono bien...ahora quiero poner el motor de 3A pero según la datasheet el integrado L298 solo alcanza para 2A entonces se me ocurrio poner 4 TIP41 a la salida del L297, con una resistencia de 1K a la base, el emisor a tierra y el colector a una resistencia de 330ohms en serie a cada una de las bobinas del motor; los comunes de las bobinas a 24V.
Mi sorpresa ha sido que en el motor si se siente que hay movimiento a cada paso que manda el L297 (he puesto unos leds para visualizarlo) pero solo eso, solo tiembla a duras penas pero el eje no se mueve.
He leído aquí en este foro que recomiendan MOSFET..he investigado un poco y parece que son un tipo de transistores de potencia?, la verdad es que nunca los he usado y quisiera ver si alguien me ayuda un poco de el porqué los TIP41 no sirven para este trabajo..o talvez estoy haciendo algo mal?

Saludos y muchas gracias de antemano por cualquier ayuda brindada. ...
29/11/2013 #2
Moderador general

Avatar de DOSMETROS

Sin el diagrama , tu mensaje no tiene sentido pica en "mas opciones" para subirlo al Foro.

Bienvenido al Foro !
29/11/2013 #4


Gracias por responder.

Saludos.
Archivos Adjuntos
Tipo de Archivo: pdf diagrama 3.PDF (10,3 KB (Kilobytes), 136 visitas)
29/11/2013 #5

Avatar de Gudino Roberto duberlin

Hola Amigo, bueno porque conectas resistencias de 330Ω en cada devanado del motor?.
Asi estas limitando la corriente a tal punto que impides su funcionamiento!. Calcula la corriente max. que obtienes y te daras cuenta del porque.
29/11/2013 #6


Hola Roberto, la verdad es que vi el diagrama en una pagina de internet y conecte el transistor de la misma manera, pero tienes razón no le esta llegando nada de corriente a los bobinados del motor. El otro problema es que al quitar esa resistencia mis TIP siempre están mandado 5V, los probé con unos LED (el colector lo cambie a 5V también y desconecte las bobinas ) y estos siempre estaban encendidos, alguna explicación?

Gracias. Saludos.
29/11/2013 #7

Avatar de Gudino Roberto duberlin

Bueno si los transistores conducen cuando no deben, pues no estan alcanzado el corte. Eso se debe a los umbrales de señal que entrega el L297. Busca un driver que corresponda para tu aplicacion.
29/11/2013 #8


Ya encontré mi error, ademas de la resistencia de 330, lo que pasa es que la resistencia a la base no la estaba calculando y haciendo los debidos cálculos obtengo un valor de 116.5 ohms considerando que el motor es a 24V/3A y que según la datasheet la ganancia de los TIP41 es un min de 15, ¿Estoy en lo correcto? además tengo varias preguntas..
¿El TIP41C puede conmutar a que frecuencias?--Esto lo pregunto debido a que quiero alcanzar una velocidad de algunos 3000 RPM (50Hz) y no se si el TIP41C alcance a conmutar como lo necesito.
Suponiendo que el calculo de la resistencia de 116.5 ohms es correcta...sacando la potencia de esa resistencia me da un valor de 4W para 100 ohms (comercial), entonces, ¿Necesitaría comprar resistencias de 4W para que no se sobre-calienten?

Agradezco toda la ayuda brindada, Gracias.

Saludos.
29/11/2013 #9

Avatar de Gudino Roberto duberlin

Amigo, que parametros tomaste en cuenta para que los calculos te indiquen utilizar resistencias de 4W?.
Revisa la hoja de datos del TIP41C, para corroborar la max. fcia. de conmutacion.
Respecto al motor depende de el angulo de avance y de la forma de excitar los devanados, para conocer si alcanza las revoluciones que pretendes.
29/11/2013 #10


Bueno la datasheet dice que 3MHZ, lo que esta más que perfecto, para los calculos:

IB = 3A/15 (3A del motor que va al emisor entre 15 que es la ganancia minima del TIP41C)
IB = 0.2A

Para la resistencia tenemos una malla de 24V (voltaje de la fuente para el motor) y 0.7 del transistor entonces:

RB = (24V - 0.7V)/0.2 lo que da igual a 116.5 ohms despues:

P = (0.2)^2 * 100 ohms = 4W

Hace unas horas he hecho la prueba y todo funciono muy bien, los transistores conmutaron y las resistencias a la base no se quemaran ni nada, lo que me paso ahora fue que, como no use disipador, el TIP se calentó demasiado tanto que la parte de atrás que es de un color metálico cambio casi a rojo y después le salio humo hehe.

También le he medido corriente al motor y aunque en las características dice 3A con el amperímetro me ha dado 7.2A. Supongo que tendré que cambiar esos transistores o usar MOSFET, que de estos últimos tengo la duda de cual seria el indicado debido a que nunca los he usado, aunque he leído un poco y creo entender que la característica principal es que se activa con voltaje y no tanto con corriente como el BJT, cierto?
30/11/2013 #11

Avatar de Gudino Roberto duberlin

Amigo, busca configuracion transistor MOSFET/BIPOLAR.
02/06/2015 #12


chuyosuna dijo: Ver Mensaje
Bueno la datasheet dice que 3MHZ, lo que esta más que perfecto, para los calculos:

IB = 3A/15 (3A del motor que va al emisor entre 15 que es la ganancia minima del TIP41C)
IB = 0.2A

Para la resistencia tenemos una malla de 24V (voltaje de la fuente para el motor) y 0.7 del transistor entonces:



Hola Chuyosuna,

Soy Alejandro y estuve leyendo este foro y queria saber.

Como salió todo tu proyecto? Ya que yo estoy haciendo casi lo mismo solo que mi motor es de 4A y 24v

Me podrias enviar el diagrama final de tu proyecto? Porque estoy cansando de quemar componentes jaja


Saludos
03/06/2015 #13


Supralejin1 dijo: Ver Mensaje
Hola Chuyosuna,

Soy Alejandro y estuve leyendo este foro y queria saber.

Como salió todo tu proyecto? Ya que yo estoy haciendo casi lo mismo solo que mi motor es de 4A y 24v

Me podrias enviar el diagrama final de tu proyecto? Porque estoy cansando de quemar componentes jaja


Saludos
Hola Alejandro, lamentablemente esto fue hace muchoo tiempo, no tengo los diagramas finales lo que si te puedo decir es que use MOSFET en lugar de transistores, y el resultado fue mucho mejor en todos los sentidos... Saludos!!
17/08/2015 #14


Hola que tal muchachos?
Estoy teniendo un problema con un driver que estoy haciendo para un motor pap, el driver está echo con un l297 junto con un l298(adjunto diagrama) el problema que tengo es que en las salidas ABCD del l297 obtengo 0101, y a pesar de habilitar lso enables, y mandar señales en el clock la secuencia no cambia, alguien me podra tirar alguna soga? ya medi todo en la placa y no hay cortos, ni discontinuidad en las pistas, las tensiones llegan a donde tienen que llegar, habrá algo mal en el diagrama? lo adjunto a ver si es eso, o el problema es el montaje, muchas gracias
Imágenes Adjuntas
Tipo de Archivo: png Sin título.png (152,1 KB (Kilobytes), 36 visitas)
19/08/2015 #15

Avatar de Ardogan

La pata SYNC esta sin conectar no? (veo que va al conector, pero no se sabe que está conectado al conector). Si esa pata está a GND o VCC entonces el L297 está sin señal de reloj interna. Hay que dejarla abierta.
19/08/2015 #16

Avatar de dearlana

chuyosuna dijo: Ver Mensaje
Hola, Buenas noches.

Verán estoy en un proyecto donde me he dado a la tarea de mover un motor a pasos unipolar que consume 3A a 24V, he visto varios circuitos y he armado el de un L297 con un L298 y lo probé con un motor unipolar de bajo amperaje y funciono bien...ahora quiero poner el motor de 3A pero según la datasheet el integrado L298 solo alcanza para 2A entonces se me ocurrio poner 4 TIP41 a la salida del L297, con una resistencia de 1K a la base, el emisor a tierra y el colector a una resistencia de 330ohms en serie a cada una de las bobinas del motor; los comunes de las bobinas a 24V.
Mi sorpresa ha sido que en el motor si se siente que hay movimiento a cada paso que manda el L297 (he puesto unos leds para visualizarlo) pero solo eso, solo tiembla a duras penas pero el eje no se mueve.
He leído aquí en este foro que recomiendan MOSFET..he investigado un poco y parece que son un tipo de transistores de potencia?, la verdad es que nunca los he usado y quisiera ver si alguien me ayuda un poco de el porqué los TIP41 no sirven para este trabajo..o talvez estoy haciendo algo mal?

Saludos y muchas gracias de antemano por cualquier ayuda brindada. ...
-----------------------------

Hola chuyosuna:

Ponle 4 TIP 2N3055 en circuito seguidor de emisor. Mientras la fuente de alimentación los tenga...y tengan refrigerador:

Pasarán 3 Amperios, 5 Amperios y los que hagan falta ( Máximo unos 17 Amperios en régimen de impulsos).
20/08/2015 #17


Ardogan dijo: Ver Mensaje
La pata SYNC esta sin conectar no? (veo que va al conector, pero no se sabe que está conectado al conector). Si esa pata está a GND o VCC entonces el L297 está sin señal de reloj interna. Hay que dejarla abierta.
Gracias por contestar ardogan,te cuento la pata sync esta sin conectar,hoy revisando descubrí que en realidad estaba mal conectadas una de las fases,ahora solo queda el motor clavado y vibrando,pero sigue sin darme bola el l297,sigue con la salida en 0101,aunque si funciona el pin enable,lo que me preocupa es que este mal el esquematico,de todas maneras ya estoy armando otro driver para ver si funciona,sino ya es problema de mi pcb,aunque revise todo mil veces y nada, ley de murphi.

si se te viene a la cabeza alguna otra idea te agradezco que comentes.
SALUDOS
PACIO
20/08/2015 #18

Avatar de locodelafonola

hola
pacio dijo: Ver Mensaje
Gracias por contestar ardogan,te cuento la pata sync esta sin conectar,hoy revisando descubrí que en realidad estaba mal conectadas una de las fases,ahora solo queda el motor clavado y vibrando,pero sigue sin darme bola el l297,sigue con la salida en 0101,aunque si funciona el pin enable,lo que me preocupa es que este mal el esquematico,de todas maneras ya estoy armando otro driver para ver si funciona,sino ya es problema de mi pcb,aunque revise todo mil veces y nada, ley de murphi.

si se te viene a la cabeza alguna otra idea te agradezco que comentes.
SALUDOS
PACIO
trata de intercambiar las coneciones ., que van del 297 al 298 ., C al in2 y B al in3 ., a ver si arranca ( comenta como te fue)
21/08/2015 #19

Avatar de Ardogan

pacio dijo: Ver Mensaje
Gracias por contestar ardogan,te cuento la pata sync esta sin conectar,hoy revisando descubrí que en realidad estaba mal conectadas una de las fases,ahora solo queda el motor clavado y vibrando,pero sigue sin darme bola el l297,sigue con la salida en 0101,aunque si funciona el pin enable,lo que me preocupa es que este mal el esquematico,de todas maneras ya estoy armando otro driver para ver si funciona,sino ya es problema de mi pcb,aunque revise todo mil veces y nada, ley de murphi.

si se te viene a la cabeza alguna otra idea te agradezco que comentes.
SALUDOS
PACIO
Aja, motor PaP vibrando me ha pasado cuando tenía un límite de corriente muy bajo, menor de lo que requería el motor. Si está vibrando significa que algo está saliendo en la secuencia de pasos, de lo contrario no haría ningún movimiento en absoluto. Como estás midiendo que la secuencia de pasos no avanza?, con osciloscopio o con un tester?.

Probá aumentar la tensión Vref (a ver que pasa al mover el preset), teóricamente sería
Vref = Ib x Rsensado
Ib: corriente por bobina
Rsensado: entre terminales sense y GND

¿El motor de que tamaño es?, NEMA17/23/otro?

Saludos
14/09/2015 #20


Hola,muchas gracias por todas las respuestas , les cuento arme otro driver (mismo diseño de pcb) y salio funcionando perfectamente,e hice otro más y funciona un solo puente h,el otro no entrega mucha corriente y además se me quemó un l298 a pesar de que estaba consumiendo 500mah a 20v, ,veo que se debe a la mala calidad de los integrados,me trajeron bastantes problemas,por lo que mi idea es seguir utilizando el l297 pero armar dos puente h con transistores , les contare a ver que tal me va..

De nuevo muchas por las respuestas
Saludos
PACIO!
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Robótica, Domótica y Mecatrónica

La electrónica Aplicada a la Robótica y sus técnicas de interface.

Cerrar
Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.