Haz una pregunta
  Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

15/07/2010 #1


Pregunta sobre un H-Bridge
Hola a todos:
Estoy intentando manejar un par de motores DC de 5 v. con un puente H-bridge de tipo L293NE y usando una placa Arduino según el esquema copiado y adaptado de http://itp.nyu.edu/physcomp/Labs/DCMotorControl y tengo el siguiente problema:
Si quiero invertir la rotación mediante un switch digital éste funciona pero la velocidad del motor en reverso es bajísima de forma que si toco con un dedo levemente el eje el motor prácticamente se para. En rotación directa el motor gira adecuadamente.
Si hago el cambio de giro mediante programa (intercambiando los valores de los pines del L293NE HIGH y LOW ) ocurre lo mismo.

Todo ello me hace pensar que el problema es inherente a como el puente L293NE maneja el voltaje en directa y en reversa y claro la pregunta del millón es si hay alguna forma de solucionarlo dentro de los voltajes de corriente que usa habitualmente la placa arduino.

Gracias y un saludo
Guillermo
15/07/2010 #2
Moderador general

Avatar de Fogonazo

Respuesta: Pregunta sobre un H-Bridge
Verifica que las señales de control de giro, que van al L293, sean las correctas para ambos sentidos de giro.
Verifica si el motor gira correctamente al alimentarlo en forma directa, sin el LM293 en ambos sentidos.
15/07/2010 #3


Respuesta: Pregunta sobre un H-Bridge
Sí ,el motor gira correctamente en ambos sentidos sin el L293 y las señales de control son correctas en tanto que invierten el sentido de giro del motor. Supongo que el voltaje suministrado por el L293 será correcto en directa y menor en reversa que es cuando el motor gira muy lentamente.Lo que no sé es por qué baja tanto
15/07/2010 #4

Avatar de Ferny

Respuesta: Pregunta sobre un H-Bridge
Pon un esquema de todas las conexiones
15/07/2010 #5


Respuesta: Pregunta sobre un H-Bridge
El esquema que he utilizado es exactamente el que indican en este enlace http://itp.nyu.edu/physcomp/Labs/DCMotorControl. El código cargado en el arduino es el que indican y la única anomalia en el funcionamiento es que cuando cambias el sentido de giro del motor con el switch éste se ejecuta muy lentamente y no sé a qué es debido. ¿El L293 no debería cambiar la polaridad sin afectar a la velocidad del motor ?.
15/07/2010 #6
Moderador general

Avatar de Fogonazo

Respuesta: Pregunta sobre un H-Bridge
guillermo3r dijo: Ver Mensaje
Sí ,el motor gira correctamente en ambos sentidos sin el L293 y las señales de control son correctas en tanto que invierten el sentido de giro del motor. Supongo que el voltaje suministrado por el L293 será correcto en directa y menor en reversa que es cuando el motor gira muy lentamente.Lo que no sé es por qué baja tanto
Al girar lentamente el motor, ¿ El integrado se calienta ?
16/07/2010 #7


Respuesta: Pregunta sobre un H-Bridge
Lo comprobé y no`parece calentarse demasiado
20/07/2010 #8


SOLUCIONADO y una nueva pregunta...
Bueno pues creo que ya dí con la solución.Encargué cuatro H-Bridge del tipo
SN754410NE que es similar al L293NE y dos de ellos funcionaban perfectamente invirtiendo el giro de los motores con la misma velocidad de giro en directa y en reversa. Pero Oh sorpresa los otros dos integrados nuevitos no funcionaban en absoluto por lo que deduzco que el L293NE funcionaba a medias.
Y ahora una nueva pregunta a los que teneís más experiencia por estos foros. ¿Es normal que de cuatro integrados sólo funcionen bien dos?:enfadado:.¿Son los IC como los melones que salen buenos unos y otros no o es que he tenido mala suerte?.:enfadado:¿No pasan controles de calidad ?. ¿Es todo así en cuanto componentes electrónicos.?.
Bueno pues muchas gracias a los que os habeís interesado por mis tribulaciones.
Guille
20/07/2010 #9

Avatar de Ferny

Respuesta: Pregunta sobre un H-Bridge
No lo creo. Seguramente estarás al límite en algún parámetro del componente y con la tolerancia que éstos tienen en unos casos funciona y en otro no, pero dudo que tengas la mitad de componentes defectuosos, al menos en los años que llevo con la electrónica mi experiencia es que es muy muy difícil encontrarte con un solo componente malo de fábrica.
20/07/2010 #10
Moderador general

Avatar de Fogonazo

Respuesta: Pregunta sobre un H-Bridge
Podrías estar ante un caso de un componente falsificado o de 3ª selección, en ciertas condiciones funcionan y otras NO
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Robótica, Domótica y Mecatrónica

La electrónica Aplicada a la Robótica y sus técnicas de interface.

Cerrar
Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.