Haz una pregunta
  Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/04/2014 #1


Problema con controlado de motor pap
realice este diseño para controlar un motor pap unipolar el cual saque parte de investigar en varios blog lo simulo en el proteus 8 y funciona pero cuando lo realice en el proto board el motor no se movía se clava en un lugar y al tomar el motor en la mano se siente que tiene tensión las bobinas. dejo un adjunto del diseño para que lo vean y si me pueden decir donde cometí el error. Desde ya muchas gracias.
25/04/2014 #2

Avatar de Daniel Meza

Hola, pon tu diagrama en algún formato reconocible para los compañeros del foro y te podamos ayudar. PDF, jpeg, etc
26/04/2014 #3

Avatar de papirrin

si sientes que solo esta tenso, pero sin dar el siguiente paso, yo creo que debes bajar la frecuencia del 555.

si hace como que quiere dar un paso pero no puede, esta mal conectado el motor.

los diodos que tienes ahi, ¿porque los pusiste asi?

si puedes pon lo que tiene en la etiqueta tu motor para saber sus carateristicas, y tambien si quieres comenta como es la fuente de alimentacion que estas usando

p.d.anexo el archivo de proteus 8 en PDF .
Archivos Adjuntos
Tipo de Archivo: pdf MOTOR PAP 10-A.pdf (44,6 KB (Kilobytes), 83 visitas)
27/04/2014 #4


papirrin dijo: Ver Mensaje
si sientes que solo esta tenso, pero sin dar el siguiente paso, yo creo que debes bajar la frecuencia del 555.

si hace como que quiere dar un paso pero no puede, esta mal conectado el motor.

los diodos que tienes ahi, ¿porque los pusiste asi?

si puedes pon lo que tiene en la etiqueta tu motor para saber sus carateristicas, y tambien si quieres comenta como es la fuente de alimentacion que estas usando

p.d.anexo el archivo de proteus 8 en PDF .
Los diodos los puse con la idea de proteger el micro de un rebote de tension, la verdad no se si son necesarios. El motor lo saque de una impresora hp el numero de parte es 35s1n15d7ya c5870-60004 supuestamente es de 7.5º voltaje maximo 24v con una resistencia de 20Ω. la alimentacion es con un trafo 220v/12v 50 hz con una etapa de rectificacion y un 7805 para la salida a 5v para la alimentacion de los micros
Archivos Adjuntos
Tipo de Archivo: pdf MOTOR PAP 10-A.PDF (51,3 KB (Kilobytes), 23 visitas)
28/04/2014 #5


Hola que tal,

primero a mi tambien se me hace raro de como pusiste los diodos de esa forma. creo que no es la forma correcta.

segundo checa bien la configuracion de tu motor, y eso lo puedes hacer con la ayuda de un multimetro.

en este link en el paso 6 viene como identificar las terminales. Una vez que las identificaste, prueba directamente con la fuente, dandole pulsos al motor manualmente, y ahi veras si gira correctamente.

tambien te adjunto una imagen de como utilizaria los diodos. prueba asi en tu circuito

Saludos!
Imágenes Adjuntas
Tipo de Archivo: jpg motorpap.jpg (32,9 KB (Kilobytes), 35 visitas)
28/04/2014 #6

Avatar de TRILO-BYTE

hola esta es una forma de colocar los diodos en un motor PaP


se supone que los diodos actuan como diodos de marcha , bla bla, bla ,teoria ,etc.

aunque no son necesarios para mover un motor a pasos o un simple motor DC.

si es importante que los lleve cuando el motor se va a mover externamente a mano
ejemplo:

tengo un motor apasos conectado a una banda ,SI YO LO MUEVO nunca falta el MANOTAS que lo mueve por jugar y ahi es donde el circuito de control se ve comprometido a ser asecinado por el voltaje inverso
que genera el motor a pasos o motor de CD comun.

cuando estas seguro que un MANOTAS no estara presente y que no moveras ese motor de forma externa si puedes omitir los diodos, "para ahorrar circuito".

pero si el circuito estara propenso a ser movido no por uno si no por varios MANOTAS ahi forsosamente debe llevar diodos tipo diodos schottky. por que deben ser rapidos y que soporten una buena corriente
por que los 1n4148 se pueden volar cuando el motor es grande y genera picos inversos de bastante corriente.

pero si es para un proyecto escolar donde es un motor PaP calabaceron pues no hay tos y no le pongas diodods
06/08/2014 #7


tengo un problema el circuito que tengo para controlar un motor pap me funciona bien cuando hago girar el motor en un sentido pero cuando le cambio el sentido de rotacion intenta hacer uno o dos pasos y se frena. si desconecto el motor y dejo solo los led funciona bien en ambos sentidos. mi pregunta es donde podria estar la falla en la fuente o en el controlador la fuente que uso es de 12v 1amp con otra salida de 5v para el ,controlador
Archivos Adjuntos
Tipo de Archivo: pdf MOTOR PAP 10-A_B.PDF (64,3 KB (Kilobytes), 27 visitas)
06/08/2014 #8

Avatar de papirrin

¿ya probaste polarizando los transistores TIP con otro transistor, digamos unos Bc548?

yo podria suponer que te falta poner algunos capacitores de 100nF en la alimentacion de cada circuito integrado.

para saber si es la fuente podrias poner dos fuentes independientes con la tierra en comun para saber si ese es el fallo, es bastante comun que los motores vuelvan locos a los integrados.

otra cosa que veo raro es que SW1 lo dejas al aire, reviza eso en el datasheet, ¿no deberia ir a +5V?
07/08/2014 #9

Avatar de Daniel Meza

Como dice Papirrín, corrige esa entrada flotante del switch1 y revisa el conexionado de los devanados a los transistores, que estén en el orden correcto
07/08/2014 #10


papirrin dijo: Ver Mensaje
¿ya probaste polarizando los transistores TIP con otro transistor, digamos unos Bc548?

yo podria suponer que te falta poner algunos capacitores de 100nF en la alimentacion de cada circuito integrado.

para saber si es la fuente podrias poner dos fuentes independientes con la tierra en comun para saber si ese es el fallo, es bastante comun que los motores vuelvan locos a los integrados.

otra cosa que veo raro es que SW1 lo dejas al aire, reviza eso en el datasheet, ¿no deberia ir a +5V?
si, por error borre la conexion a 5V. del SW1. pero al simularlo en la protoboard el sw1 lo conexto a 5v y la falla se produce cuando el sw1 esta en +5v y no cuando lo paso a tierra.
07/08/2014 #11

Avatar de papirrin

Prueba poniendo una resistencia de unos 4.7K ente el pin 1 y tierra, para que a la hora de hacer la transición no quede flotante.

si quieres sube el archivo para verlo simulando o todavia es el mismo del post #1?
07/08/2014 #12

Avatar de papirrin

Bueno yo haria lo del arcivo adjunto....

hace tiempo arme una parecida y funcionaba de 10, lo que no recuerdo bien son los valores de las resistencias que puse pero puedes probar con esas.
Archivos Adjuntos
Tipo de Archivo: pdf MOTOR PAP 10-A.pdf (49,6 KB (Kilobytes), 16 visitas)
08/08/2014 #13


papirrin dijo: Ver Mensaje
Prueba poniendo una resistencia de unos 4.7K ente el pin 1 y tierra, para que a la hora de hacer la transición no quede flotante.

si quieres sube el archivo para verlo simulando o todavia es el mismo del post #1?
aca te envio en formato rar el archivo para simular en proteus 8. ahora me voy a poner a probar lo del archivo adjunto que dejaste.
Archivos Adjuntos
Tipo de Archivo: rar MOTOR PAP 10-A_B.rar (25,7 KB (Kilobytes), 9 visitas)
28/10/2014 #14

Avatar de luvhines

Esta bueno el diseño pero, muchachos quisiera que me sacaran de una duda, como logro 1/16 o 1/32 de paso en un motor pap bipolar o unipolar, no encuentro información al respecto les agradecería.
28/10/2014 #15

Avatar de papirrin

Busca micropasos ,se hace modulando el ancho del pulso (PWM)
29/10/2014 #16

Avatar de TRILO-BYTE

yo soy ignorante en el micropaso

¿alguien podria ilustrar con un algoritmo para generar micropaso?
29/10/2014 #17


Hola TRILO-BYTE

Aunque parece sarcasmo: google es tu amigo.
Fui con mi amigo y encontré un mundo de información:
https://www.google.com.mx/?gfe_rd=cr&ei=IoNQVNTPDK7I8gfH0YE4&gws_rd=ssl#q=mi cropasos+motores+paso+paso

En el documento PDF que adjunto creo que hay buena info.

saludos
a sus ordenes
Archivos Adjuntos
Tipo de Archivo: pdf Técnica Micropasos Por PWM.pdf (181,4 KB (Kilobytes), 28 visitas)
29/10/2014 #18

Avatar de TRILO-BYTE

si lo entiendo pero nunca he visto un algoritmo hecho de el micropaso si a duras penas unos pueden prender un led
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Robótica, Domótica y Mecatrónica

La electrónica Aplicada a la Robótica y sus técnicas de interface.

Cerrar
Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.