Haz una pregunta
  Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

12/05/2013 #1


Robot - Se reinicia cuando encienden motores
Buenas tardes, de ante mano gracias.
Quisiera que pudieran ayudarme, he buscado soluciones pero no encontré alguna que me pudiera ayudar a arreglar esto, mi problema continua,, y es el siguiente.

Estoy haciendo un robot, que funciona en resumen de la siguiente maner:
Un sistema controlado mediante un PIC16F648 con su propia fuente de alimentación de 5v, que controla los sensores, y los motores.

Los motores los controla mediante un Driver L293D, que tiene su propia alimentación de 12v.
Ambas baterías con muy buena duración, de 2100mah

El problema está en que, pongo a funcionar el robot, y empieza a realizar la rutina perfectamente, controlando los motores que funcionan a 12v mediante el puente H.

Los motores son micromotores, los ocupados en minisumo.
Pero, cuando el robot decide, avanzar de lleno, o retroceder de lleno, entonces, está programado para habilitar por completo los motores en movimiento, y aqui la falla, el robot pierde el control, se queda bloqueado en su ultima instruccion.

De echo he podido darme cuenta que el pic "se reinicia", y ya regresa a su normalidad.
Pero en ocasiones, se reinicia, y se reinicia, y se reinicia, y tarda mucho en volver.


Ya intente poner capacitores a los motores, probe distintas baterías, distintos motores.
Pero me sucede lo mismo.
Creo que debe ser un problema de ruido, o algo asi, pero si alguien pudiera por favor oreitnarme se los agradeceria muchisimo

Buenas tarde,s gacias.
12/05/2013 #2

Avatar de chclau

Probablemente es ruido. El ruido se te puede acoplar de diferentes modos, a traves del aire o de los conductores (a veces en forma combinada)

proba, si podes, de poner todo tu micro en una caja metalica aislada y conectada a tierra (apantallamiento). Si no es posible, trata de apantallarlo con "semicajas" metalicas arriba y o abajo del PCB con mucho cuidado de no provocar cortocircuitos. Podes tambien probar de apantallar los motores.

Lo otro para probar es colocar filtros EMI y o optoacopladores entre el micro y los drivers de los motores.

Suerte!
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Robótica, Domótica y Mecatrónica

La electrónica Aplicada a la Robótica y sus técnicas de interface.

Cerrar
Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.