Haz una pregunta
  Foros de Electrónica » Diseño analógico » Fuentes de Alimentación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

09/09/2014 #1


Convertidor boost regulable de 25 a 100 V
Hola buenas, estoy realizando un convertidor boost regulable con 25 voltios de entrada y 100 de salida. Utilizo el integrado SG3524. La idea es que sea autorregulable, es decir, que le metas lo que le metas de entrada siempre tiene que dar 100 voltios a la salida. Cuando lo pruebo con 25 voltios me da los 100 voltios a la salida, y si le aumento la entrada a 30 o 35 también se queda en 100 voltios, pero si bajo el voltaje de entrada por debajo de unos 23 voltios también me baja la tensión de salida.

Otro problema es el ciclo de trabajo, que debería de ser del 75%, pero me sale del 50% siempre. Según comenté a mi profesor, esto puede ser debido a que el integrado SG3524 no admita mayor ciclo de trabajo del 50% y que tal vez haya que conectar las patillas 11 y 14 mediante diodos y resistencias para que aumente el ciclo de trabajo y se autorregule la tensión de salida siempre a 100 voltios, alguien podría ayudarme con esto?? muchas gracias. ...
09/09/2014 #2

Avatar de foso

Amigo tenés que postear el circuito completo que estas usando para que te puedan ayudar, sino es imposible.
¿Cómo conectaste el amplificador de error? ¿Trabajás en modo de conducción continua?
15/09/2014 #3


ok, ahora abajo lo adjunto y se puede ver cómo lo conecté, y no, estoy en modo conducción discontinua

---------- Actualizado después de 3 minutos ----------

se que también la regulación tiene un límite, es decir, que por ejemplo no puedo meterle un voltio y que salgan 100, pero la idea es que salgan 100 voltios a la salida cuando le meto de entrada un valor de 15 voltios por ejemplo, por eso que según tengo entendido era conectar las patas 11 y 14 pero no sé cómo, ya que si las conecto directamente el transistor se funde, cómo podría hacerlo??
Imágenes Adjuntas
Tipo de Archivo: jpg convertidor boost regulable 20W.JPG (32,2 KB (Kilobytes), 49 visitas)
15/09/2014 #4

Avatar de foso

Veo un detalle que no me cierra en la configuración que elegiste.
En régimen de conducción discontinua, el modo OFF, es decir cuando se desactiva el mosfet tiene una duración de:

Vi/Vo * Ts

en tu caso

15V/100V * 17 µs = 2.55 µs

Con lo cual el tiempo de desactivación del mosfet debería ser despreciable frente a este.
En tu caso estás usando un resistor de pull-down para desactivar el mosfet, en paralelo con 3.3nF. La cosntante de tiempo esta, sin contar la capacidad del mosfet es de:
726 ns y considerando que el transitorio se extingue en 5 constantes de tiempo, el mosfet tarda en apagarse:
3.63 µs

entonces ¿Cómo esperas lograr un tiempo de desactivación de 2.55 us?
15/09/2014 #5


pues la verdad es que no me había parado a pensar en ese detalle, del tiempo de desactivación.
En teoría mi circuito es 25 voltios de entrada que se obtengan 100 de salida, cosa que hace, pero la idea es que sea autorregulable, por eso te he dicho lo de los 15 voltios por poner un ejemplo.

He puesto la resistencia entre el emisor del SG3524 y el MOSFET porque el transistor tiene una impedancia de entrada muy alta, por lo que si se conecta directamente no funcionaría ya que no pasaría corriente apenas y tampoco tensión, por eso esa resistencia, para que pueda haber tensión al mosfet, y el condensador en paralelo es para que haya menos ruido, y es cerámico porque los cerámicos filtran las altas frecuencias, este circuito tiene una frecuencia de 100 kiloherzios.

Entonces que me dices que sería lo mejor, cambiar la resistencia que hay entre la pata 14 y el mosfet??, aquí te paso una imagen de la forma de onda que sale en el drenador del mosfet, da bien, lo que ocurre es que tengo que reducir el tiempo de apagado, es decir el tiempo que en el drenador se ve la tensión de entrada, que es esa especie de escalón

---------- Actualizado después de 3 minutos ----------

y otra cosa eso de los 17 microsegundos que me has puesto al principio?? teóricamente el periodo de mi señal dura 10 microsegundos ya que tengo una frecuencia de 100 kilohertz, por eso q no comprendo de donde sale, o es una constante??
Imágenes Adjuntas
Tipo de Archivo: bmp Vds con sonda x10.BMP (14,9 KB (Kilobytes), 23 visitas)
15/09/2014 #6


brother, ese capacitor de 3.3nf y esa res de 220ohm no cumplen ningún propósito allí, mas bien coloca una res de unos 4.7 ohm entre la unión de los pines 11 y 14 y el gate del irf640
15/09/2014 #7

Avatar de foso

Wolfmaister, los fabricantes de semiconductores se rompen la cabeza tratando de reducir la capacidad parásita de entrada de los dispositivos de switching. Y vos venís y le colocás 3.3 nF en la entrada, . Ese capacitor tenés que sacarlo. El valor de la resistencia me parece un poco grande también. La resistencia sí es necesaria, habría que probar valores menores.

La otra posible configuración es usar un resistor de pull-up, y conectar el Gate al colector de los transistores, y el emisor a tierra. Esto me parece mas eficiente que tu configuración.

La frecuencia del conmutador la saqué de la fórmula de hoja de datos, usando los valores de tu circuito. Te adjunto el pdf, está en la página 7.
Archivos Adjuntos
Tipo de Archivo: pdf sg3524.pdf (311,5 KB (Kilobytes), 15 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Fuentes de Alimentación

Circuitos de alimentación, reguladores de voltaje, UPS, cargadores de batería, celdas solares, acumuladores, baterias, pilas...

Cerrar
Foros de Electrónica » Diseño analógico » Fuentes de Alimentación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.