Haz una pregunta
  Foros de Electrónica » Diseño analógico » Fuentes de Alimentación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

04/01/2012 #1


Convertidor Buck y máximo voltaje de salida.
Tengo montado un convertidor buck con un TL494. El voltaje de entrada es de 44v.

Si ajusto la salida a 12v le puedo sacar más de 3A con una lampara halogena. Ahora bién, si ajusto la salida a 36v, y le conecto tres lámparas de 12v/21w en serie, no saco más de 33v y 1.6A. El máximo ciclo de trabajo es del 90%, por lo que en teoria podria sacar hasta 39.6v.

Por la entrada circulan 1.5A, entonces el rendimiento es: (33*1.6)/(44*1.5) = 80%

Supongo que no está mál, pero me queda la duda de si a salidas de voltaje cercanos a la entrada se puede sacar más rendimiento.

Un abrazo a t@dos y feliz año.
04/01/2012 #2
Moderador

Avatar de hazard_1998

micropepe dijo: Ver Mensaje
Tengo montado un convertidor buck con un TL494. El voltaje de entrada es de 44v.

Si ajusto la salida a 12v le puedo sacar más de 3A con una lampara halogena. Ahora bién, si ajusto la salida a 36v, y le conecto tres lámparas de 12v/21w en serie, no saco más de 33v y 1.6A. El máximo ciclo de trabajo es del 90%, por lo que en teoria podria sacar hasta 39.6v.

Por la entrada circulan 1.5A, entonces el rendimiento es: (33*1.6)/(44*1.5) = 80%

Supongo que no está mál, pero me queda la duda de si a salidas de voltaje cercanos a la entrada se puede sacar más rendimiento.

Un abrazo a t@dos y feliz año.
antes que nada, y para poder asistirte en tu problema, no seria mejor (mucho) que subas un esquema de lo que hiciste?, es que hoy no me anda la bola magica.....
05/01/2012 #3


Sí, jeje es mejor así.

La tensión de entrada viene de un transformador de 36v/3A, rectificado y filtrado con 6800uF. Con la carga comentada el voltaje en el condensador de filtro es de 44v.

Gracias.
Archivos Adjuntos
Tipo de Archivo: pdf Esq_TL494_FuenteConmutadaDigital.pdf (33,0 KB (Kilobytes), 277 visitas)
05/01/2012 #4


Sera por los 14mH que es una bobina con bastante resistencia por la cantidad de espiras que tiene.
05/01/2012 #5

Avatar de Gudino Roberto duberlin

Amigo, cuando dices que la max. salida con carga es de 33V., que valor tienes en la entrada principal de alimentacion?.
05/01/2012 #6
Moderador

Avatar de hazard_1998

uhm, que quilombito que hiciste en ese circuito eh.... por un lado, yo te diria que bajes la inductancia de salida, a que frecuencia corre el PWM?, pero no creo que venga por ahi el tema.... me la juego mas por el hecho que estan interactuando los OPAMP que metiste para medir tension y corriente, la del preamplificador para el shunt de salida la entiendo, pero para que colocaste el otro OPAMP con el divisor resistivo del feedback de tension tomado desde la salida de éste?, para mi esta interactuando este operacional, ya que cuando aumenta la tension de salida, aumenta tambien el efecto que produce ese opamp... proba con poner R30 directo a masa en vez de ser comandado por la salida del opamp....
05/01/2012 #7


Gudino Roberto duberlin dijo: Ver Mensaje
Amigo, cuando dices que la max. salida con carga es de 33V., que valor tienes en la entrada principal de alimentacion?.
Tengo 44v.

hazard_1998:

La frecuencia del PWM es de 4KHz, aunque probé con potencihometros con el mismo resultado.

El operacional de medida de voltaje es para compensar la caida de voltaje en el shunt de corriente, aunque a 3A son solo 0.15v, se puede eliminar esa parte.

He probado a poner R30 a masa, y a bajar la bobina (ahora es de 4mH, tambien he probado con 1mH y el rendimiento se reduce), y el resultado con tres lamparas de 35w/12v en serie es el siguiente:

Vin = 36.5v; Iin = 2.2A

Vout = 27.4v; Iout = 2.52A

Rendimiento = 86%; si intento subir el voltaje de salida, no pasa de 27.4v (con el limite en corriente a 3A).

Gracias a todos.
05/01/2012 #8


Con 1mH es mucho, cual será el grosor del alambre de cobre de la bobina.
Yo hice esos circuitos con una mayor frecuencia a 17Khz a 33Khz con bobina de 100uH a 220uH.
Quería hacer llegar a 100Khz pero necesito driver para mosfet por que asi con transistores para el gate conmute a esa velocidad ocupa mas espacio.
06/01/2012 #9


cristian_elect dijo: Ver Mensaje
Con 1mH es mucho, cual será el grosor del alambre de cobre de la bobina.
Yo hice esos circuitos con una mayor frecuencia a 17Khz a 33Khz con bobina de 100uH a 220uH.
Quería hacer llegar a 100Khz pero necesito driver para mosfet por que asi con transistores para el gate conmute a esa velocidad ocupa mas espacio.
La bobina está bobinada sobre un toroide de ferrita con hilo de 1.3mm, y para la de 1mH tengo enrrolladas 12 espiras, para la de 4mH 30 espiras. No son muy grandes de tamaño fisicamente, si es a eso a lo que te refieres.

El problema de poner bobinas más pequeñas, sobre un nucleo de polvo de hierro, es que el rizado de salida aumenta.

Saludos.
06/01/2012 #10


micropepe dijo: Ver Mensaje
La bobina está bobinada sobre un toroide de ferrita con hilo de 1.3mm, y para la de 1mH tengo enrrolladas 12 espiras, para la de 4mH 30 espiras. No son muy grandes de tamaño fisicamente, si es a eso a lo que te refieres.

El problema de poner bobinas más pequeñas, sobre un nucleo de polvo de hierro, es que el rizado de salida aumenta.

Saludos.
Bueno, he probado con otra bobina que tenia de 33uH, esta formada por dos hilos de 1mm en lugar de uno de 1.3mm, y el rizado de la salida es incluso menor. Pero sigo con el mismo problema de exprimir al máximo el voltaje de salida cercano al de entrada.

Saludos.
06/01/2012 #11
Moderador

Avatar de hazard_1998

hay otro tema mas, el amplificador de error de corriente no esta compenzado, por lo que me comentas es como que hay algo que lo esta frenando, la frecuencia que le diste al pwm es bajisima, en plena banda de audio, subila a unos 30-35Khz y baja el inductor a unos 100uHy, ademas, el nucleo del mismo debe ser de muy baja permeabilidad, y habria que calcularlo, porque si usas un toroide de ferrite (no polvo de hierro) lo mas probable es que se sature y la corriente que circule por el mismo dejará de ser una rampa para convertirse en una curva exponencial. con lo cual probablemente actue el limite de corriente por el pico de ésta cuando comience a saturarse el nucleo
06/01/2012 #12


hazard_1998 dijo: Ver Mensaje
hay otro tema mas, el amplificador de error de corriente no esta compenzado, por lo que me comentas es como que hay algo que lo esta frenando, la frecuencia que le diste al pwm es bajisima, en plena banda de audio, subila a unos 30-35Khz y baja el inductor a unos 100uHy, ademas, el nucleo del mismo debe ser de muy baja permeabilidad, y habria que calcularlo, porque si usas un toroide de ferrite (no polvo de hierro) lo mas probable es que se sature y la corriente que circule por el mismo dejará de ser una rampa para convertirse en una curva exponencial. con lo cual probablemente actue el limite de corriente por el pico de ésta cuando comience a saturarse el nucleo
Hola de nuevo,

he probado a eliminar el operacional poniendo R30 a masa (para eliminar la medida de voltaje) y poniendo R13 a masa y aplicando 5v a la entrada -I2 (pin 15 del TL494) (para eliminar el control de corriente). El resultado es el mismo que cuando el control de corriente está activo.

Por otro lado, creo que no entendí bien lo del PWM. El PWM del TL494 es de 80KHz, y yo pensé que te referias al PWM del control de corriente y voltaje, estos los uso a modo de DAC y son de 4KHz ¿Me preguntabas por el del TL494, no?

Probaré con una bobina de 100uH con nucleo de polvo de hierro.

Un abrazo.
06/01/2012 #13
Moderador

Avatar de hazard_1998

micropepe dijo: Ver Mensaje
Hola de nuevo,

he probado a eliminar el operacional poniendo R30 a masa (para eliminar la medida de voltaje) y poniendo R13 a masa y aplicando 5v a la entrada -I2 (pin 15 del TL494) (para eliminar el control de corriente). El resultado es el mismo que cuando el control de corriente está activo.

Por otro lado, creo que no entendí bien lo del PWM. El PWM del TL494 es de 80KHz, y yo pensé que te referias al PWM del control de corriente y voltaje, estos los uso a modo de DAC y son de 4KHz ¿Me preguntabas por el del TL494, no?

Probaré con una bobina de 100uH con nucleo de polvo de hierro.

Un abrazo.
eppalele, 80Khz? y con ese driver? mepa que el temita viene por ahi... hace lo siguiente, pone la salida a la maxima tension posible (creo que esos 27Vcc) y pone primero la punta del osciloscopio sobre el diodo volante (D1) y medí que ciclo de trabajo tenes, o que tiempo de conduccion de TR1 tenes, y luego pone la punta del osciloscopio entre masa y el anodo de D9, ahi te vas a dar cuenta de si el driver te roba tiempo en el encendido de TR1... para mi viene por ahi, la velocidad de conmutacion cuando pasa a encender a TR1 es tan baja que agrega mucho tiempo muerto al control. con lo cual el ciclo de trabajo maximo se reduce...si bajas la frec a alrededor de 30Khz el ciclo de trabajo va a aumentar bastante
06/01/2012 #14


Para ver cuanto se pierde por la resistencia de la bobina pon la bobina con la fuente y en serie con un foco.
06/01/2012 #15

Avatar de Sebastian1989

¿al conectar la carga el voltaje cae a 33V o ese es el voltaje máximo de salida aunque le pongas una carga mucho menor?
07/01/2012 #16
Moderador

Avatar de hazard_1998

cristian_elect dijo: Ver Mensaje
Para ver cuanto se pierde por la resistencia de la bobina pon la bobina con la fuente y en serie con un foco.
es sabido cristian que en el inductor caerá tension producto de la corriente que lo atraviesa, pero el dice que, con 36V de entrada, le entrega 27 a la salida, osea, 9V de caida, y 1,6A.... serían mas de 14w que disiparia el inductor, si fuera por ahi el tema... por eso cristian, el tema viene por el lado de que no tiene disponible el duty cycle maximo del TL494
07/01/2012 #17


hazard_1998 dijo: Ver Mensaje
eppalele, 80Khz? y con ese driver? mepa que el temita viene por ahi... hace lo siguiente, pone la salida a la maxima tension posible (creo que esos 27Vcc) y pone primero la punta del osciloscopio sobre el diodo volante (D1) y medí que ciclo de trabajo tenes, o que tiempo de conduccion de TR1 tenes, y luego pone la punta del osciloscopio entre masa y el anodo de D9, ahi te vas a dar cuenta de si el driver te roba tiempo en el encendido de TR1... para mi viene por ahi, la velocidad de conmutacion cuando pasa a encender a TR1 es tan baja que agrega mucho tiempo muerto al control. con lo cual el ciclo de trabajo maximo se reduce...si bajas la frec a alrededor de 30Khz el ciclo de trabajo va a aumentar bastante
Que razón tienes es ese driver el que está robando ciclo de trabajo al mosfet.

He bajado el valor de la bobina del driver (L1) a 39uH, y con eso le saco 34v/2.8A a la salida, con 36v en la entrada. Ahora el limite está en el voltaje de entrada, que baja al cargar la salida (como dije la entrada es un transformador de 36v/3A, rectificado y filtrado con 6800uF) ademàs de un compromiso entre rendimiento y voltaje máximo de salida. Me explico, si L1 es muy grande el rendimiento es bastante bueno pero el voltaje de salida máximo queda limitado, y si es muy pequeña el rendimiento a voltajes bajos se reduce pero se puede alcanzar un voltaje de salida mucho más cercano al de entrada.

Quizás deberia emplear otro tipo de driver que no utilice una bobina.

Un abrazo.

Sebastian1989 dijo: Ver Mensaje
¿al conectar la carga el voltaje cae a 33V o ese es el voltaje máximo de salida aunque le pongas una carga mucho menor?
El voltaje cae al conectar la carga.

cristian_elect dijo: Ver Mensaje
Para ver cuanto se pierde por la resistencia de la bobina pon la bobina con la fuente y en serie con un foco.
No entiendo muy bién lo que quieres decir, pero el problema venia del driver.
07/01/2012 #18
Moderador

Avatar de hazard_1998

micropepe dijo: Ver Mensaje
Que razón tienes es ese driver el que está robando ciclo de trabajo al mosfet.

He bajado el valor de la bobina del driver (L1) a 39uH, y con eso le saco 34v/2.8A a la salida, con 36v en la entrada. Ahora el limite está en el voltaje de entrada, que baja al cargar la salida (como dije la entrada es un transformador de 36v/3A, rectificado y filtrado con 6800uF) ademàs de un compromiso entre rendimiento y voltaje máximo de salida. Me explico, si L1 es muy grande el rendimiento es bastante bueno pero el voltaje de salida máximo queda limitado, y si es muy pequeña el rendimiento a voltajes bajos se reduce pero se puede alcanzar un voltaje de salida mucho más cercano al de entrada.

Quizás deberia emplear otro tipo de driver que no utilice una bobina.

Un abrazo..
para los que no entendieron que pasaba, esa bobina (L1) es un speed up del transistor (T1) que apaga al mosfet, lo que hace es lo siguiente, cuando los colectores del TL494 tiran hacia abajo, hacen conmutar al mosfet canal P haciendo sircular tambien corriente atraves de D2 y la bobina L1, esto hace que en el entrehierro de esa bobina se cargue cierta energia (dependiendo de los Volt-seg aplicados), cuando los colectores del TL494 se abren, esa energia acumulada en el entrehierro del inductor debe ir a parar a algun lado, y pasan a circular por la base de T1, haciendo que apague a TR1 rapidamente, ahora..., el tiempo que queda conduciendo T1 depende de, el tiempo de recuperacion de base de este, y de la cantidad de energia que tiene disponible L1 haciendola circular por la base de T1, si la inductancia es muy grande, acumula mas energia, la cual perdurará mas tiempo manteniendo a T1 en conduccion...

por otro lado, yo te diria que, entre colectores y emisores del TL494, pongas un zener de 40V, y sobre source y gate de TR1, pongas un zener de 15V, no sea cosa que quemes o el mosfet o el TL494 por picos de tension....
07/01/2012 #19


hazard_1998 dijo: Ver Mensaje
para los que no entendieron que pasaba, esa bobina (L1) es un speed up del transistor (T1) que apaga al mosfet, lo que hace es lo siguiente, cuando los colectores del TL494 tiran hacia abajo, hacen conmutar al mosfet canal P haciendo sircular tambien corriente atraves de D2 y la bobina L1, esto hace que en el entrehierro de esa bobina se cargue cierta energia (dependiendo de los Volt-seg aplicados), cuando los colectores del TL494 se abren, esa energia acumulada en el entrehierro del inductor debe ir a parar a algun lado, y pasan a circular por la base de T1, haciendo que apague a TR1 rapidamente, ahora..., el tiempo que queda conduciendo T1 depende de, el tiempo de recuperacion de base de este, y de la cantidad de energia que tiene disponible L1 haciendola circular por la base de T1, si la inductancia es muy grande, acumula mas energia, la cual perdurará mas tiempo manteniendo a T1 en conduccion...

por otro lado, yo te diria que, entre colectores y emisores del TL494, pongas un zener de 40V, y sobre source y gate de TR1, pongas un zener de 15V, no sea cosa que quemes o el mosfet o el TL494 por picos de tension....
Buena explicación, tendré en cuenta lo de los zener.

Gracias por todo.
07/01/2012 #20


Hola a todo el foro¿como podemos calcular la maxima corriente que puede dar esta fuente?

---------- Actualizado después de 3 minutos ----------

supongo que será en funcion de la potencia max de tr1,d1 y el grosor del hilo empleado en L2,y en que varia el usar diferentes valores para L2¿tendriamos los mismos resultados usando 100microhenr que 220 o incluso 10milihenr por ejemplo?
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Fuentes de Alimentación

Circuitos de alimentación, reguladores de voltaje, UPS, cargadores de batería, celdas solares, acumuladores, baterias, pilas...

Cerrar
Foros de Electrónica » Diseño analógico » Fuentes de Alimentación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.