Haz una pregunta
  Foros de Electrónica » Diseño analógico » Fuentes de Alimentación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

09/11/2008 #201
Moderador

Avatar de hazard_1998

posteo los links porque son bastante pesados, abria que pedirle a LI-ION que los ponga en el foro.. son arto interesantes.

magnetic basics:
http://ece.colorado.edu/%7Eecen5797/...Ch13slides.pdf
inductor design guidelines
http://ece.colorado.edu/%7Eecen5797/...Ch14slides.pdf
transformadorrmer design guidelines
http://ece.colorado.edu/%7Eecen5797/...Ch15slides.pdf
09/11/2008 #202


Fuente conmutada (switching)
holaa todos, soy nuevo en foro buscando un problemin que me dejaron encontre este tema y me puse a leer todos los cientos de comentario k dejaron , la verdad k vole de feo . Donde estudio armamos una fuente utilizando el Sg3524ahi esta el diagrama en el adjunto.

En el archivo adjunto deje algunas cosas k avanse y notas de lo que trate de entender del circuito armado.

ahora me dejaron rediseñar el circuito para que tenga salidas +/-12Vdc, encontre un circuito de +/-15Vdc pero no se como variar el voltaje
10/11/2008 #203


Modificar fuente de DVD daewoo DG -K301
Hola amigos, deseo modificar la fuente de un DVD daewoo DG-K301 ya que el IC SM8002C no es muy comercial, entonces quisiera que me ayuden a diseñar un circuito compuesto por un FET, un MOSFET o un TRANSISTOR, agradezco su atensión , cualquier ayuda al foro. Adjunto el diagrama donde quiero hacer la modificaciòn.
Imágenes Adjuntas
Tipo de Archivo: jpg daewoo_dg_k301_107.jpg (32,4 KB (Kilobytes), 1115 visitas)
Tipo de Archivo: jpg daewoo_dg_k301_1_123.jpg (40,7 KB (Kilobytes), 453 visitas)
14/11/2008 #204

Avatar de Juan Romero

Replica de Fuente Boost
Hola amigos, hoy revise el foro y me encuentro con una pequeña "observacion" (critica constructiva) hecha por nuestro amigo Nilfred con respecto a un diodo (FR306) que coloque en una fuente boost que postee aqui.
Bueno dejame decirte que tienes razon, porque con un solo diodo y a una corriente de consumo de 2Amp este calentaria como mierda, claro que esto no sucederia si se le coloca un disipador de eso usados en fuentes de PC de material de cobre o laton, creo que si sabes a cual me refiero ¿no?; bueno pongale dos diodos FR306, si el mismo pero con disipador y asunto arreglado, porque la corriente pico del secundario seria 4Amp maximo y esos son suficientes. Aqui subo la nueva modificacion del circuito:



Y para el amigo Hazard1998 le digo este ckto fue un pedido de un amigo forista y por lo tanto tuve que calcular cada componente del circuito, solo que yo lo hago a veces en apuntes asi de manera rapida que yo solo entiendo, asi que prepare una parte de los calculos en unas hojas las cuales scanee y lo subo aqui para cualquiera que este interesado. Por lo tanto las modificaciones ya depende de la habilidad de cada uno de uds ya que yo no lo voy hacer todo, para eso estan uds.

Aqui una imagen del encabezado lo demas descargenlo del archi ZIP que adjunto:



Bueno me despido y un saludo para todos.

Ing Juan Romero A.
Archivos Adjuntos
Tipo de Archivo: rar calculos_boost_165.rar (750,2 KB (Kilobytes), 921 visitas)
17/11/2008 #205


Fuente forward
Buenas Tardes, alguien me puede colaborar?, lo que pasa es que tengo que implementar una fuente tipo forward para la universidad y aun no consigo que funcione al 100%.

Los parámetros requeridos son:

Entrada: 120 VAC
1 Salida Regulada: +15V 2A
4 Salidas No Reguladas: +15V 500mA

Utilicé el método de diseño explicado en este enlace --> http://www.redeweb.com/_txt/articulos/56942042.pdf
Utilicé un núcleo EA77-625 de ferrita.

El circuito resultante lo adjunto como imagen.

He conseguido obtener los niveles de voltaje deseados en la salida, sin embargo al pedir corriente a la fuente, ésta no entrega un valor ni siquiera cercano a lo deseado, por ejemplo, la salida de 2A no me entrega ni 300mA y la verdad no se en que estoy fallando, creo que el problema está en el sensado de corriente pero he leido en internet y en muchas partes lo implementan de la misma forma.

Agradeceria cualquier sugerencia o correccion, de antemano muchas gracias.
Imágenes Adjuntas
Tipo de Archivo: jpg img005_197.jpg (89,1 KB (Kilobytes), 617 visitas)
17/11/2008 #206
Moderador

Avatar de hazard_1998

jeisson, a simple vista encuentro que el circuito esta errado en el lazo de realimentacion, fijate los pines 1 y 2 de tu esquema y como esta conectado al colector y al emisor del optoacoplador. por otro lado hay que chequear bien el transformador, pero primero confirmame si es que esta mal el plano solamente o si realmente implementaste asi el uc3844...
17/11/2008 #207
Moderador

Avatar de hazard_1998

perdon, ahi estoy viendo que quitaste del lazo el amplificador de error interno del uc3844, usandolo como fuente de corriente y controlando la tension de error con el opto directamente.... yo usaria el amplificador de error, por otro lado, no se si con 5k6 en serie te alcanza para darle suficiente corriente de led al led del opto te hago una pregunta, chequeaste que es el lazo de realimentacion que no llega a regular o el transformador? hace lo sig, fijate primero si en vacio el convertidor regula la tension de salida y la mantiene fija por mas que muevas la tension de entrada (usando una fuente variable en la entrada), despues empeza a probar con carga gradualmente viendo si regula, si no regula, chequea con osciloscopio que es lo que no regula, si el pwm o si se cae el transformador, luego, si es que el pwm tiene margen de regulacion y la tension no llega al nivel seteado, chequea que no te este limitando por corriente el regulador pwm, creo que el nivel de trip es de 1.1V en pata 3, a partir de ahi empieza a limitar, Aca te posteo un esquema rudimentario de una alternativa de tu fuente. fijate si lo podes implementar y conta como te fue.
Archivos Adjuntos
Tipo de Archivo: pdf fuente_forward_818.pdf (55,9 KB (Kilobytes), 858 visitas)
17/11/2008 #208


Hola. Les dejo un programita que encotré hoy buscando información sobre núcleos. Tal vez ya lo conozcan.
Todavía no lo usé pero se los dejo para que lo estudien

http://www.epcos.com/web/generator/W...locale=en.html

Es gratis, de la marca Epcos con información actualizada de sus productos.
Lo bueno es que, aparentemente, podemos ponernos estrictos en el cálculo de pérdidas y calcular parámetros del material en función de la temperatura, de la frecuencia, del flujo, etc.
Permite graficar unas cuantas cosas.

Si bien los núcleos Epcos cuestan un dinerillo más, creo yo que vale la pena la "inversión" para asegurar los resultados previstos.

Aclaro que no es un programa que te diseña toda la fuente, por las dudas.
Sirve para conocer las propiedades del núcleo. Da mucha información que no encontramos en las hojas de datos.
19/11/2008 #209


primero q todo gracias por la oportuna respuesta hazard, pero el problema persiste, en vacio tengo los 15 V pero a medida q disminuyo el valor de la carga para pedir mas corriente el voltaje cae drasticamente, calculo que no me entrega mas de 100 mA, el problema creo q esta en la regulacion pwm ya que observandolo con el osciloscopio casi siempre esta en un valor cercano al 5% - 10% por mas es que este en vacio o en carga, el ciclo util no sube; modifique el lazo de control y lo puse como en el esquematico que posteaste y el problema persiste, tambien he cambiado el valor de la resistencia de sensado de corriente pero tampoco, la verdad estoy muy confundido porq al parecer el diseño como tal esta bien :S
20/11/2008 #210

Avatar de Juan Romero

SMPS Troubleshooting TIPs
Hola Jeisson, ya que las explicaciones anteriores fueron muy pocos convincentes y demasiados excuetas al determinar las posibles fallas, me tome un tiempito en analizar tu diseño para no pecar de "chacharero" y encuentro muchos defectos; claro esta debido a tu poca experiencia y conocimiento teorico del tema, lo cual es dable al empezar en esta area de la electronica de potencia ( fuentes SMPS). Me parece muy bien que hallas empezado con un diseño de mediana complejidad , ya que veo que mucha gente inexperta quiere ya! de una vez! diseñar fuentes de 1000W sin siquiera haber hecho una a la perfeccion de 5W 8-) je,je,je,je .
Bueno, ahora si mi apreciacion de tu diseño:

PRIMERO: El IC que usas tiene ciertas caracteristicas tecnicas a considerar como son un voltaje de arranque Vst=12V, un ciclo de trabajo maximo Dmax=50%.
SEGUNDO: El nucleo de ferrita EA-77-625 del fabricante AMIDON, tiene algunas caracteristicas tecnicas tales como:
Pmax=200W; inductancia especifica Al=5210mH/1000t; area efectiva Ae=1.46cm2
Aunque el nucleo es demasiado grande para la potencia requerida (30W), este es suficiente, pero sin embargo en la seleccion del nucleo no tomaste el criterio del factor del Producto de Areas Ap=Ae*Aw.
TERCERO: Segun tu ckto la frecuencia de oscilacion Fosc=35KHz, valor determinado de la grafica del datasheet.
Calculando tu corriente pico obtengo:

Ipk=2xPo/(nxVminmax)=2x30W/(0.75x142Vx0.5)=0.56A

Calculando la Inductancia minima requerida:

L=Vminmax/(IpkxFosc)=142Vx0.5/(0.56Ax35000Hz)=3622uH

ANALIZANDO: Al tener una Ipk demasiada baja obtengo un Lmin muy elevado para la potencia requerida. Si consideramos que la inductancia de dispercion L(leack) del transformador es 3%, entonces obtenemos un L(leack)=145uH y por lo tanto habria grandes perdidas en el cobre ademas de que esta inductancia disiparia una buena porcion de la potencia entregada en el periodo Ton y no permitiendo acumular energia en el nucleo debido a su descarga en el Toff.
Un valor adecuado para esta potencia seria unos 560uH por ejm, claro esta considerando el incremento de Ipk en unos amperios. El modo de conduccion en la que trabaja tu fuente esta muy proxima a DCM.
CUARTO: Para el valor de numero de espiras del primario que propones Np=44esp, obtengo una densidad de flujo magnetico Bmax=3100Gauss, aunque esta un poco elevado esta dentro del rango, ya que la inductancia se saturacion del nucleo es aproximadamente Bsat=5000Gauss. Siempre es preferible no pasar de 2500Gauss ya que a maxima carga este tiende a incrementarse.
Tambien calculando las vueltas del secundario obtengo:

Ns=(Vo-Vd)(1-Dmax)*Np/(Dmax*Vmin)=5 espiras

Observacion: no se de donde tu calculaste 12 espiras
Los calibres de los conductores que usas tambien no son los adecuados, AWG20 en el secundario, pero si son 2Amp !ese conductor va a calentar aun mas!.
QUINTO: La forma de la realimentacion esta pesimo no se donde sacaste esa configuracion, te sugiero que uses la que publique aqui en paginas anteriores.
Tambien la resistencia sensora de corriente que calculaste no es la adecuada para la potencia que requieres.
Al ckto de realimentacion le hice un analisis de las corrientes que requieres para mejor desempeño.
Algunas corecciones mas las pudes observar en el dibujo adjunto:



Bueno mas cosas detallo luego.....
Ahora si me despido amigo y espero tus comentrios
Imágenes Adjuntas
Tipo de Archivo: jpg correccion_182.jpg (94,3 KB (Kilobytes), 415 visitas)
20/11/2008 #211
Moderador

Avatar de hazard_1998

bueno, leyendo un poco el post del sr alvarado, caigo en la cuenta de que (salvo lo que él aduce en cuanto al transformador se refiere) es practicamente lo que yo comentaba antes, aunque tengo algunas salvedades a lo que él comenta.

1)la tension que aparece en pata 1 con pata 2 a masa no es 2.5V, sino 5V, por otro lado, esa configuracion de realimentacion no es erronea, se usa bastante, ya que requiere un solo punto de compensacion (el tl431) aunque yo no la implemento, pero funciona de la sig manera, el amplificador de error del uc384X es de transconductancia, y su etapa de salida es una fuente de corriente constante para source y un transistor para sink, conectando pata 2 a masa te queda pata 1 con una fuente de corriente constante de 0.5mA tirando hacia arriba, por eso a veces se utiliza de esa manera, yo en lo personal aprobecho el amplificador de error, porque de esta manera tambien puedo regular el limite de corriente, variando el tope de tension sobre pata 1, como la corriente pico de entrada se compara con la tension en pata 1, ajustando la tension maxima de ésta limito la corriente pico de entrada (por lo gral lo hago con un 1n4148 y un zener o con un pnp y un zener)

2)en la seccion de fuente auxiliar para hacer el bootstrap de alimentacion del regulador, el diodo que agrega alvarado no hace falta, ya que por mas que sea forward, para que circule corriente de freeweeling hace falta a la salida de los diodos un inductor, que como no esta nunca puede ocurrir corriente de freeweeling por el diodo que va con anodo a masa. la resistencia que va a continuacion de esto debe ser baja, sino tableteara la fuente de alimentacion del uc384X, 100 ohm en lo personal me parece muchisimo, ya que con pulsos de 50mA la tension que caeria sobre esa R seria de 5V, con lo que podria llegar a fallar la fuente por caer muy cerca de la zona de UVLO del UC384X, ademas, esa R esta solamente para absorber ruidos de conmutacion, cosa que puede ser realmente chica.

3)teniendo en cuenta el tipo de problema que tiene jaisson, ni como este configurado eltl431, ni como este configurado el amplificador de error, ni como este hecho el transformador es el problema, ya que dice que el duty cycle esta en 5% aprox y que no se mueve de ahi cuando le cambia la carga, si el problema fuera por esos puntos el duty cycle quedaria al maximo (50%) y no entregaria mas tension, aca pasa otra cosa, que revise bien que tension llega a pata 3, que chequee y compare la tension de pata 1 contra pata 3 y que se fije si no esta limitando por corriente, por otro lado, el uc3844 necesita 16V minimos para que encienda, si no llega a levantar correctamente a la fuente auxiliar va a tener un comportamiento erratico.
22/11/2008 #212

Avatar de Juan Romero

Buen dia amigos, acabo de leer la ultima respuesta y quisiera hacer unas aclaraciones al respecto

A) Si, es cierto el voltaje en la salida del comparador (pin1) es aproximadamente 5V y no 2.5V como puse en el diagrama.
B)La configuracion que usan en ese diagrama ya lo habia visto usar en otros tipos de integrados controladores para SMPS (como los de Fairchild) pero nunca en los de la serie UC38XX y eso que yo tengo información variada de aplicaciones de este IC. Le pediria a Hazard que me remita un ckto con esta aplicacion para estudiarlo.
C)En lo personal me parece un tecnicismo decir alimentacion "bootstrap"; yo lo conosco como circuito de "bias" o ckto auxiliar de alimentacion. Aunque conosco la terminologia no he visto que la usen para identificalo asi; sin embargo si es usada en otras aplicaciones que no vienen al caso. Ejm voltaje de bootstrap: voltaje de autolevantamiento o auto generado y asi,asi,etc, tonterias ¿no?
D)En cuanto al diodo si tiene razon hazard; si este se usa necesariamente debe de tambien tener una bobina para en la salida tener una corriente entregada pòr el diodo forward y otra por el diodo freeweeling (el que adicioné)
Pero si no se usa ese condensador de salida del ckto auxiliar deberia de ser un poco mayor (470uF), para retener mas carga hasta que pase el periodo de toff y empiece el nuevo periodo ton y asi de esta manera asegurar la alimentacion del IC en ambos periodos. bla,bla,mas tonterias
E)En cuanto al la resistencia de 100ohm yo no dije que necesariamente tiene que ser 100ohm, si no que debe de estar en el rango de 10 a 100ohm y para hallar el valor adecuado no hay ecuacion que te determine su valor, bueno por lo menos yo no la conosco, pero si se que se determina experimentalmente considerandolo en maxima carga y a maximo voltaje de entrada y considerando que el voltaje de bias no sobrepase el nivel de alimentacion del IC (30V). Algunos otros IC de control llevan un ctko llamado OVP (over voltage protection) o proteccion contra sobrevoltajes y el UC38XX no lo tiene. :evil:
En los años que llevo reparando fuentes SMPS don Hazard te aseguro que si revizas una fuente de "play station" encontraras una resistencia de 120ohm en esa posicion (solo cuando se uas la seri UC38XX o KA38XX).
Y terminando esta "chachara barata" le pediria al señor Jeisson que de mas detalles de su fuente para poder ayudarle.

Saludos amigos.
01/12/2008 #213

Avatar de Juan Romero

Link de Universidades Aplicadas en SMPS
Hola compañeros, aqui les dejo un Link de una pagina WEB de aplicaciones en diseño de fuentes Conmutadas o SMPS y ademas de las instituciones dedicadas en este campo de investigacion:
El link es: http://www.smps.com/universities.shtml
Tambien pueden observar en la figura adjunta (enmarcado en rojo) donde ubicar a los docentes dedicados a esta materia en la Universidad en la cual soy miembro:



Saludos amigos.
05/12/2008 #214

Avatar de luisgrillo

Buenas colegas, despues de haberme gastado una millonada en transistores de todos colores y sabores para realizar mi fuente tipo flyback y quererle sacar por lo menos 20W, TODOS, pero todos los transistores explotan como si fueran fuegos artificiales, todo esta jalando perfecto con solo la fuente reguando, me regula perfecto los 15v y me consume solo 30 miliamperes de la red de 110V, soy de mexico hehe, le conecto un foco de 12v 4Watts y funciona bien, pero le conecto uno de 25W y PAWN.!vuela como si se hubiera tomado un redbull, aaaa, pero no se va solo, se lleva tambien el PWM, sea cual sea, ka3842, sg3525, tl494, el que sea, el transformadorr es de una fuente de computadora, tengo 30 vueltas en el primario y 19 vueltas en el secundario, (principalmente calculado para un voltaje de 25V, supongo que no debe de haber algun problema al regular con el tl431 a 15v con el debanado para 25V, pero bueno, ya estoy en la ruina por que me he gastado unos 50 dolares en los PWM y transistores, fet, bipolares y mosfet.
Porfavor nesesito ayuda, el diagrama es exactamente el mismo de la fuente de 15 volts.
Imágenes Adjuntas
Tipo de Archivo: jpg circuito_451.jpg (107,3 KB (Kilobytes), 580 visitas)
06/12/2008 #215

Avatar de Juan Romero

hola luisgrillo, me parece excelente tu determinacion en hacer funcionar esa fuente; te comento que a mi me paso lo mismo , es decir tambien queme decenas de ICs y mosfets, todavia guardo algunos de recuerdo.
Te felicito vas por buen camino, solo te falta determinar porque se queman los componentes y ya! .
Pero para poder ayudarte necesito algunos detalles respecto a tu fuente:
1) El transformador lo armaste tu o es recliclado tal cual lo encontraste en otra fuente.
2) De que valor es tu resistencia sensora?
3) Has medido hasta cuanto sube la tension a maxima carga en el bobinado auxiliar?, te pregunto, porque en mi caso esa era la falla de la fuente que hice. Parece que por tal motivo se quema el IC.

Con el valor de espiras de Np=30espiras y Ns=19espiras he podido determinar que la maxima razon de servicio que se requiere es de Dmax=15.8%, por lo tanto eso no es la falla, el IC da para mas.
Haber brinda mas detalles para ayudarte.

Saludos amigo.
06/12/2008 #216

Avatar de luisgrillo

Muy buenas Ramon, te doy mas detalles,

el transformador lo rebobine, era uno de una fuente de computadora, creo que el nucleo es un EI-33, no estoy muy seguro, no recuerdo que decia, pero la fuente me entregama maxico 450Watts.

la resistencia sensora es de .22ohms, la he variado de 2.2 asta .22, me canse de que se tronara todo y le hice un circuito aparte para medir la corriente en la resistencia y suprimirme la salida del pwm al transistor y me ha ayudado a mantener vivo a un pequeño k2645.

Al principio, cuando me regulaba bien, tenia alrededor de 20 volts en el debanado auxiliar,
pero ahorita ya no tengo salida, bueno, tengo una salida rara, el transistor se calienta muchisimo y a la salida como que el voltaje oscila, viene y va, cambie el transistor por uno nuevesito y el problema sigue,
detecte algo raro con el osciloscopio a la salida de un tl494 que tengo ahorita, cuando hay un nvel alto en la salida, veo esta salida (imagen000)
como ya no tengo mas CI`s no se si sea la causa del problema para checar en el circuito, tendre que esperar al dia de pago. asi que como lo ves?
Imágenes Adjuntas
Tipo de Archivo: jpg imagen000_254.jpg (38,7 KB (Kilobytes), 602 visitas)
07/12/2008 #217

Avatar de Juan Romero

ahora si me dejas desconcertado ; no se qie IC estas usando, primero dices que el ckto es el mismo que use yo con el UC3842 y luego comentas que las señañes de salida son del TL494 .
Para no confundirnos porque no subes tu esquema y asi nos entenderemos mejor.

Saludos.
07/12/2008 #218

Avatar de luisgrillo

hehe, esque me canse de ese circuito y agarre otro y cambie unos valores pero pues de todos modos no encuentro el problema, he buscado, rearmado y modificado y nop, sigo en las mismas, y no me pienso rendir con estas fuentes. aqui te mando el circuito
Imágenes Adjuntas
Tipo de Archivo: jpg imagen003_136.jpg (52,7 KB (Kilobytes), 856 visitas)
07/12/2008 #219

Avatar de luisgrillo

compañeros, ya pude hacer que regulara otraves , cambie el tl494 y me da la saida perfecta, regulando a 15v, a salida le pido 25W (con un foco de 12v) me los da pero el voltaje vaja a 13V y en la red me consume .95 ampleres de alterna a 110V , le pido 40W con otro foco y el voltaje se me cae asta 5V :( , y ya no alcanse a ver la corriente por que el transistor k526 trono =/, recuerden que el transformador esta diseñado para entregarme +-25volts, asi que el factor Dmax no es inconveniente. ya no se que hacer, ya me gaste dinero que no me deberia de haber gastado en transistores, aparte de que ya acave con el arsenal de transistores que habia en la tienda de electronica hehe.
grasias por todo, cualquier comentario ayudari bastante.
07/12/2008 #220


Lo único que se me ocurre es que estés saturando al núcleo.
¿Calculaste el flujo magnético máximo?
Porque si te consume unos 0,95A eficaces, la corriente pico debe ser algo grande y es probable que te sature el núcleo.
No sé qué núcleo usás, pero vamos con los cálculos para un supuesto núcleo para ver si se satura.
Supongamos:
µr = 2000µo
ln = 6cm = 0,06m
Bsat = 0,5T

B = µr x µo x N x I / ln

Isat = Bsat x ln / (µr x µo x N)
Isat = 0,5T x 0,06m / (2000 x 4x10^(-7) x Pi x 30) = 0,4A

donde:
Isat: corriente de saturación
Bsat: flujo de saturacion
ln: longitud del núcleo
N: espiras del primario (creo que dijiste que eran 30)
µr: permeabilidad relativa del núcleo
µo: permeabilidad del vacío (4x10^(-7) x Pi)

Los valores supuestos son muy optimistas, seguramente µr es mayor y ln es menor, por lo que la corriente de saturación sea menor.
Ajustá el cálculo a los datos de tu núcleo, pero supongo que va a dar algo parecido o peor.
Imaginate que con 0,4A picos ya saturás el supuesto núcleo, y vos estás midiendo una corriente eficaz de 0,95A, por lo tanto, la corriente pico es muy superior a los 0,4A.
Recordá que cuando el núcleo se satura, el primario del transformador se comporta como un cortocircuito, provocando que la corriente suba mucho y vuele tus mosfets.
Recalculá las espiras del primario para evitar que se sature, y si no te dan las cuentas, conseguí un núcleo más grande.
Calculá la corriente de saturación y en base a eso, con la resistencia sensora de corriente, asegurate que los valores de corriente no se aproximen al de saturación.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Fuentes de Alimentación

Circuitos de alimentación, reguladores de voltaje, UPS, cargadores de batería, celdas solares, acumuladores, baterias, pilas...

Cerrar
Foros de Electrónica » Diseño analógico » Fuentes de Alimentación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.