Haz una pregunta
  Foros de Electrónica » Diseño analógico » Fuentes de Alimentación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

16/06/2015 #1301


hazard_1998 dijo: Ver Mensaje
drago, podrias primero que nada postear un oscilograma de lo que hay entre drain y gnd de tu fuente en vacio y con carga? por otro lado, el layout del PCB deja bastante que desear... deberías evaluar repensar por completo el circuito impreso...
Claro amigo te envió imágenes del oscilograma y así me puedas ayudar.

La imagen 1 es sin ninguna carga

La imagen 2 es con una carga de 1.3amp

La imagen 3 es una carga que no puedo medir el amperaje ya que es donde cae el voltaje de salida a 5.8V

Las muestra fueron tomada a 2us por división y 5v*10x en la punta del osciloscopio que daría 50v por división. La fuente esta ajustada a 12.5v en salida y trabaja con 110V ya que es el suministro eléctrico en mi país. Las prueba las tomo como me dijiste (entre drain y gnd)

Amigo dime que vez mal en el layout para corregir todo en la próxima placa.
17/06/2015 #1302
Moderador

Avatar de hazard_1998

drago, para empezar, baja un poco la frecuencia de oscilacion (la estas haciendo andar a 100Khz.. bajala a 50-55Khz) despues, agregale el roll off al TL431 (esta inestable el lazo y por eso te esta oscilando la realimentacion en la imagen 3 y en la 1.

por ultimo, el layout... como te decia en el otro post... fijate como dejaste las masas.. tenes que tener en cuenta que las pistas de GND son criticas, primero porque es el retorno del gate del mosfet, ademas, es referencia de 0V del UC3842 tanto para la realimentacion como para la medicion de corriente del mosfet. con lo cual, tiene que tener la menor inductancia posible todo el lazo de masa.(pistas cortas, directas y sin muchos zigzag) la resistencia con la que se mide la corriente de source del mosfet (la que colocaste de 0.1 ohms) debe ser de baja inductancia tambien (metal film) sino va a ser imposible que funcione correctamente el lazo.
17/06/2015 #1303


Gracias amigo hazard por echarme la mano.
Tengo todo entendido ahora sobre la pcb.

Pero tengo dos pregunta.
1 Porque bajar la frecuencia a 50-55khz si todo esta calculado para 100khz o es que yo estoy equivocado en calcular la frecuencia en 100Khz.
2 Disculpa mi ignorancia en esto pero no encuentro como colocar roll off en el tl431
17/06/2015 #1304


hazard_1998 dijo: Ver Mensaje
debe ser de baja inductancia tambien (metal film) sino va a ser imposible que funcione correctamente el lazo.
Asi es, en algunos circuitos vi como 3 a cuatro resistencias en paralelo de metal film
17/06/2015 #1305


hazard ya realice las pruebas que comentas y no tuve mejora. Baje la frecuencia a 50 y no mejoro nada.

El problema de la resistencia corriente sensor es que no consigo ese material. Pero seguire buscando en chatarra.

Ahora estuve cambiando un poco la configuración en el opto y baje a un 1k la resistencia que va del pin3 del opto a gnd. También coloque una resistencia del pin1 al2 del opto como una carga y mejoro bastante. Ya logro llegar a los 5amp con solo 500mv de caída. Voy mejorando poco a poco. jejejeje
17/06/2015 #1306

Avatar de shevchenko

No te olvides de pegar muy bien el núcleo con cianoacrilato, también deja bien fijo el carretel al núcleo y no te olvides de la vuelta de cinta de cobre que envuelve al núcleo: primero una vuelta de cinta de papel o simple papel, y arriba la cinta, y la mandas a GND aunque algunos diseños al + del cap que filtra la linea
18/06/2015 #1307
Moderador

Avatar de hazard_1998

drago109 dijo: Ver Mensaje
Gracias amigo hazard por echarme la mano.
Tengo todo entendido ahora sobre la pcb.

Pero tengo dos pregunta.
1 Porque bajar la frecuencia a 50-55khz si todo esta calculado para 100khz o es que yo estoy equivocado en calcular la frecuencia en 100Khz.
2 Disculpa mi ignorancia en esto pero no encuentro como colocar roll off en el tl431
tenes que limitar el ancho de banda del TL431, haciendo que gane por debajo de 1 antes que te quedes sin margen de fase (sino te va a quedar oscilando la realimentacion) para eso, entre el catodo del zener programable y la pata de referencia, colocale (para empezar) un condensador de.. 220nF (quiza tengas que subirlo de valor posteriormente)
18/06/2015 #1308


Lamento no haber sido de ayuda, pero sigo en la opinión de que 70uh es una inductancia muy baja y como te digo impacta en el ciclo de trabajo de tu fuente.

Otra cosa a tener en cuenta sobre lo que dijo hazard sobre el pcb es que la alimentación debe ir primero al capacitor y de ahí distribuirse al resto del circuito en conexión estrella. El capacitor de 220uf (si es el que tienes puesto) también está limitado para ser una fuente de 100W.
18/06/2015 #1309


Amigo Drago: Podrias compartir tus modificaciones en un esquema?
20/06/2015 #1310


Hola como estan, estas es mi primera publicacion en el foro, me gustaria saber de donde consiguen sus transformadores. recien empiezo y el problema principal que veo son los transformadores de nucleo de ferrita o si hay alguna manera de fabricarlos. soy de Perú. Lei como 20 paginas de este foro, espero no a verme saltado la parte de los transformadores. gracias-
20/06/2015 #1311

Avatar de yosimiro

Puedes reciclarlos de monitores, lectores de DVD hogareños, fuentes AT o ATX, etc.
Así que...

A cacharrear.

O...
http://witronica.com/tabla_proveedores
20/06/2015 #1312

Avatar de shevchenko

Yo los reciclo por no poder comprarlos... con el tiempo juntaras muchos, esta bueno etiquetarlos, por ejemplo si era de una fuente de pc, o de un monitor o de lo que sea, de esta forma poder predecir con que ic era usado para saber su frecuencia aproximada (por ejemplo uc3843 tipico de monitores, o si era de una pc con tl494)
Podes reciclar tambien el carretel, incluso el alambre y los aislantes (no siempre claro)
Busque hay un post para abrirlos sin romper! ya que son frágiles....
Imágenes Adjuntas
Tipo de Archivo: jpg Foto-0008.jpg (87,7 KB (Kilobytes), 50 visitas)
Tipo de Archivo: jpg Foto-0006.jpg (84,5 KB (Kilobytes), 45 visitas)
21/06/2015 #1313


Gracias por su respuesta, me conseguire algun transformador a ver si me ayudan a saber sus caracteristicas
21/06/2015 #1314


Les vengo a comentar que ya pude hacer funcionar la fuente sacando los 8amp que esperaba obtener. Seguí el paso que me comento Shevchenko de la fuente hp de tal manera que elimine el tl431 y solo use un Zener fijo de 10v con una resistencia variable y una resistencia en paralelo con led del opto para simular una carga y los resultados fueron extraordinarios. En ful carga solo cae 500mv pero ya no es dolor de cabeza. Jejeje Use una resistencia de 0.27ohm para el sensor corriente y me limita a los 8amp de salida. En ful carga tengo una eficiencia del 75%.
Ahora ya que tengo la fuente funcionando voy a dedicarme a hacer una nueva placa corrigiendo los errores en el pcb y siguiendo los consejos que me han dado.

hazard_1998
Realice los cambio que me propusiste y no tuve resultados. Tanta guerra me dio el tl431 que termine eliminándolo. No se por que me sucedió pero fue un problema con el tl431.

vrainom de verdad que todos los comentarios son ayuda asi que les agradezco mucho por estar atento a ayudarnos en el foro.
Sobre los uh del transformador es que de verdad parece poco pero en 3 formulas que use me dio el mismo valor. Y use mas de 10 formulas de embobinado y ninguna me dio mejor resultados que la que use.

Mushito voy a corregir todos los cambio que realice en el pcb y subo el circuito para los que quieran probar de este modo.

7up
Yo en mi caso me fui para un taller de televisores de confianza y ellos tienen muchas placas que le han quedado de televisores dañado. Cuando me empezaron a sacar placas pensé que estaba en la gloria con tanto transformadores de todos tamaño que asta me termine trayendo 10 de los mas grande. También aproveche de sacarles los condensadores de 1kv que aca en donde vivo es difícil encontrarlos.
25/06/2015 #1315


Amigos quiero hacerles otra pregunta sobre una duda que quisiera despejar.

Resulta que ya tengo con la fuente mas de 4 días funcionando todo sin problemas llegando asta un limite de 8amp muy rara vez ya que mayormente esta en los 6 a 7amp pero al revisar la fuente esta todo bien solo con un detalle de que el transformador me calienta. No tanto como para quemarse pero me parece raro ya que en otras fuentes no siento que caliente el transformador. Ya le agregue mas alambre en paralelo por si es eso pero sigue dando la misma temperatura.

Mi pregunta es si eso es normal o será algún problema en el transformador.

Saludos
26/06/2015 #1316


drago109 dijo: Ver Mensaje
Mushito voy a corregir todos los cambio que realice en el pcb y subo el circuito para los que quieran probar de este modo.
Ya pues...
26/06/2015 #1317

Avatar de shevchenko

Puede calentarse por que se calienta el alambre primario, o secundario, pero si estan calculados correctamente para la potencia que le estas sacando y la frecuencia.... puede ser que el núcleo se este saturando y sea eso. Podes hacer una prueba agrandando el gap 0.5 mm, también hay que ver si el núcleo estaba diseñado para esa potencia...

Podes consultar la tabla de calibres donde dice los amperes que aguanta y la frecuencia a la que puede trabajar sin perder sección por efecto piel...

osea consulta la tabla si esta todo bien es el núcleo, también comprobá que no haya continuidad entre los bobinados y el núcleo por las dudas...
no te olvides que tiene que estar bien pegado el núcleo y bien fijo el carretel, ademas que tenes que ponerle la lamina de cobre que evita que se irradie ruido eléctrico para otros aparatos incluso el mismo integrado pwm

Saludos!
26/06/2015 #1318


Gracias amigo. Siempre atento a ayudar.
Ya recalcule el alambre y estaba bien pero de igual modo le coloque dos alambre mas al secundario y uno en el secundario y la temperatura no disminuyo. Sigue igual de tal modo que descarto el alambre.
El gap lo tengo ahorita en 0.5mm respetando la inductancia ya que si aumento el gap bajo la inductancia.
Otra cosa que noto es que el núcleo es el que calienta mas que el alambre

Pero los núcleos no los tengo bien pegado pero si bien fijado con la cinta. No los he pegado ya que el gap lo hice con unas tiras plásticas de las que usan para radiografías. Puede ser que sea eso? Lo hice de esta manera ya que muchos comenta que se puede hacer así pero no se del todo si es cierto ya que los hierros laterales no se tocan y no lograría disipar la calor.

La cinta de cobre no la tengo entre cada bobinado pero si la tengo al final que cubre bobina y núcleo para que no salga ruido. Pero para la próxima lo colocare entre cada bobina.
28/06/2015 #1319


Amigo Mushito lo prometido es deuda.
Monto imágenes del esquema pcb y fuente ya realizada.

Cabe mencionar que el circuito ya esta funcionando al 100% sin caída de tensión con un limite de 8amp a 14V después de tanto romperme la cabeza y con ayuda de los miembros del foro logre hacerla andar. Solo tuve que realizar algunos cambios en el esquema.

Comento que en la salida de la bobina Aux le he colocado un circuito estabilizador a 28V con un zener para proteger el UC3842 y el Mosfet al elevar el voltaje.

Según las pruebas realizadas la fuente tiene una eficiencia del 75% en el peor de los casos.

Bueno dejo las imágenes
Imágenes Adjuntas
Tipo de Archivo: jpg Esquema Fuente FlyBack.jpg (42,2 KB (Kilobytes), 175 visitas)
Tipo de Archivo: jpg PCB Fuente FlyBack.jpg (233,3 KB (Kilobytes), 120 visitas)
Tipo de Archivo: jpg 1.jpg (71,4 KB (Kilobytes), 106 visitas)
Tipo de Archivo: jpg 2.jpg (71,3 KB (Kilobytes), 91 visitas)
Tipo de Archivo: jpg 3.jpg (69,4 KB (Kilobytes), 90 visitas)
Tipo de Archivo: jpg 4.jpg (60,4 KB (Kilobytes), 85 visitas)
Tipo de Archivo: jpg 5.jpg (63,0 KB (Kilobytes), 82 visitas)
29/06/2015 #1320


Gracias por compartir esto, se que será de mucha utilidad para todos los que quieren montar fuentes switching de esta potencia o de otras, felicidades.
Una pregunta... ¿para que sirve S1 y S2 con su conector tipo peine hembra? otra pregunta, existe un puente que se ve en el PCB, pero en las fotos se ve una resitencia?
Gracias nuevamente.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Fuentes de Alimentación

Circuitos de alimentación, reguladores de voltaje, UPS, cargadores de batería, celdas solares, acumuladores, baterias, pilas...

Cerrar
Foros de Electrónica » Diseño analógico » Fuentes de Alimentación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.