Haz una pregunta
  Foros de Electrónica » Diseño analógico » Fuentes de Alimentación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

17/05/2008 #1


Problema con convertidor Buck 0-600V
Hola, estoy intentando armar un convertidor CC-CC que partiendo de 600V puede obtener una tensión variable de 0 a 600. Pensé en utilizar un topología tipo buck. Mi problema es el siguiente, cuando conecté la entrada del buck a 160V (el mosfet era de 600), el mosfet se quemó. Luego, para ver las posibles causas, cambié la tensión de entrada a 12V y fui variando el Duty-Cycle. Con el osciloscopio observé lo que está en las fotos que adjunto (la señal de arriba es la tensión sobre la resistencia y la de abajo la tensión Gate-Source, ambas a 10V/Div). La resistencia de carga es de 5k...No se debería ver una cuadrada sobre la resistencia? Adjunto también el esquema y una foto del circuito. Espero que puedan darme una mano con esto. Saludos
18/05/2008 #2

Avatar de Jazz_Light

Oye.... qué es el diode_virtual....?


Quizá necesites poner una resistencia entre Gate-Source para descargar la compuerta cuando desparece el pulso de disparo. El valor puedes determinarlo tú usando el osciloscopio.


Ah.... supongo que ese no es el diseño definitivo, porque le faltan varias cosas...


Suerte con tu proyecto!
18/05/2008 #3

Avatar de Eduardo

Saca esos condensadores de 680nF (que no se para que los pusiste)
18/05/2008 #4


Oye.... qué es el diode_virtual....?
Es un diodo genérico que tiene el Multisim...

Quizá necesites poner una resistencia entre Gate-Source para descargar la compuerta cuando desparece el pulso de disparo. El valor puedes determinarlo tú usando el osciloscopio.
Probé poner una resistencia de 200 Ohm pero todo sigue igual.

Ah.... supongo que ese no es el diseño definitivo, porque le faltan varias cosas...
Efectivamente, esto era solo para probar el transistor y el corte...el lo probé y quemé un transistor...por eso, estuve simplificando el circuito y me encontré con eso...

Saca esos condensadores de 680nF (que no se para que los pusiste)
Saqué los capacitores y la cosa no cambia del todo, simplemente se ve (aunque cambie el DC) como en la imagen DSCF1185.JPG...

Los capacitores los puse para eliminar las componenetes de continua que puede llegar a haber...esto lo saqué del siguiente artículo, en el cual agregan además una red snubber que yo no implementé porque no lo creí necesario (en la señal del gate no se ven picos de tensión...) aunque quizás sea necesario...

http://www.itee.uq.edu.au/~elec4400/...te%20drive.pdf

Cuando compre otro MOSFET voy a probar ponerle un zener entre gate y source para evitar que la tensión de gate se eleve mas allá de limites razonables...quizás de esta forma pueda evitar que se queme.
18/05/2008 #5

Avatar de Eduardo

fchouza dijo:
.....Saqué los capacitores y la cosa no cambia del todo, simplemente se ve (aunque cambie el DC) como en la imagen DSCF1185.JPG...

Los capacitores los puse para eliminar las componenetes de continua que puede llegar a haber...esto lo saqué del siguiente artículo, en el cual agregan además una red snubber que yo no implementé porque no lo creí necesario (en la señal del gate no se ven picos de tensión...) aunque quizás sea necesario...

http://www.itee.uq.edu.au/~elec4400/...te%20drive.pdf
El circuito que usaste de referencia tiene en la sallda otro diodo+C+R , sin eso, es lo mismo que tener la salida del transformador y el diodo.

El condensador del primario es conveniente en el otro circuito porque esta excitando con un 7414 , vos estas usando un TL494 que tiene salida de colector abierto.
18/05/2008 #6


Ok, voy a probar copiar el circuito tal cual. De todas formas en el texto dice sobre el diodo+C+R que es un "snubber to dissipate voltage transients caused by loosely coupled secondary inductance", y en el osciloscopio no se ve ningún pico de tensión. Es más, la tensón en la compuerta cae bastante rápidamente, no siendo así la tensión Vds.

Yo el TL494 lo conecto de la siguiente forma



Bueno, voy a probar esto y les digo como me fué...

Saludos
18/05/2008 #7


Cambié la resistencia de carga del mosfet de 5k a 100 ohm y la forma de la señal mejoró...quedó como muestra la figura, a que s epuede deber esto?.

De todas formas, cuando el DC se hace muy grande, la tensión en el gate va cayendo y corta antes de tiempo...

La señal de arriba corresponde a la tensión sobre la resistencia y la de abajo a la tensión en el gate respecto al source.
Imágenes Adjuntas
Tipo de Archivo: jpg dscf1195_764.jpg (18,4 KB (Kilobytes), 852 visitas)
Tipo de Archivo: jpg dscf1194_162.jpg (18,1 KB (Kilobytes), 843 visitas)
Tipo de Archivo: jpg dscf1193_358.jpg (18,4 KB (Kilobytes), 846 visitas)
18/05/2008 #8

Avatar de Eduardo

fchouza dijo:
...Yo el TL494 lo conecto de la siguiente forma ...
? ? Y al primario del transformador con el condensador en serie donde lo pones?

Edito y agrego:

Los oscilogramas bien.
Pero porque no pones el circuito de prueba completo? En lo poco que pusiste se ve que es cualquier cosa.
18/05/2008 #9


Acá va el diagrama del circuito de prueba. Saludos

Edito: El diodo es un UF4007
Archivos Adjuntos
Tipo de Archivo: pdf mosfet_104.pdf (45,2 KB (Kilobytes), 236 visitas)
18/05/2008 #10

Avatar de Eduardo

? ? ? Que descarga a C1 --> Nada, termina cargandose con 12V.
Para usar eso necesitas un resistencia de pull down.

Por que no le haces la salida clasica al TL494 en lugar de estar adaptando configuraciones de integrados completamente diferentes?
18/05/2008 #11

Avatar de Elvic

Verificar
hola fchouza

bueno he estado leyendo un poco lo que cometan sobre esto; según lo que pude entender la señal PWM si la recibe el mosfet , el driver por lo tanto esta funcionando, aquí lo critico es la bobina que utilizas, es decir, debe ser de un valor adecuado la que mustrsa en la imagen no funcionara por lo general las que se utilizan para este tipo de circuitos son con núcleo de ferrita, ademas a que frecuencia estas conmutando el mosfet, el ultimo Circuito que pones no se parece mucho a la configuración buck



pues el circuito que tu propones lo único que haces es mandar a tierra la carga, que supongo es la R de 100ohm
verifica bien la configuración del buck;

solo como dato... no lo simules en multisim este tipo de circuitos, mejor utiliza otros que son mas especifico como el ORCAD o PSCAD.

otra cosa veo que indicas un trasformador de aislamiento para la compuerta del mosfet, no es necesario por lo pronto, pues estas utilizando la misma fuente para alimentar el driver y el mosfet según el ultimo circuito que has puesto.


algo de teoría
http://ciecfie.epn.edu.ec/Automatiza...c7_conver.html
19/05/2008 #12


Hola Elvic

Sin duda el driver esta funcionando. La señal al gate llega correctamente y con cargas pequeñas la señal se muestra como corresponde. Es más, en la simulación, al alimentar el MOSFET con un generador de señales cuadradas sucede los mismo, así que se debe tratar de alguna propiedad del MOSFET que no estoy teniendo en cuenta. En otro foro me sugirieron que podía deberse a la capacidad de Miller que presenta el MOSFET entre gate y drain.

Ahora yendo al problema en concreto, el circuito que ponía era simplemente para probar el MOSFET, el inductor, el diodo y el capacitor de filtrado no los puse en ese circuito porque era simplemente una prueba. Anteriormente a realizar esta prueba, monté el circuito entero y lo alimenté con 36V, y el circuito funcionaba ok, podía variar la tensión entre 0 y
34V, pero solo con una pequeña carga, cuando aumentaba la corriente, la tensión bajaba y el MOSFET comenzaba a calentar (supongo que la operación estaría cambiando de modo contnuo a discontinuo). Luego, en mi afán de seguir experimentando, cambié la tensión de entrada a 160V (volviendo a poner la carga de 5k) y el mosfet se quemó.

Por otra parte, me encuentro con algunas dificultades a la hora de calcular el inductor, ya que en todos los casos, los cálculos son para una tensión de salida, en mi caso, necesito una tensión variable. Por lo tanto, to0mé un valor medio, no se si esto es correcto...que opinan ustedes?
19/05/2008 #13

Avatar de Jazz_Light

Qué mosfet estás usando?
19/05/2008 #14


Bueno, les comento que estuve haciendo pruebas con el circuito y armé el circuito que adjunto. Es un buck que varía entre 0 y 12V. El problema fundamental es que la señal en el gate tiene un fall time muy grande (mas tarde voy a probar agregarle una etapa push-pull al TL494) entonces para DC muy bajos no queda una cuadrada sino algo raro...Además, estuve intentando medir la corriente que circula por el inductor colocando una resistencia pequeña en serie. Les adjunto las fotos de las formas de señal, la de abajo es la tensión del gate para varios duty cycle y la de arriba es la tensión sobre la resistencia en serie con el inductor (la de abajo son 10V/div y la de arriba 0.5V/div...así que haciendo la cuenta, serían algo así como 0.8A/div y ambas 2uS/div). Por lo que puedo observar esta operando en modo discontinuo...

El mosfet que estoy utilizando en este momento es un IRF3205...El que estaba usando antes era un IRFP250.

Bueno, ahora me voy a comprar unos MOSFET de mas tensión para seguir haciendo pruebas...

Saludos
Imágenes Adjuntas
Tipo de Archivo: jpg dscf1201_118.jpg (21,5 KB (Kilobytes), 382 visitas)
Tipo de Archivo: jpg dscf1200_295.jpg (20,7 KB (Kilobytes), 373 visitas)
Tipo de Archivo: jpg dscf1199_120.jpg (22,5 KB (Kilobytes), 376 visitas)
Archivos Adjuntos
Tipo de Archivo: pdf buck_178.pdf (15,1 KB (Kilobytes), 105 visitas)
20/05/2008 #15

Avatar de Elvic

fchouza dijo:

pero solo con una pequeña carga, cuando aumentaba la corriente, la tensión bajaba y el MOSFET comenzaba a calentar (supongo que la operación estaría cambiando de modo contnuo a discontinuo). Luego, en mi afán de seguir experimentando, cambié la tensión de entrada a 160V (volviendo a poner la carga de 5k) y el mosfet se quemó.

Por otra parte, me encuentro con algunas dificultades a la hora de calcular el inductor, ya que en todos los casos, los cálculos son para una tensión de salida, en mi caso, necesito una tensión variable. Por lo tanto, to0mé un valor medio, no se si esto es correcto...que opinan ustedes?
hola otra ves pues la tensión disminuye precisamente por eso, al aumentar la carga demandas mas corriente, lo cual provoca una rápida descarga del capacitor y como la bobina no es capas de mantearla la corriente por lo tanto el voltaje se cae, y si varias el ciclo de trabajo del PWM paarq ue l mosfet se quede activo pues el consumo de corriente que circula por e mosfet es muy grande y por eso se calienta. por cierto a que frecuencia estas conmutando el mosfet?; debe de encontrarse en una rango de 1khz a 100 khz.
y es verdad eso eso de el calculo de la Bobina es para tensiones ya establecida según la necesidad que se tenga, no me entendí bien, de que era variable 0 a 600v.
Pues un convertidor CC CC se podría entender como si se tratase de un "trasformador" en este caso de CC;(pongo entre comillas pues no quiero que se mal interpreten esta palabra) pues en estos lo que proporciona es una tensión constante pero no variable como bien me hiciste notar.
ahora para esto que tu quieres hacer, seria mejor diseñar un regulador lineal <No un convertidor >
o esperemos a que alguien mas experimentado nos diga otra cosa en relación a esto

suerte
23/05/2008 #16


Gracias por las respuestas, respecto a tu comentario:

ahora para esto que tu quieres hacer, seria mejor diseñar un regulador lineal <No un convertidor> o esperemos a que alguien mas experimentado nos diga otra cosa en relación a esto
Ya estoy en eso, de hecho, ya esta funcionando la fuente lineal. Aunque con un pequeño problema que puse en otro thread.
27/10/2008 #17


Hola a todos.

Ya pregunté esto en otro hilo que no tuvo mucho éxito y no obtuve respuesta. De hecho citaba como fuente de mi pregunta el articulo sobre disparar mosfet con transformadorr de pulsos que hay en un link aqui publicado por eso vengo ahora a preguntar aquí directamente

El articulo, subido por fchouza es el siguiente, repito el link:
http://www.itee.uq.edu.au/~ele.....0drive.pdf


Veo que para este convertidor BUCK el mosfet se dispara sin problema con el transformador de pulsos

Pero para una topología en puente como la de la imagen, alguien ve algun problema?
Espero que no sea una barbaridad... jeje

Ya se que lo habitual es poner un Driver tipo el IR2210 pero me interesaría alguna forma de disparo que aporte aislamiento galvánico (como esto) o tambien óptico.

Saludos!
Imágenes Adjuntas
Tipo de Archivo: gif bridge_148.gif (13,0 KB (Kilobytes), 171 visitas)
07/11/2008 #18


Diganme al menos que les parece.

es una pregunta maldita! jaja
Ya lo he preguntado en dos hilos del foro relaciondos con el tema durante el mes pasado sin recibir ni una opinion.

Imagino que no podrá hacerse.

Saludos
I
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Fuentes de Alimentación

Circuitos de alimentación, reguladores de voltaje, UPS, cargadores de batería, celdas solares, acumuladores, baterias, pilas...

Cerrar
Foros de Electrónica » Diseño analógico » Fuentes de Alimentación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.