Haz una pregunta
  Foros de Electrónica » Diseño analógico » Fuentes de Alimentación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

16/08/2008 #1


¿Tendré Problemas de condensador o de cristal?
Hola gente qué tal...

Sucede que debo alimentar un circuito a partir de un transformador que tiene salidas de 26 V y
11 v, cabe anotar que el circuito impreso está compuesto por microcontroladores pic16f877 y cristales de 4mhz, que se encargan de controlar unos displays grandotes (que consumen bastante corriente).

Hasta ahí todo normal, pero cuando alimento las diferentes etapas que son:
1. alimentación de displays
2. alimentacion de µC

El circuito se vuelve loco, es tan curioso, que cuando uno le da un leve toque al cristal del circuito impreso, el sistema trata de funcionar (el algoritmo de los micros está bien hecho, porque se ha montado en placas de prueba y ha funcionado perfectamente). Alguno de ustedes sabe (o tiene un circuito) cómo se debe acoplar un transformador de bastante corriente como el que estoy utilizando, para alimentar correctamente sistemas de 5 voltios y sistemas de 32 voltios, sin que haya inconvenientes o interferencias.

Además he intentado colocando unos condensadores a la salida del transformador, y el circuito trata de encender los displays, pero se apaga de un momento a otro, tal vez no sé qué condensador debo utilizar, he probado la continuidad de los cristales, y están en buenas condiciones.

Agradezco su respuesta...

Un saludo
16/08/2008 #2

Avatar de Eduardo

Re: ¿Tendré Problemas de condensador o de cristal?
Diederick dijo:
...Hasta ahí todo normal, pero cuando alimento las diferentes etapas que son:
1. alimentación de displays
2. alimentacion de µC

El circuito se vuelve loco...
Aparentemente el problema esta en la distribucion de las pistas que llevan una corriente importante (principalmente las pistas de masa).
Es imposible adivinar como hiciste el conexionado.
17/08/2008 #3


Es decir que una probable solución sería dividir las tierras?
17/08/2008 #4


Hola

Muestra el circuito y las pistas del mismo, es lo mismo que si cuando estas malo mandas a tu vecino al medico para que lo reconozca...

Un saludo
18/08/2008 #5


Hola qué tal...

Pues he estado analizando el circuito y me he dado cuenta que el problema es el siguiente:

Tengo un transformador que funciona a 110V, sus salidas son de 9 y 22 voltios, cuando trato de alimentar el circuito con la salida de 22 voltios; la regulo a 5 voltios para alimentar el micro, y también derivo otra salida para alimentar los displays, pero hay un problema: cada vez que voy a medir los micros, pasan varias cosas; una de ellas es que los 5 voltios se bajan cada vez que alimento los displays de 22 voltios, y otras veces cuando trata de funcionar, simplemente el voltaje de los micros se baja a 4.6 y por lo tanto no hace lo que se le ha programado, será que el micro necesita más voltaje, o será que simplemente no puedo utilizar ese transformador para sacar 5 y 22 voltios al mismo tiempo, agradecería su respuesta..

Alguno de ustedes ha utilizado circuitos de mediana o alta potencia con microcontroladores, cómo los acoplan?

Un saludo
19/08/2008 #6

Avatar de pepechip

Cuando alimentes los displays mide en la salida del transformador para asi comprobar si es este el que se viene abajo porque no suministre la corriente necesaria que necesitan los displays.

Como yan han dicho otros: Seria aconsejable que subieras el esquema
21/08/2008 #7


HOla gente pues no tengo el esquema pero si tengo el archivo brd hecho en eagle, ahí lo dejo por si quieren echar un vistazo...y darme algún consejo o recomendación sobre el problema citado..
Archivos Adjuntos
Tipo de Archivo: brd circuitoprincipal_jam_687.brd (89,2 KB (Kilobytes), 21 visitas)
21/08/2008 #8

Avatar de Eduardo

El trazado de las pistas de +5 y masa es un desastre. Para que eso funcione confiablemente vas a tener cortar unas cuantas pistas y soldar cables decentes desde el conector de alimentacion a lugares 'estrategicos'. Ademas de poner condensadores de 100n junto a los integrados criticos.

Buscate apuntes con Google sobre distribucion de masas.
Ej: http://www.google.com/search?client=...utf-8&oe=utf-8
22/08/2008 #9
Moderador

Avatar de Chico3001

Ok.. no he visto el esquematico pero te recomiendo esto :

1.- Trata siempre de usar fuentes separadas para potencia y para los micros, sobretodo y si es posible transformadores separados o con bobinados independientes

2.- une las tierras en un unico punto para evitar corrientes de retroalimentacion entre la etapa de micros y de potencia

Por lo que describes de la caida de voltaje me inclino a pensar que el transformador no da la corriente suficiente para alimentar el circuito... cuanta corriente consumen los leds y cuanta corriente puede proporcionar el transformador?
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Fuentes de Alimentación

Circuitos de alimentación, reguladores de voltaje, UPS, cargadores de batería, celdas solares, acumuladores, baterias, pilas...

Cerrar
Foros de Electrónica » Diseño analógico » Fuentes de Alimentación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.