Haz una pregunta
  Foros de Electrónica » Diseño analógico » Circuitos de Radio
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

14/03/2006 #1


Envio de 4 bits por radio frecuencia, distancia 15 m.
El proyecto que tengo es un regador automatico, sin embargo el cerebro del circuito necesita estar en el interior del edificio y enviar por radio 4 bits control hacia afuera con una distancia aproximada de 15 metros donde estara un receptor que por medio de un microcontrolador decidira que electrovalvulas activar y el tiempo que estaran activadas para una mejor distribucion de riego. Sugerencias? (Nota: Todo el control ya esta hecho, solo falta la parte de radio para enviar los 4 bits y recibir de la otra parte los mismos bits.) Gracias!
14/04/2006 #2


Bueno zoniko la unica forma que yo conozco de radiar datos digitales es modulandolos con señales analogicas, algo asi como PSK o QAM o alguna de sus variaciones, si no estoy mal ya mas de un micro posee modulos para estas tecnicas de modulacion digitales.
25/04/2006 #3


ht
podrias utilizar un circuito transmisor de tonos por fm y en el receptor utilizar un decodificador de tonos Ht9170b y mandar los bits a un pic16f84 que controle reles y estos las electrovalvulas ( aunque deberias de tener un soft para el pic) yo en mi empresa uso este principio para controlar vehiculos
25/04/2006 #4


electronica2000
hola en electronica2000.com podes ver un transmisor fm de tonos y un receptor tambien creo que de ahi puedes empezar a experimentar y quiza yo pueda ayudarte con el tema de el HT.
03/05/2006 #5


Te sugiero que uses la pareja TLP434A / RLP434A. Son respectivamente un transmisor y receptor digitales, que eusan modulación ASK y transmiten a 315, 418 o 433,92 MHz. El datasheet lo encuentras aqui: http://www.datasheetcatalog.net/es/d.../TLP434A.shtml
03/05/2006 #6


No sabes si se conseguirá en Argentina?
03/08/2006 #7


el rlp tlp no creo que los haya en argentina, en la pagina de la http://www.laipac.com/easy_434a_eng.htm solo tienen oficinas en mexico, africa y europa
Por cierto, en Mexico, de donde soy yo, no hay, hay que pedir en cantidad grande. en http://www.electronicaestudio.com/rfestudio.htm los venden pero estan al doble de su precio de la distribuidora, ademas el llevarlos por mensajeria estaria $$$ evalua tus necesidades y posibilidades... Que tengan un buen dia ¡¡¡
02/09/2006 #8

Avatar de EinSoldiatGott

zidaemon dijo:
el rlp tlp no creo que los haya en argentina, en la pagina de la http://www.laipac.com/easy_434a_eng.htm solo tienen oficinas en mexico, africa y europa
Por cierto, en Mexico, de donde soy yo, no hay, hay que pedir en cantidad grande. en http://www.electronicaestudio.com/rfestudio.htm los venden pero estan al doble de su precio de la distribuidora, ademas el llevarlos por mensajeria estaria $$$ evalua tus necesidades y posibilidades... Que tengan un buen dia ¡¡¡
Hola, yo quiero ocupar ese transmisor/receptor, pero en los links que puso no mencionan precios, sabe usted exactamente cuanto cuestan en méxico???

Saludos y gracias por los links
17/10/2006 #9


Tienen un precio de 115 pesos mexicanos. (unos 12 dolares usd) puedes consultar en http://www.electronicaestudio.com/ventas_dep.htm, es una tienda mexicana. Ojala te sirva, Saludos.
17/10/2006 #10

Avatar de EinSoldiatGott

zidaemon dijo:
Tienen un precio de 115 pesos mexicanos. (unos 12 dolares usd) puedes consultar en http://www.electronicaestudio.com/ventas_dep.htm, es una tienda mexicana. Ojala te sirva, Saludos.
Hola, si ya encontré la lista de precios muchas gracias incluso mande ya pedir unos con un primo que vive en el DF en cuanto me lleguen les comento que tan buenos son.

Saludos
18/07/2007 #11


Lo que quiero saber es si alguien a usado directamente este TLP y RLP ya que me paraece
que tienen un poco de ruido, agradecería me dijeran como disminuirlo y también si se puede trabajar directamente con el UART de un microcontrolador para la transmisión de los 4 bytes sin ningún problema.
18/07/2007 #12

Avatar de EinSoldiatGott

Hola, yo ya los use.
La solución es eliminar el ruido por software.

No se donde se origina el problema, pero después de 1 segundo sin emitir datos, el receptor comienza a interpretar ese silencio de manera extraña, manda a su salida un dato que no existe en su entrada. Por tal razón. Yo me vi en la necesidad de implementar bits de inicio y la constante transmisión de basura.

Explicado de otra forma, mi transmisor esta siempre emitiendo esto 101010101....

Y en cuanto le digo que emita un dato primero manda un bit de inicio me parece que utilicé casi 3Khz de frecuencia no rebasé el límite, entonces cuando ya quiero emitir un dato primero envió una secuencia de bits de inicio 01110 y luego mi dato de cuantos bits se desee.
Esta fue la única manera en que logre solucionar el problema.

Adjunto le mando un documento donde hice diagramas de flujo para cuando expuse mi proyecto, tal vez le den una idea de las secuencias a implementar.

Saludos

****
El adjunto es muy grande, mejor descárguelo desde http://files.filefront.com/Diagramas...formación.html
26/07/2008 #13


En esta pagina pueden conseguir información de como utilizar los modulos:

http://robots-argentina.com.ar/Prueba_RFLink.htm

Yo no los he probado todavia pero pienso utilizarlos para comunicar la PC con unos robots.
30/08/2008 #14


Yo los he probado en condiciones malas y son geniales, parecen de película por lo chiquitos que son, no los pude probar transmitiendo mis datos porque no puedo terminar mi proyecto con PIC, pero andan a mas de 150 metros de distancia reemplazando algunas de los tipo llaveros. Todo el truco está en la antena.
30/08/2008 #15


Justamente, yo te hiba a recomendar los módulos TWS y RWS. En Argentina salen entre $15 y $16. Son muy buenos, y junto con los HT12D y HT12E que son un decodificador y un codificador respectivamente, son infalibles. Estos CI tienen 4 entrada y 4 salidas, y 8 bit para la encriptación, o sea 256 conbinaciones diferentes que se seleccionan dejando al aire el pin o ponerlo a masa.

Cuanto el Decoder detecta la señal proveniente del Ecoder, en su salida correspondiente, se pone a 0 lógico.
12/10/2008 #16


Proyecto Trasmisor y Receptor RF
Saludos a todos, tengo un proyecto de una alarma y les comento que he comprado un receptor y transmisor que lo pueden ver en www.sparkfun.com; van Products: Wireless; y buscan WRL-07816 RF Link - 4800bps - 315MHz ; bueno les cuento que el pic manda la data (data de 8bist 00010001b) y pues no logro conseguir la transmision, alli abajo en Good AVR Tutorial hay un codigo que no de que trata creo que configura el UART del pic, alguien me podria ayudar a solucionar el problema.
Un dato que unos colegas me han dado es que el circuito de transmision como receptor tienen que ir en placa aparte con una buena porcion de GND, y esta bien que use una antena de tarjeta inalambrica esa de color negro..
Gracias por su atensión.
AHHH una cosa importante sera necesario que con esos modulos que le comento arriba, use el codificador HT12E y el decodificador HT12D
26/01/2009 #17

Avatar de Diego_eliasv

Hola a todos, les quería preguntar si saben cómo hacer para calcular la frecuencia del tren de pulsos que genera el ht12e, ya que lo tengo que sincronizar con otro dispositivo y en el datasheet no lo encontré. Si alguien sabe se lo agradezco de antemano, saludos!
27/01/2009 #18

Avatar de Ferny

Diego, espero que este datasheet te sirva: http://docs-europe.electrocomponents...6b8005134f.pdf Tengo el HT12E y el HT12D aunque todavía no me ha dado tiempo a probarlos...

Les comento que yo estoy desde hace unos días con esto, me compré unos transmisores/receptores de 433 y 315 MHz y he conseguido transmitir con ambas frecuencias vía serie a 2400 baudios desde un pic a una pc, separados unos 6 metros entre muros (lo hice dentro de casa )

En mi caso hice varias pruebas hasta que lo logré, en resumen:

- Si se detiene la transmisión o se envía un mismo nivel lógico durante mucho tiempo seguido, el receptor empieza a recibir basura.
- Si se envían continuamente datos sin pausas, al final el puerto serie se desincroniza y no se recibe información

Para solucionar esto, lo que hice en el pic fue hacer envíos de 4 bytes y esperar 5ms entre cada envío. De esta forma no se perdía ninguna trama, salvo cuando movía la protoboard para llevarla de un lado a otro (imagino que en un circuito bien soldado no debería pasar ). Tengo pendiende hacer un protocolo de comunicación con cabecera y comprobación CRC, se supone que eso ayudaría a descartar las tramas mal recibidas...

Espero que sea útil esta información...
28/01/2009 #19

Avatar de Diego_eliasv

Hola ferny, mil gracias por ese datasheet, el que yo tenia le faltaban las ultimas hojas, asi que ahora me pondre ha realizar los calculos correspondientes. Muy agradecido, saludos!
06/07/2009 #20


hola a todos primero que todo
escribia para pedir ayuda contrui un transmisor y un receptor
con 433 recibo y transmito sin problemas pero cuando conecto
un motor ( 220 ac) el equipo me funciona por unos segundos y luego se bloquea
pense que tenia un error en el programa pero lo pruebo con bobillos y trbaja bien
y no se bloquea pero nesecito controlar un par de motores
creo que es el campo manetico pero coloque el receptor lejos de los motores y sigue
pasando lo mismo
si alguien me podria dar algun consejo se lo agradesco mucho
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos de Radio

Transmisores, Receptores, Antenas...

Cerrar
Foros de Electrónica » Diseño analógico » Circuitos de Radio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.