Haz una pregunta
  Foros de Electrónica » Diseño analógico » Circuitos de Radio
Foros Registrarse ¿Olvidaste tu contraseña?
04/05/2012 #181
Moderador

Avatar de tiago

marcelo2112 dijo: Ver Mensaje
Entonces con solo puentear el j3 y j4 ya esta?No hay que hacer nada para que memorice?
Correcto. El ajuste es memorizado automaticamente.

Saludos.
02/06/2012 #182


saludos a todos, pregunto, por las dudas, alguien tiene el diseño de le placa del prescaler u664b ? saludos nuevamente
03/06/2012 #183
Moderador

Avatar de tiago

exetv dijo: Ver Mensaje
saludos a todos, pregunto, por las dudas, alguien tiene el diseño de le placa del prescaler u664b ? saludos nuevamente

Hola, exetv mira el post #26. Hay un archivo *.rar que contiene el PCB.

Saludos.
06/06/2012 #184

Avatar de Xapas

Problema con el medidor
Hola, que tal?
Hace tiempo que escribí en este tema, porque llevo mucho tiempo detrás de construir el medidor de bobinas propuesto por "masterk" y "tiago", el cual sale en la revista EPE. Pero me surgieron multitud de problemas. Primero lo construí, y no funcionaba, así que pensé que era por la versión del pic, ya que el proyecto usa el 16F628 y yo tengo el 16F628A. Me cansé de buscar el otro pic, pero no lo encontré, debido a que, según me dijeron, dejaron de fabricarlo (por lo menos aquí en Granada, España). Lo dejé durante un tiempo y, al cabo de un mes, me animé de nuevo, pero esta vez construí el que proponía "asterión", pero la versión mejorada, la cual usa nuevamente el 16F628. Llegó a funcionar, pero no me convenció, porque la lectura era errónea y la pantalla refrescaba continuamente. Observé que el medidor de la revista EPE tenía valores de escala mucho mayores que el de "ironback", así que volví a montarlo de nuevo, hasta hoy. Y, como muestro en las imágenes, es lo único que he conseguido. Conecto el circuito a corriente y sólo me aparece la primera linea del LCD negra entera. Debo decir que no es problema del LCD, puesto que lo probé en otros proyectos y funcionaba perfecto. Mi pregunta es, qué estoy haciendo mal? A alguien le funcionó el medidor EPE?? Es problema del pic, o del programa?? Programé el pic con el hex que proporcionó "masterk" en el post http://www.forosdeelectronica.com/f2...tometro-15013/
También probé ayuda en otros foros, que me proporcionaron el mismo programa, pero adaptado al 16F628A, pero todos fallaron.
Estoy desesperado, y no quiero pensar que me he gastado el dinero tontamente para construir algo que nunca funcionará.
Si alguien pudiera ayudarme, se lo agradecería
PD: El circuito está igual que el que se muestra en el pdf, a excepción de que el potenciómetro del pin 3 del LCD lo sustituí por una resistencia de 220R y los condensadores del cristal de cuarzo son de 22pF, para que oscilara mejor, me parecía insuficiente 10pF.
Archivos Adjuntos
Tipo de Archivo: rar lc_meter.rar (444,2 KB (Kilobytes), 136 visitas)
Tipo de Archivo: rar Medidor LC.rar (605,2 KB (Kilobytes), 115 visitas)
06/06/2012 #185
Moderador

Avatar de tiago

¿Algo que nunca funcionará? ... Jamas he pensado eso cuando comienzo un proyecto. Quizá si que piense en el trabajo que me va a dar, pero nada mas.

1-Por lo que veo has utilizado una placa del tipo "Uniprint", es muy facil cometer errores con ese tipo de placas, ya que hay que hacer manualmente los conexionados. Revísala varias veces y compara valores resistivos y de voltaje mirando el esquema y usando un tester.

2- Yo compré hace un par de dias dos piezas del 16f628, la verdad es que no me he fijado si en el que monté use el normal o el que termina en "A", puede que este último soporte mas velocidad, no lo se, pero deberia funcionar con ambos, ya que en el listado de componentes sólo se requiere el 628 a secas. El chip, que yo sepa, se sigue fabricando.

3- No varies capacidades de condensadores, montalo como reza el esquema y una vez lo hayas echado a andar, mejóralo. No insertes mejoras en algo que no has hecho funcionar de base.

4- La resistencia de 10K a masa es para ajustar el contraste del display, de forma que si te pasas, las celdas quedan todas en negro y si no llegas, no ves nada, por eso se asigna una resistencia ajustable, una vez lo tengas ajustado de contraste, mide el valor que dá la ajustable y ponle una fija de ese valor, con 220Ω quizá estes saturando.Mejor coloca una de 2K2

5- No te desesperes, en el hilo tienes todas las herramientas para que lleves a término tu montaje, busca los post donde estan los códigos HEX y programa el pic con esos datos, no estoy seguro si los subí, en todo caso te dejo el hex al pié del post.

Si tienes posibilidad, haz el circuito con un fotolito y placa insolable, quítate de problemas con las Uniprint, que a veces te montan un lio.

Saludos.
Archivos Adjuntos
Tipo de Archivo: zip lcfmeter_Archivos.zip (11,0 KB (Kilobytes), 134 visitas)
06/06/2012 #186


Aquí les dejo algo relacionado con el LCM, con el uso de perfboard y reciclaje.
Mi LCM Fue montado en la caja de un multímetro desahuciado.

Las fotos no son muy buenas, que las tomé con un cel y una lente adicional para lograr acercamiento.

En cualquier momento las tomo con la cámara y las cambio.

Reciclando la electrónica

También en ese post hay imagenes del mismo.
Imágenes Adjuntas
Tipo de Archivo: jpg LCM_00_1.jpg (117,6 KB (Kilobytes), 87 visitas)
Tipo de Archivo: jpg LCM_04_1.jpg (74,5 KB (Kilobytes), 65 visitas)
Tipo de Archivo: jpg LCM_06.jpg (58,5 KB (Kilobytes), 74 visitas)
16/06/2012 #187


Hola he mirado el tema, pero el link que ponen para ver el diagrama del autor a mi me sale inaccesible, podrian ustedes hacer el favor de mandar la información que había en dicha dirección a este post de esta pag:
http://ironbark.bendigo.latrobe.edu....lc/index2.html
Alguna manera de ver el diagrama entero de lo que hicieron asterión y tiago, pasa que me lei los post pero solo Tiago subio el codigo para su pic pero queria ver los diagramas con el pic16f84, desde ya les doy las gracias por la atención...

Un saludo...
17/06/2012 #188
Moderador

Avatar de tiago

Eggman dijo: Ver Mensaje
Hola he mirado el tema, pero el link que ponen para ver el diagrama del autor a mi me sale inaccesible, podrian ustedes hacer el favor de mandar la información que había en dicha dirección a este post de esta pag:
http://ironbark.bendigo.latrobe.edu.au/~rice/lc/index2.html
Alguna manera de ver el diagrama entero de lo que hicieron asterión y tiago, pasa que me lei los post pero solo Tiago subio el codigo para su pic pero queria ver los diagramas con el pic16f84, desde ya les doy las gracias por la atención...

Un saludo...
Aquí tienes el esquema: http://www.lw3ewz.com.ar/modules.php...ticle&sid=1759

Utiliza los codigos que hay en el hilo para programar el PIC.

Saludos.
17/06/2012 #189


Órale!, entonces en total hicieron estos:

https://sites.google.com/site/vk3bhr/home/fm2

y

https://sites.google.com/site/vk3bhr/home/index2-html

con algo más?...

Un saludo...
18/06/2012 #190
Moderador

Avatar de tiago

Eggman dijo: Ver Mensaje
Órale!, entonces en total hicieron estos:

https://sites.google.com/site/vk3bhr/home/fm2

y

https://sites.google.com/site/vk3bhr/home/index2-html

con algo más?...

Un saludo...
Es el mismo y, si, se le puso un prescaler para poder alcanzar 1'2 - 1'3 Ghz de rango. Si no se lo pones, creo que no lee mas allá de los 40 - 50 Mhz. El prescaler tambien viene descrito en éste hilo.

Saludos.
18/06/2012 #191


Si tiago, si ví en el post el prescaler, bueno eso es todo, será este mi proyecto a largo plazo porque mi trabajo y el estudio no me da para dedicarme de lleno... Si salen dudas espero contar contigo, gracias tiago por la atención...

Un Saludo...
05/07/2012 #192

Avatar de Rigeliano

Hola tiago no se si sea el mismo error pero me pasa exactamente lo mismo que a Xapas solo se muestra una linea oscura en el LCD, probé independientemente el PIC con un LCD y hace lo mismo una sola linea negra.
Alguna sugerencia.
PD: hice el circuito sin variar ningún componente a exepción del PIC 16f628A.
06/07/2012 #193
Moderador

Avatar de tiago

Rigeliano dijo: Ver Mensaje
Hola tiago no se si sea el mismo error pero me pasa exactamente lo mismo que a Xapas solo se muestra una linea oscura en el LCD, probé independientemente el PIC con un LCD y hace lo mismo una sola linea negra.
Alguna sugerencia.
PD: hice el circuito sin variar ningún componente a exepción del PIC 16f628A.
Es dificil de darte un consejo sin examinar el circuito. Primero prueba a revisar todas las conexiones del LCD a placa y a verificar que no hay cortos en las pistas, puede ser:

Que el LCD tenga el contraste al máximo y no deje visualizar, ó que el firm no está funcionando,revisa si éste está diseñado para el PIC que empleas, ya que 16f84 y 16f628 suelen ser "compatibles" para muchos montajes, pero los programas que hay que aplicarles son diferentes. A ver si Xapas nos comenta algo

¿Que quieres decir "a excepción del PIC 1f628A" ?

Ya cuentas. Saludos
06/07/2012 #194

Avatar de Rigeliano

significa que lo hice con el 628A y no con el 628, revisare de nuevo las conexiones al LCD auque seria la n-esima vez, tal vez ahora mas despejada la mente encuentre el error
07/07/2012 #195
Moderador

Avatar de tiago

¿Que firm has utilizado? ...Donde lo obtuviste?
Saca fotos de la placa por lado componentes y por soldaduras. Que se vean claras, por favor.
Y dime cómo has conectado la patilla 3 del display.

Saludos.
19/07/2012 #196


Antes de nada, mi saludo y mi agradecimiento a todos los participantes de este foro, de forma especial a Tiago, Asterión, Anthony123 …..

Aunque es el primer post que escribo aquí, llevo más de una semana sumergido en el foro. Al principio tuve un poco de lío entre los montajes de “LC Meter” y “LCF Meter”; muchas veces no sabía de cual se hablaba, quizá la confusión provenía de que el enlace del primer post no funciona y me fui a buscarlo por Internet donde encontré varios diseños; pero a base de leerme las diez páginas del post una y otra vez, al final creo que me he enterado.
He efectuado el montaje del LCF Meter en una “protoboard” desde hace unos días; paso a describiros mi experiencia:

Capacitancia: puedo aseguraros que en modo lectura de condensadores me ha asombrado su precisión; habré medido unos trescientos condensadores desde 10 pF hasta 6.8 mF y –a pesar de lo que he leído en el post- en mi modesta opinión, es preciso desde 10 pF hasta algunos mF.
Al principio cuando seleccionaba la opción de medida de C, me salía en menos de un segundo el mensaje “Time out” y no conseguía medir nada; después leí en el foro que había que juntar las puntas de medición y efectuar la corrección consiguiente pulsando el botón “Set” . A partir de ese momento la lectura es prácticamente perfecta.

Inductancia: me daba errores de bulto, que intenté corregir arrancando el montaje teniendo pulsado el botón “Set”; pero la corrección es porcentual (%) sobre el valor y si intentaba corregir para 82 uHy, las de bajo valor (pocos uH) y las de alto valor (de 1 a 5 mHy) me salían muy distorsionadas de lectura. Entonces me dí cuenta de que uniendo las puntas antes de una lectura (aparece un valor cercano a 10 uH que es el valor de la inductancia L1) y pulsando el botón “Set” , a partir de ese momento las lecturas son relativamente buenas.

Frecuencía: Intenté –al no disponer de un osciloscopio- he tenido que pensar en un "Osciloscopio en su PC" tal como por ejemplo el "Visual Analyser " ( a partir de ahora VA), y efectuar las pruebas con él. Al principio no detectaba señal alguna de entrada, por lo que decidí buscar un frecuencímetro en la red. Leí en este foro sobre el “Frequency Meter V2” de Phil Rice VK3BHR https://sites.google.com/site/vk3bhr/home/fm2lo construí. Utilicé primero un generador de funciones con un TS555, pero no me convenció ya que a frecuencias superiores a 500 kHz y hasta el límite de 2,7 mHz el error era muy grande (cercano al 20%). Intenté utilizar un circuito de oscilador con un cristal que vi en alguno de los post (creo que de Tiago) pero no lo conseguí y no sé exactamente como interpretarlo. Luego utilicé el VA y quedé asombrado por la precisión del Frecuencímetro y del VA El problema es la limitación del VA ya que funciona a través de la tarjeta de sonido y en el mejor de los casos alcanza los 22 KHz ( ó 44 KHz no lo sé muy bien) por lo que me he quedado sin medios para probarlo a frecuencias en el ámbito de 25 kHz a 5 megaHz.
Animado por los resultados obtenidos con el frecuencímetro indicado antes, continué con el “LCF Meter” aplicándole la señal generada por el VA, pero no conseguía lectura alguna hasta que me dí cuenta de que en el esquema del frecuencímetro (señalado anteriormente) la señal aplicada era ampliada por el transistor BFR91, por lo que apliqué a la señal generada por el VA el circuito del BFR91 con sus tres resistencias, la bobina y el condensador, pero tampoco leía nada. Entonces empecé a cambiar las resistencias del divisor de tensión (ver http://www.kemisa.es/utilizar_pc_como_osciloscopio.php) hasta que logré algunos resultados; por ejemplo, para una señal de 6.000 Hz de onda cuadrada obtengo una lectura doble de 27.027,027 (curioso número) y 6.3xx (ahora no me acuerdo exactamente). En el display, ambos valores se van alternando cada pocos segundos.
¿Tiene alguien idea de que puede estar fallando?¿Habéis tenido que ampliar la señal de entrada de frecuencias para que la capte el LCF Meter?

Gracias por vuestra atención y os pido disculpas por la extensión del post .

Un saludo

Trifonc
Imágenes Adjuntas
Tipo de Archivo: jpg DSCF0003_resize.JPG (67,4 KB (Kilobytes), 37 visitas)
Tipo de Archivo: jpg DSCF0001_resize.JPG (85,8 KB (Kilobytes), 36 visitas)
Tipo de Archivo: jpg DSCF0004_resize.JPG (80,3 KB (Kilobytes), 46 visitas)
Tipo de Archivo: jpg DSCF0005_resize.JPG (73,9 KB (Kilobytes), 36 visitas)
Tipo de Archivo: jpg DSCF0006_resize.JPG (78,6 KB (Kilobytes), 39 visitas)
Tipo de Archivo: jpg DSCF0007_resize.JPG (70,6 KB (Kilobytes), 47 visitas)
19/07/2012 #197
Moderador

Avatar de tiago

Hola trifoncar. Varias cosas:

La primera es darte la bienvenida al foro ... Y las otras son:

Debes hacer medidas de capacidad a ser posible con condensadores de la misma tolerancia,si mides hasta 10 Pf, con ondensadores cuya tolerancia es mayor que los que usas para las mediciones a partir de 10 Pf, es normal que obtengas mas precisión en ése rango. A tener también en cuenta las tolerancias de error del propio aparato.

El botón set está para hacer una puesta a cero, ya que estos dispositivos no tienen reset automático, sobre todo al medir bobinas, has de juntar las puntas y resetear el medidor, para que éste asigne cero a esas condiciones y la inductancia que puedan generar las puntas de prueba sea descartada.

El problema con el frecuencímetro, creo que lo tienes en alguna autoscilación provocada por las limitaciones de las proto-board (mal comportamiento) para las frecuencias a las que vas a someter el montaje. El enjambre de cables que se forma para los conexionados se comporta cómo una antena, generando y difundiendo todo tipo de oscilaciones parásitas que evitan una lectura correcta.

El osciladorcito que monté al cual haces mención, le puedes cambiar el cristal por uno de 4 Mhz y así quedar dentro del rango de lectura del frecuencímetro.

Saludos.
23/07/2012 #198


Hola foreros, hola Tiago. Disculpa que no haya contestado antes; ha sido debido a que he repasado de nuevo la mayor parte del hilo. Por otra parte, se me olvidó felicitarte/os (a ti y también a Asterión) por este hilo. ¡Enhorabuena y gracias por compartirlo!

He efectuado el montaje del frecuencímetro (que presentais en este hilo) y funciona perfectamente; con un cristal de 4,000 MHz me ha marcado 3.999.86x Hz. No he conseguido acercarme más a pesar de haber movido un trimmer de 65 pF de extremo a extremo, y de haber cambiado por diferentes valores el otro condensador del cristal de (33 pF). En la imagen el prescaler no está conectado; únicamente está el oscilador que da la señal directamente al frecuencímetro, por eso marca los 4 MHz. Sé que lo habréis deducido, pero por si acaso lo quería aclarar.

Por otra parte, he montado el prescaler a la entrada del frecuencímetro y no he logrado nada. Lo he montado sin transistor porque –como tú comentabas- ya tiene un BFR91 en la entrada de la señal del frecuencímetro. También lo he probado poniéndole un transistor a la salida del prescaler, y no he conseguido obtener ninguna lectura. Si he conseguido que aparezca el menú del prescaler con los contactos de los jumpers , pero nada más.

Yo no sé calcular si con el transistor del esquema del prescaler la señal se saturará en el transistor de entrada en el frecuencímetro o no. Lo único que puedo probar es si funciona o no, con él o sin él. Y no ha funcionado en ninguno de los dos casos. También he variado un poco los valores de las resistencias del esquema del prescaler y tampoco he conseguido nada.

La situación en mi caso es que el frecuencímetro funciona perfectamente, pero al ponerle el prescaler, con o sin su transistor, no funciona. He comprobado la alimentación del prescaler y es 4,69 v. ¿Tenéis idea de que puede estar fallando?

Me alegraría un montón que me ayudaseis a encontrar la solución porque es un aparato que me encantaría tener en mi pequeño “laboratorio”, y muy en particular porque veo que es muy preciso.

Un saludo ... y ¡gracias de nuevo!

Trifonc
Imágenes Adjuntas
Tipo de Archivo: jpg DSCF0006-resized.JPG (189,3 KB (Kilobytes), 41 visitas)
23/07/2012 #199
Moderador

Avatar de tiago

trifoncar ...

Lo primero: Que prescaler has usado ..? No parece el U664 el chip que se vé.
Si has usado otro, adjunta el esquema. Recuerda que en protoboard, los errores y malos contactos están cantados. Y para esas frecuencias, puede que sea simplemente un problema con la proto.

Si es el U664, grábale al PIC el firm del post Nº 26, que en el modo prescaler acepta un ratio de 64.

Saludos.
23/07/2012 #200


Hola Tiago,

te envío una imagen escaneada y un esquema de los encapsulados DIP y SIP del U664B.

Las líneas en color son las que yo he diseñado para utilizar con el encapsulado SIP. He utilizado de base un prescaler con el encapsulado DIP que coincide con el que vosotros habeis utilizado.

Ya había probado el fichero que me comentas y no me funciona.

Estoy un poco desfondado de tanto probar, sin ideas.

Gracias Tiago

Trifonc (Gerardo)
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos de Radio

Transmisores, Receptores, Antenas...

Cerrar
Foros de Electrónica » Diseño analógico » Circuitos de Radio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.