Haz una pregunta
  Foros de Electrónica » Diseño analógico » Circuitos de Radio
Foros Registrarse ¿Olvidaste tu contraseña?
31/07/2012 #241


¿Eso es como decir que tendría que ajustarlo con lo que se denomina FI (+/-)?

Saludos
02/08/2012 #242


Alcanzada la meta de construir y comprobar el frecuencímetro con y sin prescaler, os agradezco la ayuda prestada y emigro hacia los foros hacia donde apuntan más mis inquietudes actuales, frecuencímetro y radio, ya que he comprobado que hay varios que tratan de ello.

Muchas gracias a todos, especialmente a Miguelus, Tiago, etc. Ha sido un placer.

Saludos
04/08/2012 #243


Qué les parece este?... me lo estoy por hacer:
http://www.e-radiocontrol.com.ar/?Ci...84_o_PIC16F628
04/08/2012 #244


Arsenic dijo: Ver Mensaje
Qué les parece este?... me lo estoy por hacer:
http://www.e-radiocontrol.com.ar/?Ci...84_o_PIC16F628
Es exactamente el mismo proyecto que se está manejando en este hilo, el cual, ya más de uno de los foristas lo tiene ensamblado y funcionando (me incluyo).

Más aún en este hilo se ha agregado el proyecto extendido LCFmeter, que lee L y C en un rango mucho más extenso que el LCmeter básico y, por demás, mide frecuencia.
05/08/2012 #245


Ya lo he terminado; no me funciona el oscilador, está en cero y no despega de ahí... qué puede ser? alguna idea? les cuento que ya sustituí todos los componentes dos veces (excepto los pic's porque tengo varios y los cambio). También estoy haciendo esta versión, vamos a ver que pasa:

Circuito y distribución de componentes en PCB:
PCB:
Programa en HEX (SOLAMENTE PARA PIC16F628 ó PIC16F628A):
14/08/2012 #246


Hola de nuevo,

aunque sé que el tema al final derivó en LCF, pero como comenzó con el LC Meter, os dejo una imagen de mi proyecto de LC; está hecho con *****shop pero espero construirlo materialmente esta semana.

Un saludo

G.
Imágenes Adjuntas
Tipo de Archivo: jpg Copia de Modelo A7_resize.jpg (266,6 KB (Kilobytes), 40 visitas)
14/08/2012 #247


Finalmente la versión segunda que hice funciona, pero en partes no... cuando coloco la llave en posición 1, el oscilador tira 55630 aproximadamente (eso está dentro de los resultados esperados)... pero cuando mido C, toma valores aleatorios y nunca se queda fijo... lo mismo sucede con el oscilador. Alguien podría darme un dato? La verdad que es deprimente no poder hacerlo funcionar... (me refiero a la versión que utiliza el 16F628A para no tener que usar el LM311).
14/08/2012 #248
Moderador

Avatar de tiago

Es dificil determinar algo de ésta forma, yo te diría que revisases todo y comprobases los componentes, así como el correcto funcionamiento de la llave conmutadora y cableado de la misma.

Creo entender que has montado finalmente la versión que usa únicamente un PIC,(16f628A) sin LM ¿Es así?

Prueba otro PIC y usa el *.hex que se ofrece en el hilo a ver que ocurre.

Saludos.
14/08/2012 #249


¿Cuanto te marca en F2?
14/08/2012 #250


trifoncar dijo: Ver Mensaje
¿Cuanto te marca en F2?
En F2 me marca 2000000... pero no fijos... es un valor enorme!
14/08/2012 #251


tiago dijo: Ver Mensaje
Creo que son de este tipo, pero no se que denominación tienen, se les llama relés tipo reed.

Saludos
SY-4030, los fabrica la empresa norteamericana JAYCAR.
15/08/2012 #252


tiago dijo: Ver Mensaje
Es dificil determinar algo de ésta forma, yo te diría que revisases todo y comprobases los componentes, así como el correcto funcionamiento de la llave conmutadora y cableado de la misma.

Creo entender que has montado finalmente la versión que usa únicamente un PIC,(16f628A) sin LM ¿Es así?

Prueba otro PIC y usa el *.hex que se ofrece en el hilo a ver que ocurre.

Saludos.
Exacto. El que he montado es el que solamente lleva el PIC16F628A. Ya he controlado todo y está correcto. A qué HEX te referís? Revisé todas las paginas y no vi ninguno para este proyecto... :S

PD. Si consigo los materiales, me monto el lcfMeter que proponen aquí... la verdad se me complica bastante pero tengo fé... el cristal sobre todo, que es de un valor bastante... poco común...
15/08/2012 #253
Moderador

Avatar de tiago

Arsenic dijo: Ver Mensaje
Exacto. El que he montado es el que solamente lleva el PIC16F628A. Ya he controlado todo y está correcto. A qué HEX te referís? Revisé todas las paginas y no vi ninguno para este proyecto... :S

PD. Si consigo los materiales, me monto el lcfMeter que proponen aquí... la verdad se me complica bastante pero tengo fé... el cristal sobre todo, que es de un valor bastante... poco común...
Pues te lo dejo aquí. Lo etiqueto como "lc" para diferenciarlo de otros. Prueba a ver si te funciona, ya veo que has comparado F1 y F2.
Es un fallo en el oscilador, pero hay que determinar ...

Saludos
Archivos Adjuntos
Tipo de Archivo: rar lc.rar (2,4 KB (Kilobytes), 60 visitas)
15/08/2012 #254


Arsenic, yo también creo que tienes algo mal en el montaje. Soy poco ducho en esto y estuve unos dias muy liado entre los contactos del relé y los del conmutador. Tuve que hacerme un pequeño croquis basado en los esquemas aquí publicados. Por si te ayudase en algo subo dos de ellos.

También diré que sustituí el relé de Jaycar aquí mecionado por uno corriente (de mayor amperaje) pero añadiendo un transistor 2N2222 y una resistencia de 3,3 kOhmios.

Espero que logres efectuar el montaje con éxito.

Un saludo.

Gerardo
Imágenes Adjuntas
Tipo de Archivo: jpg Detalle Conmutador 2.jpg (50,2 KB (Kilobytes), 22 visitas)
Tipo de Archivo: jpg Esquema - Detalle Conmutador.jpg (36,7 KB (Kilobytes), 25 visitas)
15/08/2012 #255


No sé que brujería has hecho en assembler tiago, la cuestión es que con ese HEX que me pasaste, lo he podido hacer funcionar a la perfección... sólo un margencito de error, ya que solamente conseguí capacitores de 1000pF, pero con tolerancia K (creo que corresponde a los 10% o 15%...) el resto es tal y como lo pide el circuito. La medición de un capacitor de 100nF arroja 122nF y la de un inductor de 100uH me da un valor de 168uH... lo del relay que no "pegaba" era porque la corriente era insuficiente para alimentarlo, así que le agregué un NPN para controlarlo y también quedó solucionado ese problema. Si alguien ha tenido ese problema, que me avise y le paso el esquema. Saludos y millones de gracias. Ahora voy por el LCF que han propuesto anteriormente pero me voy a esmerar en conseguir exactamente los componentes que piden. Al cristal ya lo he conseguido.

---------- Actualizado después de 2 minutos ----------

trifoncar dijo: Ver Mensaje
Arsenic, yo también creo que tienes algo mal en el montaje. Soy poco ducho en esto y estuve unos dias muy liado entre los contactos del relé y los del conmutador. Tuve que hacerme un pequeño croquis basado en los esquemas aquí publicados. Por si te ayudase en algo subo dos de ellos.

También diré que sustituí el relé de Jaycar aquí mecionado por uno corriente (de mayor amperaje) pero añadiendo un transistor 2N222 y una resistencia de 3,3 kOhmios.

Espero que logres efectuar el montaje con éxito.

Un saludo.

Gerardo
Gracias! ya lo hice funcionar! justamente hice lo del transistor yo también porque se ve que el relé de Jaycar no llega a este condenado país


---------- Actualizado después de 40 minutos ----------

Bien, por las dudas que lo pidan, acá les envío las fotos. Aprovecho para decirles que en realidad el Inductor de 100uH me arroja 116 y de paso medí uno de 82uH y me arroja 97... es un error casi despreciable, ya que el inductor que he adquirido es de banda de plata (Es decir, con un 10% de tolerancia).
Archivos Adjuntos
Tipo de Archivo: rar fotos lcmeter.rar (1,39 MB (Megabytes), 86 visitas)
15/08/2012 #256


Arsenic dijo: Ver Mensaje


Bien, por las dudas que lo pidan, acá les envío las fotos. Aprovecho para decirles que en realidad el Inductor de 100uH me arroja 116 y de paso medí uno de 82uH y me arroja 97... es un error casi despreciable, ya que el inductor que he adquirido es de banda de plata (Es decir, con un 10% de tolerancia).
Te indico, realmente, poco importa la capacidad o la inductancia que montaste en LC-Meter.

Ahora que ya funciona, toma un puñado de capacitores y otro de inductores. Midelos con el medidor tal como te ha quedado hasta que consigas los especímenes del valor requerido. Luego de que los tengas, cambia los que habías instalado en el instrumento y listo.

Para los capacitores hazte de unos de los que son de polyester o mylard.
15/08/2012 #257


y de paso... digo, un buen gabinete no? jaja. Tengo de poliestireno, que son los que requiere el que lo ha diseñado. También los de Tantalio tal cual los pide. Se me complicó conseguir los de 1000pF con la tolerancia requerida, pero claro... llevo un tiempo en esto y he acumulado varias placas y los he desoldado de ellas... hice exactamente lo que acabas de recomendar, medir y reemplazar... asimismo creo que el error estaba en el programa, ya que eso lo hice antes y el error persistía. Con el HEX que me tiró tiago anduvo a la perfección y sin cambios "Físicos" ya que todo fué revisado debidamente VARIAS veces...
15/08/2012 #258


Arsenic dijo: Ver Mensaje
y de paso... digo, un buen gabinete no? jaja. Tengo de poliestireno, que son los que requiere el que lo ha diseñado. También los de Tantalio tal cual los pide. Se me complicó conseguir los de 1000pF con la tolerancia requerida, pero claro... llevo un tiempo en esto y he acumulado varias placas y los he desoldado de ellas... hice exactamente lo que acabas de recomendar, medir y reemplazar... asimismo creo que el error estaba en el programa, ya que eso lo hice antes y el error persistía. Con el HEX que me tiró tiago anduvo a la perfección y sin cambios "Físicos" ya que todo fué revisado debidamente VARIAS veces...
Las medidas que obtuviste de los mismos capacitores e inductancias, no deben cambiar en absoluto. Esas son sus medidas.

Te recuerdo que el instrumento no mide capacitancia ni inductancia. Solo mide la frecuencia de un oscilador, primero la que corresponde a los componentes patrón, tanto C como L; luego la que se obtiene agregando el capacitor a medir o la inductancia a medir. El software es quien "CALCULA" el valor de los componentes, según la desviación de la frecuencia que ellos han producido. Por lo tanto, para un mismo componente, no puede haber diferencia de valor, independientemente del instrumento con el cual se mide.

Si el valor de un mismo componente varía de un instrumento a otro, uno de los dos instrumentos está mal.
16/08/2012 #259


mcrven dijo: Ver Mensaje
Las medidas que obtuviste de los mismos capacitores e inductancias, no deben cambiar en absoluto. Esas son sus medidas.

Te recuerdo que el instrumento no mide capacitancia ni inductancia. Solo mide la frecuencia de un oscilador, primero la que corresponde a los componentes patrón, tanto C como L; luego la que se obtiene agregando el capacitor a medir o la inductancia a medir. El software es quien "CALCULA" el valor de los componentes, según la desviación de la frecuencia que ellos han producido. Por lo tanto, para un mismo componente, no puede haber diferencia de valor, independientemente del instrumento con el cual se mide.

Si el valor de un mismo componente varía de un instrumento a otro, uno de los dos instrumentos está mal.
claro, lo que pasó con las medidas, fue que al principio, yo los medía con cables comunes con sus puntas peladas... eso de alguna manera obligaba a sostenerlas y me tomaba las manos con la inductancia en paralelo... pero con las puntas me tira el valor que comenté a lo último...
27/08/2012 #260


Bueno amigos, les dejo las fotos de mi proyecto terminado. MIL gracias a tiago por la ayuda y predisposición y disculpas por las molestas preguntas y la desprolijidad del gabinete (admito que debo mejorar al respecto):









NOTA: Para facilitar el montaje, he realizado un PCB aparte para la llave selectora, el pulsador y el encendido, este último mediante un pulsador con retención. Se los dejo como consejo, ya que si utilizan este tipo de switch's o pulsadores que no son para placa, van a tener una dificultad grande a la hora de montarlos.



¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos de Radio

Transmisores, Receptores, Antenas...

Cerrar
Foros de Electrónica » Diseño analógico » Circuitos de Radio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.