Haz una pregunta
  Foros de Electrónica » Diseño analógico » Circuitos de Radio
Foros Registrarse ¿Olvidaste tu contraseña?
15/10/2012 #281


"Ya lo terminé y lo calibré".

Lo pongo así, entre comillas, ya que falta el ornato y el conector para la lína AC.

No le voy a poner batería y tampoco me interesa ponerle conector para Frecuencímetro.

Les dejo fotos, saludos:
15/10/2012 #282
Moderador

Avatar de tiago

Estupendo trabajo mcrven, Pero hay algo que no llego a entender, quizá porque no haya leido con la debida atención.
Dices que el valor para la capacitancia arranca por defecto en 100. Correcto. Una vez entrados en el modo de corrección, sí que podemos elevar o bajar el factor de corrección, no es obligatoriamente un valor que sólo puede subir, también puede bajar:

Modo correccción: Con el pulsador, si tenemos el selector en modo capacidad, al pulsar subiremos el valor. Si lo ponemos en modo inductancia, al pulsar lo disminuimos.

Para seleccionar la función (Inductancia - capacitancia) a corregir, sólo tenemos que seleccionarlo y con el pulsador apretado, arrancar el aparato, de esa forma entramos en el modo de corrección de la función seleccionada al arranque. Una vez iniciado el modo de corrección, el selector de inductancia - capacitancia, es un mero selector de up - down a las ordenes del pulsador, que incrementa o decrece a cada pulsación.

Saludos.
15/10/2012 #283


tiago dijo: Ver Mensaje
Estupendo trabajo mcrven, Pero hay algo que no llego a entender, quizá porque no haya leido con la debida atención.
Dices que el valor para la capacitancia arranca por defecto en 100. Correcto. Una vez entrados en el modo de corrección, sí que podemos elevar o bajar el factor de corrección, no es obligatoriamente un valor que sólo puede subir, también puede bajar:

Modo correccción: Con el pulsador, si tenemos el selector en modo capacidad, al pulsar subiremos el valor. Si lo ponemos en modo inductancia, al pulsar lo disminuimos.

Para seleccionar la función (Inductancia - capacitancia) a corregir, sólo tenemos que seleccionarlo y con el pulsador apretado, arrancar el aparato, de esa forma entramos en el modo de corrección de la función seleccionada al arranque. Una vez iniciado el modo de corrección, el selector de inductancia - capacitancia, es un mero selector de up - down a las ordenes del pulsador, que incrementa o decrece a cada pulsación.

Saludos.
Bien Tiago...

Lo marcado en azul es correcto, lo que está en rojo no.

Cada valor de corrección es almacenado a parte del otro. Si lees el post anterior te darás cuenta que indico las direcciones de la sección DATOS del PIC en las cuales esos valores son almacenados.

Cada CORRECTION ( CAP/IND ) funciona por separado y con su valor correspondiente:
La corrección CAP solo permite incrementar el valor hasta 199. Alcanzado el límite, no se puede retroceder.
La corrección IND solo permite decrementar el valor hasta 1. Igualmente, si es alcanzado este límite, no se puede retroceder.

Solo es posible reiniciar estos valores reprogramando el PIC, de esta forma retornarán ambos valores a su inicio de 100.

Yo necesité un valor más bajo para CAP CORRECTION, así que, cambié el valor 100 al valor 80 en ambas celdas de memoria del PIC. El firmware LCFMET737-50.hex que subí ayer ya está cargado para eso, por si alguien lo necesita.

Ya hoy pude localizar el XTAL de 3.2768 MHz y en la mañana probaré con él. Así despejaré la duda.

Saludos a todos y hasta la próxima:
16/10/2012 #284
Moderador

Avatar de tiago

mcrven, respondo a tus comentarios: No me has entendido.

Cada valor de corrección es almacenado a parte del otro. Si lees el post anterior te darás cuenta que indico las direcciones de la sección DATOS del PIC en las cuales esos valores son almacenados.

Lo ví

Cada CORRECTION ( CAP/IND ) funciona por separado (...Lo sé) y con su valor correspondiente:
La corrección CAP solo permite incrementar el valor hasta 199. Alcanzado el límite, no se puede retroceder.

En mi LCF llego a 199, cambio el conmutador a inductancia y el "Correction cap" decrece

La corrección IND solo permite decrementar el valor hasta 1. Igualmente, si es alcanzado este límite, no se puede retroceder.

Llego a 1, cambio el conmutador a capacidad y el "inductor correction" aumenta.

Solo es posible reiniciar estos valores reprogramando el PIC, de esta forma retornarán ambos valores a su inicio de 100.

Yo necesité un valor más bajo para CAP CORRECTION, así que, cambié el valor 100 al valor 80 en ambas celdas de memoria del PIC. El firmware LCFMET737-50.hex que subí ayer ya está cargado para eso, por si alguien lo necesita.


Ya hoy pude localizar el XTAL de 3.2768 MHz y en la mañana probaré con él. Así despejaré la duda.


Saludos a todos y hasta la próxima:


Puede que no sea el mismo *.HEX, el que usamos, aunque creo que no hay mas que uno.

Saludos
16/10/2012 #285


tiago dijo: Ver Mensaje
mcrven, respondo a tus comentarios: No me has entendido.

Cada valor de corrección es almacenado a parte del otro. Si lees el post anterior te darás cuenta que indico las direcciones de la sección DATOS del PIC en las cuales esos valores son almacenados.

Lo ví

Cada CORRECTION ( CAP/IND ) funciona por separado (...Lo sé) y con su valor correspondiente:
La corrección CAP solo permite incrementar el valor hasta 199. Alcanzado el límite, no se puede retroceder.

En mi LCF llego a 199, cambio el conmutador a inductancia y el "Correction cap" decrece

La corrección IND solo permite decrementar el valor hasta 1. Igualmente, si es alcanzado este límite, no se puede retroceder.

Llego a 1, cambio el conmutador a capacidad y el "inductor correction" aumenta.

Solo es posible reiniciar estos valores reprogramando el PIC, de esta forma retornarán ambos valores a su inicio de 100.

Yo necesité un valor más bajo para CAP CORRECTION, así que, cambié el valor 100 al valor 80 en ambas celdas de memoria del PIC. El firmware LCFMET737-50.hex que subí ayer ya está cargado para eso, por si alguien lo necesita.


Ya hoy pude localizar el XTAL de 3.2768 MHz y en la mañana probaré con él. Así despejaré la duda.


Saludos a todos y hasta la próxima:


Puede que no sea el mismo *.HEX, el que usamos, aunque creo que no hay mas que uno.

Saludos
Bien tiago, ya me dediqué un rato a verificar lo que indicaste aquí más arriba y debo comunicarte que tus observaciones resultaron ser ciertas. No me había percatado de ello a pesar de haber leído y re-leído el texto del artículo de John Becker; el cual traduje y coloco aquí para que puedan darse cuenta de que, a pesar de que menciona algo del asunto, lo hace de una manera muy escueta e incompleta que no permite siquiera adivinar.

El capítulo ALIGNMENT:

ALINEACIÓN:

Dado el caso de que el valor de los componentes utilizados para los osciladores no sea exactamente igual a aquel para el cual el software fue escrito, existe la posibilidad de compensarlo mediante la elección de una rutina, al momento en el cual el LCF Meter es encendido.

Con el instrumento apagado (off), seleccione el modo de capacitancia o inductancia según la corrección que se quiera aplicar utilizando el conmutador S2. Mantenga presionado el pulsador S3 mientras procede a encender el instrumento y aparezca en la pantalla CAP o IND CORRECTION. El software del PIC, durante la rutina de inicialización, reconocerá el estado de presionado del pulsador S3 saltando a la rutina adecuada según la selección de S2.

Esto será mostrado en la línea 1 de la pantalla, ej.: "CAP CORRECTION". La línea 2 de la pantalla mostrará el valor de corrección establecido, el cual por defecto será 100.

Durante el funcionamiento normal, los valores calculados de corrección para la capacitancia e inductancia son multiplicados por el valor establecido de corrección y luego divididos por 100. Debido a ello, si el valor de corrección es 100, no habrá corrección alguna, ya que, multiplicar por 100 y luego dividir entre 100 es lo mismo que multiplicar por 1 y así no será introducido ningún cambio.

Mientras que, si el valor de corrección fuese 101, se multiplicará el valor por 1.01, resultando en un incremento del 1%. Al contrario, si el valor fuese 99, se producirá una multiplicación por 0.99, lo cual introducirá un decremento del 1%.
El rango posible para los valores de corrección está fijado entre 1 y 199 para un rango de multiplicación entre 0.01 y 1.99.-

Cuando la pantalla muestre que el modo de corrección ha sido seleccionado, libere S3. Espere aproximadamente 2" mientras la rutina de protección anti saltos concluye (0.5 segundos). Ahora se podrá cambiar el valor de corrección seleccionado utilizando S2 y S3.

Si S2 está en la posición 2 (capacitancia), cada vez que se oprima S3 hará que el valor de corrección sufra un incremento. Al contrario, si S2 está en la posición 1, cada opresión de S3 hará que el valor de corrección sea decrementado.

Cada opresión de S3 fijará el nuevo valor en la memoria no-volatil interna del PIC (EEPROM), donde queda resguardado aún cuando el instrumento quede apagado.Los valores de anulación (nulling) no serán resguardados luego de que el instrumento se haya apagado.

Cada vez que el instrumento es encendido, los valores de corrección almacenados en la memoria serán leídos y aplicados a cada valor en los cálculos.

Para evitar la colocación de un interruptor adicional para comunicarle al software la salida del modo de corrección, se dejó una única forma de salir del modo, la cual consiste en apagar el instrumento y encenderlo de nuevo, dejando un breve espacio entre ambas operaciones, permitiendo así que los capacitores de la fuente de alimentación se descarguen.

La corrección para la rutina del otro oscilador es seleccionada de la misma manera, seleccionando S2 en la posición contraria antes de encender el instrumento.


Por otro lado, ya lo anunciado ayer fue cumplido. Instalé el XTAL de 3.2768 MHz y las lecturas se estabilizaron. También corregí ciertos detalles mecánicos e instalé los capacitores C3 y C4 que no había instalado antes (Esto último sí que no mostró ninguna mejora). También conecté a masa (-) la caja del XTAL, esto contribuye a reducir la irradiación la frecuencia del XTAL.

Bueno, también contrasté las lecturas con el LCMeter y las diferencias resultantes son irrelevantes.

La corrección para CAP quedó en 113 y la de IND en 98. Y eso que los componentes instalados en los osciladores fueron calibrados pero, siempre hay capacidades adicionales e inductancias agregadas también.

En cuanto termine el frente, subiré nuevas fotos.

Saludos:
03/11/2012 #286


Hola a todos: arme el lc meter de VK3BHR que solo usa el 16f628, funciona, pero no logro estabilizar el cero suba y baja y cuando le doy calibrar me queda con una capacidad entre 7 y 18 pf, que luego es la que sube y baja. El hex es el original de la web del VK pero la version para lcd de 2 lineas.
Controle la oscilacion del xtal con frecuencimetro y esta correcta justo en 4 mhz. Los tantalio son nuevos y correctamente polarizados. La bobina L de 100 microh le puse una de 82 comercial encapsulada en plastico. En el pin 2 del pic tengo 758.9 khz onda cuadrada y eb el pin 3, y aca estaria el problema tengo 578, 452, 349, va variando erraticamente. El Ccal y el C de 1000 pf son plates buena calidad 1 %. Les paso las fotos. El realy es de 5 v segun recuerdo bobina apta para circuitos logicos, o sea 500 ohms. probe un cap de 48 pf conectado al pin 1 del pic por si eran parasitos pero nada. Segun vi con el osciloscopio en el pin 3 donde la oscilascio es erratica no es bien cuadrada la onda y se va entrecortando a un ritmo constante de la misma velocidad que las lineas del lcd. A ver si alguien me da una mano porque me tiene loco este circuito, si no fuera por este foro ya lo hubiera desarmado, y es una lastima por el trabajo que le puse al gabinete. Saludos LU1FDU
Imágenes Adjuntas
Tipo de Archivo: jpg lc1.JPG (19,4 KB (Kilobytes), 71 visitas)
Tipo de Archivo: jpg lc2.JPG (30,0 KB (Kilobytes), 70 visitas)
03/11/2012 #287


LU1FDU dijo: Ver Mensaje
Hola a todos: arme el lc meter de VK3BHR que solo usa el 16f628, funciona, pero no logro estabilizar el cero suba y baja y cuando le doy calibrar me queda con una capacidad entre 7 y 18 pf, que luego es la que sube y baja. El hex es el original de la web del VK pero la version para lcd de 2 lineas.
Controle la oscilacion del xtal con frecuencimetro y esta correcta justo en 4 mhz. Los tantalio son nuevos y correctamente polarizados. La bobina L de 100 microh le puse una de 82 comercial encapsulada en plastico. En el pin 2 del pic tengo 758.9 khz onda cuadrada y eb el pin 3, y aca estaria el problema tengo 578, 452, 349, va variando erraticamente. El Ccal y el C de 1000 pf son plates buena calidad 1 %. Les paso las fotos. El realy es de 5 v segun recuerdo bobina apta para circuitos logicos, o sea 500 ohms. probe un cap de 48 pf conectado al pin 1 del pic por si eran parasitos pero nada. Segun vi con el osciloscopio en el pin 3 donde la oscilascio es erratica no es bien cuadrada la onda y se va entrecortando a un ritmo constante de la misma velocidad que las lineas del lcd. A ver si alguien me da una mano porque me tiene loco este circuito, si no fuera por este foro ya lo hubiera desarmado, y es una lastima por el trabajo que le puse al gabinete. Saludos LU1FDU
Problema con LC Meter

Creo identificar el problema en la sección que corresponde al oscilador LC, más específicamente al sistema de conexiones del conmutador L/C y la distancia entre éste y las bananas para la conexión de la muestra.

A propósito te sugiero des una mirada a la imagen #3 del link que te indico arriba. Es mi ejecución del LC Meter, versión 1 con el 16F84 y LM511. Al lado derecho puedes ver la plaqueta correspondiente al oscilador. El conmutador L/C es el push-button de color verde que aparece apuntando hacia arriba. Como podrás notar, todos los elementos correspondientes al tanque de oscilación y al conmutador se encuentran situados a distancias muy cortas unos de otros, todo muy cerca del LM511 y toda conexión entre ellos muy recta y con ángulos muy rectos también.

Siendo radio-aficionado debes de conocer bien las reglas a seguir para la construcción de elementos para RF. Ese oscilador "ES" un oscilador de RF. Debe funcionar en las cercanías de los 550 KHz. El tanque LC (82 µH, 1000 pF) es muy sensible a cualquier variación y la longitud de las conexiones que has hecho, mucha. Introducen mucha L y C en el oscilador y, como los cable no están fijos, estos valores están sujetos a variar con cualquier cosa. El solo acercar y retirar la mano al aparato introduce variaciones de capacidad y cualquier vibración o movimiento de la caja puede hacer variar la L introducida por los cable. Te recuerdo que el instrumento es capaz de leer décimas de pF o de µH.

Te sugiero que redistribuyas el cunjunto banas+conmutador a fin de reducir al máximo las distancias de sus conexiones y que los acerques lo más posible a las entradas correspondientes del PIC, para el mismo fin.

También repasa muy bien las soldaduras y, SUERTE.

El mío funciona muy bien.
04/11/2012 #288


Hola Mrcven:

te comento que modifique la posicion de la llave para acortar al minimo las conexiones. Ahora la f2 es 00041746 y la f2 00058088, pero me sigue marcando 10.1 pf por mas que lo calibre, ademas controle con un capacitor bueno de 100 pf y me da 736.9 pf, mientras que el tester que tengo me da 80 pf. Podra se un promela de la llave de cambio que tenga capacidad interna? Tambien probe de desconectar la conexion a las puntas y nada, y tambien probe de desconectar el reset de calibracion y nada sigue igual. Ya no se que puede ser mas que el solftware, pero no dispongo de otro .hex mas que el original.

Saludos Cordiales LU1FDU
05/11/2012 #289


LU1FDU dijo: Ver Mensaje
Hola Mrcven:

te comento que modifique la posicion de la llave para acortar al minimo las conexiones. Ahora la f2 es 00041746 y la f2 00058088, pero me sigue marcando 10.1 pf por mas que lo calibre, ademas controle con un capacitor bueno de 100 pf y me da 736.9 pf, mientras que el tester que tengo me da 80 pf. Podra se un promela de la llave de cambio que tenga capacidad interna? Tambien probe de desconectar la conexion a las puntas y nada, y tambien probe de desconectar el reset de calibracion y nada sigue igual. Ya no se que puede ser mas que el solftware, pero no dispongo de otro .hex mas que el original.

Saludos Cordiales LU1FDU
Bien amigo, si sospechas de la llave pues, cámbiala. Trata de conseguir algo de calidad, contactos dorados o algo similar. Por otro lado, te sugiero revises con cuidado el correcto funcionamiento y orientación de sus contactos, así cómo del conexionado.

La lectura de la f1 que obtuviste luce algo alta, puede ser defecto del valor del capacitor y/o de la bobina. Te sugiero seleccionar una bobina y el capacitor del tanque utilizando el mismo LC Meter, tal cual está funcionando ahora. Igual mente selecciona con él el capacitor C-Cal. Luego sustituye los componentes seleccionados en el aparato y prueba de nuevo.

La lectura que obtuviste con el tester no creo sea muy confiable. Ese tipo de instrumentos utilizan técnicas muy diferentes para esas lecturas y en capacitores pequeños las tolerancias pueden resultar muy elevadas.

Saludos y éxitos:
18/01/2013 #290

Avatar de Rigeliano

Hola hace algun tiempo arme el circuito del LCF y no funciono ahora que tengo un poco mas de tiempo lo probe de nuevo y sigue sin funcionar solo me muestra la primera linea del LCD con cuadros negros y nada mas, lo probé en protoboar y una placa entrenador mas y siempre da los mismos resultados, probé solo el LCD conectado al PIC pero tampoco manda nada, ahora le pregunta no se supone que debe de mostrar algo en el LCD aun sin el resto del circuito :(????
19/01/2013 #291
Moderador

Avatar de tiago

Rigeliano dijo: Ver Mensaje
Hola hace algun tiempo arme el circuito del LCF y no funciono ahora que tengo un poco mas de tiempo lo probe de nuevo y sigue sin funcionar solo me muestra la primera linea del LCD con cuadros negros y nada mas, lo probé en protoboar y una placa entrenador mas y siempre da los mismos resultados, probé solo el LCD conectado al PIC pero tampoco manda nada, ahora le pregunta no se supone que debe de mostrar algo en el LCD aun sin el resto del circuito :(
????
El "lcd" si solo es alimentado, sin que a él lleguen datos de ningún tipo por sus correspondientes entradas, responde de la forma que estas describiendo, por lo tanto, y con lo que dices, pienso que: o no está funcionando el PIC o el LCD no interpreta nada porque está averiado. Me imagino que esto último ya lo habrás comprobado.

El circuito funciona perfectamente, pero si no te vá, lo único que puedes hacer es comprobar y medir pieza por pieza y soldadura por soldadura. Tambien verifica que el PIC está bien programado.Y cuentanos que archivo le grabaste.

Saludos.
19/01/2013 #292

Avatar de Rigeliano

Hola tiago, bueno no creas que es la primera vez que armo algo con LCD por lo cual descarto que haya conectado mal o alimentado mal algo, probe y reprobe todo y no anda, el LCD esta funcionando bien no creo que sea el PIC aunque tendría que comprobar cada uno de los puertos tal vez alguno esta quemado .......pero aun así el programa en simulación tampoco corre no aparece nada se queda en blanco el LCD :(........
PD:Probare cada pin del PIC para descartar el micro.
El .hex que uso es el LCFMET737.hex que esta en este hilo.
Archivos Adjuntos
Tipo de Archivo: zip Prueba.zip (17,6 KB (Kilobytes), 51 visitas)
20/01/2013 #293


Rigeliano dijo: Ver Mensaje
Hola tiago, bueno no creas que es la primera vez que armo algo con LCD por lo cual descarto que haya conectado mal o alimentado mal algo, probe y reprobe todo y no anda, el LCD esta funcionando bien no creo que sea el PIC aunque tendría que comprobar cada uno de los puertos tal vez alguno esta quemado .......pero aun así el programa en simulación tampoco corre no aparece nada se queda en blanco el LCD :(........
PD:Probare cada pin del PIC para descartar el micro.
El .hex que uso es el LCFMET737.hex que esta en este hilo.
Hola, en la simulación posiblemente no te funcione o tarde en simular revisa si en la barra inferior te indica el anuncio simulation is not running in real time due to excessive CPU load.
26/01/2013 #294


Hola a todos los del hilo...

He adjuntado las imágenes del LC Meter y del LCF Meter ya terminados y funcionando.

Los frontales o carátulas, como les plazca llamar, son impresiones sobre vinil auto adherible. El material es delgado y las tintas de esa impresión soportan hasta la intemperie.

Saludos y, hasta la próxima
Imágenes Adjuntas
Tipo de Archivo: jpg LCF_Meter-terminado(menor).jpg (68,6 KB (Kilobytes), 126 visitas)
Tipo de Archivo: jpg LC_Meter-terminado(menor).jpg (82,3 KB (Kilobytes), 114 visitas)
26/01/2013 #295
Moderador

Avatar de tiago

mcrven dijo: Ver Mensaje
Hola a todos los del hilo...

He adjuntado las imágenes del LC Meter y del LCF Meter ya terminados y funcionando.

Los frontales o carátulas, como les plazca llamar, son impresiones sobre vinil auto adherible. El material es delgado y las tintas de esa impresión soportan hasta la intemperie.

Saludos y, hasta la próxima
Me parece poco usar el botón de "me gusta" para calificar unos aparatos acabados con tan buen gusto y detalle.
Por tanto, consten mis felicitaciones.

Saludos.
27/01/2013 #296

Avatar de Marce

Buenas, estos son mis capacimetros. uno es ESR, y el otro de capacitancia, ambos de neoteo.
http://www.neoteo.com/microcontrolad...tro-autorrango
http://www.neoteo.com/medidor-de-esr-esr-meter
Ambos funcionan perfectamente, y para programar, (use el pic16f628a) utilize este programador
Buen Programador de Pics (12, 16, 18) y eeproms (24cxx) y funciona mas que bien, usando el winpic800
[IMG][/IMG]
10/03/2013 #297

Avatar de Xapas

asterión dijo: Ver Mensaje
Hola amigos, monte este LC Meter:

http://ironbark.bendigo.latrobe.edu....lc/index2.html

hace ya un tiempo, no lo he usado mucho. Pero ahora que le estoy "dando duro" me han surgido unos problemas que quiero dar a conocer al foro:

- Probe mi LC meter jumpeando el link 1 y 2 y me salia 00000001 o algo asi, en ambos, asi que pense que el pic tenia algo malo, como dice el manual de construccion del lc meter. Fui a comprar otro pic.

- Lo grabe, y cuando lo puse, encendi el lc meter y decia: calibrating y no cambiaba, y escuchaba que una y otra vez sonaba el relay. mire conecciones y no vi nada raro. Asi que volvi a sacar el pic nuevo y puse el antiguo.

- Luego de poner de nuevo el antiguo ya no pasaba ese problema del relay. Ya me estaba conformando cuando vuelvo a jumpear a ver que sale, y me salieron valores buenos en el link 1 y 2 a diferencia de lo que me salio rato antes. Entonces pense. Oh se arreglo solito?? lo volvi a calibrar y medi la inductancia con toroide de ferrita que es la que he estado bobinando ultimamente. y me marco 2.26uH (paralelamente les cuento que habia medido esa misma inductancia en el oscilador que la pagina del creador del bitx puso. Mi frecuencimetro marcaba 8.algo Mhz, luego de algunos calculos me salio el valor de 2.24uH para la inductancia, asi que pense que ya estaba bien la cosa).

- Luego me puse a medir otra inductancia y no marcaba nada, pense que no estaba bien el conector o algo. Probe mediendo un condensador y me marco un numero lejanisimo de la realidad. Lo saque y volvi a poner y no marcaba nada.

- Lo apague. Luego de un momento puse un condensador nuevamente y nada de marcar. en la tercera apagada y prendida comenzo a marcar valores para los condensadores (cercanos a la realidad) pero en inductancias no marca nada, pero nada, osea salia que estaba fuera del rango.

- Volvi a jumpear los links 1 y 2 para ver que pasa y me marco nuevamente 00000001 o algo asi como cuando estaba mal....

Que pasa???
Es el pic? eso es lo mas probable no???
Acabo de terminar de armar el mismo medidor, y me ocurre exactamente lo mismo que al compañero asterion.
He revisado lo menos 10 veces el circuito y está todo bien. A la hora de enchufarlo, el lcd muestra "Calibrating", y el relé parpadea todo el rato, sin mantenerse fijo. Alguien sabe como solucionar este problema? He de decir que he realizado la versión del PIC 16F628A.
10/03/2013 #298


Un par de opiniones.

1._El prescaler U664 es dificil de conseguir,podrian perfectamente usar el SDA4212 de Siemens

2._El crsital del PIC es importante que sea igual al indicado,de no se asi como va a medir con
exactitud una inductancia o capacitancia?.
El calculo de ambos parametros lo realiza el Pic midiendo la frecuencia que le llega y si la base
de tiempos usada por el PIC y derivada de su reloj no es correcta no puede hacer un calculo
exacto de valores,para la opcion frecuencimetro mas de lo mismo.

3._Los condensadores al calentarlos durante la soldadura cambian de valor .Midan la capacidad de un MKT ,sueldenlo ,desueldenlo y vuelvan a medir.

4._Usen diodos de protecion a la entrada frecuencimetro del tipo barrera y no aberraciones
como los 1N4148 .

5._ Si quireren construirse un frecuencimetro de alta precision busquen un Soft que utilice
un clock de 10 MHz y monten un TCXO ,es bastante usado este valor ,tambien son frecuentes valores de 4 MHz y 12.8 MHz.

6._Por que no montarlo en Manhattan para reducir al maximo las pistas y coneXiones?

7._L a precision del condensador de calibrado es muy importante
11/03/2013 #299
Moderador

Avatar de tiago

Xapas dijo: Ver Mensaje
Acabo de terminar de armar el mismo medidor, y me ocurre exactamente lo mismo que al compañero asterion.
He revisado lo menos 10 veces el circuito y está todo bien. A la hora de enchufarlo, el lcd muestra "Calibrating", y el relé parpadea todo el rato, sin mantenerse fijo. Alguien sabe como solucionar este problema? He de decir que he realizado la versión del PIC 16F628A.
Graba el *.hex del mensaje 282 y prueba. No descartes cambiar el PIC, que mas de una vez ha resultado que estaba defectuoso.
Borra el dispositivo antes de grabar.

Saludos.
11/03/2013 #300

Avatar de Xapas

Hola, y gracias por responder, tiago.
Reprogramé el pic como me dijiste, y parecía que funcionaba, ya que calibró en seguida y mostró en el modo condensador 0'0pF. Sin embargo, cambié al modo de bobinas y ponía "over range", asi que pense, perfecto.
Desconecté el aparato, y lo volví a conectar, y me volvió a pasar lo mismo... No sé que fallo tendrá.
Podría ser que el pic no proporcione suficiente corriente como para excitar el relé? No es un reed relay, sino un relé normalito, de 5V, cuya resistencia interna es de unos 140 ohmios, asi que la intensidad necesaria para excitarlo sería, si Ohm no nos miente, de unos 35-40 mA. No sé si será eso, no lo creo, puesto que en el primer momento que funcionó, cuando cambié a las bobinas se accionó sin problema.
El pic no creo que sea, porque lo compré nuevo justo para esto, y lo he programado dos o tres veces.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos de Radio

Transmisores, Receptores, Antenas...

Cerrar
Foros de Electrónica » Diseño analógico » Circuitos de Radio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.