Haz una pregunta
  Foros de Electrónica » Diseño analógico » Circuitos de Radio
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

29/03/2011 #1


Problema Módulos ASK + PICs
Que tal?
Estoy tratando de hacer un enlace inalámbrico con una pareja de Módulos RF con modulación ASK @ 434MHz.
Estoy utilizando el UART de 2 PICs 16F688. Cuando conecto ambos micros con cable, la comunicación se da sin ningún problema, todos los bits son transmitidos íntegramente.
Según el datasheet de los módulos RF, éstos operan entre 200bps y 3kbps, por lo que yo estoy trabajando a 1.2kbps.
El problema viene cuando quito el cable que interconecta los PICs, y trato de enviar las señales a cada uno de los módulos. Al parecer, el módulo para Tx si hace su trabajo de modulación y envío, así como el de Rx demodula y convierte a serial (puse LEDs en la salida y entrada de datos de los módulos RF). Lo malo es que la info llega completamente distorsionada, y separé los módulos a distancias de 70cm, 2 metros, 5 metros, incluso 15 metros, y aún así hay enlace, mas no se reciben de manera adecuada los bits. Por lo que he revisado en distintas páginas, hay gente que los utiliza sin problemas hasta poco más de 100 metros de separación, sin errores en la recepción de datos.

Otra observación: cuando enciendo el PIC con el módulo receptor, y el PIC que transmite está apagado, comienzan a aparecer datos completamente aleatorios a alta velocidad. Supongo que eso es ruido, pero no me explico de donde proviene. El sistema de Tx (PIC + módulo TX) y el de RX (PIC + módulo RX) están en protoboards separados, y cada uno de ellos está alimentado con una bateria de 9V y un regulador 7805, con capacitor de 1µF a la salida del regulador. Estuve intentando infinidad de cosas, pero sin ningún resultado.

Ahhh, las antenas que coloqué a los módulos son alambres calibre 26, de 17cm cada uno. Intenté eliminando la antena de los módulos, colcando una Dummy-Load de 50Ohms, y nada.

Para los PICs estoy utilizando PIC Simulator IDE, y los comandos HSEROPEN, HSERIN y HSEROUT.

Ya no sé que hacer. Si alguien tiene idea de qué podría estar haciendo mal, por favor, comente.


Gracias
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos de Radio

Transmisores, Receptores, Antenas...

Cerrar
Foros de Electrónica » Diseño analógico » Circuitos de Radio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.