Haz una pregunta
  Foros de Electrónica » Diseño analógico » Circuitos de Radio
Foros Registrarse ¿Olvidaste tu contraseña?
15/07/2009 #1


Señal inestable en un receptor a 433Mhz ¿problema con la antena?
Hola,

hace tiempo compre un par receptor/emisor a 433Mhz de baja potencia, mi idea es conectar dos micros AVR de forma inalámbrica. Una vez montado todo he hecho una prueba con una señal cuadrada para ver que tal la pillaba el receptor, la sorpresa ha sido que el receptor coge mucho ruido y la señal es muy inestable, pero por accidente he tocado la antena del receptor con la mano y esta ha quedado clara y muy bien definina.

Mi pregunta entonces es ¿que sucede para que la señal solo se vea estable cuando pongo la mano en la antena del receptor?

Las antenas (tanto receptor como emisor) son dos cables de cobre rígido de 16cm extraidos de un coaxial, que se han soldado directamente al PCB.

Os adjunto un par de imágenes

Muchas gracias!
15/07/2009 #2

Avatar de Ferny

¿Tienes algún diagrama del circuito? ¿Lo tienes montado sobre una protoboard o ya hiciste algún PCB?
15/07/2009 #3

Avatar de alexus

describi los transceptores
15/07/2009 #4


es una pareja TX/RX de la marca Quasar (QAM-TX1 & QAM-RX4)
Especificación del emisor
Especificación del receptor
Están montados sobre una placa de prototipos con un micro AVR que genera la señal cuadrada de entrada al receptor
Os adjunto un par de fotos de los prototipos donde se puede ver parte de las antenas

Gracias !
Imágenes Adjuntas
Tipo de Archivo: jpg img_3151_166_536.jpg (233,2 KB (Kilobytes), 92 visitas)
Tipo de Archivo: jpg img_3152_385_179.jpg (137,7 KB (Kilobytes), 77 visitas)
16/07/2009 #5

Avatar de Ferny

Por lo que veo tienes la antena bastante alejada del receptor. Prueba soldando la antena directamente sobre el pin del receptor, y lo mismo con el transmisor (lo sueldas al mismo punto donde va soldado el pin del transmisor/receptor). En este caso la longitud de antena debe ser de 17.3 cm. No hace falta que sea del mismo material, yo he usado cable awg24 enrollado en espiral para hacer antenas para unos TX/RS similares y funciona bien

Si el ruido aún se mantiene, es posible que necesites añadir algún condensador de desacoplo, pero sin tener el diagrama del circuito es difícil saber dónde... Me pasó una vez algo parecido y la cosa mejoró algo cuando añadí 100nF en los pines de alimentación del receptor.

Saludos
16/07/2009 #6


muchas gracias Ferny, voy a probar lo que dices. ¿En caso de enrollarlo en espiral la longitud tiene que ser la misma?, ¿como calculo el diámetro y el número de vueltas?

Gracias de nuevo
16/07/2009 #7

Avatar de Ferny

Para que te hagas una idea, yo corté 17.5 cm de cable y los enrollé alrededor de un destornillador, de forma que al final quedó una espiral de unos 6 ó 7 milímetros de diámetro, unos 2 ó 3 cm de altura, y el número de vueltas que fuera (no me paré a contarlas ). Pelé un extremo de la espiral unos 2 mm y eso lo soldé directamente a donde iba soldado el pin de antena del TX/RX, de forma que la parte de la espiral medía los 17.3 cm necesarios.

Ese montaje lo hice al principio sobre una protoboard de las que se "pinchan" los componentes sin soldar, y me pasó eso mismo que te pasa a ti, al pone la mano en alguna parte del circuito (no sólo la antena), la transmisión funcionaba bien, pero quitándola iba sólo a ratos... Después de añadir un condensador de 100nF en la alimentación del TX/RX lo más cerca posible de sus pines, la cosa mejoró mucho, pero de vez en cuando surgía el problema.

Al final, cuando hice un PCB ya bien diseñado, todos los componentes bien soldados, etc... ya no fallaba 8-)
16/07/2009 #8

Avatar de anthony123

Si.. estoy de acuerdo con las sugerencias! Yo recomendaria que colocaras una antena siguiendo la ley L(metros)=300/F(Mhz)

En RF, un desacoplo masivo no es "excesivo" o "algo loco".. Unos 3 104, 1 103, un inductor de 100uH y un electrolitico de 10uF no caeria mal!
16/07/2009 #9

Avatar de Ferny

anthony123 dijo:
Si.. estoy de acuerdo con las sugerencias! Yo recomendaria que colocaras una antena siguiendo la ley L(metros)=300/F(Mhz)

En RF, un desacoplo masivo no es "excesivo" o "algo loco".. Unos 3 104, 1 103, un inductor de 100uH y un electrolitico de 10uF no caeria mal!
En mi caso utilizo la cuarta parte de ese resultado, es decir: L(metros)=(300/F)/4 De ahí salen los 17.3cm que decía antes...

No soy experto en RF pero eso lo saqué de algún manual que no recuerdo, recomendaban usar como longitud de antena la mitad o la cuarta parte de la longitud de onda, o algo así era... En mi caso, quedaba más corta y pequeña la cuarta parte

Respecto de los desacoplos, he estado revisando mi PCB y al final usé 220nF cerámicos en los pines de alimentación de los RX y TX, por si sirve...

[EDITO] Añadí una foto del TX y del RX
Imágenes Adjuntas
Tipo de Archivo: jpg rf_146.jpg (299,4 KB (Kilobytes), 88 visitas)
25/07/2009 #10


pues veo que solo usan como antena la mitad de la misma, sea derecha o enroscada , sigue siendo la mitad de la antena, una antena necesita y a ambas antenas les falta el contrapeso, puedes hacerlo colocando un cable por todo el contorno de la placa donde armaste el circuito del transmisor y del receptor, luego este cable lo conectas a masa o tierra del circuito, eso hara que la "antena" trabaje como una verdadera antena.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos de Radio

Transmisores, Receptores, Antenas...

Cerrar
Foros de Electrónica » Diseño analógico » Circuitos de Radio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.