Haz una pregunta
  Foros de Electrónica » Diseño analógico » Circuitos de Radio
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

30/06/2016 #381


Hola ribevi.
* Entiendo QAS operaciones matemáticas, y entiendo que la posición de memoria y 02, simplemente no entienden cómo ya se ha cargado este valor, y es estándar en el que ver. La mina solución sea capaz de modificar era crear una variable (freq_inicio) con el valor inicial de 1928 como un ejemplo y cambiar la línea en negrita a continuación.

High LED
Print At 1,1, " FM TRANSMITTER "
Print At 2,1, " Rdvv ViProje "
DelayMS 300
Frecuencia_step = Freq_inicio 'Frecuencia de inicio
If Frecuencia_step > 0 Then ComPLL


Gracias.
30/06/2016 #382


Macs dijo: Ver Mensaje
Hola ribevi.
* Entiendo QAS operaciones matemáticas, y entiendo que la posición de memoria y 02, simplemente no entienden cómo ya se ha cargado este valor, y es estándar en el que ver. La mina solución sea capaz de modificar era crear una variable (freq_inicio) con el valor inicial de 1928 como un ejemplo y cambiar la línea en negrita a continuación.

High LED
Print At 1,1, " FM TRANSMITTER "
Print At 2,1, " Rdvv ViProje "
DelayMS 300
Frecuencia_step = Freq_inicio 'Frecuencia de inicio
If Frecuencia_step > 0 Then ComPLL


Gracias.
Al grabar el pic se puede alterar cualquier valor de la memoria eeprom directamente.
Este programa (como esta)lee el valor de dicha posición de memoria(02 y 03 ya que la variable a la que esta cargándose ocupa dos posiciones de memoria por ser del tipo WORD.) y lo carga en dicha variable.
Si esta con valor 0 procede a entrar al modo programación de la frecuencia automáticamente.
Una vez seleccionada(Subir, Bajar) la frecuencia y almacenada(Grabar) ya queda escrito dicho valor en dicha posición por lo que la próxima vez que se encienda se cargara este valor almacenado.
Siempre al encender carga y coloca el PLL a la misma frecuencia programada la ultima vez que se uso Grabar mientras no se presione dicho botón. Esta acción en principio, lleva a entrar al modo programacion para cambiar la frecuencia.
Si uno quiere no tener todo estas posibilidades, el programa se simplifica a enviar un valor fijo almacenado siempre sin la intervención de ninguna tecla o botón para alterara el valor(Subir, Bajar, Grabar).
No se si soy claro por que no alcanzo a comprender que quieres hacer(a parte de entender como funciona el programa).

Ric.
02/07/2016 #383


Buenas tardes ...
Encontré la respuesta a mis dudas.
En los archivos descargados que los botones simulador de proteus ya había sido precionados y se muestra en la pantalla una frecuencia de 96,40 MHz, por lo que en la EEPROM era un valor de 0778 hex.
Para mí no tenía sentido, ya que al principio del programa, dijo que la frecuencia _step= Eread 02, y yo no había visto ningún comando para escribir algo antes de esa línea.

He diseñado un nuevo circuito en Proteus y carga el programa y la pantalla muestra una frecuencia de 327,63 MHz, que la EEPROM de un valor hexadecimal = FFFF. Oh, sí que tiene sentido porque creo en la EEPROM de forma predeterminada inicialmente todo esto en FF.

Gracias a ricbevi que intentó enteder mí, incluso el uso de un traductor.
02/07/2016 #384


Macs dijo: Ver Mensaje
Buenas tardes ...
Encontré la respuesta a mis dudas.
En los archivos descargados que los botones simulador de proteus ya había sido precionados y se muestra en la pantalla una frecuencia de 96,40 MHz, por lo que en la EEPROM era un valor de 0778 hex.
Para mí no tenía sentido, ya que al principio del programa, dijo que la frecuencia _step= Eread 02, y yo no había visto ningún comando para escribir algo antes de esa línea.

He diseñado un nuevo circuito en Proteus y carga el programa y la pantalla muestra una frecuencia de 327,63 MHz, que la EEPROM de un valor hexadecimal = FFFF. Oh, sí que tiene sentido porque creo en la EEPROM de forma predeterminada inicialmente todo esto en FF.

Gracias a ricbevi que intentó enteder mí, incluso el uso de un traductor.
Así es, Proteus almacena si fue usado el valor y en el próximo encendido carga el valor almacenado.
Al programar por primera ves un chip virgen, efectivamente todas las posiciones de memoria se encentan a valor $FF(hexadecimal o 255 decimal). En este caso en particular como lee dos posiciones la primera vez tiene que cargarse el valor $FFFF(Hexadecimal o sea 65535 en decimal)
Te aclaro que es un programa muy básico y se puede mejorar mucho en mucho de los aspectos(visuales, operativos).
Yo solo me limite a traducirlo e interpretar lo que ya estaba echo.

Ric.
06/08/2016 #385


Buenas tardes después de casi un año retome de nueva cuenta el proyecto, por motivos de que estuve fuera, así como conseguir los componentes, ahora solo me faltan dos resistencias que comprare el lunes.
Me habían comentando acerca de la calibración por medio de los trimmers (fue una hazaña conseguirlos) lo cual agradezco, pero tengo un duda acerca de la antena, ya que había hecho anteriormente solo transmisores pequeños (sintonizada con cap e inductor) y usaba antena telescópicas de radios, es posible usar en este estas mismas, solo para verificar su funcionamiento?
(La placa la hice por método de serigrafia lo componentes activos están en la parte inferior ya que la coloque sin querer alrevez)
Imágenes Adjuntas
Tipo de Archivo: jpg FB_IMG_1470160366850.jpg (57,4 KB (Kilobytes), 57 visitas)
07/08/2016 #386


Acabo de ver su montaje, paso que transfirio la imagen sin volcarla como espejo. Y ya probo ella?
07/08/2016 #387


Estan correctamente posicionados es decir es como si se hubiera hecho el espejo de la imagen, creo qUE eso no hay problema, la duda es con respecto a la antena telescopica solo para probar..

---------- Actualizado después de 18 minutos ----------

Probe solo la parte de la transmisión pic y lcd, solo que no lo deje mucho por miedo a quemar el transistor de salida (aunque trae un disipador), al parecer esta bien, hasta mañana haré las pruebas ya que necesito 2 resistencia que no tengo.
08/08/2016 #388


Seria bueno, que puedas leer este articulo amigo.

http://www.neoteo.com/antenas-dipolo-para-fm-88-108mhz

Espero te sirva.
11/08/2016 #389


Ya compre los componentes que me faltaban, ahora surgió un problema, cuando enciende aparece unlocking, hasta ahi todo normal la frecuencia me marco 100 Mhz, la cosas es que enseguida parpadea solo el led lock-unlock , probé cambiando la frecuencia de operación, y sigue igual, el varicap que uso es el bb112, me imagino que no debería tener problema ya que abarca un gran margen para enganche, en el display aparece lock-unlock intermitentemente (al igual que el led). revise el voltaje de enganche me marca solo algunos milivolts y no los 5v que deberia, a alguien le paso esto?
12/08/2016 #390

Avatar de djmyky

Pues deberías de probar en frecuencia bajas 88 mhz o más arriba 106 mhz y ver el comportamiento y también abriendo o cerrando las bobinas del oscilador suerte
12/08/2016 #391

Avatar de NowhereMan

El BB112 es un diodo varicap para circuitos de AM, en un post se aclara que para este circuito el diodo varicap debe ser el BB109, BB132, BB133, los de punto rojo, verde o amarillo; o cualquier otro que tenga una capacitancia entre 1 y 80pf.
12/08/2016 #392


Pues me di a la tarea revisar cada componente, quite el varicap, transistor bf494, y llegue al bc548 que se encuentra en la rama de la salida RA0 del pic, el cual activa y desactiva el el lock-unlock, probe sin el transistor (no tengo a la mano reemplazo), quedo estable eganchado(sin parpadeos y lcd "lock"), por lo cual tengo la sospecha que su beta es pequeño o esta dañado (no esta en corto) .
adjunto imagen de la etapa del diagrama
Imágenes Adjuntas
Tipo de Archivo: jpg w.jpg (55,4 KB (Kilobytes), 34 visitas)
13/08/2016 #393


SATANCHIA6 dijo: Ver Mensaje
Pues me di a la tarea revisar cada componente, quite el varicap, transistor bf494, y llegue al bc548 que se encuentra en la rama de la salida RA0 del pic, el cual activa y desactiva el el lock-unlock, probe sin el transistor (no tengo a la mano reemplazo), quedo estable eganchado(sin parpadeos y lcd "lock"), por lo cual tengo la sospecha que su beta es pequeño o esta dañado (no esta en corto) .
adjunto imagen de la etapa del diagrama

Hola...Dudo que el problema sea por ese transistor...para mi la carga que representa a el VCO(Q3) la etapa que componen Q4(habilitado por Q7...el de la cuestión) hace que disminuya la señal hacia el IC PLL y U2 y este se queda sin referencia(desengancha)....cuando se desconecta dicha etapa, aparece nuevamente el nivel de señal y pasa a habilitar nuevamente dicha etapa produciéndose así un funcionamiento intermitente.
Es solo especulación ya que nunca construí dicha placa pero el BF494 para ese lugar no seria de mi primer elección y tampoco el 2N4427 que lo sigue como separador.
Saludos.

Ric.
13/08/2016 #394


SATANCHIA6 dijo: Ver Mensaje
Ya compre los componentes que me faltaban, ahora surgió un problema, cuando enciende aparece unlocking, hasta ahi todo normal la frecuencia me marco 100 Mhz, la cosas es que enseguida parpadea solo el led lock-unlock , probé cambiando la frecuencia de operación, y sigue igual, el varicap que uso es el bb112, me imagino que no debería tener problema ya que abarca un gran margen para enganche, en el display aparece lock-unlock intermitentemente (al igual que el led). revise el voltaje de enganche me marca solo algunos milivolts y no los 5v que deberia, a alguien le paso esto?
Separa las bobinas de la salida de rf. Seria bueno que muestres una imagen de tu pll
14/08/2016 #395


hola señores le comento que he tenido problemas para que enganche y la solucion fue una resitencia en la base del bc 548 que llega al pic atraves de un jumper a masa. de esa forma e podido hacerlo enganchar. subo imagenes y ahi esta andando . si algien tiene alguna sugerencia la escucho
Imágenes Adjuntas
Tipo de Archivo: jpg 20160628_193942.jpg (114,3 KB (Kilobytes), 63 visitas)
Tipo de Archivo: jpg 20160701_192721.jpg (137,1 KB (Kilobytes), 63 visitas)
Tipo de Archivo: jpg 20160701_192732.jpg (116,9 KB (Kilobytes), 64 visitas)
14/08/2016 #396

Avatar de djmyky

al parecer las resistencias de 4,7 k los has puesto de 47 ohms las de 4,7k vendrían a ser amarillo ,violeta ,naranja y por ahí varias resistencias que usas son de precision pero no del valor ten en cuenta eso
Imágenes Adjuntas
Tipo de Archivo: jpg 1.JPG (137,4 KB (Kilobytes), 37 visitas)
14/08/2016 #397

Avatar de elgriego

Hola ,algo raro pasa con ese pll,,,esta algo corrido del punto de sintonia,,no entiendo como entra en rango de captura,,,el cristal del divisor programable es el correcto,o hay algo raro en el programa del pic.???


Saludos.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos de Radio

Transmisores, Receptores, Antenas...

Cerrar
Foros de Electrónica » Diseño analógico » Circuitos de Radio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.