Haz una pregunta
  Foros de Electrónica » Diseño analógico » Circuitos de Radio
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

08/05/2012 #101
Moderador

Avatar de tiago

ugt dijo: Ver Mensaje
hola tiago saludos, una consulta yo tengo armado todo el pll con el tsa5511 y un pic16f84 pero no engancha, con la diferencia que uso el tsa5511T SMD adjunto foto del que uso, sera este TSA.que no me sirve?? lo has probado ?? ya que es fácil conseguirlo esta en selectores de canales de tv.. agradezco respuesta tiago ó algún amigo del foro que lo aya armado gracias..
Éste es el primero que monto con esta configuración, he montado otros PLL con el TSA y el mismo PIC, que los puedes ver un poco mas arriba en éste mismo hilo y funcionan perfectamente, puede ocurrirte que no te esté oscilando o no lo haga bien. Has probado si oscila?

Saludos.
08/05/2012 #102

Avatar de ugt

hola tiago!!! gracias por responder.. si probé con todo y si! oscila el tsa5511t oscila pero no engancha.. he probado varias formulas pero me queda 1 la veré y te cuento gracias
09/05/2012 #103
Moderador

Avatar de tiago

ugt dijo: Ver Mensaje
hola tiago!!! gracias por responder.. si probé con todo y si! oscila el tsa5511t oscila pero no engancha.. he probado varias formulas pero me queda 1 la veré y te cuento gracias
¿En que frecuencia te oscila? Tienes que medirlo. Situa el PLL en el centro de la banda, y mandame el hex que le has grabado, tambien dime si usas 16f84 ó 16f628.

Saludos.

Edito: Una foto del aparato por la parte de los componentes no vendria mal. Que se vea clara por favor. ¿Usas el varicap adecuado? Cuando digo sioscila, me refiero al oscilador de RF, o sea, al primer transistor, hay que medir frecuencia simplemente metiendo la sonda en la bobina.
09/05/2012 #104

Avatar de ugt

bueno medí el oscilador del tsa5511t que tiene que entregar 3.2mhz y si lo hace. y uso un pic16f84a ya que no tengo otro tipo de pic, el problema que yo arme un oscilador distinto al tuyo tiago, por falta de componentes del original pero ya los tengo vere el circuito y are ese oscilador que armaste tu te adjunto el .hex que me regalo un amigo del foro para que lo pruebes y me cuentes como anda,
pd: la foto es un ejemplo del tsa que tengo no es lo que uso
el oscilador es el que arme solo hasta el tr donde sale la muestra de rf y un amplificador mas de rf en su salida salen al redor de 100 mili watt, esto anda bien los varicap use unos de selector de tv que se usan en las etapas de uhf. los probé en otros proyectos de alta frecuencia y responden muy bien.. bueno tomare unas fotos y las colgare aca gracias tiago
Archivos Adjuntos
Tipo de Archivo: rar TSA5511_FM.rar (2,0 KB (Kilobytes), 263 visitas)
Tipo de Archivo: rar osilador armado.rar (941,7 KB (Kilobytes), 391 visitas)
Tipo de Archivo: rar tsa smd sacado de la red como ejemplo.rar (573,4 KB (Kilobytes), 316 visitas)
09/05/2012 #105
Moderador

Avatar de tiago

ugt dijo: Ver Mensaje
bueno medí el oscilador del tsa5511t que tiene que entregar 3.2mhz y si lo hace. y uso un pic16f84a ya que no tengo otro tipo de pic, el problema que yo arme un oscilador distinto al tuyo tiago, por falta de componentes del original pero ya los tengo vere el circuito y are ese oscilador que armaste tu te adjunto el .hex que me regalo un amigo del foro para que lo pruebes y me cuentes como anda,
pd: la foto es un ejemplo del tsa que tengo no es lo que uso
el oscilador es el que arme solo hasta el tr donde sale la muestra de rf y un amplificador mas de rf en su salida salen al redor de 100 mili watt, esto anda bien los varicap use unos de selector de tv que se usan en las etapas de uhf. los probé en otros proyectos de alta frecuencia y responden muy bien.. bueno tomare unas fotos y las colgare aca gracias tiago
Entonces ... La foto corresponde a tu aparato??? , no cuadra con el esquema, al menos en el PIC Tu le has puesto un TSA SMD??? El patillaje es de 16 pin y la versión normal es de 18, y el PIC que usas ¿Cual es?

Saludos.
09/05/2012 #106

Avatar de ugt

no tiago, la foto no corresponde a mi aparato!! es solo para dar una idea del asunto. yo uso el pic16f84a no cuento con otro pic, tengo armado el pic16f84 y el tsa 5511t en una placa aparte,tengo que armar un oscilador que me de 88a 108 mhz y acoplarla a el pll, bueno hay subo fotos ...de lo que tengo
Archivos Adjuntos
Tipo de Archivo: rar control tsa5511t.rar (997,1 KB (Kilobytes), 331 visitas)
Tipo de Archivo: rar la arme comp'leta no funciono el osilador si!!.rar (1,11 MB (Megabytes), 339 visitas)
09/05/2012 #107
Moderador

Avatar de tiago

ugt dijo: Ver Mensaje
no tiago, la foto no corresponde a mi aparato!! es solo para dar una idea del asunto. yo uso el pic16f84a no cuento con otro pic, tengo armado el pic16f84 y el tsa 5511t en una placa aparte,tengo que armar un oscilador que me de 88a 108 mhz y acoplarla a el pll, bueno hay subo fotos ...de lo que tengo
Pero el display que te visualiza..?

Saludos.
09/05/2012 #108

Avatar de ugt

el displey me muestra la frecuencia y los comandos eso bien, ahora el la en la salida del tsa... deveria tener un voltaje en los pines SDA Y SCL??? bueno como tu me dieses estoy muy consciente de los pines y las diferencias que hay en el formato smd de 16 pines y el formato grande(de 18 pines ) vi el data y me guie por eso. yo no puedo encontrar el tsa5511 de 18 pines el grande por eso uso el SMD. prueba TIAGO CON LOS .hex Y ME CUENTAS POR FAVOR COMO TE ANDAN PUEDE QUE HAY ESTE EL DRAMA..TE DEJO ESTOS .HEX PARA QUE ME DIGAS SI FUNCIONAN ...
Archivos Adjuntos
Tipo de Archivo: rar F84_TSA5511_FM_2.rar (2,0 KB (Kilobytes), 176 visitas)
09/05/2012 #109
Moderador

Avatar de tiago

ugt dijo: Ver Mensaje
el displey me muestra la frecuencia y los comandos eso bien, ahora el la en la salida del tsa... deveria tener un voltaje en los pines SDA Y SCL??? bueno como tu me dieses estoy muy consciente de los pines y las diferencias que hay en el formato smd de 16 pines y el formato grande(de 18 pines ) vi el data y me guie por eso. yo no puedo encontrar el tsa5511 de 18 pines el grande por eso uso el SMD. prueba TIAGO CON LOS .hex Y ME CUENTAS POR FAVOR COMO TE ANDAN PUEDE QUE HAY ESTE EL DRAMA..TE DEJO ESTOS .HEX PARA QUE ME DIGAS SI FUNCIONAN ...
Mas bien puede que esté en el varicap la solución, si no es el que toca, se te irá de banda y no te enganchará. Ponle audio y prueba a sintonizar con un receptor de radio, aunque el PLL no funcione, si está dentro de banda, deberias sintonizar tu emisión. El PLL solo le dá estabilidad al oscilador, pero éste debe funcionar por si solo.Si posteas el diagrama de tu placa será mas fácil.

Ves al post #39 y bájate el firm del f84 que ese si que funciona porque es el que yo uso. De todos modos mañana pruebo el tuyo y te cuento.
17/05/2012 #110
Moderador

Avatar de tiago

Bueno, el circuito está montado con todo el cuidadoque he sido capaz de poner.

El PIC actua con normalidad, pues visualiza la presentación y posterior seteo de frecuencia, apagado y encendido de lampara de pantalla etc...

El caso es que no engancha. En otros osciladores, colocando la sonda del frecuencimetro al lado de la bobina osciladora, me muestra la frecuencia de trabajo con precisión. En este caso, no mustra visualización alguna, el circuito no resuena.

He comprobado los componentes respecto al esquema teórico correspondiente a la etapa de RF y que posteo al pié en formato *.zip, y he visto que está todo correcto, me pregunto si alguien que haya montado este proyecto ha encontrado errores o realizado modificaciones para que funcione, si es así agradezco la ayuda.

Pongo una foto del bloque oscilador y PLL por si revela algo que pueda dar una idea de lo que puede fallar. A ver si quienes lo lograron montar pueden reportarme alguna pista.



Pienso que el oscilador deberia arrancar dentro de la banda aunque el PLL no esté funcionando, aunque esto lo tengo comprobado con transistores convencionales, con mosfet no tengo ni idea si debe ser así.

Saludos.
Imágenes Adjuntas
Tipo de Archivo: jpg Osc.jpg (230,3 KB (Kilobytes), 533 visitas)
Archivos Adjuntos
Tipo de Archivo: rar rf.rar (88,6 KB (Kilobytes), 241 visitas)
17/05/2012 #111

Avatar de J2C

Tiago

Que tensiones CC existen en Drain y en G2 T1 ???.


A titulo personal me parece excesiva la tensión de G2 derivada desde Drain con una resistencia de solo 56 Ω. También verificaria la corriente que circula por R7 de 220 Ω pero que la podemos calcular al conocer la tensión de Drain.


Buscaria en la web para sacarme la duda, algún otro ejemplo de Oscilador con MosFet doble compuerta aunque no sea en la misma banda de frecuencias.



Saludos, JuanKa.-
17/05/2012 #112
Moderador

Avatar de tiago

J2C dijo: Ver Mensaje
Tiago

Que tensiones CC existen en Drain y en G2 T1 ???.


A titulo personal me parece excesiva la tensión de G2 derivada desde Drain con una resistencia de solo 56 Ω. También verificaria la corriente que circula por R7 de 220 Ω pero que la podemos calcular al conocer la tensión de Drain.


Buscaria en la web para sacarme la duda, algún otro ejemplo de Oscilador con MosFet doble compuerta aunque no sea en la misma banda de frecuencias.

Saludos, JuanKa.-
Hola Juanka.

En la placa, la resistencia R7 de 220 Ohm no va entre R6 y C7, como figura en el esquema. Si no que va entre C6 y R6.

Las tensiones que me pides son 8'64 voltios en los dos casos, con la punta del - del tester a masa y 5'17 voltios en ambos casos con la punta + a positivo.

Es extraño, parece un circuito muy sencillo como para que no tire.

Saludos.
17/05/2012 #113

Avatar de J2C

Tiago
tiago dijo: Ver Mensaje
..... En la placa, la resistencia R7 de 220 Ohm no va entre R6 y C7, como figura en el esquema. Si no que va entre C6 y R6. .....
Realmente esa configuración me parece extrañisima. Estoy acostumbrado a ver un divisor de tensión desde V+ (9V en este caso) con un capacitor a masa como el que tiene en el G2 del MosFet Dual Gate, independiente de las tensiones de Drain de dicho MosFet.
Por otra parte, nunca lo he visto con una tensión tan alta.



tiago dijo: Ver Mensaje
..... Las tensiones que me pides son 8'64 voltios en los dos casos, con la punta del - del tester a masa .....
Suponiendo que tienes colocado el 78L09 y despreciando la caida de tensión en R11 anoto .36V de caida sobre R7 lo que me da una corriente aproximada de 1.6 mA que es demasiado baja, eso me hace suponer que el oscilador no oscila de ahi que no hayas podido ver nada aproximando la sonda a la bobina.
Algo tal vez fuera de lugar, verificaste con la Datasheet del BF981 las conexiones de sus electrodos???, te lo pregunto por que como ejemplo el BF961 tiene invertidos el G2 y el Source con respecto al BF981.




tiago dijo: Ver Mensaje
..... y 5'17 voltios en ambos casos con la punta + a positivo. .....
Imagino que esta medición la has realizado a +13.8 V con lo cual no nos permite calcular la corriente que circula por la R7. Igual ya lo he respondido aproximadamente en el punto anterior.





Fuera de todos los comentarios previos, yo probaria lo siguiente:
Conectaria R7 directo al Drain de MosFet.
Quitaria R6.

Realizaria un divisor resistivo con 100KΩ y 47KΩ:
Un extremo de 100KΩ a +9V, el otro a 47KΩ, C6 y G2 del MosFet.
El otro extremo de 47K a masa.
De esta forma polarizo G2 con aproximadamente 3 V positivos respecto del Source que son valores más normales.
Puedes hacerlo estilo araña/Manhattan solo para probar, se que eres muy cuidadoso con todo lo que has armado; pero es para hacer una prueba y salir de dudas.




Saludos, JuanKa.-
17/05/2012 #114
Moderador

Avatar de tiago

J2C dijo: Ver Mensaje
Tiago

Realmente esa configuración me parece extrañisima. Estoy acostumbrado a ver un divisor de tensión desde V+ (9V en este caso) con un capacitor a masa como el que tiene en el G2 del MosFet Dual Gate, independiente de las tensiones de Drain de dicho MosFet.
Por otra parte, nunca lo he visto con una tensión tan alta.




Suponiendo que tienes colocado el 78L09 y despreciando la caida de tensión en R11 anoto .36V de caida sobre R7 lo que me da una corriente aproximada de 1.6 mA que es demasiado baja, eso me hace suponer que el oscilador no oscila de ahi que no hayas podido ver nada aproximando la sonda a la bobina.
Algo tal vez fuera de lugar, verificaste con la Datasheet del BF981 las conexiones de sus electrodos???, te lo pregunto por que como ejemplo el BF961 tiene invertidos el G2 y el Source con respecto al BF981.





Imagino que esta medición la has realizado a +13.8 V con lo cual no nos permite calcular la corriente que circula por la R7. Igual ya lo he respondido aproximadamente en el punto anterior.





Fuera de todos los comentarios previos, yo probaria lo siguiente:
Conectaria R7 directo al Drain de MosFet.
Quitaria R6.

Realizaria un divisor resistivo con 100KΩ y 47KΩ:
Un extremo de 100KΩ a +9V, el otro a 47KΩ, C6 y G2 del MosFet.
El otro extremo de 47K a masa.
De esta forma polarizo G2 con aproximadamente 3 V positivos respecto del Source que son valores más normales.
Puedes hacerlo estilo araña/Manhattan solo para probar, se que eres muy cuidadoso con todo lo que has armado; pero es para hacer una prueba y salir de dudas.




Saludos, JuanKa.-
OK, mañana lo pruebo. El Bf 981 tiene que ser colocado con la serigrafia hacia abajo para que coincidan las patillas, claro que me he asegurado que patilla iba a que lugar, lo he soldado verificando en cada momento, es extraño, este circuito circula mucho por la red y parce que funciona sin pegas con esa configuración.

Dejo archivo con la placa y serigrafia de componentes para poder comparar mejor.

Saludos
Archivos Adjuntos
Tipo de Archivo: rar 1.rar (114,4 KB (Kilobytes), 254 visitas)
17/05/2012 #115

Avatar de J2C

Tiago
tiago dijo: Ver Mensaje
..... El Bf 981 tiene que ser colocado con la serigrafia hacia abajo para que coincidan las patillas, claro que me he asegurado que patilla iba a que lugar, lo he soldado verificando en cada momento .....
Si lo colocas de esa manera, compensas la duda que generaba la Datasheet del BF961 que también mire en ese momento.



tiago dijo: Ver Mensaje
..... es extraño, este circuito circula mucho por la red y parce que funciona sin pegas con esa configuración .....
No te discuto eso, solo que muchos pueden haber tenido algún problema como tu ahora y al solucionarlo no comentan nada, entendes a que me refiero???.
Lo que sugeri modificar lo podrás ver en detalle en algún viejo Handbook de la ARRL ya que ellos hace ya más de 32 años mostraban circuitos con su famoso MosFet Dual Gate 40673 de la RCA!!!.
En el momento que respondi estaba trabajando y no tenia tiempo para investigar.



Saludos, JuanKa.-
18/05/2012 #116
Moderador

Avatar de tiago

Si, ya entiendo a que te refieres. Probaré lo que me has sugerido.

Mira esta configuración que he encontrado por ahí, es muy similar, quizá te de una idea mas clara de como se debe polarizar el mosfet. Aqui se utiliza una R de 100K para polarizar la puerta, lo cual me parece mas logico.




Esta es la dirección del circuito al completo: http://www.ea4nh.com/articulos/tx_vhf/tx_vhf.htm

Saludos.
Imágenes Adjuntas
Tipo de Archivo: jpg doble puerta.jpg (25,7 KB (Kilobytes), 584 visitas)
18/05/2012 #117


J2C dijo: Ver Mensaje
Tiago
...
Lo que sugeri modificar lo podrás ver en detalle en algún viejo Handbook de la ARRL ya que ellos hace ya más de 32 años mostraban circuitos con su famoso MosFet Dual Gate 40673 de la RCA!!!.
...
Juanka, al margen del tópico, no te imaginas cuantas veces le he sugerido a nuestros foristas que se bajen el Radio Amateur Handbuck de la ARRL.

Lo repito como radioaficionado (YV 5 MHE): Ese libro es la biblia de la RF.

No está escrito por aficionados, se los aseguro, cada artículo es el producto de uno o varios ingenieros que también son radioficionados.

Existe una versión gratuita en la red, en español, solo que fue publicada en varios archivos y hay que bajarlos uno a uno.

Se los recomiendo una vez más a todos.

Imagino que tú ya lo tienes. Sería bueno que Tiago también lo tuviese, y los demás también claro.

Saludos y felicitaciones Tiago, van quedando muy bien los equipos.
18/05/2012 #118


alguem de vocês já fez um transsmissor desses que relamente funciona ? eu já fiz uns 3 desses e não funcionou bem não
18/05/2012 #119
Moderador

Avatar de tiago

marcosaq dijo: Ver Mensaje
alguem de vocês já fez um transsmissor desses que relamente funciona ? eu já fiz uns 3 desses e não funcionou bem não
Hola, al principio del hilo, el amigo clausalan asegura que el suyo funciona. gatxan, tambien parece haberlo probado y no le convenció, pero parece que le funcionaba.

Juanka, ya he polarizado la gate con 2'99 volt y nada, en lugar de 56 Ohm he puesto 56K y en paralelo con C6 una R de 33K con lo que formo un divisor que me proporciona esta tensión. Pienso si no habria que desacoplar el drenador y otra cosa que me llama la atención es que en el circuito similar que he posteado antes, toman la RF de la source y no de drain. No se de Mosfet y puede que segun trabaje el transistor será posible hacerlo.

No se si sospechar del transistor. Como se comprueba un mosfet de doble puerta?

Otra cosa, aunque el PLL no trabaje ...deberia oscilar dentro de la banda de frecuencia? Lo digo por si el PLL esta fallando. Quizá la bobina osciladora... Se puede sustituir el varicap con un condensador de unos 10 Pf para probar?

Saludos.
18/05/2012 #120

Avatar de J2C

Tiago

Mis disculpas por no haber respondido antes, lo estaba haciendo tipo 12:00 de Bs. As. pero un corte de energía electrica en mi zona me interrumpio y borro totalmente la respuesta que estaba elaborando, luego ha regresado tipo 18:30 pero estaba ocupado (son ahora las 23:10 de Bs. As.).


Si bien has logrado una tensión como te sugeria yo en mi post #113 y que tu también has visto en la página de EA4NH la misma debería estar independizada del Drain en tu esquema original. Como?, la resistencia de 56KΩ deberia ser conectada a la R11 de 10Ω que sale del regulador 78L09 y no al DRAIN de MosFet Dual Gate.

La otra diferencia que has notado entre ambos osciladores es que el tuyo tiene salida por DRAIN (Colector, valga la analogía bipolar) y el de EA4NH tiene salida por SOURCE (Emisor analogicamente). No tengo el detalle exacto de los cambios pero deberiamos pensar por la parte de una mayor o menor impedancia de salida del oscilador, por otra parte en la salida por SOURCE el oscilador es suceptible a cambios de frecuencias ante variaciones de la carga del buffer (hablo teoricamente en el aire [se entiende? ]).



tiago dijo: Ver Mensaje
..... Otra cosa, aunque el PLL no trabaje ...deberia oscilar dentro de la banda de frecuencia? Lo digo por si el PLL esta fallando. Quizá la bobina osciladora... Se puede sustituir el varicap con un condensador de unos 10 Pf para probar? .....
Todo lo que dices es 100% correcto, debería oscilar no se si dentro de la banda o ligeramente fuera de la misma; pero DEBERIA OSCILAR.
Primero sustituye el Varicap por un C como dices, te lo iba a comentar si fracasaba esta prueba. También podría ser la bobina si no hace buen contacto la derivación ó la misma no esta en la cantidad de espiras adecuada faltando la realimentación suficiente que mantiene la oscilación.
Se puede subir el TAP al 33% de la cantidad de espiras y probar como lo ha hecho EA4NH en su circuito.



tiago dijo: Ver Mensaje
..... No se si sospechar del transistor. Como se comprueba un mosfet de doble puerta? .....
También podría estar en malas condiciones por que son muy sensibles a las descargas electrostaticas aunque los mismos tienen ambas compuertas (gate) protegidos. Me parece (no estoy seguro), que sino tienes otro hasta podrías reemplazarlo por un FET de Juntura tipo BF244/BF245 (ó similar) para probar, no tiene la segunda compuerta asi que esa parte quedaría sin conexión. Piensa que es solo una prueba para tratar de descubrir que es lo que esta pasando.






McrVen

Tengo una parte (me quedo en la casa de mis hijos después de separarme/divorciarme [hace 19 años] junto a otras cosas [un Osciloscopio Monfrini 410B {10 Mhz de ancho de banda}] que no fueron adecuadamente cuidados por mi ex) que recupere con el tiempo del HandBook 1978 en castellano que imprimia en Argentina la Editorial Arbó con licencia de la ARRL. También tengo una edición creo que posterior al 2000 y si mal no recuerdo en Inglés en el Disco Rígido Portable que debería buscar, me lo anotare y luego les comento.

Por otro lado si bien no soy radio-aficionado tengo 28 años de experiencia entre RadioComunicaciones y TeleComunicaciones (BLU, VHF, UHF, MicroOndas desde 1.5 GHz hasta 18 GHz, Mux FDM, Mux PCM, PDH, ADM's SDH, Fibra Optica, Punto Multi-Punto, Onda Portadora sobre líneas de 500 KVca, etc.), dicha experiencia fue adquirida en dos empresas internacionales (en las sedes ubicadas en Argentina) pero conocidísimas cada una en su rubro.


Dejando de lado el palabrerio, lo fundamental para los electrónicos (aunque solo seamos técnicos) siempre ha sido profundizar la lectura (y las mediciones [medir, medir, hasta encontrar el problema]) cuando nos encontramos ante algo que no nos funciona como deseamos. Debemos agradecer la enorme cantidad de info que es posible hallar en "la" Internet.



Saludos, JuanKa.-


P.D.: Marcosaq trata de escribir en castellano (usa el traductor del Google a pesar de los errores que comete el mismo aunque muchos de nosotros te comprendamos) para que no te manden a Moderación tus post, piensa que es una de las normas de Foros de Electrónica y no nos cuesta nada respetarlas; además, que mejoran la CyberConvivencia !!!, también si colocas la ciudad donde vives nos daremos cuenta que eres de Brasil ó Portugal .



MIL DISCULPAS por tanto palabrerio.-


.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos de Radio

Transmisores, Receptores, Antenas...

Cerrar
Foros de Electrónica » Diseño analógico » Circuitos de Radio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.