Haz una pregunta
  Foros de Electrónica » Diseño analógico » Circuitos de Radio
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

19/05/2012 #121
Moderador

Avatar de tiago

Je, je, Juanka, tienes para todos

Bien, ahora en serio. Si que tengo un par mas de mosfet del mismo tipo, puede que la excesiva tensión de puerta que recibió al principio pueda haberlo averiado, en todo caso, lo sustituyo y duda despejada.

Modificaré el circuito como me has dicho y jugaré un poco con la bobina, voy a pasar el dia fuera y no tendré ocasión de avanzar mucho hoy. Tambien estoy pensando construir una pequeña placa con el circuito oscilador y someterla a pruebas hasta que funcione, con ello evito el inevitable deterioro de pistas al soldar y desoldar continuamente. Esta tarde añadiré mas info y haremos andar este bicho.

Mi hijo te manda un saludo, tiene 8 años
19/05/2012 #122

Avatar de J2C

Tiago

Haz las pruebas y/ó plaquetas que consideres necesarias, en la medida de mis posibilidades y conocimientos aportare mi grano de arena como he hecho hasta ahora.



tiago dijo: Ver Mensaje
..... Mi hijo te manda un saludo, tiene 8 años
Tienes al lado tuyo al Futuro Locutor Radial???, cuando mis hijos eran pequeños siempre estaban mirando que hacia yo en el pequeño taller que tenia en el fondo de mi casa, es agradable aunque a veces molesto cuando las cosas no nos salen por las continuas preguntas con que nos interrumpen, pero tiene su sabor familiero . Los mios son todos profesionales universitarios (ó casi) pero ninguno/a se metio con la Electrónica, solo el mayor se acerco a la parte Informática/Sistemas; el resto Económicas, Química y Hematología.



Saludos, JuanKa.-
20/05/2012 #123
Moderador

Avatar de tiago

No me parece un locutor Radial, entra a cacharrear , pero le gusta desmontar sus juguetes con mis herramientas ... Ya veremos

De momento posteo el circuito oscilador tal y como ha quedado despues de las modificaciones, no funciona todavia, pero nos acercamos a la causa, la bobina la he cambiado y le he hecho varias tomas, probando en cada una de ellas, nada. He sustituido el transistor y solo me queda sustituir el varicap por un condesador fijo. No se si seria conveniente desacoplar el Drain con 10n a masa. Seguimos adelante.



Saludos.
Imágenes Adjuntas
Tipo de Archivo: jpg modificacion.jpg (121,8 KB (Kilobytes), 505 visitas)
20/05/2012 #124

Avatar de J2C

Tiago

El Drain no lo desacoples con 10nF a masa por que es la salida de la señal de RF.

El esquema de ese oscilador corresponde al tipo Hartley que siempre oscilan, lo único que no has cambiado aún es el Varicap y el Cap. serie con el Varicap.


Para hacerlo oscilar (no nos importa la frecuencia en este momento) solo debes colocarle un Cap. Ceramico NPO en paralelo con los extremos de la bobina, 8.2pF ó 10pF debería ser un valor aproximado al equivalente de la serie de Varicap y 100 pF.

Lo importante es lograr que oscile y que puedas medir a que frecuencia lo hace, luego veremos de normalizar el circuito para el uso del Tx de FM.



Saludos, JuanKa.-

P.D.: Me estoy yendo a almorzar, calculo que en 1 hs regreso donde tengo la PC, suerte.-
20/05/2012 #125
Moderador

Avatar de tiago

J2C dijo: Ver Mensaje
Tiago

El Drain no lo desacoples con 10nF a masa por que es la salida de la señal de RF.

El esquema de ese oscilador corresponde al tipo Hartley que siempre oscilan, lo único que no has cambiado aún es el Varicap y el Cap. serie con el Varicap.


Para hacerlo oscilar (no nos importa la frecuencia en este momento) solo debes colocarle un Cap. Ceramico NPO en paralelo con los extremos de la bobina, 8.2pF ó 10pF debería ser un valor aproximado al equivalente de la serie de Varicap y 100 pF.

Lo importante es lograr que oscile y que puedas medir a que frecuencia lo hace, luego veremos de normalizar el circuito para el uso del Tx de FM.


Saludos, JuanKa.-

P.D.: Me estoy yendo a almorzar, calculo que en 1 hs regreso donde tengo la PC, suerte.-
El almuerzo es sagrado.

Con 10 Pf saltando diodo y condensador de 100pf no oscila, he quitado el de 100pf para no asociar capacidades, me pregunto si los transistores estarán bien, yo cuando testeo un mosfet pongo el tester en modo diodo, coloco una punta en drain y otra en source, compruebo que no hay comunicación, toco la puerta con una de las patillas, no recuerdo cual y vuelvo a medir entre drain y source, compruebo que hay comunicación, el transistor ha quedado abierto, para cerrarlo, toco la puerta con la patilla contraria, el transistor se cierra.

Pero con estos no hay forma, no se si será porque son doble puerta o es que están malos.

Sludos
20/05/2012 #126

Avatar de J2C

Tiago

La experiencia que he tenido con los MosFet Dual Gate de Baja Señal era comprarlos y colocarlos directamente al circuito con el menor manoseo posible, fue en una época donde no dudaba de si era original o falsificado por lo tanto no necesitaba probarlos y me funcionaron siempre. La mayoria de ellos los comercios de electrónica los entregaban con un dispositivo que cortocircuitaba las 4 conexiones ó venian envueltos en papel de aluminio.

Yo no sabría decirte como hacer para probarlos, incluso en algún momento dije de usar un FET de Juntura tipo BF244/BF245 que no son tan sensibles, solo para asegurarnos que logramos la oscilación.



Saludos, JuanKa.-
20/05/2012 #127
Moderador

Avatar de tiago

J2C dijo: Ver Mensaje
Tiago

La experiencia que he tenido con los MosFet Dual Gate de Baja Señal era comprarlos y colocarlos directamente al circuito con el menor manoseo posible, fue en una época donde no dudaba de si era original o falsificado por lo tanto no necesitaba probarlos y me funcionaron siempre. La mayoria de ellos los comercios de electrónica los entregaban con un dispositivo que cortocircuitaba las 4 conexiones ó venian envueltos en papel de aluminio.

Yo no sabría decirte como hacer para probarlos, incluso en algún momento dije de usar un FET de Juntura tipo BF244/BF245 que no son tan sensibles, solo para asegurarnos que logramos la oscilación.



Saludos, JuanKa.-
Creo que los transistores estan mal, no puede ser que no oscile ya con dos de ellos cambiados, y siendo un circuito tan sencillo, veo normal que me oscile fuera de banda, que el PLL no enganche, que el ajuste sea delicado, pero que no tire nada en absoluto, lo veo raro.

Dime cómo coloco un fet como el que me comentas y lo pruebo, me imagino que serán de una sola puerta. Mañana mismo posteo resultados. He pedido tres doble puerta mas a otro proveedor, mientras llegan, vamos a hacerlo como sugieres.

PD: He probado el transistor que me queda sin usar y tengo 11 Ohm entre source y Gate 2 ponga las puntas como las ponga, he quitado el que está en el circuito, no da continuidad, pero no logro abrir source - drain polarizando la gate o las gates, sospecho que están en mal estado.
Saludos.
20/05/2012 #128

Avatar de J2C

Tiago

Las equivalencias de MosFet Dual Gate a Fet de Juntura son:

Dual Gate -+- Juntura
Drain -+- Drain
Source -+- Source
Gate1 -+- Gate
Gate2 -+- NC

NC= No Conectado

Espero que se entienda, cualquier cosa comentame.



Saludos, JuanKa.-
20/05/2012 #129
Moderador

Avatar de tiago

J2C dijo: Ver Mensaje
Tiago

Las equivalencias de MosFet Dual Gate a Fet de Juntura son:

Dual Gate -+- Juntura
Drain -+- Drain
Source -+- Source
Gate1 -+- Gate
Gate2 -+- NC

NC= No Conectado

Espero que se entienda, cualquier cosa comentame.

Saludos, JuanKa.-
Si, que la gate 1 es la que tengo que polarizar para hacer las pruebas de integridad del transistor para probarlo igual que uno de gate sencilla.

No tengo dudas, tengo por aquí un par de mosfet de potencia para RF y responden perfectamente a las pruebas que te he comentado algo mas arriba. Lo he googleado y están bien medidos, el que tiene la gate comunicada no vale, y si no obtengo una lectura "baja" entre source y drain polarizando gate 1 es que tampoco funcionan.

Bueno, el dia llega a su fin, mañana mas. Pero dime si puedes, como poner un fet de juntura sustituyendo al doble puerta para comprobar oscilación.

Saludos.
20/05/2012 #130


[http://www.frn.net/tech/xmitters/fm/bf900/

El TX del enlace es muy similar al que posteas aquí, Tiago. A ver si encuentras alguna diferencia.
21/05/2012 #131
Moderador

Avatar de tiago

mcrven dijo: Ver Mensaje
[http://www.frn.net/tech/xmitters/fm/bf900/

El TX del enlace es muy similar al que posteas aquí, Tiago. A ver si encuentras alguna diferencia.
Bueno, parece que han afinado mas en lo que es la sintonización, al no llevar PLL a mi modo de ver han depurado mejor la parte resonante para darle estabilidad. Por lo demas está configurado igual que tengo el mio actualmente, con una tensión en G2 de 3'2 Volt, me imagino que no será excesiva.

He pedido transistores nuevos a un par de proveedores diferentes, estoy seguro que los que le puse estaban malos. Cuando lleguen vuelvo a las pruebas.

Saludos.
21/05/2012 #132


tiago, en este tipo de placa, el mosfet iba con la serigrafia hacia el impreso, logré que oscile, pero no funcionaba el PLL, oscilaba con los valores que indicaba el diagrama; el mosfet viene con un terminal largo y corte sesgado (D), el terminal opuesto es G1, y otro terminal tiene una ligera prominencia cuadrada (S), lado opuesto a este terminal es G2,, yo utilice el BF960, ver el datasheet, y osciló; lo mas probable es que te estes confundiendo al instalarlo, dicho esto sin mala fe, saludos
21/05/2012 #133
Moderador

Avatar de tiago

moises calderon dijo: Ver Mensaje
tiago, en este tipo de placa, el mosfet iba con la serigrafia hacia el impreso, logré que oscile, pero no funcionaba el PLL, oscilaba con los valores que indicaba el diagrama; el mosfet viene con un terminal largo y corte sesgado (D), el terminal opuesto es G1, y otro terminal tiene una ligera prominencia cuadrada (S), lado opuesto a este terminal es G2,, yo utilice el BF960, ver el datasheet, y osciló; lo mas probable es que te estes confundiendo al instalarlo, dicho esto sin mala fe, saludos
Moises, los he puesto con la serigrafia hacia el impreso y estoy seguro de que patilla era el drain, source etc ...

Mira el dibujo, así es como queda con la serigrafia hacia arriba, solo hay que voltearlo, source arriba, donde queda la bobina y g2 abajo, tomando g1 y drain como eje. De esa forma es como cae sobre la placa.

Saludos.
Imágenes Adjuntas
Tipo de Archivo: gif BFxxx_2.gif (2,0 KB (Kilobytes), 23 visitas)
Tipo de Archivo: gif Sin título-1 copia.gif (2,9 KB (Kilobytes), 466 visitas)
22/05/2012 #134
Moderador

Avatar de tiago

Al fin oscila
Bien, buenas noticias, el circuito por fin oscila.

Problema: Los transistores mosfet en mal estado. Buscando soluciones he hallado un viejo sintonizador que incorporaba un bf961, que es un equivalente del bf981 y es el que he colocado. Lo he comprobado con el tester y el transistor, al contrario que los que compré nuevos, abria y cerraba paso entre source y drain, simplemente tocando las gates con unas pinzas metalicas antiestaticas.

Lo he colocado y he comprobado que con la configuración que se consiguió con ayuda de J2C,podia oscilar, siempre que la tension en gate 2 fuese igual o superior a 4'5 Volt, por lo que modifiqué el divisor de tensión poniendo una R de 22K allá donde habia una de 33K y comenzó a funcionar, pero la curiosidad me llevó mas lejos.

Pensé que con esos voltajes tan altos en puerta, quizá la disposición del diagrama fuese viable, como deberia ser, por lo que desmonté todo el divisor y coloqué los componentes como al principio. El oscilador seguía funcionando ...Pero...

Me he dado cuenta que la bobina es muy critica y oscila de forma errática, entra y sale de la banda de FM por la parte superior (por encima de 88 Mhz) a veces al PLL le cuesta mucho enganchar o se queda muy proximo sin poder alcanzar la frecuencia, manipulando la bobina logro hacer que enganche, pero recorto por un lado u otro de la banda, no logro que tenga una linealidad total, aunque me imagino que será cuestión de ir probando bobinas y donde se coloca la toma hasta lograr un enganche en toda la banda. Cuando ajusto la bobina de forma que enganche en un ancho de 3 ó 4 Mhz, lo hace muy rápidamente, creo que el "Quid" de la cuestion es la bobina en sí, por favor sugerencias al respecto.



El otro problema es que si dejo alimentada la parte de potencia de RF, cuando se consigue el enganche y el transistor se pone en servicio, el PLL se me vuelve loco, el led de LOCK sigue iluminado y en la pantalla también veo LOCK visualizado, pero el frecuencimetro me está bailando entre la frecuencia establecida y 30 Mhz por arriba, fluctuaciones en la medida de frecuencia , el radioreceptor con el que sintonizo volviendose loco y la aguja del Watimetro
subiendo y bajando

Me imagino que habrá que filtrar la alimentación o algo por el estilo para evitar este problema, me gustaria tambien que me sugirieseis cómo hacerlo.

Adjunto una foto del aparato funcionando, en el centro de banda (O próximo) apenas da problema. A ver si dejamos esto fino. Hay algún condensador de los que acoplan las etapas de RF que no se vé, está por debajo de la placa.



Saludos,
Imágenes Adjuntas
Tipo de Archivo: jpg oscilando.jpg (336,0 KB (Kilobytes), 501 visitas)
Tipo de Archivo: jpg RDVV foro.jpg (340,0 KB (Kilobytes), 491 visitas)
22/05/2012 #135

Avatar de clausalan

Hola Tiago,



Problema: BF961 no es mui bueno en el circuito poner uno BF981 = BF982, la bobina ok.


El otro problema: La parte de potencia de RF, una solucione puede ser: las 2 resistencias 150R quitar e poner uno choque RF 100uh y choque (BFR96TS) quitar y poner las 2 resistencias 150R, debe poner siempre uno transistor 2N3553.


Por fin no aconselho el ciruito con este pcb no es mui bueno.


Subo uno mui bueno, con uno 2sc1947 4w, con uno MRF237 5w.


Saludo,
Archivos Adjuntos
Tipo de Archivo: rar 4w-Lcd2x16-PIC16F84A.rar (488,9 KB (Kilobytes), 445 visitas)
Tipo de Archivo: rar Foto1.rar (1,43 MB (Megabytes), 352 visitas)
Tipo de Archivo: rar Foto2.rar (1,51 MB (Megabytes), 290 visitas)
22/05/2012 #136
Moderador

Avatar de tiago

clausalan dijo: Ver Mensaje
Hola Tiago,



Problema: BF961 no es mui bueno en el circuito poner uno BF981 = BF982, la bobina ok.


El otro problema: La parte de potencia de RF, una solucione puede ser: las 2 resistencias 150R quitar e poner uno choque RF 100uh y choque (BFR96TS) quitar y poner las 2 resistencias 150R, debe poner siempre uno transistor 2N3553.


Por fin no aconselho el ciruito con este pcb no es mui bueno.


Subo uno mui bueno, con uno 2sc1947 4w, con uno MRF237 5w.


Saludo,
Hola, en principio deberia funcionar con bf 961, al fin y al cabo son muy pocas diferencias con el 981, de hecho es un reemplazo este último transistor.. Cuando lleguen los 981 lo cambiaré para compara el funcionamiento.

saludos.
22/05/2012 #137


Tiago, lo más seguro es que la relación L/C del tanque oscilador no sea la adecuada para la banda y el ancho de banda que quieres cubrir. El Q del circuito resonante muy alto. Esto te conduce a que, variaciones muy pequeñas producidas por calor vibraciones y/o pequeñas variaciones de la tensión de alimentación hagan fluctuar la frecuencia muy rápidamente y el PLL no tenga la velocidad suficiente para mantenerse enganchado.

Si mal no recuerdo se debe aumentar la L de la bobina - 1 o 2 espiras en este caso - y reducir C. Se debe lograr que la variación total del trimmer cubra desde algo más abajo hasta algo más arriba del ancho de la banda (80 MHz ~ 120 MHz). La bobina debería construirse preferiblemente sobre una forma muy sólida y con alhambre preferiblemente estañado y bastante grueso (2mm o más) para evitar la dilatación por efecto de la temperatura y las variaciones producidas por vibraciones circundantes.

Prueba todo sin el PLL conectado pues, como ya mencionaste debe funcionar primero sin él.

Se debe logra que el oscilador sea bien estable aún sin PLL y blindado en caja cerrada. Así el PLL no deberá trabajar demasiado para mantener la f0 asignada.
22/05/2012 #138
Moderador

Avatar de tiago

mcrven dijo: Ver Mensaje
Tiago, lo más seguro es que la relación L/C del tanque oscilador no sea la adecuada para la banda y el ancho de banda que quieres cubrir. El Q del circuito resonante muy alto. Esto te conduce a que, variaciones muy pequeñas producidas por calor vibraciones y/o pequeñas variaciones de la tensión de alimentación hagan fluctuar la frecuencia muy rápidamente y el PLL no tenga la velocidad suficiente para mantenerse enganchado.

Si mal no recuerdo se debe aumentar la L de la bobina - 1 o 2 espiras en este caso - y reducir C. Se debe lograr que la variación total del trimmer cubra desde algo más abajo hasta algo más arriba del ancho de la banda (80 MHz ~ 120 MHz). La bobina debería construirse preferiblemente sobre una forma muy sólida y con alhambre preferiblemente estañado y bastante grueso (2mm o más) para evitar la dilatación por efecto de la temperatura y las variaciones producidas por vibraciones circundantes.

Prueba todo sin el PLL conectado pues, como ya mencionaste debe funcionar primero sin él.

Se debe logra que el oscilador sea bien estable aún sin PLL y blindado en caja cerrada. Así el PLL no deberá trabajar demasiado para mantener la f0 asignada.
Ok, son cosas muy interesantes las que me estais contando, no tenemos trimmer al uso en éste montaje. No dispongo de hilo estañado, no se de donde obtenerlo. De momento cambiando el punto de toma de la bobina he conseguido cubrir toda la banda, la dificultad está arriba del todo, aunque he conseguido que enganche sin problemas añadiendo un condensador de 1n al filtro de entrada del PLL al varicap, formado por C4 de 47µf y C5 de 10n.

Pero en cuanto muevo la ajustable que suministra tensión al transistor driver (BFR96), es decir, en cuanto éste arranca, parece que me introduce oscilaciones en la alimentación y me descompone la frecuencia en la que está enclavado. Es el único punto que me queda por pulir.



Saludos.
Imágenes Adjuntas
Tipo de Archivo: jpg driver.jpg (311,5 KB (Kilobytes), 490 visitas)
23/05/2012 #139


tiago dijo: Ver Mensaje



Saludos.
Si este de arriba es el circuito que estás montando, tengo varias observaciones:

1.- en otro circuito oscilador con BJT muestra un trimmer de 4 a 25 pF en paralelo con una bobina de 40 nH.

2,- El varicap está en serie con un capacitor de tan solo 3,3 pF.

En este tienes un capacitor de 100 pF en serie al varicap y no pones trimmer en paralelo a la bobina.

Me luce que, cuando el VC está a mínima capacidad, la oscilación quedaría a cargo de una L pura - casi pura, que hay capacidades dispersas - y la frecuencia se debe ir a las alturas muy rápidamente.

Cuando el voltaje de control lleva el VC a máxima capacidad (supongamos que lo lleva a 100 pF) esta llegará a 50 pF de golpe, haciendo que la variación inducida por el PLL sea muy brusca. Te recuerdo que la variación que debe introducir el PLL debe ser de tan solo 1 o 2 kHz, si acaso menos.

Te sugiero utilices un tanque con los valores descritos en los puntos 1 y 2 para probar.

Aprovecha tu LCMeter para medir la L de la bobina. Ajústala espaciando las espiras antes de soldarla al circuito. Particularmente te sugiero que utilices una bobina de 6 espiras, por motivo de que, la derivación debe estar a 1/3 de espiras desde la masa. Si te da una L muy alta, ensanchando las espiras se achica y viceversa. Si con este método aún sigue alta, se debe reducir un poco el diámetro interno. Para obtener alhambre estañado, tomas uno de cobre desnudo y lo estañas con el cautín y, si te quieres refinar aún más mándalo a platear (Estoy hablando de PLATA, símbolo químico AG o Argentum).

En fin, puede refinarse mucho. Tienes buena mano y buen detalle para los trabajos.

Saludos:
23/05/2012 #140
Moderador

Avatar de tiago

Hola mcrven.

Estoy usando el esquema original, lo puedes ver en el post #110

El problema es que le cuesta enganchar de 107 hacia arriba,raras veces lo logro, sin embargo, en 87 lo hace sin pegas, habrá que retocar el oscilador, aunque me preocupa mas el asunto del patinazo de frecuencia cuando alimento driver o transistor final.

Edito: La falta de apantallamiento es algo que se me habia pasdo por alto . Poniendo una lámina de papel de aluminio (El de envolver los alimentos) por debajo de la placa y conectada a masa, engancha en toda la banda sin problema alguno

Saludos.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos de Radio

Transmisores, Receptores, Antenas...

Cerrar
Foros de Electrónica » Diseño analógico » Circuitos de Radio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.