Haz una pregunta
  Foros de Electrónica » Diseño analógico » Circuitos de Radio
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/12/2012 #41


[QUOTE=DJ_Glenn;744235]mil disculpas, pero no logro identificar la r de 2m2 (¿en paralelo al 1n4148?).[/QUOTE

Efectivamente es la que va en paralelo con el 1N4148.

Ric.
02/12/2012 #42


por aca encontré el diagrama del módulo de pretección del fm1000... es el mismo... un poco más legible, pero igual bastante dificil de leer... pero ahí si se lee el 2m2. Gracias ricbevi.
02/12/2012 #43

Avatar de cinaradio

Aqui subo el esquema del PLL M31 que basicamente es el mismo tanto para FM y UHF
Archivos Adjuntos
Tipo de Archivo: rar diagrama PLL M31.rar (232,5 KB (Kilobytes), 259 visitas)
02/12/2012 #44


ahora sí, copié en el circuit wizard el circuito de protección y se ve como se va descargando lentamente el condensador de 22µ y luego pone en 0v el BC548 (¿o BC549?). El cable amarillo va a la fuente de alimentación... entra al centro de un divisor resistivo que está entre base y colector del tip31c... lo interesante es que no se usan medios electromecánicos como un relé, pero no sirve a mi proposito porque la fuente ya la tengo :(... continuando con la simulación... la parte de temperatura no responde... está bien lo que se muestra en el diagrama? el que había hecho yo era un comparador simple... pero esto se ve más escueto... RESUELTO! el termistor es larte de un divisor resistivo... vaya uno a saber de que valor es la resistencia que falta, pero le agregué una a +10v y fui variando su valor hasta que respondió a la variación del termistor... con una resistencia de 1k responde a una temperatura de 70º más o menos si se usa un termistor de 10k@25ºc (unos 860 ohms más o menos), si la resistencia que se usa es de 1,6k, responderá a unos 55º más o menos.

Qué temperatura sería ideal? desde dónde resulta más conveniente tomarla? M31 pone el termistor sobre el disipador... aunque hace varios meses me llegó un transmisor RVR que tenía el termistor sobre el transistor de salida.

No se si todo esto que vengo tratando es sólo de interés mío o le sirve a alguien más? siento que es un monólogo. Tal vez sea demasiado extenso por no tratarse del asunto original que trata este tema, pero es igual de válido para el exitador como para el transporte de programa. Los moderadores decidiran si corresponde borrar todo lo que escribí.

Cinaradio, decis que el pll es basicamente el mismo tanto para fm y uhf (recordemos que el transporte de programa transmite en vhf... ya que según entiendo, U es a partir de los 300 mhz). En qué cambia?
02/12/2012 #45

Avatar de cinaradio

en la programacion de las llaves y la separacion de canales en los pin 5, 6, 7 segun entiendo tambien el pin 19 si esta en off tiene un peso o on es otro algo asi como 100 khz y 200khz

lei en el foro que el PLL de un transporte es 120 mhz y ahi pasa por un duplicador para lograr los 220/240 mhz.
02/12/2012 #46


si señor... lo leíste en este tema seguramente (aunque ya se mencionó en otro tema). Pero más allá de la la configuración del banco RA y de las llaves con peso más significativos, en el resto de los componentes y su distribución ves algo diferente?
02/12/2012 #47


Bastante confuso todo, pero resumiendo por las pruebas que hiciste.. es la placa del pll la causante de todo.
Revisaste que las pistas este bien, no existan soldaduras frias?.
Si tenes otro pll igual, tenes la referencia para medir los componentes y tensiones, eso te va a facilitar el trabajo.

Es muy raro lo que te pasa, mas cuando estaba funcionando y dejo de hacerlo solo.. me juego a alguna falla tonta como una pista o soldadura mala
03/12/2012 #48

Avatar de cinaradio

Buenas tardes a todos, aqui les dejo mas fotos de Tx UHF esquema pcb para que se vea bien legible tome una foto general para que ubiquemos todas las partes y despues tome otras con mayor zoom.
Imágenes Adjuntas
Tipo de Archivo: jpg PLL 71.JPG (183,8 KB (Kilobytes), 170 visitas)
Tipo de Archivo: jpg PLL 94.JPG (154,7 KB (Kilobytes), 166 visitas)
Tipo de Archivo: jpg PLL 95.JPG (153,4 KB (Kilobytes), 141 visitas)
Tipo de Archivo: jpg PLL 96.JPG (150,8 KB (Kilobytes), 127 visitas)
Tipo de Archivo: jpg PLL 98.JPG (162,3 KB (Kilobytes), 130 visitas)
Tipo de Archivo: jpg PLL 97.JPG (152,6 KB (Kilobytes), 127 visitas)
Tipo de Archivo: jpg PLL PCB 79.JPG (185,4 KB (Kilobytes), 120 visitas)
03/12/2012 #49


La única tensión que deberá importarte es la que obtengas en "tensión de enganche", que deberá ser lo más cercana posible a 4vcc. Esto lo logras moviendo muy muy muy lentamente el trimer verde. El led probablemente se apague con una tensión distinta, dentro del rango de enganche, pero el correcto margen de seguridad lo tenes con esos 4vcc. Reemplazar el trimer verde podría ser recomendable.

Con el frecuencímetro comprobas que está operando en la frecuencia que esperas (y te va a ayudar a encontrar ese voltaje de error) y sólo con este instrumento podes tocar el trimer azul para redondear tu frecuencia. Uno económico es el Gooit Gy 560, muy popular... no tiene gran resolución, pero varios colegas lo usan porque les resulta cómodo para transportar.
04/12/2012 #50

Avatar de cinaradio

Buenas tardes DJ Glenn

Estuve mas una vez intentando encontrar la falla al Tx UHF con el swichero en posicision como lo compre y comence a hacer pruebas ajustando milimetro a milimetro el trimer verde y en uno de esos momentos vi que al encender el equipos se apago el el led de enganche, por un momento hasta que se apague el led SWR y vuelve a encender, retoque el trimer verde y nada, igual nomas, coincidentemente el trimer quedo practimente en la mima posicion de ajuste de fabrica por que antes de tocar los ajustes marque los trimers.

apague el tx y volvi a enceder lo mismo se apaga el led de eng. al segundo y vuelve a encerderce cuando apaga el led de ROE SWR.

Entonces realice el procedimento con el trimer azul, a ciegas claro sin frecuencimetro, y como lo tenia marcado solo tengo 4 posiciones de ajuste y efectivamente en una de las pociciones el led de enganche comenzo a parpader pero irregualar no siempre igual el parpadeo, en ningun momento marco algo de potencia en el vatimetro.

El voltaje en el LM358 pin 1 mide 8 vol y no baja ajustando el trimer verde y cuando baja, baja a 0.9 vol en el pin 3 mide 4.7 vol el pin 2 mide 1.3 vol

Estoy pensando en reemplazar todos los componentes que aun no lo cambie, como ser resistores y cap ya retoque todas las soldaduras.

A todo esto me queda una duda el pin 19 del MC145152P2 va en On o Off para 247.3 me suena que de fabrica vino levantada la patita 19 del MC pero no estoy seguro, se que ese pin le da mayor peso a las llaves, no se si en Off las llaves pesan mas o menos...???
05/12/2012 #51

Avatar de miguelus

Buenos días cinaradio

El Pin 18 es la señal N8 y tiene un peso Binario de 256

Si el Pin 18 está levantado su nivel Lógico será "1", como consecuencia de esto tendríamos un factor de división de, por lo menos 256,
Hagamos un pequeño cálculo.

El prescaler es un 64/65
La referencia son 25Khz
Asumiendo que todos los demás Micro Switch de programación están a "0"
Entonces, 256 x 64 x 25 nos da que la frecuencia sería de 409,600 Mhz, de ahí para arriba.
Pero parecer ser que esto no es posible ?????
Lo más lógico es pensar que los Pines 19 y 20 tienen que estar a "0"

Sigamos pensando un poco

Parece ser que ese equipo está diseñado para trabajar en un frecuencia cercana a los 120Mhz, a continuación hay un doblador de frecuencia.

Asumamos que queremos obtener 120Mhz...
¿Qué factor de división necesitaríamos?...

120000/64/25 nos dá que en el divisor N tendríamos que poner un 75 en Binario.
75 = 1001011
Para ello...

N0 Pin 11 = "1"
N1 pin 12 = "1"
N2 Pin 13 = "0"
N3 Pin 14 = "1"
N4 Pin 15 = "0"
N5 Pin 16 = "0"
N6 Pin 17 = "1"
N7 Pin 18 = "0"
N8 Pin 19 = "0"
N9 Pin 20 = "0"

Para está aplicación los Pines 19 y 20 tendrán que estar siempre a "0"

Los Pines 10, 21, 22, 23, 24 , 25 son para programar la parte Fracional, si la hubiere, de la divión...

Por ejemplo queremos obtener una frecuencia de 120.375 Mhz ¿Cómo tendríamos que programar el MC145152?

Tendríamos que dividir entre 75.234375... (120375 /64/25 = 75.234375)

El 75 en Binario lo cargamos en el Divisor N
La parte Fracional .234575 la multiplicamos por 64 (nos da 15)

Este 15 en Binario lo cargamos en el Divisor A


Esto vale para cualquier frecuencia.

Hay que leer el Data Sheet del MC145152 y entender de va eso de los Divisores Fracioneles y Preescaler Doble Módulo.

Otra forma de proceder es por el sistema de “ Prueba y error” total son solamente unas 65535 combinaciones.

En el Filtro del Lazo hay dos condensadores Electrolíticos de 22mF., son dos firmes candidatos para justificar la avería que tienes, pero primero asegúrate de que el PLL esté bien programado.


Sal U2
05/12/2012 #52

Avatar de homebrew

miguelus


Entonces, 256 x 64 x 25 nos da que la frecuencia sería de 409,600 Mhz, de ahí para arriba.
Pero parecer ser que esto no es posible ?????
Lo más lógico es pensar que los Pines 19 y 20 tienen que estar a "0"

Sigamos pensando un poco

Parece ser que ese equipo está diseñado para trabajar en un frecuencia cercana a los 120Mhz, a continuación hay un doblador de frecuencia.
Asumamos que queremos obtener 120Mhz
----------------------------------------------------------------------------------------------------
muy bien miguelus estas en lo correcto

Como mencione mas arriba estos enlaces trabajan doblando frecuencia, el vco y pll deben programarse para el rango 112.5 a 120 mhz por eso no les dan las cuentas si programan directamente la frecuencia final, aparte de eso la frecuencia maxima de entrada al prescaler esta entorno a los 225 mhz ?
05/12/2012 #53

Avatar de miguelus

Buenos días homebrew

Te doy toda la razón-

Como es lógico, para trabajar en frecuencias cercanas a los 120Mhz los Pines 18 y 19 que tienen un peso Binario de 256 y 512 tienen que estar a "0", e incluso es posible que el Pin 17 "N8" que tiene un peso Binario de 128, tambien tenga que estar a "0" ya que 128 x 64 x 25 = 204.800Mhz, lo que parece una frecuencia muy eleva si asumimos que luego se multiplica por dos.
Si utilizamos solamente los 7 Primeros bits podremos llegar a un factor máximo de división de 127 lo cual ya entra dentro de lo razonable para este Sintetizdor tan particular.

Este PLL, el MC145152, es uno de esos Integrados a los que habría que hacer un monumento, es a la RF lo que el 555 al resto de la Electrónica, durante décadas ha sido masivamente utilizado en multitud de PLL.
Recuerdo que hace muchos años, a principio de los 80´s realizé un generador de RF que cubría desde 1Mhz hasta 50MHZ en pasos, de 1Hz para ello utilicé "Multi lazos", en todos los lazos había un MC145152, quizás de esa época viene mi "cariño" por este Sintetizador con el cual aún sigo realizando algún que otro PLL.

Volviendo al tema que nos ocupa, el problema que después de tantos Post aún no está clara la frecuencia de funcionamiento del enlace por lo que es complicado definir la posición exacta de los µSwicht.

Sal U2
05/12/2012 #54


Por lo que comenta, sobre que engancha pero cuando se apaga la protección por roe (en este equipo es un retardo en el encendido para dar tiempo a que enganche el pll, luego da potencia), insisto en que para mi el problema puede estar en el amplificador... tal vez mal ajustado, o vaya uno a saber que...

cinaradio, si desconectas el rg174 que val desde el modulador hasta el lineal (tranquilo que no se estropea nada, el led se mantiene apagado y la tensión de enganche cercana al valor mencionado?
06/12/2012 #55

Avatar de cinaradio

Buenos días a todos,
Aplicando lo indicado por colegas del foro, Cargue esta combinación 247.300/2/64/25=77.28125 28125*64=18

247.xxx 77 en Sistema Binario=1001101 esta combinación en switch de 8 laves= 1-3-4-7 en On
xxx.300 18 en Sistema Binario=10010 switch de 4 laves= 2 en On

Y aparentemente se soluciono la estapa de enganche, ajuste el trimer verde, ahora quedo amplio el la variación del trimer hasta que desenganche unos 3 milímetros de recorrido. el sonido ahora sale en el receptor, solo que al atornillar el PLL en su lugar corta el audio, al intentar acomodar el RG174 vuelve el sonido al soltar queda igual, es decir creo que tuvimos un progreso pero no la solución en definitiva.

Al desoldar el RG 174 no se apaga el led, otro detalle que aporto la etapa amplificadora ninguna vez fue tocado desde fabrica, el TX tiene 1 año +o- de uso 3 hs por día.

Ajustando el trimer de fuente al máximo llega disipar 6 vatios

Otra cuestion que ahora surge, quedo distinto la posicion de llas llaves a lo que estava antes, pregunto en base a este ajuste en el TX como cargar la misma programacion en el Receptor...??? por que es diferente las posiciones de los switch del TX al RX
06/12/2012 #56


" cinaradio "...Los ajustes deben hacerse con la placa como va a ir definitivamente no en el aire y si estas escuchando la transmisión en el receptor no tenes que tocar NADA ya esta y si querés saber por que las llaves en el receptor van distintas que en el transmisor debes estudiar el funcionamiento de un receptor de simple conversión y allí encontrara la respuesta...de forma corta por que el oscilador debe esta en la fundamental +- la FI de trabajo.
Saludos.

Ric.
06/12/2012 #57

Avatar de miguelus

Buenas noches cinaradio

Bueno pues parece que hemos avanzado algo

Ahora puede ser que tengas alguna soldadura defectuosa en algún cable y al moverlo deja de funcionar. Lo mejor es realizar una minuciosa inspección visual.
Presta especial atención al cable Coaxial y su malla.

Con paciencia y ciencia, al final todo funciona.

PD. Por privado, alguien me ha preguntado el Porqué de esa forma de programar los dos divisores, A y N

Pero para no complicar la cosa, de momento dejo la explicación para otro Post, aunque si leemos el Data Sheet del MC145152 lo entenderemos perfectamente.

Sal U2
07/12/2012 #58

Avatar de cinaradio

Buenas tasdes, y quiero agrader a todos por lo aportado, experiencias y conocimiento, y daria por finalizado lo abordado en este tutorial. Realmente estaba mal la programacion, al tocar tome nota de la programacion y lo que estaba en On lo anote como "Off" y viceversa, y desngancho por estar muy al borde el ajuste, me faltaria el ajuste fino del trimer azul, pero eso cuando tenga mi frecuencimetro.

Quedo funcionado el Transporte de programa, sale audio engancha normalmente, con una potencia maxima de 7 watios.

Hice tantos calculos matematicos que un poco me mareo, y para ello hare un repaso de todo que encuentro en el foro al respecto a como calcular cualquier frecuencia.

De los datos que aporte como si fuesen de fabrica, estuve equivocado en algo, les dije el ajuste de fabrica seria el siguiente: switch de 8= 3-6-8 en ON y no me fije en una flechita que indica off para el otro lado en el swtchero de 8.... esntonces lo correcto es: 3-6-8 en "OFF" y switch 4 llaves: 1-3-4 en OFF
Lo que no me quedo claro o si es asi que se calcula...??? es los calculos que se emplean para programar el MC145152P2
Para 247.300 Mhz (supuestamente frecuencia de fabrica, al lado del conector de salida a antena esta escrito en letras rojas TX 247.300 11W)
en switchero de 8 tendia este numero binario= 10100100 que en decimal es= 164 multiplicando 164*25*64= 262.400 Mhz seria esta la frecuencia que trabaja el equipo, me surge la duda o la gente de M31 te ajusta y te escribe otra frecuencia, para que no le copien datos.

La programacion del Receptor es esta= switch 8= 3-4-6-7 en "ON" y switch 6= 2-4 en "ON" (ahora mire bien) datos que le puede servir a alguien y Repito Tx switch 8= 3-6-8 en "OFF" switch 4= 1-3-4 en "OFF"

Tx UHF M31 Funcionado, les agradesco nuevamente a todos
07/12/2012 #59

Avatar de miguelus

Buenas noches cinaradio.

Creo que no estás atajando el problema de la forma adecuada...

Me remito a una pregunta que realicé en el Post #31 la cuál se quedo sin respuesta...

Sin tener el esquema, con los datos que aportas, no es posible calcular la frecuecia en la que está programado el Transmisor .
Para poder calcular la frecuencia en la que trabaja el Transmisor sería necesario conocer los niveles de tensión en los siguientes Pines del MC145152

Divisor de la Frecuencia de Referencia, Pines 4, 5, y 6
Divisor "N", Pines 11, 12, 13, 14, 15, 16, 17, 18, 19, y 20
Divisor "A", Pines 10, 21, 22, 23, 24 y 25

Conociendo los niveles en esos Pines es muy fácil conocer la frecuencia en la que trabaja el Trasmisor.



Medir los nivels en los Micro Interruptores no nos da muchas pistas ya que no estamos seguros a que Pines del MC145152 corresponden.
¿Cómo podemos estar seguros del orden en el que el fabricante los ha colocado?
Si medimos los niveles directamente en los Pines del CI. si podemos sacar conclusiones.

Como he manifestado en Post anteriores, la programación del MC145152 es muy muy sencilla.
pero tenemos que tener los datos claros y por lo que veo, a estas alturas lo único que parece claro esque el Enlace funciona pero no estamos seguros de la frecuencia en la que lo hace.

Sal U2
07/12/2012 #60

Avatar de cinaradio

Ok, medire los cada pin...respecto al esquema pense que seria lo que subi en el post#48
pero en cuanto a los pines (me hice una tablita para saber a que llave corresponde cada pin) podeis estar seguros de esto:
Divisor de la Frecuencia de Referencia, Pines 4NC, 5NC, y 6 a Tierra o Masa

Divisor "N", switch de 8 llaves+Pines 11=1 12=2 13= 14=4 15=5 16=6 17=7 18=8 19, y 20 a Tierra

Divisor "A", Pines 10 a tierra, switch de 4 llaves+23=1 21=2 22=3 24=4 y 25 a tierra

---------- Actualizado después de 18 minutos ----------

Las mediciones serian estas:

Divisor de la Frecuencia de Referencia, Pines 1=6.4 vol 3=4.8 vol 4=4.3 vol 5=4.3 vol y 6=0.0 vol 7=4.7 vol 8=4.7 vol
Divisor "N", Pines 11,0.0 vol 12,0.0 vol 13=4.3 vol 14,0.0 vol 15,0.0 vol 16=4.3 vol 17,0.0 vol 18=4.3 19,0.0 vol y 20, 0.0 vol
Divisor "A", Pines 10,0.0 vol 21,0.0 vol 22,0.0 vol 23=4.3 vol 24= 4.3 vol y 25,0.0 vol

---------- Actualizado después de 11 minutos ----------

Cuando en numeros binarios, por ej. "1" en el switchero como va en ON o en Off...??? por lo que veo al medir los pin #13-#16-#18-#23 y #24 miden 4.3 vol y estan a mi entender en Off... es correcto...???
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos de Radio

Transmisores, Receptores, Antenas...

Cerrar
Foros de Electrónica » Diseño analógico » Circuitos de Radio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.