Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

01/10/2013 #1

Avatar de Daniel Meza

Amplificador de instrumentación con una sola fuente
Buenas compañeros...

Ando armando un amplificador de instrumentación "discreto", cada uno de los operacionales por separado.
Para el diagrama ando siguiendo el que pone de muestra el fabricante



El fabricante aclara el uso de una sola fuente de alimentación. Lo primero que hago es pasarlo por el simulador tal y como viene el diagrama y no funcionó



Dudando un poco del simulador me decido pro hacer la prueba en físico y obtengo nuevamente resultados inesperados:



El siguiente paso que realicé fue utilizar una fuente simétrica +5/-5 V para la alimentación y tanto en el simulador como en físico funcionó el circuito





Mi pregunta después de esta experiencia es ¿el fabricante toma alguna consideración extra para afirmar que su aplicación funciona con una sola fuente?. ¿O algo en que yo me haya equivocado?. ...
01/10/2013 #2

Avatar de Gudino Roberto duberlin

Hola Amigo, bueno personalmente utilizo amp de instrumentacion con fuente unica. Para obtener max. excursión lo que hago es ajustar R7 a un valor mayor que R6 o bien conecto el terminal que se dirige a masa a una tensión de referencia hasta alcanzar 1/2Vcc en la salida teniendo las entradas cortocircuitadas. (las resistencias que menciono lo hago según tu ultimo esquema para ser claros en la ubicación).
02/10/2013 #3

Avatar de Daniel Meza

Gracias por contestar, si de hecho es lo que comenta el amigo Cosmefulanito en el post #8 de éste post
Amplificador de instrumentacion con opamps (no IC)

no lo he probado pero puede funcionar, pero mi duda es la misma ¿porqué el fabricante asegura que su circuito tal y como está funcionará con una sola fuente?
02/10/2013 #4


Daniel Meza, en la configuracion con fuente simple : U4(V1)=0V la has puesto como GND ; tendrias que colocar V2-V1=30mV de modo "flotante", de modo diferencial (sin colocar V1=GND).
02/10/2013 #5

Avatar de Daniel Meza

Antes había colocado V1=20mV y V2=50mV dando los mismos resultados erróneos, ¿dejar la terminal flotante no captará ruido precisamente por que es diferencial?. Mañana seguiré haciendo pruebas... Gracias
02/10/2013 #6


El tema es que la entrada diferncial, V2-V1, debe colocarsele un offset de VCC/2. El Vdif V2-V1 se refleja en R8 y circula una intensidad , I8: (V2-V1)/R8= 30mV/2K= 15uA , la misma que circula por las R1=R3=100K. Ahora : 100K X 15uA = 1.5V ; si el extremo superior de R8 ( R8 union con R1 ) esta a 0V ( GND) es imposible que se genere un V negativo a la salida del AO superior teniendo solo fuente simple.
02/10/2013 #7

Avatar de dmc

Estoy de acuerdo con lo que dice opamp, no se puede generar valores negativos con fuentes simples, pero yo varias veces lo hice y es efectivo.
02/10/2013 #8

Avatar de Daniel Meza

Ok, voy entendiendo mejor, ¿y entonces ese offset se debe de agregar al nodo suma de cada entrada?, es decir en los nodos comprendidos entre R3-R8 y R8-R1.



(En el diagrama solo lo pongo para el nodo inferior y sigue dando errores) :S
03/10/2013 #9


Se lo sumo a V1 ( U4 ) =0V (GND).se trata de levantar la señal de entrada, (V2-V1). Suponiendo que Ve-V1 es la tension que entrega una termocupla, le sumo VCC/2.
04/10/2013 #10

Avatar de Daniel Meza

No termino de entender, amigo opamp me podría explicar con algún diagrama por favor. Apliqué 2.5 volts como en la propuesta anterior pero esta vez al nodo entre R3 y R8 y los resultados siguen estando mal
20/10/2013 #11

Avatar de Daniel Meza

Bueno, al final de todo no pude hacerlo como propone el fabricante, así que cambié R8 por dos resistencias independientes de puesta a tierra




Ahora ya funciona como lo esperado, pero sigo intrigado con mi duda inicial. Consulté con un profesor y me dijo que el circuito es funcional solamente cuando los operacionales tienen un bajo voltaje de offset a sus salidas y que sólo pocos LM324 cumplen con esta propiedad, digamos 2/10
20/10/2013 #12


Es cierto que el LM324 es un opamp de proposito general, (no es de alta precisión ),pero si lo estás simulando el ruido industrial "real" no le afecta( solo es una demostración virtual ). Lo que te he sugerido es que le sumes VCC/2 a tu señal diferencial : V1-V4 = 10mV a 1KHz para que la notes mejor a la salida con el osciloscopio y puedas leer el offset final ( VDC ). Si alimentas con VCC:10V, le sumas 5VDC a tu señal de 10mV/1KHz, si deseas implementas una configuración SUMADORA no inversora de ganancia 1 ,(SEGUIDOR, Rf:0 Ohm). Estoy comentando sobre el AI de tus post #1 el de fuente simple, NO la última versión de tu post #11.
25/10/2013 #13

Avatar de Daniel Meza

Les notifico que ya hallé la explicación del problema, no era tanto el offset de la señal diferencial sino un "problemita" que surge debido al diseño del LM324. La explicación la da el amigo Ardogan en el post 35 de éste tema.

Siguiendo esa condición, simulé nuevamente el circuito inyectando voltajes mayores y obtengo los resultados esperados.

Gracias por sus comentarios y sugerencias
26/10/2013 #14


Daniel Meza, puedes colocar los valores del Vdiferencial( U1-U4 ) para los cuales cumple tu amp de instrumentación con fuente única de 5VCC.
27/10/2013 #15

Avatar de Daniel Meza

Por el momento se los pondré de acuerdo a los resultados de la simulación, por necesidad tuve que desmontar el circuito del protoboard y no tengo donde hacer pruebas.

Teniendo el circuito armado como en el post #1 pero con R2=100k en vez de 2k (ganancia de 3) la salida cumple con la ecuación característica del amplificador de intrumentación cuando ambas entradas diferenciales están por arriba de 0V por aprox 400mV y la diferencia entre V+ y V- es de al menos 200mV.
Cuando haga la prueba en físico notificaré en que punto estos valores corresponden con los esperados
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.