Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

12/09/2011 #1


Comandar relé con señales de dos sensores
Hola gente, tengo un sensor que entrega una señal de 0.6V hasta 4V, y otro que varía de 2.5V hasta 1V.
Un relé maneja una electroválvula que debe cerrarse cuando la primera señal sea de 0.65V o mayor, y cuando la segunda sea mayor de 2V.
De electrónica entiendo poco, pero después de un par de pruebas llegué al circuito de la imagen, pero tengo algunos problemas:
1) No se como calcular el valor de las resistencias.
2) Los transistores no abren el circuito al mismo voltaje que lo cierran.

Necesito si me pueden decir que les parece el circuito, que mejoras se le pueden hacer, supongo que los transistores que puse no son los mejores.

Muchas gracias por las respuestas !
12/09/2011 #2

Avatar de soerok

Otra opción es usar comparadores y una compuerta AND, los comparadores los regulas a el voltaje necesario, en este caso 0.65V y 2V, cuando tus 2 sensores lleguen a el voltaje seteado en los comparadores se activara la salida de la compuerta AND, y de la compuerta AND a un transistor y de ahí al relevador que controla la electrovalvula.

Saludos.
21/09/2011 #3


Hola soerok, probé con lo que me recomendaste y llegué a este circuito que adjunto. En el programa Livewire anda como quiero, pero probando con el circuito no lo puedo hacer andar. Estoy usando un LM339. ¿Tenés idea que es lo que puede estar mal?? gracias
Imágenes Adjuntas
Tipo de Archivo: png circuito 2.png (16,7 KB (Kilobytes), 18 visitas)
21/09/2011 #4

Avatar de Daniel Meza

Agrega un resistor en la salida de cada comparador, el LM339 tiene salidas de colector abierto por lo que le es imposible poner sus salidas a +Vcc, para ello se utiliza un resistor de sujeción a Vcc.

PD: también quita la res de 10K en serie con la salida del comparador, utiliza esta para conectar esta salida a Vcc
21/09/2011 #5


Gracias daniel, mañana o el fin de semana voy a intentar hacerlo andar. Después comento si funciona!
21/09/2011 #6

Avatar de Daniel Meza

Ok, si surgen más dudas por aquí andamos. Otra cosa, no olvides poner unos diodos en inversa en cada relé para evitar el sobrevoltaje por la desconexión de estos y proteger al transistor.
01/10/2011 #7


Daniel entendi que tenia que agregar esto al circuito, ¿esta bien?? gracias por la ayuda!
Imágenes Adjuntas
Tipo de Archivo: png circuito 3.png (4,9 KB (Kilobytes), 7 visitas)
01/10/2011 #8

Avatar de Daniel Meza

Exacto a eso me refería... ahora solo ármalo y comprueba su funcionamiento
01/10/2011 #9


no anda
01/10/2011 #10

Avatar de Daniel Meza

Revisa la salida del comparador verificando si su salida toma los dos valores posibles 1 o 0, para esto utiliza un multímetro. Si observas que no anda, mide los voltajes en las entradas de los comparadares, puede que el error venga de allí. ¿Fisicamente como logras la tensión de referencia de 1V?
01/10/2011 #11


En la salida del comparador tengo 0V, a la entrada negativa le regulo la tensión con un potenciómetro. Y no se por qué en la entrada positiva, sin conectar nada, tengo una tensión parecida a la que regulo en la otra
01/10/2011 #12

Avatar de Daniel Meza

No dejes desconectada la terminal +, de igual forma conectale un potenciometro para polarizar esa entrada y verifica si el relevador conmuta, hecho esto descartarás que el comparador tenga alguna falla
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.