Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

09/08/2011 #1


Condición de señal para un Shunt
Buenas tardes:

Mi problema es el siguiente. Estoy diseñando un amperímetro a través de una resistencia SHUNT. Tiene que medir la corriente para máquinas industriales de soldadura. En primer lugar lo instalé en la masa de la máquina. Acondicioné la señal de 0-60 mV a través de un amplificador operacional a una correspondiente salida de 0-5 V que va hacia un pic que trata la señal analógica y relaciona este voltaje a la correspondiente salida de corriente 0-450A. Todo iba correctamente hasta que a la misma masa se le conectó una máquina de corte por plasma, la cual hace que la masa o tierra que para la máquina de soldadura es negativa, para el plasma es positiva, por lo que en el shunt circula corriente y es detectada en el micro.
La solución viene poniendo el shunt en el latiguillo positivo, la cuestión es que no consigo acondicionar la señal, ya que como las tensiones son altas, tengo que hacer la diferencia entre ambos puntos del shunt para llegar a los 0 a 60 mV. ¿Alguien sabe como hacer la amplificación diferencial para que el cálculo de configuración y resistencias correspondan a la realidad?

Muchas gracias por todo.

Espero contestación, necesito ayuda rápida porfavor.
09/08/2011 #2
Moderador general

Avatar de DOSMETROS

Una opción para positivo o negativo es que uses un operacional como "rectificador de onda completa de precisión" y luego un "integrador"

. . . a Googlear

Saludos !
09/08/2011 #3


Agradezco mucho tu respuesta tan rápida DOSMETROS pero se me presenta una duda, si mi tensión es continua, es decir la diferencia de potencial en el shunt es continuo para qué un rectificador de onda completa de precisión.

Muchas gracias
09/08/2011 #4
Moderador general

Avatar de DOSMETROS

Porque en un caso es positiva y en el otro negativa , la rectificás de onda completa y listo !

El rectificador de precisión no pierde los 0,6 o los 1.2 de los díodos

Saludos !
09/08/2011 #5


Para mi siempre es positiva. El shunt lo tengo instalado en el latiguillo positivo.
09/08/2011 #6
Moderador general

Avatar de DOSMETROS

Ok , entonces solo te falta "integrar" la señal o con un OA o . . . resistencia serie , capacitor a masa , otra resistencia serie , otro capacitor a masa . . .

Los capacitores podrían tener resistencia de mayor valor en paralelo.

Saludos !
09/08/2011 #7


Como he comentado en la explicación inicial, he intentado ver la diferencia de tensión en el mismo latiguillo haciendolo con un AO diferencial. He realizado los cálculos de resistencias y demás, pero a la hora de instalarlo no me funciona como deseo.

Aunque la diferencia de tensión es pequeña, tensión es bastante pequeña, es decir:

terminal del shunt más positivo: 30V
terminal del shunt más negativo (en el caso de mayor diferencia de potencial):29,40V

como adapto esta señal de forma bastante precisa. Esa es mi duda. Creo que no me habia explicado bien.

Muchas gracias.
09/08/2011 #8

Avatar de fdesergio

Diagramssssssss diagramasssssss asi es imposible, talvez el error sea que medis la tension pero respecto a que??? tendrias que usar un amplificador diferencial y de esa manera obtener la diferencia (600mV) de potencial del shunt pero respecto a tierra, como dije sin diagramas imposible, otra cosa estas en un error si colocas el shunt en la tierra y te marca como maximo 60mV como es que el mismo shunt arriba en el positivo te marca 600mV?? no lo entiendo, chauuuuuuuuu
10/08/2011 #9


Teniendo el circuito característico de amplificador diferencial, y entre la zona inversora y no inversora conecto la resistencia de shunt, es decir, diferencia máxima de tensión 60mV, me va dando una relación proporcional de 0 a 5 V en Vout, en función va variando la diferencia de entrada, de 0 a 60 mV. El problema se me plantea si en ambos terminales entran la misma tensión, la salida del operacional es la máxima.
Este problema se me plantea debido a que en mi máquina de soldar, cuando aprieto el gatillo de la pistola, me da tensión pero no circula corriente hasta que no haga contacto con la masa, sin embargo aunque en el shunt no hay diferencia de tensión, ya que no hay corriente que circule por ella, en ambos puntos existe la misma tensión y el operacional me da el máximo. Si hago un banco de pruebas es como si abriera el circuito.
Cómo puedo solucionar este problema.

Muchas gracias de nuevo.
Imágenes Adjuntas
Tipo de Archivo: gif amplif-dife.gif (3,6 KB (Kilobytes), 107 visitas)
10/08/2011 #10

Avatar de ecotronico

Hola:

A ver si entendí bien: se te va la tensión al máximo en la salida del operacional --> Creo que es problema de referencia de tierras. Según tu esquemático, ¿cuál de los bornes del shunt uniste a tu tierra del circuito? Debes fijarte que que debes unir sólo un borne a la tierra de tu circuito amplificador diferencial.
10/08/2011 #11

Avatar de fdesergio

Si es diferencial al tener la misma tension en las entradas (0 corriente por el shunt) deberia tener en la salida la diferencia de entradas por el valor de ganacia de tension pero como Vdiferencial =0 entonces tension de salida=0, repito sin esquematico es dificilisimoooooooooooo, chauuuuuuuuu
10/08/2011 #12
Moderador general

Avatar de Fogonazo

rossanato dijo: Ver Mensaje
............ Estoy diseñando un amperímetro a través de una resistencia SHUNT. Tiene que medir la corriente para máquinas industriales de soldadura. En primer lugar lo instalé en la masa de la máquina. Acondicioné la señal de 0-60 mV a través de un amplificador operacional a una correspondiente salida de 0-5 V que va hacia un pic que trata la señal analógica y relaciona este voltaje a la correspondiente salida de corriente 0-450A. Todo iba correctamente hasta que a la misma masa se le conectó una máquina de corte por plasma, la cual hace que la masa o tierra que para la máquina de soldadura es negativa, para el plasma es positiva, por lo que en el shunt circula corriente y es detectada en el micro..........
¿ Esta en etapa de diseño ? o ¿ ya se encuentra armado ?
Si lo tenias funcionando en el modo soldadora y debes invertir la polaridad para emplear el plasma, ¿ Por que deberías invertir el shunt ? si la inversión de la polaridad la haces después de este.
10/08/2011 #13

Avatar de Gudino Roberto duberlin

rossanato dijo: Ver Mensaje
Buenas tardes:

Mi problema es el siguiente. Estoy diseñando un amperímetro a través de una resistencia SHUNT. Tiene que medir la corriente para máquinas industriales de soldadura. En primer lugar lo instalé en la masa de la máquina. Acondicioné la señal de 0-60 mV a través de un amplificador operacional a una correspondiente salida de 0-5 V que va hacia un pic que trata la señal analógica y relaciona este voltaje a la correspondiente salida de corriente 0-450A. Todo iba correctamente hasta que a la misma masa se le conectó una máquina de corte por plasma, la cual hace que la masa o tierra que para la máquina de soldadura es negativa, para el plasma es positiva, por lo que en el shunt circula corriente y es detectada en el micro.
La solución viene poniendo el shunt en el latiguillo positivo, la cuestión es que no consigo acondicionar la señal, ya que como las tensiones son altas, tengo que hacer la diferencia entre ambos puntos del shunt para llegar a los 0 a 60 mV. ¿Alguien sabe como hacer la amplificación diferencial para que el cálculo de configuración y resistencias correspondan a la realidad?

Muchas gracias por todo.

Espero contestación, necesito ayuda rápida porfavor.
Hola Amigo, antes que nada como dice el colega tienes que subir algun esquematico, bueno, para conectar una R SHUNT, debes instalarla en la entrada principal de alimentacion a los equipos, de esta manera te libras del comportamiento de la carga. O puedes utilizar un transformador de corriente.-
10/08/2011 #14
Moderador general

Avatar de DOSMETROS

Gudino Roberto duberlin dijo: Ver Mensaje
. . . O puedes utilizar un transformador de corriente.-

Es corriente contínua , el transformador de corriente ahí no funciona , funcionaría algún integrado que mida por Hall !

Googleá ---> Current Sensor ICs

http://www.allegromicro.com/en/Produ...ider/index.asp

Saludos !
10/08/2011 #15

Avatar de Gudino Roberto duberlin

DOSMETROS dijo: Ver Mensaje
Es corriente contínua , el transformador de corriente ahí no funciona , funcionaría algún integrado que mida por Hall !

Googleá ---> Current Sensor ICs

http://www.allegromicro.com/en/Produ...ider/index.asp

Saludos !
Hola Amigo, justamente aclare que el Shunt o transformador de corriente deberia estar conectado obviamente en la "entrada" de alimentacion, cual es el sentido de conectarlo en la salida?.-
11/08/2011 #16


A ver, comienzo la estructuración de mi pregunta de otra forma.
Como gestiono la diferencia entre estos dos puntos de la resistencia. La diferencia máxima es de 60 mV. Con amplificador diferencial no es viable.

Alguna sugerencia??

Muchas gracias
Archivos Adjuntos
Tipo de Archivo: pdf ISIS Professional - UNTITLED2.pdf (19,8 KB (Kilobytes), 90 visitas)
11/08/2011 #17
Moderador general

Avatar de DOSMETROS

Desde los extemos del shunt entrás en un "amplificador integrador" (Google) , pero debes tener en cuenta que dicho circuito debe permanecer flotante respecto del resto de la soldadora.
24/12/2012 #18


continuando el tema estaba tratando de hacer lo mismo pero mas sencillo
solo con un par de led

en realidad no quiero medir con numeros
solo quiero que cuando la corriente sea mayor a 1A se encienda un led

calculando la resistencia shut en 0.01Ω
y quiero medir entre 0 y 7A
el voltaje variara entre 0 y 70mV

entonces arme el clasico circuito con led resistencias y un bc548 fuente 12V

el problema es que necesito 700mv en la base del bc548 para encender el led
o sea 700A

entonces como puedo hacer el invento
24/12/2012 #19
Moderador general

Avatar de Fogonazo

analogico dijo: Ver Mensaje
. . . .entonces como puedo hacer el invento


¿ Cual invento ?,¿ Alguien sabe de que cosa estas escribiendo
24/12/2012 #20
Moderador general

Avatar de DOSMETROS

Invento : encender un led con corriente superior a 7 A

Ponele úno o dos díodos rápidos en serie con la resistencia y uno invertido en paralelo , y probá ahí tu led. O fijate de manejar la base de un transistor con eso.

Saludos !
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.