Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

10/04/2009 #1


Conexión correcta de CD4016 o CD4066
Hola amigos del foro, quería preguntar cual era la forma correcta de concetar el cd4016 o el cd4066, pues mis integrados no responden como los estoy conectando y tengo dudas de que me los hayan vendido quemados. Pero para salir de dudas les pregunto: ¿cómo debo conectar los pines 7 y 14?¿a corriente continua o a corriente alterna?¿necesitaría una fuente?¿como tendría que ser esta?
Muchas gracias por su respuesta y un saludo desde la distancia
11/04/2009 #2


Amigo por que no pones el circuito que estas usando haci es mas facil a clararte la duda.. y los pines correspondiente a 7 y 14, estos son tierra (GND) y positivo (+VCC) consecutivamente, voltaje DC no voltaje AC ya que si por el contrario lo conectas en AC los dañarias (los quemarias)... mira esta imagen de su data haver si te sirve de algo http://www.premiumorange.com/daniel..../4016_4066.GIF oh si no te recomiendo que pongas una imagen del circuito...
11/04/2009 #3


Gracias por la respuesta Blackpic. Ahí pongo el circuito, bueno en realidad este lo armé para probar el bendito integrado (cd4016 y cd4066), se supone que si es un switch bidireccional analógico debería funcionar bien para prender esos LEDs al presionar su respectivo pulsador, pero esto no sucede. Lo que no entinendo es la parte que pongo con rojo eso que a veces aparece GND o VSS y también VCC o VDD, no entiendo la diferencia. Tampoco entiendo si debo ponerle una fuente y eso de corriente alterna y corriente
continua y si es que lo puedo conectar a una batería de 9V.
Les agradezco por su ayuda. Saludos.

PD: ya se habrán dado cuenta: soy principiante jeje
Imágenes Adjuntas
Tipo de Archivo: gif cd4016__cd4066_104.gif (5,7 KB (Kilobytes), 1027 visitas)
11/04/2009 #4


amigo espero que con esta imagen puedas soluccionar tu problema hay te muestro 2 maneras de como puedes poner a funcionar el 4066, si te fijas en el primer circuito apago los led ya que los swich estan conectados a tierra y en un segundo los enciendo, ya que los swich estan conectados al positivo... y tienes que saber tambien que los led llevan sus respectivas resistencia de limite para no dañarlo ya que estos operan con un voltaje que circula entre los 2v-3.5v dependiendo del color del led.... ah (VSS-GND), son los mismo y corresponde al pin de tierra.. y (VCC-VDD) son igual tambien y corresponden al pin positivo de tu fuente oh bateria... espero haverte ayudado......
Imágenes Adjuntas
Tipo de Archivo: jpg 4066_180.jpg (124,1 KB (Kilobytes), 1654 visitas)
12/04/2009 #5


Gracias por tu respuesta nuevamente. Me parece que en tu segundo circuito los switch no estan bien ubicados, ya que deben ir en los pines de control (6, 5, 12, 13), pues sino practicamente se estaría anulandose el integrado, sería como si no se usara, aunque no estoy muy seguro (soy principiante). Bueno he probado los circuitos que pusiste. Probé incluso lo más basico posible, lo más simplificado: con un solo led, pero tampoco funciono. El LED se mantiene prendido sin presionar el pulsador. Este circuito mas simple es el que pongo en la imagen. Quizas.... sea el voltaje o tal vez... se necesite una fuente simétrica o un rectificador (no entiendo bien que son esas cosas)? No se cómo hacer para que funcione.

Gracias de antemano

Saludos
Imágenes Adjuntas
Tipo de Archivo: jpg cd4016__cd4066_simple_931.jpg (18,8 KB (Kilobytes), 494 visitas)
13/04/2009 #6

Avatar de Dr. Zoidberg

En el esquema modificado que te adjunto está lo que tenes que hacer para que funcione. Ya te lo han explicado antes, pero seguis insistiendo con el mismo esquema que está equivocado.

Vos decís que sos principiante, pero se puede apreciar que no sabés nada de tecnicas analógicas y digitales, así que sería bueno que tomes un libro y vayas leyendo y estudiando, por que en caso contrario nos vamos a pasar el año intentando que enciendas un led.

Por otra parte, te aviso que el esquema que estas usando no es adecuado para encender un LED, por que la capacidad de corriente del switch analógico del CD4066/4016 es insuficiente para manejar los 10 miliamperes que requiere un LED para encender bien y es probable que termines dañando el chip si lo haces....pero quemando se aprende.

La resistencia de 820 ohms que he colado en serie con el LED es imprescindible que vaya puesta ahí y te va a limitar la corriente del LED a menos de 10 mA, pro que el switch analógico también tiene una cierta resistencia interna, que podes ver el valor en la hoja de datos, y que cambia a medida que cambia la tensión de alimentación del chip.

La resistencia de 100K a masa también es necesaria, ya que fija el potencial de la entrada de control del switch cuando el interruptor a Vcc está abierto. Sin ella, es probable que el LED quede siempre encendido o que destelle cuando el interruptor está abierto, debido a la impedancia de entrada de la pata de control.

Saludos!
Imágenes Adjuntas
Tipo de Archivo: jpg cd4066_simple_535.jpg (19,3 KB (Kilobytes), 662 visitas)
15/12/2009 #7


Respuesta: Conexión correcta de CD4016 o CD4066
hola a todos espero que me puedan ayudar, estoy diseñando un dispositivo en el que preciso manejar el control remoto de un TV por medio de un PIC la cuestion es que el control basicamente activa los botones cortocircuitando ciertos pines, yo lo que quiero hacer es conectar esos dos pines a un CD4016 y al activar el habilitador, sean cortocircuitados y le hagan creer al control que se presionó el botón. Mi pregunta es, lo puedo hacer con el CD4016 o existe algo mas recomendable, les comento también que he intentado con el 4016 pero definitivamente no pasa nada, hice la conexión que muestra el amigo ezavalla donde basicamente a los pines 1 y 2 conectaba era los pines del control, pero nada pasa cuando presiono el boton. Otra cosa, en el data Sheet dice que puedo polarizar con 5V, lo que para mi sería muy bueno porque el pic es TTL, la pregunta es: que tan recomendable es polarizar con 5V o es mejor con 12V?, gracias por la ayuda que puedan prestar.
20/12/2009 #8


Respuesta: Conexión correcta de CD4016 o CD4066
Hola. Al igual que tú he probado todos los circuitos que se publicaron arriba y ninguno me funcionó. Claro que cuando uno lo prueba en algun programa de simulación de circuitos sí funciona, pero cuando uno lo arma no resulta. Mira, buscando y buscando encontré este link http://www.doctronics.co.uk/4016.htm allí hay una imagen de un circuito de prueba con leds (mostrado abajo) que fue el único que a mí me funcionó.



Parece que son necesarias esas resistencias y sobre todo el condensador, pero lo que no entiendo mucho es cuál es su función.

Ahora respecto al voltaje, debes recordar que este switch CD4016 tiene una resistencia que varía respecto al voltaje que le suministres y a la temperatura. En la hoja de datos están esos datos para algunos voltajes. Me parece que mientras mayor es el voltaje menor es la resistencia. Ah y menor resistencia ofrece su hermano CD4066. Por lo tanto debes elegir el voltaje de acuerdo a lo que tu circuito requiera.

Espero haberte ayudado anuque sea un mínimo.

Saludos
22/12/2009 #9


Respuesta: Conexión correcta de CD4016 o CD4066
Hola Ruben gracias por responder, te comento que el problema ya lo había corregido y pues olvidé anunciarlo aquí, pero te agradezco mucho la respuesta, aprovecho para comentar que el circuito que muestras allí debe funcionar perfectamente, porque algo parecido fue lo que monté aunque no necesitaba las resistencias porque mi conexión no era hacia un interruptor sino hacía un microcontrolador, esa resistencia de 10K que se muestra se debe utilizar para que el CD vea tierra cuando el interruptor esté abierto y no vea un circuito abierto (es necesaria, porque el CD se deshabilita cuando se hace conexión a tierra, si no ve la tierra siempre se queda habilitado), la resistencia de 470 supongo que la utilizan para limitar la corriente que fluye hacia el LED y evitar que se queme (es de 470 porque tienen una fuente de 9V, si pones una de 5V con una R de 220 estaría bien) el capacitor no estoy seguro, supongo que es para eliminar el rizado que pueda tener la fuente de voltaje y hacerla mas DC pero no te aseguro nada. De nuevo agradezco por responder ahh y agrego el CD4016 si se puede polarizar con 5V, la verdad mi problema resultó ser que la protoboard tenía una línea rota y no estaba llegando la conexión a tierra hasta el integrado, solo lo descubrí haciendo muchas medidas y la verdad son los problemas que uno menos espera. gracias
13/05/2010 #10


Respuesta: Conexión correcta de CD4016 o CD4066
Estuve leyendo y vi que he hecho mal, prebe conectar el 4066 y la hice sin las R. Se quema el IC?

Gracias
16/09/2010 #11


Respuesta: Conexión correcta de CD4016 o CD4066
Perdon que me entrometa en este tema pero estaba buscando informacion del CD4066 y del 74HC4066.

Alguien me puede decir que integrado puedo utilizar para hecar lo siguiente ????:
Quiero que al oprimir un pulsador sin retencion, este pulso se convierta en 4 salidas. 2 salidas que permanezcan cerradas mientras el pulsador esta apretado y las otras dos que se mantegnan cerradas aunque soltemos el boton y que, para que vuelvan a estar abiertas, tengamos que pulsar nuevamente. En definitiva tengo que convertir un pulsador simple en uno con 2 salidas de pulsador y 2 tipo switch On/off.

Perdonen pero mis conocimientos de electrónica no son muchos pero soy bastante bueno siguiendo esquemas pero, de alli a diseñarlo..........

Desde ya muchas gracias y disculpen por colarme en este tema.

Saludos:
Matías.
16/09/2010 #12
Moderador general

Avatar de Cacho

Respuesta: Conexión correcta de CD4016 o CD4066
matalcacer dijo: Ver Mensaje
Quiero que al oprimir un pulsador sin retencion[...]2 salidas que permanezcan cerradas mientras el pulsador esta apretado...
Para esto no necesitás ningún circuito
matalcacer dijo: Ver Mensaje
...y las otras dos que se mantegnan cerradas aunque soltemos el boton...
Un Flip Flop y tomás las dos salidas de ahí.

No busques una solución compleja si hay una simple


Saludos
04/12/2010 #13


Hola Amigos del foro, estoy usando un cd4016 en forma de switch analógico, quisiera saber cual es la razon por la que al enviar un uno por la pata de control (ej. 13) se produce una caida de voltaje a la entrada (seria pin 1), dejando pasar a la salida un valor mas bajo. Por ejemplo lo que esta pasando es lo siguiente:
Tengo 3V a la entrada en el pin 1 cuando el pin de control de ese puerto esta a GND, pero cuando pongo el control a VCC la tension que hay a la entrada del pin 1 cae de 3v a 2,45v dejando pasar este nuevo valor a la salida.
(es normal que se produzca semejante caida de tension???)
alguien me puede dar una mano??
04/12/2010 #14
Moderador general

Avatar de Fogonazo

gonbaldan dijo: Ver Mensaje
Hola Amigos del foro, estoy usando un cd4016.....
¿ Esquema ? la descripción NO se entiende
04/12/2010 #15


ok, aca envio el esqeumático,

http://img10.imageshack.us/i/switch4016.png/

Básicamente son 4 señales que vienen de relojes de temperatura, presión, etc. de una máquina en forma de onda contínua de 0 a 5V.
El Micro es un pic18f452 que básicamente lee las señales de voltaje, y devez en cuando deja pasar de a pares las señales, seleccionando los puertos de control (pines 12,13,5,6) del 4016, a través de las salidas del pic (CONT1/4).
y Aqui resumo el problema que tengo, ya sea en el circuito, el cual ya esta implementado, o cuando pruebo el 4016/4066 solo en protoboard, lo que pasa es que cuando llega una señal de por ej 3v a una entrada, y cambia el estado de la pata de control del 4016, de "cerrado" a "abierto", se produce una caida de voltaje, significativa, pasando de 3v a 2,4, midiendo 2,4V tanto a la entrada como a la salida.

He probado con alimentacion de 12v y 5v, usando ese mismo voltaje para excitar los puertos de control, tambien probé colocando resistencias de 100k o 10k a masa (en todas las entradas de control).

Sospecho que puede ser algun problema de corriente, pero no me doy cuenta como solucionarlo,
espero que algun iluminado se pueda ver que es...
Gracias desde ya!

las IN2, IN3, IN4, IN5 son las entradas analogicas que multiplexa el 4016.
Imágenes Adjuntas
Tipo de Archivo: jpg switch4016.jpg (102,8 KB (Kilobytes), 235 visitas)
25/01/2011 #16

Avatar de Meta

En la imagen parece ser que el interrutor está cerrado, el Led se apaga, pensé que era que si un PIC le da 5V y cierra el circuito, el Led se enciende y aquí el famoso CD4016 lo hace al revés de lo que creía.

01/08/2011 #17


Conexión correcta de CD4016 o CD4066
Hola estoy intentando controlar una una señal senoidal con el integrado CD4066 mi intención es que el paso de esta señal este controlado a través de un arduino. Pero no consigo que funcione correctamente.
Adjunto pongo como lo tengo conectado( R1 es de 10K) y unas capturas de lo que obtengo.

Si os fijáis en las capturas que hice en el osciloscopio la señal senoidal que obtengo a la salida viene con offset y ademas de cuando no tiene activa la señal de control(5 V) pasa la señal con una amplitud(200 mVpp Aprox.) cuando no debería haber nada.

A ver si alguien que haya trabajado con este integrado puede ayudarme.

Gracias de antemano.
Imágenes Adjuntas
Tipo de Archivo: jpg Esquema_conexion_CD4066.jpg (16,7 KB (Kilobytes), 103 visitas)
Tipo de Archivo: jpg señal.JPG (42,9 KB (Kilobytes), 62 visitas)
Tipo de Archivo: jpg señal_detalle.JPG (52,0 KB (Kilobytes), 54 visitas)
01/08/2011 #18

Avatar de Black Tiger1954

Qué amplitud tiene la señal sinusoidal?
La tensión de control (5V) me parece muy baja, para una alimentación de 10 volts recomiendan 7 volts, si la placa de control maneja 5 volts, te aconsejo bajar la alimentación del 4066 a ese mismo valor, o en su defecto usá un transistor extra para controlarlo.
A la salida le estás poniendo alguna carga?
El osciloscopio está conectado en DC?
01/08/2011 #19


Hola Black Tiger1954, gracias por responder:
A la salida tengo unas resistencia de 100K
he conectado el switch a 5 V y sale lo mismo, pero sigue saliendo lo mismo aunque deje la patilla al aire.
La señal tiene una amplitud de unos 2 voltios la cual puedo regular ya que la salida de este integrado tengo que amplificarla. Por ello quiero quitar el problema del offset y del paso de señal cuando no deberia.
01/08/2011 #20

Avatar de Black Tiger1954

Ok Juanjo. El primer detalle es que para tener un offset de 0 volts, el CD4066 lo tenés que alimentar con +/- no con +/gnd, en este caso +5/-5 debería funcionar bien.
Eso te puede complicar un poquito el control pero no mucho.
La pata de control no debe dejarse al "aire", o va a Vdd o a Vss, pero nunca al aire.

PD: también podés desacoplar las señales mediante capacitores, pero seguro que va a producir un "plop" cuando conmute.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.