Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

26/07/2016 #561

Avatar de djstigma

hola compañero
por lo que veo vas muy bien
ok segun mi criterio no vas a tener problemas con los presets de 50k, hay un margen.
lo que si te recomiendo para que marque correctamente el escpectro audible es regularlos bien
siguiendo como ejemplo un video con la grafica correcta de frecuencias, te lo paso mañana porque lo hice para esto justamente. aunque creo que ya lo comparti aqui
por otro lado, tincho te recomienda alimentar con 12 la placa que conectarias a los led, eso seria bueno si haces como yo que puse leds de alto brillo. en tu caso (no es necesario)
ya que usas leds comunes.
te recomiendo que para la primera prueva solo uses 5v. y no pases de 5v la placa con el 7660.
lo que hago incapie es en las placas, sin errores en lo posible, con calma aunque lleve el doble de tiempo. no importa si es entera o en 2 partes, lo importante son las pistas bien terminadas
bueno un abrazo a todos, nos vemos pronto
26/07/2016 #562


djstigma dijo: Ver Mensaje
hola compañero
por lo que veo vas muy bien
ok segun mi criterio no vas a tener problemas con los presets de 50k, hay un margen.
lo que si te recomiendo para que marque correctamente el escpectro audible es regularlos bien
siguiendo como ejemplo un video con la grafica correcta de frecuencias, te lo paso mañana porque lo hice para esto justamente. aunque creo que ya lo comparti aqui
por otro lado, tincho te recomienda alimentar con 12 la placa que conectarias a los led, eso seria bueno si haces como yo que puse leds de alto brillo. en tu caso (no es necesario)
ya que usas leds comunes.
te recomiendo que para la primera prueva solo uses 5v. y no pases de 5v la placa con el 7660.
lo que hago incapie es en las placas, sin errores en lo posible, con calma aunque lleve el doble de tiempo. no importa si es entera o en 2 partes, lo importante son las pistas bien terminadas
bueno un abrazo a todos, nos vemos pronto
Lo de ajustar los trimmers no lo vi en este post, o lo pase por alto Pero si me puedes indicar como hacerlo te lo agradeceria bastante.

Respecto al voltaje, pues, pasare todo con 9v, total, todo los integrados aguantan dicho voltaje, y el mas "delicado", el 7660, aguanta hasta 10v, asi que no habra problemas. Ademas, como bien dices, no necesito 12v ya que usare los leds amarillos rectangulares.

Sobre las placas y el acabado no tengo ningun problema, ya tengo experiencia jiji (fabricandolas ).

26/07/2016 #563

Avatar de blanko001

Hay que estar pendiente de un detalle: Siempre hay que calcular las resistencias de los LED para la tensión que usaremos, hay que tener en cuenta los parámetros básicos de tensión de trabajo del LED (cada color tiene su tensión) y la corriente máxima de operación o la corriente necesaria para el brillo deseado.

RLED=((Vfuente-Vtransistor1-Vtransistor2)-Vled)/Iled

R: Ohms; V: Voltios; I: Amperios

Saludos!
27/07/2016 #564


blanko001 dijo: Ver Mensaje
Hay que estar pendiente de un detalle: Siempre hay que calcular las resistencias de los LED para la tensión que usaremos, hay que tener en cuenta los parámetros básicos de tensión de trabajo del LED (cada color tiene su tensión) y la corriente máxima de operación o la corriente necesaria para el brillo deseado.

RLED=((Vfuente-Vtransistor1-Vtransistor2)-Vled)/Iled

R: Ohms; V: Voltios; I: Amperios

Saludos!
Tenia entendido que el LM3915 no trabaja con tension, sino con corriente constante.
27/07/2016 #565

Avatar de blanko001

En ésta ocasión la matriz de leds es alimentada directamente de la tensión de alimentación... las corriente de salida del LM solo está activando unos transistores, no directamente a los LEDs.
Saludos.
27/07/2016 #566


blanko001 dijo: Ver Mensaje
En ésta ocasión la matriz de leds es alimentada directamente de la tensión de alimentación... las corriente de salida del LM solo está activando unos transistores, no directamente a los LEDs.
Saludos.


Lo malo es que para estas cosas soy lentisimo, y eso que me fascina


O sea, no podre usar 9v con las R de 100 (no entendi bien la operacion RLED=...). Mis disculpas... Igual tambien tengo una fuente de 5v-1A, pero queria salir de dudas (¿sera suficiente 1A?).

Ademas de eso, tengo dos dudas mas: El valor de los trimmers y si a la final se van a iluminar las dos ultimas filas de leds, porque en los videos eso no ocurre (de la pagina web).
27/07/2016 #567

Avatar de blanko001

Xabdeth dijo: Ver Mensaje


Lo malo es que para estas cosas soy lentisimo, y eso que me fascina


O sea, no podre usar 9v con las R de 100 (no entendi bien la operacion RLED=...). Mis disculpas... Igual tambien tengo una fuente de 5v-1A, pero queria salir de dudas (¿sera suficiente 1A?).

Ademas de eso, tengo dos dudas mas: El valor de los trimmers y si a la final se van a iluminar las dos ultimas filas de leds, porque en los videos eso no ocurre (de la pagina web).
Hola.

En primer lugar no creo que sea muy critico tomar el valor de la caída de las tensiones en los transistores (Vce). Vamos a trabajar sobre los 9V de tu fuente y partiendo de que cada color de LED tiene una tensión de conducción diferente. Sería muy bueno si tienes el dato del fabricante; por ejemplo si compraste cantidad por ebay o de china. Igual... no hay lío con eso, no es del otro mundo averiguarlo o suponerlo.

Ejemplo: Si usas 9 voltios y tuvieses LEDs con tensión de operación de 2.2V y 20mA (corriente máxima típica en LEDs de uso común) calcularías la resistencia así:

RLED=(Vfuente-VLED)/ILED

RLED=(9V-2.2V)/0.02A=340Ω

Un valor comercial cercano de una resistencia común de carbón (por encima) sería de 390Ω. Para 390Ω tendríamos una corriente sobre los LEDs de unos 0,017A = 17mA. Perfecto!

Por otro lado la fuente 5V y 1A es más que suficiente... No sé si el diseño pueda funcionar con 5V, lo digo por la etapa de los filtros de banda con los operacionales. No recuerdo cuanto es la tensión de alimentación de la misma.

En todo caso... el cálculo de las resistencias de 100Ω del circuito propuesto por el autor es un valor muy tomado a la ligera (ya pasaríamos a analizar si ello es compensado por los valores de las resistencias de las bases de los transistores y la caída de tensión en los transistores). Aún a 5V excede la corriente típica de funcionamiento de los LEDs comunes. Lo que hizo el autor fue generalizar que los LEDs se alimentan con 3V. Y al calcular (5V-3V)/0.02A, obtenemos 100Ω. Siempre es mejor calcular el valor según el color de LEDs a usar.

Por último no creo que exista gran diferencia con usar trimmers de 47KΩ o 50KΩ. El circuito propuesto no es algo profesional que "mida" y muestre de manera estricta las frecuencias. Es la unión entre algo estético y funcional. Y con djstigma se hicieron muchos ajustes hasta lograr iluminar todo correctamente. Hasta se implementó un circuito de la hoja de datos del LM3915 o LM3916 para lograr un efecto mejorado. Se hicieron varios ajustes y sería bueno en la medida del desarrollo de su analizador que él nos proporcione fotos o diagramas de como y con que valores quedó la versión final.

Saludos!
27/07/2016 #568


blanko001 dijo: Ver Mensaje
Hola.

En primer lugar no creo que sea muy critico tomar el valor de la caída de las tensiones en los transistores (Vce). Vamos a trabajar sobre los 9V de tu fuente y partiendo de que cada color de LED tiene una tensión de conducción diferente. Sería muy bueno si tienes el dato del fabricante; por ejemplo si compraste cantidad por ebay o de china. Igual... no hay lío con eso, no es del otro mundo averiguarlo o suponerlo.

Ejemplo: Si usas 9 voltios y tuvieses LEDs con tensión de operación de 2.2V y 20mA (corriente máxima típica en LEDs de uso común) calcularías la resistencia así:

RLED=(Vfuente-VLED)/ILED

RLED=(9V-2.2V)/0.02A=340Ω

Un valor comercial cercano de una resistencia común de carbón (por encima) sería de 390Ω. Para 390Ω tendríamos una corriente sobre los LEDs de unos 0,017A = 17mA. Perfecto!

Por otro lado la fuente 5V y 1A es más que suficiente... No sé si el diseño pueda funcionar con 5V, lo digo por la etapa de los filtros de banda con los operacionales. No recuerdo cuanto es la tensión de alimentación de la misma.

En todo caso... el cálculo de las resistencias de 100Ω del circuito propuesto por el autor es un valor muy tomado a la ligera (ya pasaríamos a analizar si ello es compensado por los valores de las resistencias de las bases de los transistores y la caída de tensión en los transistores). Aún a 5V excede la corriente típica de funcionamiento de los LEDs comunes. Lo que hizo el autor fue generalizar que los LEDs se alimentan con 3V. Y al calcular (5V-3V)/0.02A, obtenemos 100Ω. Siempre es mejor calcular el valor según el color de LEDs a usar.

Por último no creo que exista gran diferencia con usar trimmers de 47KΩ o 50KΩ. El circuito propuesto no es algo profesional que "mida" y muestre de manera estricta las frecuencias. Es la unión entre algo estético y funcional. Y con djstigma se hicieron muchos ajustes hasta lograr iluminar todo correctamente. Hasta se implementó un circuito de la hoja de datos del LM3915 o LM3916 para lograr un efecto mejorado. Se hicieron varios ajustes y sería bueno en la medida del desarrollo de su analizador que él nos proporcione fotos o diagramas de como y con que valores quedó la versión final.

Saludos!
De verdad, gracias por la pronta respuesta


Los leds son amarillos rectangulares, segun especificaciones, son de 2.2v y 20mA (mas o menos lo "comun", como ha colocado). Entonces voy a pillar 10 de 390 Ohm.

Del resto, alimentare todo (con ese cambio) a 9v, tengo varios adaptadores desde 0.85A hasta 1.2A. El integrado mas "delicado" es el 7660 y aguanta hasta 10v.

Y bueno, espero que djstigma me indique los ajustes de los trimmers, es lo unico que me faltaria
27/07/2016 #569

Avatar de djstigma

hola perdon por la demora.
te dejo este comprimido con 2 videos de referencia para que regules los presets, solo los vas regulando de a uno y miras que el analizador responda igual que el video y listo.
y por si queres te pase el programa que use para generar las frecuencias
http://www.mediafire.com/download/q1...recuencias.zip


P.D. insisto en no pasar el 7660 de 5v. 9v estas al limite y ese ic es muy delicadito
ademas no precisas variar resistencias. suerte !!

P.D.2. por si no se entedio, tenes que conectar el analizador a la computadora donde reproducis el video, el audio del video es la base para regular ok
30/07/2016 #570


djstigma dijo: Ver Mensaje
hola perdon por la demora.
te dejo este comprimido con 2 videos de referencia para que regules los presets, solo los vas regulando de a uno y miras que el analizador responda igual que el video y listo.
y por si queres te pase el programa que use para generar las frecuencias
http://www.mediafire.com/download/q1...recuencias.zip


P.D. insisto en no pasar el 7660 de 5v. 9v estas al limite y ese ic es muy delicadito
ademas no precisas variar resistencias. suerte !!

P.D.2. por si no se entedio, tenes que conectar el analizador a la computadora donde reproducis el video, el audio del video es la base para regular ok
Ya entendi como se "calibra" cada banda. Creo que podre usar un generador de frecuencias llamado fg lite para afinar cada banda de leds. Todo conectado al Pc gracias a mi DAC SMSL Sanskrit (por USB) y mi amp Pioneer SA 508.

Sobre el 7660, no hay problema en usar 9v, tengo otros circuitos asi y jamas presentaron ningun tipo de fallos. Intente conseguir el 7660A, el cual aguanta hasta 12v, pero nada, no lo consigo (ni en Panama). Las resistencias de 390 ya las tengo.

Por cierto ¿cual sera el motivo por el que no le encienden las dos ultimas hileras de leds? Me refiero al de la pagina de donde fue sacado este proyecto.


Del resto, gracias por las respuestas, sin duda alguna es el mejor foro de electronica en el que he estado. Y agradezco mas por el tiempo tomado con las explicaciones, que a pesar de tener tiempo en esto, siempre me cuesta entender todo
31/07/2016 #571

Avatar de blanko001

Xabdeth dijo: Ver Mensaje
Sobre el 7660, no hay problema en usar 9v, tengo otros circuitos asi y jamas presentaron ningun tipo de fallos. Intente conseguir el 7660A, el cual aguanta hasta 12v, pero nada, no lo consigo (ni en Panama). Las resistencias de 390 ya las tengo.
Y si utiliza antes un LM7805 por si acaso tu fuente no está bien regulada... ese IC (7805) lo debe haber hasta en marte jejeje
Saludos
31/07/2016 #572


blanko001 dijo: Ver Mensaje
Y si utiliza antes un LM7805 por si acaso tu fuente no está bien regulada... ese IC (7805) lo debe haber hasta en marte jejeje
Saludos
Tenia pensado eso, pero medi el voltaje del adaptador que usa mi SMSL Sanskrit y da 8,9, casi los 9 exactos. Tambien tengo otro de un tp-Link, pero ese da 9,6, asi que lo he descartado.

Usare el primero. Igual tengo pensado en armarme una fuente variable.

Ya colocare imagenes de las placas (tal vez mañana), ademas, el sabado que viene me llegan los ultimos componentes que me faltan.



Edit: Añado imagenes.

Solo tuve un pequeño error, y fue en la 3ra imagen, la primera hilera de leds (desde la derecha), en el 2do led, la pista no continua bien, del resto todo esta perfecto.. Ah si, y se me olvido quitar el feo nombre de las placas Terrible....

¿Como lo ven?
Imágenes Adjuntas
Tipo de Archivo: jpg Placa1.jpg (108,6 KB (Kilobytes), 24 visitas)
Tipo de Archivo: jpg Placa3.jpg (70,1 KB (Kilobytes), 20 visitas)
Tipo de Archivo: jpg Placa4.jpg (71,6 KB (Kilobytes), 22 visitas)
03/08/2016 #573

Avatar de djstigma

hola bro, prolijas me gustan. buen trabajo
lo que no me gusta es ese tipo de pertinax el pcb que venden jaja
aca lo venden pero nunca lo compraria, compro otro de fibra de vidrio mas grueso y diferente
color es mas clarito casi blanco.
respecto a tu pregunta de las 2 ileras de led del video, seguramente tenga baja la señal de audio
ami me paso que me prendian menos aun 3 o 4 ileras nada mas, y le puse una pre estereo
le saque el pote de 500k y listo ahi si prendio todo jaja
03/08/2016 #574


djstigma dijo: Ver Mensaje
hola bro, prolijas me gustan. buen trabajo
lo que no me gusta es ese tipo de pertinax el pcb que venden jaja
aca lo venden pero nunca lo compraria, compro otro de fibra de vidrio mas grueso y diferente
color es mas clarito casi blanco.
respecto a tu pregunta de las 2 ileras de led del video, seguramente tenga baja la señal de audio
ami me paso que me prendian menos aun 3 o 4 ileras nada mas, y le puse una pre estereo
le saque el pote de 500k y listo ahi si prendio todo jaja
Gracias

Bueno, las dos mas grandes son como indicas, el color es claro como se ve en esta imagen. La de los leds no es delgada, pero el material no es igual como bien has dicho (no tenia de otra).

Del resto, pues, he agrandado algunos orificios (en la imagen aun no lo habia hecho) para el potenciometro, el conector de 3.5mm y la entrada del adaptador. Creo que tambien tendre que hacerlo para los trimmers (me llegan el sabado).

Respecto a las dos hileras de leds, bueno, ya probare a ver que tal cuando tenga todo listo. Por supuesto, comentare al respecto del proceso y finalizacion.
Imágenes Adjuntas
Tipo de Archivo: jpg Placa2.jpg (65,4 KB (Kilobytes), 12 visitas)
07/08/2016 #575


Actualizo:

El 7660 que me compraron es el que tiene la S al final, revise y aguanta hasta 12v.

Ya tengo todos los componentes restantes. El unico fallo fue el potenciometro de 500k, me lo compraron lineal (B), y para este proyecto se necesita de un logaritmico (A). Ya lo buscare por aca.

Tambien tengo trimmers tipo "mesita", los verticales ya no los necesito.
07/08/2016 #576

Avatar de blanko001

Hola.

Xabdeth dijo: Ver Mensaje
...Ya tengo todos los componentes restantes. El unico fallo fue el potenciometro de 500k, me lo compraron lineal (B), y para este proyecto se necesita de un logaritmico (A). Ya lo buscare por aca.
No creo que sea problema si es logarítmico o lineal en éste caso.

Xabdeth dijo: Ver Mensaje
...Por cierto, ¿en que topic puedo preguntar sobre unos transistores? Tanto para saber si son originales como otros por su equivalencia.
En el tema de Componentes electrónicos falsificados puede preguntar para especular un poco sobre su "originalidad"

Saludos... y buenas placas!
08/08/2016 #577


@blanko001 Seguramente, igual probare con ambos a ver que tal. Y gracias por el link, habia editado porque lo habia visto antes de que respondieras.

Por cierto, me sobraron 3 resistencias de esa lista: 1 de 4,7K - 1 de 47k y 1 de 680k.

Aca una actualizacion, para que vean como va:
Imágenes Adjuntas
Tipo de Archivo: jpg 2016-08-09 00.05.30.jpg (114,0 KB (Kilobytes), 28 visitas)
Tipo de Archivo: jpg 2016-08-09 00.05.50.jpg (129,0 KB (Kilobytes), 24 visitas)
Tipo de Archivo: jpg 2016-08-09 00.06.07.jpg (96,8 KB (Kilobytes), 22 visitas)
Tipo de Archivo: jpg 2016-08-09 00.06.20.jpg (133,7 KB (Kilobytes), 21 visitas)
16/08/2016 #578

Avatar de djstigma

hola bro, veo que vas muy bien
me llamo la atencion eso de las resistencias jaja como que sobran ?? las contaste a ver si no hay demas.
segun mi experiencia lo hice andar sin el pote porque daba lo mismo jaja
despues que lepuse una pre stereo si le puse pote de 100k que tenia a la mano,
pero solo con la señal del pc x ejemplo apenas le daba. proba sin pote primero.
saludos !!
16/08/2016 #579


djstigma dijo: Ver Mensaje
hola bro, veo que vas muy bien
me llamo la atencion eso de las resistencias jaja como que sobran ?? las contaste a ver si no hay demas.
segun mi experiencia lo hice andar sin el pote porque daba lo mismo jaja
despues que lepuse una pre stereo si le puse pote de 100k que tenia a la mano,
pero solo con la señal del pc x ejemplo apenas le daba. proba sin pote primero.
saludos !!
Si, me sobraron resistencias de la lista de la web:

De las 3 de 4,7K, me sobro una.
De las 7 de 47k, me sobro una.
Tambien me sobro la unica de 680k.

Respecto al Pot, recorde que el LM3915 es quien hace el trabajo logaritmicamente. Probare con el de 500k, ya luego vere que tal resulta.

Y bueno, aca otras imagenes:
Imágenes Adjuntas
Tipo de Archivo: jpg 1se.jpg (110,6 KB (Kilobytes), 19 visitas)
Tipo de Archivo: jpg 3se.jpg (84,4 KB (Kilobytes), 17 visitas)
Tipo de Archivo: jpg 5se.jpg (104,2 KB (Kilobytes), 15 visitas)
Tipo de Archivo: jpg 6se.jpg (93,1 KB (Kilobytes), 13 visitas)
26/08/2016 #580


Bueno, lo he terminado, y a la primera prueba, luego de revisar todas las pistas (encontre 3 que hacian contacto donde no debian, X-ACTO y listo, pequeñitas imperfecciones)... Funciona!

Ya colocare imagenes, y vere si puedo hacer un video. Y bueno, no me queda mas que agradecerle a @djstigma y @blanko001 por toda su ayuda (y a los que participaron anteriormente en este tema).
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.