Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

21/10/2013 #1

Avatar de seaarg

Consulta sensor hall lineal UGN3503
Estimados foristas,

Estoy armando algo con un sensor hall lineal 3503 para detectar el paso de corriente por un conductor.

Lo conecto a una fuente de 5v (el usb de la computadora) y un tester en la salida del mismo, para probar que tanto varia con diversos campos magneticos.

Resulta que, su salida en estado quieto sin magnetismo es de unos 2.5v aprox como dice el datasheet pero, al yo acercarme o alejarme del sensor, veo que hay variacion de algunos milivolts en su salida. Este efecto es constante, es decir el voltaje disminuye al acercarme y aumenta al alejarme, siempre y en repetidas pruebas.

El campo magnetico que quiero detectar, que es debil, cuando esta presente, hace que varie 11mV la salida del mismo (si le pongo un iman tengo variaciones de hasta 1volt)

Como pretendo conectarlo a un amplificador de instrumentacion con ganancia x 100, que varie con la presencia de una persona es inaceptable.

¿Es esto normal? no soy de los X-Men asi que, ¿es comun esto? ...
21/10/2013 #2
Moderador general

Avatar de Fogonazo











Puede ser que lo que capte el multímetro sea alguna radiación electromagnética que emplea tu cuerpo como antena.
Agrega un filtro pasa-bajos sobre la salida del sensor y un capacitor cerámico 100nF sobre la alimentación (Muy cerca del Chip)
21/10/2013 #3
Moderador general

Avatar de DOSMETROS

Probaste a blindar el cachivache ?

Supongo que si el circuito que estás midiendo es de baja impedancia , se mete ruido
21/10/2013 #4

Avatar de seaarg

Fogo, si pense en algo similar porque magneto no soy jaja. Puse un 104 en la alimentacion y una R de 10k en la salida del hall con un capacitor 332 a masa. Mismo resultado

Dosme, agarre una tapa de lectora de CD con un cable a masa y meti el sensor ahi adentro, mismo resultado.

Me desconcerto un poco, voy a llevar la protoboard con una bateria lejos de la compu para ver si son radiaciones de la misma afectadas por mi presencia.

Que ironico, estuve meses investigando sensores de presencia capacitivos y cuando busco un sensor magnetico para corriente, me hago sin querer un sensor de presencia jajajaja

Edito: no hay circuito aqui aun por eso no publico, es solo el sensor hall conectado a alimentacion y multimetro.

Edito 2: El mismo efecto lo tengo con otro sensor hall lineal, el A1302
21/10/2013 #5

Avatar de Sebastian1989

Yo he usado unos A1302 para medir la corriente en un conductor y no recuerdo que me haya pasado eso, yo le di 4 vueltas a un núcleo de ferrita con el conductor a medir y luego con una sierra le hice una ranura donde puse el sensor de efecto hall, funciono perfecto.
Imágenes Adjuntas
Tipo de Archivo: jpg IMG_20131021_132230.jpg (43,0 KB (Kilobytes), 35 visitas)
21/10/2013 #6

Avatar de seaarg

Sebastian,

Exacto, lo que sugeris es la forma mas adecuada de medir corriente. Lamentablemente en mi caso no puedo emplearla por lo que tengo que diseñar pensando en que los minimos gauss de campo magnetico alrededor del cable comun, sin enrrollar ni nada, me den esos preciados mV que amplificados con un op instrumental me den algo medible.

Lo que tengo que medir no es cuanta corriente pasa, sino simplemente si pasa corriente. Entonces, en mis experimentos tengo 11mV de diferencia cuando pasan 4A por el cable (con el sensor apoyado en el mismo). Esta bastante bien y es estable en distintas mediciones hechas. Pero por alguna razon la presencia mia cerca del sensor hace una variacion de la misma magnitud que el campo magnetico debil del cable.

Aunque probablemente no pueda usarlo en el diseño final, voy a probar lo del toroide de ferrita por la razon de que, al concentrar el campo magnetico, quiza este prevenga que la presencia de una persona cerca lo afecte
21/10/2013 #7

Avatar de solaris8

seaarg

estas haciendo algo asi??

Imágenes Adjuntas
Tipo de Archivo: jpg Clamp meter.jpg (115,1 KB (Kilobytes), 74 visitas)
21/10/2013 #8
Moderador general

Avatar de Fogonazo

Prueba conectar todo a tierra.
21/10/2013 #9

Avatar de seaarg

Aun no habia hecho circuito, solamente puse el sensor en un protoboard.

Sin embargo, el efecto indeseado dejo de ocurrir cuando hice un circuito de prueba asi:



Donde en V1 pongo un divisor de tension con 2 resistencias iguales para obtener VCC/2 = 2.5v
Y en V2 pongo la salida del sensor hall (que es VCC/2 en condicion libre, sin magnetismo).

El valor de todas las resistencias es 100K y RGain es 1K8. El operacional que uso es el LM324 alimentado a 12V y un 78L05 para el sensor, todo con su capacitor de desacople y en la alimentacion un filtro pasa-bajos con un inductor 220uH + electrolitico 220uF a masa.

Con esto obtuve una perfecta diferencia de 1V al pasar 4A por el cable, sin toroide ni enrollar, simplemente el sensor apoyado sobre el cable.

Ya con circuito, dejo de hacer el efecto de variar la salida cuando me acerco, vaya a saber que era!

Funciono muy bien en un entorno ruidoso como es el auto, en condiciones dificiles ya que esta en protoboard, con variaciones constantes de algunos milivoltios en la salida que dejan de ser importantes porque ya tengo algo muy amplificado (x100) y que, ademas, se solucionaria con un pasabajos seguramente.
22/10/2013 #10
Moderador general

Avatar de Fogonazo

seaarg dijo: Ver Mensaje
Aun no habia hecho circuito, solamente puse el sensor en un protoboard.

Sin embargo, el efecto indeseado dejo de ocurrir cuando hice un circuito de prueba asi: . . . . .
Cosa lógica ya ese es un amplificador diferencial, con característica de alto rechazo a las señales que entran en modo común, ambas entradas +V1 y +V2 al mismo tiempo, tal como sería la captación de interferencias EMI

Seria deseable que emplees resistencias al 1% (O mejor) para R1, R1', R2, R2' R3 y R3'
22/10/2013 #11

Avatar de seaarg

Excelente Fogo,

Estoy usando resistencias metal film (de las celestes) que tengo entendido son 1% es asi? Y estimo que tu sugerencia es para que sean bien igualitas a fin de no tener diferencias en ganancia en los distintos OA.

En el diseño final usare resistencias smd, que tambien creo que son 1% (por favor, corrijanme si le estoy errando)
22/10/2013 #12
Moderador general

Avatar de Fogonazo

seaarg dijo: Ver Mensaje
Excelente Fogo,

Estoy usando resistencias metal film (de las celestes) que tengo entendido son 1% es asi? Y estimo que tu sugerencia es para que sean bien igualitas a fin de no tener diferencias en ganancia en los distintos OA.
Satamente
En el diseño final usare resistencias smd, que tambien creo que son 1% (por favor, corrijanme si le estoy errando)
No todas, hay de varias calidades. Ante la duda se pueden aparear.

Una diferencia de valor da como resultado diferencia de ganancia en una de las ramas, y eso podría permitir que se filtre ruido indebido, amén de que te falsee algo la medición.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.