Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

08/05/2009 #1


Controlar reles con NE555N
Hola muy buenas, estoy realizando un circuito con el 555 (NE555N) que controle 2 reles de 12Vdc, en concreto los reles G2R-2 de Omron. Quiero temporizar como mucho 3 segundos. He montado el circuito como el de la imagen, los reles a la salida, que no aparecen, (cada relé consume 43,6mA) están en paralelo para que actuen los dos a la vez.

He colocado 2 resistencias variables de 220K con un condensador de 10uF (se que no llego a los 3 segundos pero es para hacer una prueba), pero solo puedo controlar la frecuencia con el potenciometro superior, por mucho que muevo el inferior, nada de nada. Encima los reles van a una velocidad muy superior a la esperada. Los tiempos deberían ser de 1,67 segundos a nivel alto y otros tantos a nivel bajo y en realidad los reles conmutan a una velocidad muy superior, pero mucho.
He comprobado las resistencias y el diodo y esta todo ok.

Las resistencias que he usado son las de la figura y el condensador de la red RC es de 10uF (en el ejemplo he puesto el de 1uF para que se pueda ver bien la simulación).

1º- No entiendo por que, en la simulación, a la salida hay 1,2V (una decima parte de la alimentación).

2º- ¿Por que temporiza erroneamente en la realidad?

¿Cual es el fallo?

Un saludo y gracias.
08/05/2009 #2


1º- No entiendo por que, en la simulación, a la salida hay 1,2V (una decima parte de la alimentación).
intentaste colocandole una R de 1kohm entre GND y OUT?

2º- ¿Por que temporiza erroneamente en la realidad?
cuanto es la diferencia entre lo simulado y la realidad?
08/05/2009 #3


Gracias por responder, ¿para que sería poner una resistencia de 1K entre GND y OUT?

En teoria con la resistencia variable puesta al 50%, t on (tiempo de descarga del C) = 0,693 * (R1 + R2) * C = 0,693 * (22k+110K) * 10uF = 0,91 segundos mas o menos, lo que resultaría si hago lo mismo con R4 el mismo tiempo en off, por tanto el rele conmutaría casi como un segundero de un reloj, pero lo hace unas 5 veces más rapido por lo menos.

En la simulación al menos los tiempos son iguales que en la teoria, pero en la practica ya te digo, unas 5 veces más rápido

He probado a colocar un condensador de 470uF y lo mismo que el de 10uF ¿puede que haya estropeado el 555 al soldar?

Un saludo.
08/05/2009 #4


¿para que sería poner una resistencia de 1K entre GND y OUT?
me refiero al circuito de la simulacion. Tambien pudiera ser que tengas la opcion atenuacion habilitada.

He probado a colocar un condensador de 470uF y lo mismo que el de 10uF ¿puede que haya estropeado el 555 al soldar?
hay posibilidades de eso, de preferencia simepre hay que poner una base para el IC. Checalo en un proto.

ademas recheca las conexiones en el circuito soldado.
08/05/2009 #5

Avatar de zaiz

Re: Controlar reles con NE555N
Antonio Jesús dijo:

1º- No entiendo por que, en la simulación, a la salida hay 1,2V (una decima parte de la alimentación).

2º- ¿Por que temporiza erroneamente en la realidad?

¿Cual es el fallo?

Un saludo y gracias.
Qué raro, en livewire funciona bien así como lo tienes desde el primer post.
Aquí lo subo.

(A menos que me esté equivocando en algo)

Revisa bien tus conexiones tanto en el simulador como en la práctica.

Saludos.
Archivos Adjuntos
Tipo de Archivo: zip osc555_1_zaiz_104.zip (5,0 KB (Kilobytes), 43 visitas)
08/05/2009 #6


No lo entiendo, he revisado tropecientas mil veces el esquema y está correcto pero no funciona.
He cambiado el integrado por uno nuevo con zocalo por si lo había dañado con el soldador, pero nada.
No se me ocurre nada de nada para saber que puede estar pasando.
El integrado que estoy usando es el dual, el 556, no creo que sea relevante ya que son 2 555 en la misma pastilla.
Que mala suerte no tener un osciloscopio para saber que está pasando.

Espero vuestras soluciones alternativas, muchas gracias.

Os agradezco el interes.

Saludos
09/05/2009 #7
Moderador general

Avatar de Cacho

Hola Antonio

No se me ocurre otra razón que una falla en las conexiones o componentes (por lo menos con los datos que das del circuito) que explique la diferencia en la frecuencia.

Con respecto al accionamiento del relé... ¿Cómo lo hacés?
El 555 (556 en tu caso) no puede manejar demasiada corriente (alrededor de 150mA) y es probable que el relé le pida más de lo que puede entregar.
Un transistorcito (BC547 por ejemplo) hará maravillas en caso de que no lo hayas usado todavía y quizá la baja en el consumo hasta haga que se estabilice la frecuencia... Estoy adivinando nomás.

Si no tenés manera de medir la frecuencia, poné la más baja que te sea posible (quizá cambiá el condensador de 1uf por uno más grande para lograr que sean fácilmente visibles) y usá un LED y una resistencia de 470Ω para que te de una señal luminosa. Con eso deberías tener unos 20mA de corriente que son manejables por el integrado y mensurables a ojo por vos.

Saludos
09/05/2009 #8


Gracias de nuevo por aportar alguna idea. Voy a hacer lo que dices, pondré un led a ver que pasa. Los reles consumen como dije antes como mucho 50mA (la especificación del fabricante es 43,6mA) cada uno por tanto son 100mA máximo, les he puesto un diodo de libre circulación también.

El caso es que lo probe en una protoboard con un NE555 y funcionaba perfectamente, pero en la placa que he fabricado con el NE556 no. Como digo, he revisado el circuito muchas veces y no encuentro ningun fallo

Lo dicho, voy a probar a poner un Led a ver que pasa, si funciona es una faena, porque tendré que modificar el diseño .

Venga voy a probar y os cuento.

Saludos
09/05/2009 #9
Excluido


si probaste con un 555 y anda y con un 556 (1/2) no anda............el 556 rsta quemado.
fijate que el 556 tiene 2 .configuralo con el otro.

probalo al 556 :
alimentas, todas las patasa al pedo al potencial que coresponda, theresould y la otra a masa (ents. de disparo) a travez de una R .
la salida a un led con R o al tester.
y con un cable le das toques de + a el par de disparo y ves la salida .
09/05/2009 #10


Alucino, he probado en una protoboard con el 556 usando solo un 555 de los 2 que tiene y le he puesto un LED a la salida y funciona , por tanto descarto que esté estropeado. Ahora a la salida le he puesto un BC337 con resistencia de base 2,2K para atacar los dos reles y funcionan perfectamente.

Solo queda probarlo en mi placa para ver que tal funciona, aunque en principio debe de funcionar correctamente.

Muchas gracias cacho por la idea del transistor, ojala funcione en mi placa (debería )

Lo dicho, lo pruebo y os cuento.

Gracias de nuevo a todos.
09/05/2009 #11


Pruebas realizadas con exito, era la salida del 556 que parece que no da para mucho, puesto que los dos reles que juntos no llegan a 100mA no es capaz de governarlos.

Con un BC337 va de lujo

Muchisimas gracias por arrojarme un rayo de luz, la verdad es que nunca pensé que estuviera el problema en las salidas del 556 governando los reles.

Gracias de nuevo y un saludo!
09/05/2009 #12
Moderador general

Avatar de Cacho

De nada Antonio Jesús.
Me alegro de que te haya servido la idea y esté funcionando tu circuito.

Saludos
09/05/2009 #13


Por cierto cacho, para dejar lo más perfecto posible el BC337 he estado mirando su hoja de datos para calcular la resistencia de base, pero vienen varias ganancias en corriente (hFE) y la verdad, nunca he hecho nada con transistores ops: , de lo que recuerdo es que tenía que saber la corriente de colector y con esta, y la hFE, sacar la de la base.

BC337

En la segunda página vienen los valores de hFE (yo me esperaba un solo valor) pero son para distintas condiciones de prueba (Ic=100mA e Ic=300mA), el BC337 que yo he adquirido es del grupo 40.
¿Me podrías decir que valor de hFE debo elegir para realizar los cálculos de la resistencia?
Elegí la de 2,2K porque en la simulación con livewire (por cierto, gracias zaiz, no conocía este programa) funcionaba con ese valor, pero me gustaría saber para este caso y futuros como elegir la hFE y porque.

Sabiendo la hFE, se calcularía:

Ic max = 500mA (creo que va más que sobrado con este valor)

Ib = Ic / hFE

Rb = Vb / Ib

Muchas gracias de nuevo.
09/05/2009 #14
Moderador general

Avatar de Cacho

Hola Antonio

En tu caso, estás buscando ajustar la ganancia para una corriente de 100mA más o menos (es lo que toman los dos relés) y en ese rango de corrientes la ganancia típica de tu transistor está por 400. Eso sale de la primera sección del cuadro de la página 2.

Si te fijás al final de la página 3 del datasheet vas a ver las curvas de Hfe vs. Ic. De ahí entenderás que la ganancia cambia de acuerdo a la corriente que circula por el transistor y como ves, hay tres curvas a distintas temperaturas. Otro factor que hace variar la ganancia. Más caliente el transistor, más ganancia. Más frío, menos. Simple.
Las curvas que ves corresponden a un transistor del grupo -25, pero las formas son similares por lo general en los otros gupos, sólo desplazadas hacia arriba o abajo.

A la hora de calcular los valores entra a jugar el tipo de conexión que hayas hecho. Si posteás un diagrama será más fácil apuntar en la dirección correcta.

Saludos
10/05/2009 #15

Avatar de nietzche

cambia el diodo por un 1n4148 y cierra las terminales de los potenciometros que tienes sin conectar arriba, te sugiero que quites r3, Pero si quieres que solo funcione tres segundos te sugiero el siguiente circuito que te mande:

y segun los calculos: 1.1 x R x C

podrias utilizar una resistencia de 500k ohms y un capacitor de 5.5 micros, o el que mejor se acerque a ese valor para que te den los 3 segundos
Imágenes Adjuntas
Tipo de Archivo: jpg 713px_555_monoestable_407.jpg (26,1 KB (Kilobytes), 32 visitas)
10/05/2009 #16


Gracias nietzche, pero lo que quiero es que vaya conmutando y poder ajustar el tiempo de conmutación, además me hacen falta dos tiempos de conmutación.

Os subo el esquema y un PDF con el esquema para los que no tengais el livewire.

cacho, pensaba que eligiendo una corriente de 500mA tendría de sobra para governar los reles, ¿debo entonces ajustarme a la corriente aproximada que voy a manejar? quisiera poder manejar más corriente por si acaso debo sustituir el rele algún dia y éste necesite más corriente porque sea de otra marca. Según el livewire, los reles consumen cada uno sobre los 120mA,por tanto con 300mA voy bien, así elegiría la hFE de 320.

Aun así, ya para culturilla general , quisiera saber si eligiendo una hFE de 320 podría manejar cargas de menos amperaje, por ejemplo 50mA y si existe algún problema. Viendo la grafica que comentas, pasando de 100mA la curva de hFE varía mucho, ¿debería elegir otro transistor?

Perdona, estoy un poco verde con los transistores ops: .

Muchas gracias por la ayuda.

Saludos
Archivos Adjuntos
Tipo de Archivo: rar 556_170.rar (10,3 KB (Kilobytes), 22 visitas)
10/05/2009 #17


Buenas a todos, me ha llevado un tiempo encontrarlo en el foro, pero al final lo encontré, algo tenía que haber .

Según parece en este mensaje especifican como saturar el transistor para hacer la tarea que quiero realizar en mi placa.

No consigo saturar transistor de potencia

Aqui explican que hay una grafica donde te dice la ganacia en saturación.

Esta gráfica se encuentra en la pagina 3 y 4 de la hoja de datos del BC337 que puse en un mensaje de más arriba. La grafica es "Collector saturation voltage versus collector current" y la otra "Base saturation voltage versus collector current". Son tablas que se complementan mutuamente. Como indica la ganancia correcta a utilizar es 10.
Como los reles consumen 43,6mA cada uno, en total serán 87,2mA, pero para dejar un pequeño margen de seguridad que no se si será correcto este margen, calcularé para una corriente de 120mA, por tanto Ib=12mA y en mi caso Rb=933ohm o sea, con una Rb de 910ohm (valor comercial más proximo) debo de tener suficiente.

¿Que te parece cacho? Si le das el visto bueno, me considero respondido , así creo que queda bastante bien completo el tema.

Muchas gracias y un saludo.
10/05/2009 #18
Moderador general

Avatar de Cacho

Antonio, la ganancia no se elige. Es fija del transistor.

Yendo a los hechos, por el transistor NUNCA van a circular más de 100mA a menos que pase algo malo con los relés, eso es seguro: Según las especificaciones, con 90mA ya caen los 12V en sus bobinados. Tomo 100mA porque es un número lindo para hacer las cuentas y no da un error tan grande. Lo correcto sería usar 87,2mA.

Entonces (y acá está el asunto) con la ganancia de tu transistor (400) sabés que vas a tener una Ib=100mA/400=0,25mA.

Sabés también que el emisor va a estar a 0V constantemente (está conectado a tierra, o en configuración de emisor común) y que hay un voltaje máximo que soporta el transistor entre base y emisor (Vbeo) y tenés una señal de 12V. Vbeo en este caso son 5V (está en el cuadro al principio) y en general se da ese valor.

Con esos datos sabés que en la resistencia de base tienen que caer por lo menos 7V (12V-5V) y como máximo 11,2V (primer gráfico de la página 4, donde para Ic=100mA hace falta un Vbe de 0,8V por lo menos).
Para el primer caso (Vbe=5V), Rb será de 28kΩ.
Para el segundo (Vbe=0,8V), Rb será de 44k8.

Con esos valores Vbe se mantendrá dentro de los valores establecidos mientras permiten una corriente de colector de 100mA o más, con lo que se dará una caída de 12V en los relés.
Si usás una resistencia más grande que la mayor, Ic máx será menor, si es más chica que la menor, Vebo será demasiado grande.
Particularmente el segundo valor limita la corriente máxima de colector a 100mA, al limitar muy ajustadamente la tensión en la base, pero si baja la corriente que circula, la caída de tensión en el juego de relés será menor y la caída de tensión en el transistor irá en aumento. Si se multiplica la caída en el transistor por la corriente, se tiene la potencia que tiene que disipar el transistorcito y debe estar SIEMPRE por debajo de 0,625W (conviene tomar 0,4W para hacer los cálculos).

En condiciones normales es esperable tener 0,7V de caída en el transistor (todo el resto cae en las bobinas de los relés) y en tu caso, 0,1A de corriente (poco menos en realidad). Con eso tenemos una potencia de 0,07W, más que manejable por el BC337.

En caso de querer modificar el circuito y que el 337 maneje más corriente, revisá los valores de ganancia que te de para esa corriente y el cálculo de Rb.

Creo que no me equivoqué, pero si encontrás errores, me avisás (o si los encuentra cualquier otro, claro).

Saludos
11/05/2009 #19


Muy buenas, tienes razon la ganancia es algo fijo del transistor, pero según las simulaciones todo parece indicar que lo que he supuesto es correcto, si pongo un valor de Rb de 9,5K en adelante (Vb=12V=tension de salida del 556) se funde el transistor por exceso de potencia.

Según la simulación para unos reles que consumen 235mA una Rb=500, Potencia en el transistor = 42,58mW con una Vce=101mV(0,1V) y Vbe=850mV(0,85V)
Conforme aumento la resistencia de base, aumenta la Vce, y disminuye la Vbe, la potencia va en aumento cuanto más grande es la Rb.

Prueba a simularlo veras que es cierto lo que te comento. Tomando una ganancia de 10 como dice el primer gráfico de la página 4, para que el transistor entre en saturación la simulación funciona correctamente y es cuando menos consume el transistor.

Quizas para trabajar en saturación se deben tomar los datos de las gráficas que hemos comentado, pero para trabajar en amplificación es necesario hechar mano de la hFE.

Para mi los transistores han sido siempre mi punto debil y mira que parecen faciles, en fin, quizas no le dedique suficiente tiempo.

Un saludo!
11/05/2009 #20
Moderador general

Avatar de Cacho

Hay un detallecito que no tuviste en cuenta en tu planteo.

¿Qué ganancia tiene el transistor de la simulación? Si ponés medidores de corriente de base y de colector te darás cuenta de que está alrededor de 160, mientras que el tuyo tiene 400.
Con eso cambia la corriente de base.

Usá una resistencia de 120Ω/2W como carga para estar seguro de que estás simulando 100mA de corriente en el colector y teniendo en cuenta la disparidad de ganancias (pongamos 2,5 a 1), te darás cuenta de que la Ib del modelo será 2,5 veces la de tu transistor, por lo tanto Rb deberá ser 2,5 veces menor en el modelo para obtener los mismos resultados.
Con eso, Rb deberá variar entre (redondeando) 11 y 18kΩ, manteniendo las corrientes de base en valores bajos.
Si lo querés hacer para simular los 87,2mA de los relés reales, a hacer la cuenta y poner una resistencia equivalente.

Si querés usar los 240mA de los dos relés, simplemente rehacé los cálculos, pero tené en cuenta una ganancia de 160 en el transistor de la simulación.

Fijate también en los gráficos del datasheet cuyo nombre empieza con "Common Emmiter" (esa es la configuración que estás usando) para ver qué parámetros tenés que lograr. No te olvides de que esos están basados en los transistores del grupo central, así que para uno de los de tu grupo tendrás que corregir los valores de las corrientes un poco.

Saludos
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.