Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

26/04/2009 #1


Detector de cruces por cero
hola amigos teng dudas con el calculo algunas resistencias en el detector de cruces por cero del archivo adjunto. necesito que optoacoplador 4n25 funcione en corte y saturacion. Hay cosas que desconozco del datasheet del opto pero yo hice los calculos de la siguiente manera

Icsat: (10 - 0,5)/ R2

En el datasheet te dan estos datos en test condition de voltaje colector emisor de saturacion(max:0,5v)
( Ic: 2mA , If: 50mA)

Ahora calculo R2: (9,5 / 2mA) : 4750 Ohm

una duda que tengo es que ahora para calcular R1 tomo el valor de if: 50mA? ahora aqui tomo el valor de voltaje de entrada en directa que es 1.2V que lo da el datasheet

If: (12(1.4)V - 1.4V -1.2V)/ R1

R1: (12(1.4)V - 1.4V -1.2V) / 50ma: 14.37V / 50ma : 287,41 ohm

tengo esa duda por favor pueden cerciorarme en ese dato o si estoy cometiendo un error tomando ese valor de If para el calculo de R1
26/04/2009 #2


hola randymaiden,
para utilizar el optoacoplador lo unico que necesitas es un resistencia que proteja al emisor y otra para que el pulso varie rapidamente de 0 a vcc y viceversa, esta ultima resistencia va en otro transistor aparte que aproximadamente es de 10k.
debes tener cuidado con la potencia de la resisitencia del proteje al diodo emsior, no necesitas resistencia de base del siguiente transistor pues la corriente de transferencia es del 20% y solo llegarian 2ma a este
ahi anexo el diagrama.....disculpara el dibujo

bueno asi me lo explico mi profesor..........y sirvio bien
26/04/2009 #3


oye pero para que colocas el otro transistor y en mi caso no trabajo con la linea de 120 v sino con 12 vac con f:60hz y el esquema que mande yo lo use con la linea de 110 y con R1: 16K y R2: 10k y funciono perfectamete, sin el transistor que tu le colocaste. Entonces el diodo emisor del opto solo aguanta hasta 10 ma como maximo?, pq asi si variaria los calculos y R1 da en el orden de los 1,4k que opinas de eso
trash metal jajaj
01/05/2009 #4


Que pena la demora, como la corriente de transferencia es solo un 20%, en mi caso no asegura que varie el pulso de 0 a 5 y al contrario, por eso le pongo otro transistor para que amplifique la corriente y asi varie rapidamente, y acerca de la max corriente debes mirar la hoja de datos del componente que estas utilizando
03/05/2009 #5


gracias hermano la practica salio bien esos calculos que realice era correctos y muy interesante lo del transistor
07/06/2012 #6


Hola amigos, he estado revisando varios temas de este foro y llegue a este. Estoy haciendo un sistema de control de luces por computadora y PIC via puerto USB. Hasta ahora puedo enviar y recibir señales del PIC y desde el mismo respectivamente. Mi problema es que yo quiero controlar las luces desde dos puntos, la computadora y el apagador ubicado en la pared de cada habitacion. En la aplicacion que realice estoy monitoreando cuales luces estan encendidas y cuales no. El punto es que he andado buscando un circuito que me detecte si la luz o lampara se encuentra encendida o no y llegue a este que muestran arriba. Lo arme y si me envia señal al PIC y me lo muestra en pantalla, pero de El problema es que despues de unos momentos el puerto USB deja de funcionar y el LED del PIC que me avisa si esta listo o no(bicolor) me empieza a parpadear en rojo dandome a entender que hay un error con el dispositivo USB.
He intentado de todo y no puedo hacerlo funcionar. Agradeceria su ayuda y cualquier cosa que me falte aclarar con gusto lo pongo.
Gracias
08/06/2012 #7
Moderador general

Avatar de Fogonazo

grcarlos dijo: Ver Mensaje
Hola amigos, he estado revisando varios temas de este foro y llegue a este. Estoy haciendo un sistema de control de luces por computadora y PIC via puerto USB. Hasta ahora puedo enviar y recibir señales del PIC y desde el mismo respectivamente. Mi problema es que yo quiero controlar las luces desde dos puntos, la computadora y el apagador ubicado en la pared de cada habitacion. En la aplicacion que realice estoy monitoreando cuales luces estan encendidas y cuales no. El punto es que he andado buscando un circuito que me detecte si la luz o lampara se encuentra encendida o no y llegue a este que muestran arriba. Lo arme y si me envia señal al PIC y me lo muestra en pantalla, pero de El problema es que despues de unos momentos el puerto USB deja de funcionar y el LED del PIC que me avisa si esta listo o no(bicolor) me empieza a parpadear en rojo dandome a entender que hay un error con el dispositivo USB.
He intentado de todo y no puedo hacerlo funcionar. Agradeceria su ayuda y cualquier cosa que me falte aclarar con gusto lo pongo.
Gracias
Podrías, por ejemplo, publicar el esquema de lo que hiciste
08/06/2012 #8

Avatar de Gudino Roberto duberlin

Amigo grcarlos, en tu caso no necesitas un detector de cruce por cero para identificar la accion de una carga, puedes hacerlo con, ya sea un transformador de corriente, o la clasica resistencia shunt, como detectora.
08/06/2012 #9


Buenas tardes.
Fogonazo: Aqui subo un diagrama de lo que quiero realizar. En este caso ya tengo las conexiones para encender o apagar el foco desde dos partes, lo que me falta es el circuito de detección para el foco. Espero quede mas claro como lo pongo.
Gudino Roberto duberlin: Ya habia leido de hacerlo con una resistencia shunt. De usar transformador de corriente no había leído absolutamente nada. Tengo algo de conocimientos en electrónica pero no los suficientes todavía; te agradecería muchísimo si me pondrías algo así como un esquema para realizarlo y comprobar su funcionamiento.

Imágenes Adjuntas
Tipo de Archivo: jpg Esquema luces.jpg (59,9 KB (Kilobytes), 147 visitas)
Archivos Adjuntos
Tipo de Archivo: doc Esquema.doc (87,5 KB (Kilobytes), 38 visitas)
08/06/2012 #10

Avatar de Gudino Roberto duberlin

Bueno, pues bien si tienes informacion de hacer tu detector de corriente con una resistencia shunt, adelante!, solo debes cuidar que mediante este metodo NO tienes aislacion electrica, es decir cualquier parte del circuito tendra potencial de RED!.-
11/06/2012 #11


Buenas tardes de nuevo,
Aqui donde vivo es complicado conseguir una resistencia Shunt y lo del transformador de corriente no he logrado hacerlo. Despues de buscar en el foro mas veces, decidi adecuar el detector de lamparas fundidas que encontre en otro tema. La imagen de la simulacion en Proteus la adjunto para que vean el arreglo que hice en la salida del opto.

Mi problema es que en protoboard me da perfectamente la caida de voltaje que necesito, pero cuando lo hago en placa el voltaje que me da el PIC lo toma como un 1 logico y entonces el puerto siempre esta recibiendo una senial de encendido.
Ojala me puedan ayudar
Imágenes Adjuntas
Tipo de Archivo: jpg detector lampara.jpg (163,7 KB (Kilobytes), 137 visitas)
11/06/2012 #12

Avatar de Gudino Roberto duberlin

Hola Amigo, bien que valor de tension tienes en la resistencia de salida en un estado y otro, es decir, cuando la lamp. esta encendida y cuando no.
11/06/2012 #13


Gudino Roberto duberlin dijo: Ver Mensaje
Hola Amigo, bien que valor de tension tienes en la resistencia de salida en un estado y otro, es decir, cuando la lamp. esta encendida y cuando no.
No entendi tu indicacion. Me la podrias volver a explicar si se puede un poco mas claro?
Te agradezco la rapidez que tuviste para contestar
11/06/2012 #14

Avatar de Gudino Roberto duberlin

Disculpa amigo, la torpeza, me referia al valor de tension que obtienes en R3 tanto como cuando la lamp. se encuentra encendida a cuando no.
11/06/2012 #15


Gudino Roberto duberlin dijo: Ver Mensaje
Disculpa amigo, la torpeza, me referia al valor de tension que obtienes en R3 tanto como cuando la lamp. se encuentra encendida a cuando no.
Gracias por contestar Amigo Gudino.

Mientras esperaba a que me respondieras, diseñe nuevamente la placa en base a otra simulación en proteus y magicamente funciono Le puse componentes nuevos a la placa nueva y no tuve problemas para que me funcionara. Me pregunto que habrá sido, yo creo que el transistor porque los diodos los cheque con el multimetro uno por uno y todos servían.
Se me ocurre que haya sucedido algo porque en la placa pasada estañe todas las pistas y en esta no, pero es ilógico hasta mi punto de vista.

De cualquier manera muchas gracias por la ayuda. Cuando termine el proyecto lo subire completo.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.