Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

23/01/2008 #1


Duda en relación a la tensión en un comparador
Hola, tengo una duda acerca del circuito que adjunto. El circuito consiste en dos cadenas de medida que con el ventilador apagado funcionan correctamente, la sensibilidad del sensor de Tª es de 10mV/ºC, y el sensor de humedad va de 1V (10% humedad relativa) a 10V (100%RH). Cuando la tensión entregada por la cadena de medida del sensor RH es superior a la de la Tª, el ventilador se enciende, y cuando esto sucede, la tensión que hay a la entrada no inversora del comparador aumenta 3V de golpe, distorsionando la medida. Cuando se apaga (forzando una ganancia superior a la tensión entregada por el sensor de Tª), la tensión en la entrada no inversora vuelve a ser la normal (1-10V). No llego a entender la relación que puede haber entre la tensión que haya en el colector del transistor que controla el ventilador y la entrada + del comparador.

A ver si alguien puede ayudarme, que ando un poco perdido ya...
Muchas gracias de antemano.
23/01/2008 #2

Avatar de Saint_

hola tibali, no veo nigun problema en el esquema que nuestras...
en cuanto a que si existe una relacion entre la salida del comparador i la entrada no inversora de este , te comento qe no, no deveria afectar en nada.

te sugiero que revises tu cableado y que verifiques el buen estado de tu comparador.
23/01/2008 #3


Ante todo, gracias por responder.

La cosa es que está verificado el correcto funcionamiento, tanto cableado como cada componente, incluido el comparador, funcionan correctamente sin el ventilador. Incluso funcionan correctamente con el ventilador, siempre que esté apagado. He pensado en poner un seguidor a la salida del comparador, pero es que me rompe los esquemas que no funcione tal y como está ahora, y me parece curioso (por no decir desesperante) que tenga ese disparo de 3V cuando todo parece funcionar bien. Alguna sugerencia?

un saludo y gracias
23/01/2008 #4


Cordial Saludo.

Ante todo, sugiero a la gente que no conteste por contestar, si no pueden aportar nada util, pues una respuesta algo así como "revisa tu cableado" siempre sobra.

Tibali, no se que integrado usas como comparador, pero yo uso un lm339, y este debe tener una Resistencia de pull-up a la salida para que funcione.
Estoy casi seguro que el problema no es el ventilador, a mi me ha pasado algo similar, así que te sugiero muy puntualmente que pruebes poniendo una Resistencia de valor grande (1-10 Meg) en paralelo a la entrada del comparador, prueba y me comentas si te funcionó el truco.
23/01/2008 #5

Avatar de Saint_

Nene, yo no soy un gasnapiro que solo contesta por contestrar.
muchas veces cuando el diceño esta bien "en papel" solo falla el armado, un mal cableado o el proto que esta usado y no tiene buenos contactos.

Por si no has visto el amigo esta utilizando un amplificador operacional "que acaso no vez que el circuito tiene Vcc y Vee que especifica que es de +12v y -12v".

y aunque no fuera asi y utilizaria un comparador que hobiamente es de colector abieto no deberia presentar el problema que se susita. "la salida de un comparador y la de un amplificador operacional esta totalmente separada la entrada de la salida mediante espejos de corriente" por tanto lo que ocurre a la salida del comparador no deveria influenciar en las entradas a menos que este se encuentre dañado".

Las entradas tanto inversoras como no inversoras estan acopladas mediante seguidores y como se sabe estas entregan niveles de voltaje.

"por si acaso sabes por que le pusiste esos resistores que te dieron buen resultado, en que situaciones es nesesario y en cuales no...y porque no mejor un resistor de 1k o 100 ohm o tambien te lo reconmedaron alguna vez".

ahora mi sujetenciaa.

Separar totalmente el betilador del circuito de control.

en el transistor de salida en vea de el bentilador ponle un ralay para qie este active al bentilador con una fuente alimeta al circuto y con otra al bentilador toma en cuenta qie esta fuente no debes estar unidas para nada "si siquiera por tierra".

tabien fijate que tu fuente entreque la corriente necesaria.

un saludo y comenten los resultados....
23/01/2008 #6


Amigo Tibali, no pierdas el tiempo agregando cosas del tipo bla bla bla que solo te van a complicar, solo agrega un par de resistencias en paralelo a las entradas del comparador y veras q se soluciona el problema.
Amigo Saint, hay infinidad de integrados que usan fuente dual, no solo opamp de proposito general, basta ya de llenar los foros con información q nadie necesita
23/01/2008 #7


Haya paz...

Gracias a los dos por el interés, adjunto el circuito un poco más elaborado y completo, añadiendo un seguidor a la salida del comparador, que será la primera prueba que haré mañana, y si no da resultado, probaré con las resistencias en paralelo a ambas entradas. Decir que no es problema de proto ya que el circuito está soldado por módulos y no hay posible cortocircuito, ya que están testeados individualmente y funcionan bien. Añadir también para el que le interese, sin tener en cuenta la parte del comparador y el ventilador, se trata de una cadena de medida de un sensor capacitivo para la medida de la humedad relativa (el 2322 691 90001/HUMIDITY-SENSE-E) con una sensibilidad de 1%HR/100mV, es decir, va de 1V a 10V para 10%-100%RH respectivamente.

Gracias, un saludo
Imágenes Adjuntas
Tipo de Archivo: jpg circuitoambientador_157.jpg (75,1 KB (Kilobytes), 27 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.