Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

20/10/2014 #1


Error raro en Operacional 741
Buenas tardes a todos! Les comento! Resulta que tengo un sensor de corriente ACS712 que a su salida tira una continua de 2.5V, en ella montada una alterna proporcional a la corriente medida. Si estoy midiendo 1A eficaz, tira a la salida una continua de 2.5 y en ella una alterna de 185 mV eficaz. Ese es mi tope ya que voy a medir entre 0 y 1 amper, el tema es que 185 mV para el micro es muy chico por ende con un 741 quiero amplificar a 5V (picos) para que el adc pueda realizar bien la medicion. Como lo primero que quiero hacer es sacar esa continua de 2.5V le pongo un capacitor de 1 uF ceramico a la entrada...asi solo tendria la alterna de 185 mV en la entrada del operacional. El tema es que todo funciona bien solo cuando mido con el osciloscopio la entrada , luego de que ya paso por el capacitor. Si yo mido en otro lado o no mido la entrada a la salida la señal empieza a disminuir en tension hasta irse a valores negativos. Nada de esto ocurre si yo vuelvo a poner la punta de medicion en la entrada del circuito. La configuracion del operacional es no inversora y probe con varias configuraciones de resistencias y es lo mismo. Que esta pasando? Yo hice las cuentas y con el cap de 1uF tengo una impedancia de 3K1 lo cual es baja respecto a los 2 MegaOhms del operacional, no deberia afectar a la alterna y frenar totalmente a la continua. Si yo no desacoplo la continua, en la entrada del ao tengo 2.7 V...satura y no muestra nada...me queda probar con algunos microfaradios mas el tema es que mucha mas capacidad no hay en ceramico , en poliester creo que llegas a 3 uF....que me dicen? Es loco porque midiendo anda todo, dejo de medir y chau jajaja

Edito: Para descartar errores, puse un buffer con otro 741 antes , osea seria sensor --> buffer -> operacional amplificador y el resultado es el mismo...

Saludos!!
20/10/2014 #2

Avatar de aguevara

Pon el esquema y te entiendo mejor
20/10/2014 #3


Ahi subo el esquema. De esa manera funciona todo correctamente. Si yo saco la punta de medicion de la entrada se pudre todo jaja

20/10/2014 #4

Avatar de Dr. Zoidberg

Poné una resistencia entre la entrada no-inversora del AO y masa, por que si nó, la tensión de entrada no tiene ninguna referencia. Usá tipo 100K o por ahí... no sé cual es la frecuencia de la señal de entrada para calcular mejor el filtro...
20/10/2014 #5


La frecuencia es de 50 hz. La resistencia la pondria antes o despues del capacitor? Saludos!

---------- Actualizado después de 15 minutos ----------

Master, ya esta! Le puse una de 100K. Cual seria la correcta para 50 hz? Con 100K andubo perfecto. Ya no se va la señal al desconectar el canal del osciloscopio !!! Muchas Gracias

Edito: Siempre para amplificar hay que poner una resistencia de esta manera ? El sensor esta conectado a la misma masa del operacional (el cual esta conectado a una fuente simetrica)
Cual seria el calculo que hay que realizar segun la frecuencia?

Muchas gracias!
20/10/2014 #6
Moderador general

Avatar de Fogonazo

adri_ariel_05 dijo: Ver Mensaje
. . . . Master, ya esta! Le puse una de 100K. Cual seria la correcta para 50 hz? Con 100K andubo perfecto. Ya no se va la señal al desconectar el canal del osciloscopio !!! Muchas Gracias
100KΩ está bien
Edito: Siempre para amplificar hay que poner una resistencia de esta manera ?
No es para amplificar, es para hacer una "Referencia de tierra" para el operacional.
El sensor esta conectado a la misma masa del operacional (el cual esta conectado a una fuente simetrica)
Cual seria el calculo que hay que realizar segun la frecuencia?

Muchas gracias!
Se calcula el capacitor como para que no presente una resistencia significativa, a la frecuencia de trabajo.
Para esto se debe conocer el valor de la resistencia de polarización (100KΩ) y la impedancia de entrada del operacional.
Estos 3 elementos forman un divisor resistivo que debe degradar la señal lo menos posible.
20/10/2014 #7


Dicha referencia de tierra se debe colocar en todas las configuraciones en las que se puede utlizar el AO?
La resistencia de entrada del 741 es aproximadamente de 2 MOhms. La tension que cae en la resistencia de 100K es la misma que la que cae en el AO, lo que difiere es la corriente que circulara por la resistencia de 100k (la corriente en el ao seria cero..asi tengo entendido que funciona). La impedancia del capacitor se calcula (al ser un regimen senoidal) por fasores, 1/2Pi x F x C. Para 1uF , segun nuestra frecuencia, 50 hz me da 3K1. correcto? Lo que no me quedo claro es porque 100K y no otro valor , hay algun parametro a tener en cuenta? Gracias!!!
20/10/2014 #8

Avatar de aguevara

ok me ganaron la respuesta, pero celebro que hayas resuelto tu problema saludos
20/10/2014 #9

Avatar de Dr. Zoidberg

Esa configuración C[serie]R[a masa] es un filtro pasa-altos que con R=100K y C=1uF corta por debajo de 1.59Hz. Es decir, te va a dejar pasar cualquier frecuencia "superior" a 1.6Hz y te va a bloquear la DC que tengas a la entrada.
21/10/2014 #10


100 k ? Porque es el valor que se nos ocurre para empezar a probar, o vos creés que todo es cálculo en la vida. Generañmente se empieza probando. Y si anda bien, bueno, te dicen que está bien y luego el Dr. te aclara porqué, pero de entrada usamos una R que la experiencia nos dice por donde empezamos. Bueno así trabajo yo y la mayoría de los aficionados a la electrónica. Claro que ahora todo loo quieren simulado y que ande de entrada. ¿Viste que simpñle fué la solución? Y no te olvides: no podés dejar en el aire una entrada de operacional.
22/10/2014 #11

Avatar de miguelus

Buenas tardes.

La Resistencia que hay que poner entre la entrada + (Pin3) y masa sería el valor equivalente al paralelo de R1 y R2... 270KΩ//10KΩ = ~9.K64, con una Resitencia de 10KΩ tiene que funcionar correctamente.

Sal U2
22/10/2014 #12

Avatar de Dr. Zoidberg

miguelus dijo: Ver Mensaje
La Resistencia que hay que poner entre la entrada + (Pin3) y masa sería el valor equivalente al paralelo de R1 y R2... 270KΩ//10KΩ = ~9.K64, con una Resitencia de 10KΩ tiene que funcionar correctamente.

Eso es para minimizar el offset a la salida pero eso no es problema... por ahora.
Si ponés 10K la frecuencia de corte del FPA es de 16Hz y ya se te altera la amplitud de la señal de 50Hz.
Fijate esta simulación, la verde con 10K y la roja con 100K:

Imágenes Adjuntas
Tipo de Archivo: gif filtroPA.gif (16,3 KB (Kilobytes), 81 visitas)
23/10/2014 #13


Muchas gracias por la aclaracion de como funcionaba el filtro!!!! Ahora me tope con otro problema. A la salida de mi sensor de corriente, para 1Amper tenemos 185 mV eficaz, cuyo valor pico es de 261 mV. Si esto lo queremos multiplicar hasta llegar a los 5V, necesitamos una X ganancia...no viene al caso. Luego sacamos la componente negativa con un diodo de germanio para que no se robe tanta tension. Compenzamos esos 0.3V con ganancia en el AO. Eso entra al ADC de un PIC. Lo que me salto la ficha es que si por alguna razon, circula mas de 1amper por el sensor, el mismo va a tirar una señal mas grande, con un pico mucho mayor, el AO amplificara mucho mas, y en el pin del PIC tendre mucho mas de 5V....alimento el AO actualmente con 12+12 , es decir que corro el riesgo de volar el PIC. Entonces se me ocurrio bajar la tension de alimentacion del AO para que sature a los 5V de salida, o si se pasa se pase por poco, como maximo el PIC admite 5.5V. Simulando en Proteus, me dio que con una alimentacion de 6.3 Volts +/- logro amplificar hasta 5V y que luego recorte. Por ende apenas tenga los materiales voy a realizar un rectificador con regulacion de la tension de salida y voy probando con el osciloscopio hasta que recorte en 5V. Se les ocurre otra solucion? ...el diodo lo pongo para meter señales positivas en el ADC aclaro...Saludos!
23/10/2014 #14

Avatar de Dr. Zoidberg

Que tal si ponés algún esquema??
Y lo de bajar la tensión de alimentación no sirve por que no es confiable ni constnate entre modelos del mismo AO. Hay que usar diodos protectores y resistencias limitadoras, y eso no tiene nada que ver con la ganancia del AO...
24/10/2014 #15


El esquema es el mismo que puse arriba. Yo lo que necesito es hacer un limitador de tension. Que tope el AO tire 5 V Pico a la salida

---------- Actualizado después de 12 minutos ----------

Aca les dejo el circuito:



Podria limitar la tension de salida con un zener? de 5.1V , total el micro hasta 5.5V aguanta.
24/10/2014 #16

Avatar de chclau

Si, con un Zener te tiene que funcionar
24/10/2014 #17


Me quedan dudas con el tema de la resistencia limitadora.

Ya que a traves de ella circularia la señal a medir en el ADC. La corriente es minima, el micro casi no consume nada. va de 0 a 5V picos. (Es una media onda, con el micro hago un muestreo y busco el valor mayor). Seria resistencia en serie y zener de 5.1 V en paralelo, asi mas que eso no puedo tener...pero que valor de resistencia pongo?

---------- Actualizado después de 42 minutos ----------

Bueno agrego actualizaciones....

Hice las cuentas para la resistencia, Calcule una R de 690 ohms, teniendo en cuenta, voltaje maximo a la salida 12V (que es mi fuente de alimentacion), y el zener de 5.1V . Corriente maxima de la carga 10 mA. La realidad es que desconozco lo que traga el micro pero seguro debe ser mucho menor que eso. La potencia de la resistencia, 1/2W para estar cubierto. La potencia del zener 1/4W. Simule en proteus y todo parece andar bien. Voy a comprar los materiales y ver en la realidad en el osciloscopio a ver que pasa.

Este seria el circuito final:



Entra la señal del sensor, para el caso de 1Amper, que es lo maximo que voy a medir en condiciones normales. Eso seria una continua de 2.5V y en ella montada una alterna de 185mV eficazes y de pico 261 mV. Con el capacitor y la resistencia matamos la continua. Nos queda solo la alterna. Pasamos por una etapa buffer para no romperle las bolas al sensor, luego pasamos al amplificador, con el preset nos permite ajustar la ganancia. Pasamos por el diodo de germanio para matar la componente negativa de la señal, ahi dice 1n4007 pero en realidad ponemos uno de germanio. Luego pasamos por la resistencia limitadora calculada para un maximo de 10 mA (guazada) y luego por el zener de 5.1 que si elevo la tension empieza a trabajar y me corta la señal para no joder al micro. La caida de tension en la resistencia del zener la compenzo con mas ganancia en el AO, para eso tengo dos pines de "calibracion" donde yo meto una carga de 1Amper y a la salida tengo que tener 5V pico en la media onda que me muestra el osciloscopio. En proteus todo anda de maravillas. Esperemos que asi sea en la practica.
24/10/2014 #18

Avatar de chclau

No se necesita resistencia limitadora poque el opamp no puede entregar mucha corriente a su salida
24/10/2014 #19


Es verdad, pero creo que la corriente de un op es mayor a la del zener, no le hace mal tener una resistencia ya que la entrada al pic es de alta impedancia, lo que no me cierra es que el catodo del diodo entra directamente sin resistencia de drenaje, puede que no se necesite, pero me ha pasado he incluso en la época que se usaban diodos como llaves, se les colocaba una resistencia a masa para que circule una minima corriente por el diodo, ojo, puede funcionar de una y no necesitar mas nada, pero aclaro por las dudas, por si la resistencia de entrada al pic es muy alta.
24/10/2014 #20


Yo calcule la resistencia como para un consumo de 10 mA cosa asquerosamente zarpada, ya que nunca puede consumir eso el ADC...que segun datasheet tiene una impedancia de entrada de 10 K...a 5V..da una corriente de 0.0006 A...osea micro Amperes. Una resistencia hay que poner igual...
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.