Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/02/2015 #1


Excitar relee con comparador de voltaje LM311
Hola,
Resulta que estoy armando un comparador de voltaje simple utilizando el LM311. Lo estoy alimentando con 5 Vcc regulados por un 7805 y le aplico los voltajes a comparar mediante divisores resistivos. El circuito funciona ya que la salida del LM311 se pone a tierra cuando un voltaje es mayor que el otro (salida colector abierto según veo en el datasheet).
El problema que tengo cuando intento activar un relee. Lo primero que probe fue con un transistor PNP (BC327) (adjunto esquema). Desconectando el relee, tengo 9 Vcc cuando se activa el comparador. Sin embargo, cuando conecto el relee la tensión cae a 1 Vcc y el relee no se mueve.
Pensando que quizás la corriente sobre la base del transistor no era la suficiente como para saturarlo, utilice un opto acoplador a la salida del comparador (adjunto esquema). Obtuve los mismos resultados que en el primer caso.
Cabe destacar que probé tanto con relee de 12 V y 6 V y no logre que ninguno se moviera.
Revisando en el foro veo que en la mayoría de los casos terminan usando un transistor y funciona. ¿Estoy haciendo algo mal?

EDITO: En la segunda imagen hay un error en la polaridad del opto acoplador. En la realidad lo conecte correctamente.

Muchas gracias por sus repuestas
Saludos
25/02/2015 #2

Avatar de pandacba

En el primer caso deberias colocar una R entre la salida y la base y el relay del otro lado es decir entre el colector y masa

En el segundo caso esta mal conectado el opto el anodo debe ir al positivo via un resistencia de 330Ω el cátodo a masa y del colector del TR del opto una R hacia los 9V de unos 150Ω
25/02/2015 #3


pandacba dijo: Ver Mensaje
En el primer caso deberias colocar una R entre la salida y la base y el relay del otro lado es decir entre el colector y masa

En el segundo caso esta mal conectado el opto el anodo debe ir al positivo via un resistencia de 330Ω el cátodo a masa y del colector del TR del opto una R hacia los 9V de unos 150Ω
Muchas gracias por la respuesta.
En el primer caso, en un primer momento había utilizando una resistencia de 2.2K, pero sin resultados. Voy a probar cambiar el rele de lugar
En el segundo caso, mil disculpas, es un error del gráfico. En la realidad esta conectado bien como vos decis. La resistencia la obvie por que por lo visto es muy poca la corriente que hace circular el LM311 (probe con un LED común sin resistencia y se encendió 3/4, algo de unos 15mA que para el opto esta mas que bien). No entendí la función de la resistencia de 150, te agradecería si pudieras explicarme.

EDITO: ¿En el segundo caso también el relee del otro lado?

Desde ya muchas gracias
25/02/2015 #4

Avatar de pandacba

Si, colocalo del lado del colector, proba y comenta que tal te fue
25/02/2015 #5

Avatar de Daniel Meza

Si el relé es de esos pequeños puedes incluso olvidarte del transistor de salida y conectar directamente la bobina a la salida del comparador (no olvidando su diodo en antiparalelo)



Salu2
25/02/2015 #6


Daniel Meza dijo: Ver Mensaje
Si el relé es de esos pequeños puedes incluso olvidarte del transistor de salida y conectar directamente la bobina a la salida del comparador (no olvidando su diodo en antiparalelo)

http://www.electro-tech-online.com/i...lm311relay.gif

Salu2
Ojala pudiera hacerlo tan sencillo... El estado alto del comparador me da 3.3V. Probe con el relee de 5 V que es el mas chico que se consigue y ni se movió.
Voy a probar lo que planteó pandacba y les comento.
Saludos!
25/02/2015 #7

Avatar de Daniel Meza

Pero en realidad lo que se busca es el "estado bajo", el comparador funcionará como drenaje de corriente no fuente. Es decir un extremo de la bobina se conecta a V+ y el otro extremo a la salida del comparador
25/02/2015 #8


pandacba dijo: Ver Mensaje
Si, colocalo del lado del colector, proba y comenta que tal te fue
Hola, probé el circuito de la primera imagen con el relee del lado del colector (emisor a 9 Vcc) y nada. El voltaje cae a 500 mV y el relee no se dispara.

¿Alguna otra idea?

Saludos
25/02/2015 #9

Avatar de Daniel Meza

haz la prueba sin el transistor como te comento
25/02/2015 #10


Daniel Meza dijo: Ver Mensaje
haz la prueba sin el transistor como te comento
Sisi, ya la realice con un rele de 5 V de los pequeños, conectado directamente a la salida del LM311. Como te comentaba en el otro post, el comparador en alto tira 3.3 V y no llega a disparar el relee.

EDITO: En alto me refiero a que midiendo entre la +5 Vcc y el pin 7 tengo 3.3 V. Entiendo que funciona como un drenaje de corriente.

Saludos!
25/02/2015 #11

Avatar de fdesergio

Ese primer circuito NUNCA te funcionara, olvidaste lo esencial para que un Tr trabaje 0.7VBE, debes con una resistencia atacas el TR PNP este a su vez tiene el voltaje de la fuente en el emisor y por el colector alimenta el rele que a su vez tiene por el otro lado la GND, hacelo asi, chaooooo
25/02/2015 #12


No logro ver que es lo que estas haciendo mal, pero algo esta mal seguro.

Primero, como bien te dijeron, el relay va de colector a masa, y hace los siguiente, ponele una resistencia de 47k a + en la base, y desconecta el comprador por un momento, tendrías la r de 47k desde base a +, el emisor a + y el colector a una punta del la bobina del relay y la otra punta a masa, en ese estado el relay esta desactivado, pone la base a mas y debería activar el relé, si esto no te anda algo esta quemado en tus componentes.
25/02/2015 #13

Avatar de Daniel Meza

sergiot dijo: Ver Mensaje
No logro ver que es lo que estas haciendo mal, pero algo esta mal seguro.

Primero, como bien te dijeron, el relay va de colector a masa, y hace los siguiente, ponele una resistencia de 47k a + en la base, y desconecta el comprador por un momento, tendrías la r de 47k desde base a +, el emisor a + y el colector a una punta del la bobina del relay y la otra punta a masa, en ese estado el relay esta desactivado, pone la base a mas y debería activar el relé, si esto no te anda algo esta quemado en tus componentes.
La otra terminal a V+
04/03/2015 #14


Hola,
Recién hoy pude ponerme de nuevo con el asunto. El comparador de voltaje es parte de un circuito limitador de corriente. Es decir, una de las entradas del comparador va a un voltaje de referencia variable, la otra entrada a la tensión que cae en un shunt de 0,1 Ω (100mV por cada 1 A) en serie con la carga, y la salida del comparador activa un relee que desconecta la carga en caso de que la corriente supere el limite establecido.
Hasta ahora todo bien. El tema es que como carga de prueba estaba utilizando un motor de 12 V. Termine por darme cuenta de que el motor introduce una componente de alterna al comparador y es por eso que este a la salida entrega una onda "rara" y despareja que no logra excitar el relee.
Probando con una puramente resistiva no tuve problemas.
¿Tengo alguna forma de eliminar la componente de alterna a la entrada del comparador? ¿Con un capacitor en paralelo? ¿Un rectificador de precisión?

Espero que puedan orientarme con esto.
Muchas gracias por las respuestas
Saludos!
04/03/2015 #15

Avatar de fdesergio

la tension generada por el shunt enviala a un rectificador de precision y el voltaje de salida si al comparador, asi evitas eso, chaoooo
04/03/2015 #16

Avatar de Daniel Meza

Agregar un arreglo de resistencias para darle un poco de histeresis al comparador también puede ayudar, aquí en el foro se ha tratado el tema
05/03/2015 #17

Avatar de Dr. Zoidberg

sergiot dijo: Ver Mensaje
No logro ver que es lo que estas haciendo mal, pero algo esta mal seguro.
Claro que está mal!!!
La salida del LM311 es de colector abierto, así que usándolo como salida de tensión NUNCA va a funcionar!!!!

RTFM!!!!
05/03/2015 #18


Dr. Zoidberg dijo: Ver Mensaje
Claro que está mal!!!
La salida del LM311 es de colector abierto, así que usándolo como salida de tensión NUNCA va a funcionar!!!!

RTFM!!!! http://www.forosdeelectronica.com/ga...58c7e_1385.gif
Hola,
En ningún momento use la salida del LM311 como salida de tensión, siempre como masa. Lee el tema completo.

Saludos
05/03/2015 #19

Avatar de Dr. Zoidberg

AgusI dijo: Ver Mensaje
En ningún momento use la salida del LM311 como salida de tensión, siempre como masa. Lee el tema completo.

En el primer post, segundo dibujo tenés mal conectado el LED del opto.
En el primer post, primer dibujo no tenés polarizada la salida open-collector del LM311, con lo cual la base del transistor está a "masa" o "al aire", y eso no funciona... y ahí estas asumiendo que el LM311 entrega tensión por el pin 7 cuando tiene la salida en alto, pero no entrega NADA...

Sabés lo que es una salida de "colector abierto"?????
05/03/2015 #20


Dr. Zoidberg dijo: Ver Mensaje

En el primer post, segundo dibujo tenés mal conectado el LED del opto.
En el primer post, primer dibujo no tenés polarizada la salida open-collector del LM311, con lo cual la base del transistor está a "masa" o "al aire", y eso no funciona... y ahí estas asumiendo que el LM311 entrega tensión por el pin 7 cuando tiene la salida en alto, pero no entrega NADA...

Sabés lo que es una salida de "colector abierto"?????
Si... en el tercer post aclare que era un error del gráfico y que en la realidad estaba conectado correctamente.

En el segundo dibujo, tengo entendido que como es un transistor PNP debo poner a masa la base para saturarlo. Por eso, asumiendo que el pin 7 "pone a masa", conecte ahí la base del transistor. Es probable que me equivoque (mi nivel de electrónica no es alto), pero en la simulación que adjunto funciona perfectamente (y en la práctica también).
Si, se lo que es una salida del tipo colector abierto. Y desde un principio aclaré el tipo de salida de este comparador (ya revise el diagrama equivalente).

Saludos
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.