Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

19/10/2013 #1


Inconvenientes con el amplificador de instrumentación INA128 y INA129
Saludos a todos los integrantes de este foro, hoy les vengo a presentar un problema que me ha surgido con el amplificador de instrumentación INA128 e INA129, resulta que estaba diseñando y montado el siguiente circuito:

(lo monté en mi perfil, ya que no pude ponerlo en este mensaje)

y en pocas palabras es un amplificador con ganancia 100 para una termocupla, con su sistema de compensación (sistema de compensación de unión fría), el offset del amplificador de instrumentación me estaba dando en el orden de 25 mV con los pines entrada conectados a tierra, inclusive anulando el circuito extra del opa177, mandando el pin de referencia a tierra, esto es algo absurdo, porque en las peores no me puede dar más de unos cientos de micro voltios, y para rematar este offset no era fijo, se la pasaba variando continuamente mas o menos 5mv; lo medí con multímetro de precisión así que dudo que sea el multímetro, lo intenté alimentar con una fuente switcheada y con una fuente normal de transformador, sin ningún resultado.

Por favor si alguien ya ha trabajado con estos tipos de amplificadores de instrumentación por favor díganme en que me estoy equivocando, y si no es mucha molestia pasarme un circuito básico funcional con el amplificador

De antemano les agradezco su atención, ATT: Juan Manuel ...
19/10/2013 #2


Hola lordjuan, no puedes subir el circuito porque solo tienes un mensaje en este foro (o sea recién empiezas), para poder darte una mejor respuesta deberíamos poder ver el circuito, por que no subes el circuito en algún hosting como http://imageshack.us/ y luego colocas el link en una respuesta.

Así por arriba no se me ocurre que puede llegar a ser el problema ya que el INA es un integrado muy sencillo de usar, de decirte algo diría que el problema lo tienes en la parte del circuito donde integras la compensación de punto frío y la señal de la cupla, pero como te digo, solo estoy suponiendo.

Esperemos poder ver ese diseño.

Un saludo.

Atte. CARLOS.
19/10/2013 #3
Moderador general

Avatar de DOSMETROS

No puede subir-pegar links , pero si puede darle a "mas opciones" y subir la imagen al Foro

Saludos !
20/10/2013 #4


Ya subí la foto a mi perfil, pero no la pude enlazar a este foro, supuestamente por mi experiencia en el foro

20/10/2013 #5
Moderador general

Avatar de Fogonazo

A mi gusto estas empleando los integrados en orden inverso.

Yo pondría la termocupla sobre la entrada diferencial del INA129 y el offset lo corrijo con el OPA177 actuando a la salida del INA129
20/10/2013 #6


Fogonazo dijo: Ver Mensaje
A mi gusto estas empleando los integrados en orden inverso.

Yo pondría la termocupla sobre la entrada diferencial del INA129 y el offset lo corrijo con el OPA177 actuando a la salida del INA129
De echo el opa177 es el circuito de compensación fría que se suma a la señal de salida del ina128 mediante el pin de Vref, la otra fuente es la termocupla, sin embargo el problema es que omitiendo el circuito del opa177 y llevando el pin de Vref a tierra, el offset del INA128 es absurdamente grande
20/10/2013 #7
Moderador general

Avatar de Fogonazo

lordjuan dijo: Ver Mensaje
De echo el opa177 es el circuito de compensación fría que se suma a la señal de salida del ina128 mediante el pin de Vref, la otra fuente es la termocupla, sin embargo el problema es que omitiendo el circuito del opa177 y llevando el pin de Vref a tierra, el offset del INA128 es absurdamente grande
Pero así tampoco aprovechas el modo diferencial
Mira esto:

21/10/2013 #8


Hola lordjuan, en mi opinión y experiencia conectando los pines 2, 3, y 5 a masa la tensión de offset, debería estar muy próxima a cero (máximo 50uV según datasheet), por lo que esta es la primera prueba que debes realizar y comprobar que el INA129 este en buenas condiciones.
Se me pasaba, como consejo extra, no uses las resistencias de 14 ohms, y coloca dos capacitores de 0.1uF en las entradas de alimentación (uno para Vcc y otro para Vee) y lo más cerca que puedas de los pines 7 y 4 del INA.
Si con todo lo anterior el offset se mantiene alto y variable, pues creo que el INA no está en buenas condiciones

En el esquema que posteaste el OPA177 lo usas para dos funciones, hacer la compensación de la unión fría y corregir el offset. Yo te recomendaría que este OPA lo uses solo para el ajuste del offset (conectado como segidor de tensión, variando la tensión del pin 3 y no usando los pines 1 y 8) y coloques otro a la salida del INA para hacer la compensación de la unión fría (conectado como sumador), de esta manera tienes un mejor control de cada función.

Igual y sin compensar el offset del INA, lo veo muy difícil que tengas una tensión tan alta en la salida, como tú dices es ridiculamente alta.

Como consejo te refiero a que mires el datasheet del INA128/INA129 de la firma Burr-Brown y en el mismo hay varios circuitos de aplicación (corrección de offset, uso con termocuplas, etc.) y en base a estos esquemas y haciendo un "rejunte" diseñes el tuyo.

Espero los resultados que obtengas y veremos que pasa.

Un saludo.

Atte. CARLOS.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.