Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/10/2011 #1


Mal funcionamiento Amplificador Operacional OP07CP
Hola amigos, estoy haciendo un proyecto de medición de intensidad lumínica (es para un proyecto de astronomía, se pretende medir la luz reflejada por la luna) y estoy usando para ello unas LDR (resistencias variables que cambian su valor según la intensidad lumínica que reciban). Estoy tratando de amplificar la señal que sale de la LDR (la cual es muy pequeña) con un Amplificador Operacional OP07CP, que según he leído es muy bueno para aplicaciones de instrumentación, y la señal la recibe un microcontrolador con el cual registrare los valores de intensidad lumínica que necesito.

La cuestión esta en que quiero hacer funcionar al OP07CP con una fuente de alimentación sencilla (solo Vcc y gnd) ya que no dispongo de alimentación simétrica y estoy trabajando directamente con el puerto USB de la compu (esa es mi fuente de alimentación).

Este es el circuito que monte (utilice livewire que era el que tenia a la mano y lo simule con un amplificador operacional ideal y si trabajo perfecto, pero en fisico usando el OP07CP no funciona):


Uploaded with ImageShack.us

En el simulador funciona pero cuando monto el físico, no hace nada... Si pudiera alguno ayudarme a hacerlo funcionar se lo agradecería mucho.

Tengo dudas sobre como hacerlo trabajar bien con alimentación sencilla y ademas de que no entiendo lo del offset de este amplificador operacional, que segun es bajo y que de paso se puede ajustar con un arreglo extraño.

Muchas gracias, espero me puedan orientar.

Saludos.

Encontre este circuito aqui (http://www.todopic.com.ar/foros/index.php?topic=36172.0) y no lo pude adaptar a mis necesidades cuando simulo no me sirve cuando alimento con Vcc y gnd solamente =( asic como esta funciona perfecto, de hecho se puede apreciar en la imagen, pero a mi no me sirve cuando lo alimento de manera sencilla.



Uploaded with ImageShack.us

Saludos.
07/10/2011 #2


La configuración que elegiste con el AO es la de amplificador no inversor.
Como bien vos decís la LDR es una resistencia variable, y se la estas metiendo en la pata mas del AO, osea que no va hacer nada, ya que la LDR no entrega tensión, vos en tu simulador usaste una fuente de tensión variable, no una resistencia variable.

Lo que podes hacer es interconectar en serie con la LDR otra resistencia, y estas alimentarla con tu alimentación, ahora si cuando varié la resistencia de la LDR varia la tensión sobre la misma.

Por otra parte, no se como se comportara con una fuente simple, de tan baja tensión. Pero como primer medida arregla lo anterior.
08/10/2011 #3


Hola ars, muchas gracias por tu respuesta. Efectivamente uso una configuración no inversora por que supongo que debe ser la mejor para la aplicación que quiero hacer, ademas de que no voy a tener nunca tensiones negativas.

Yo en la simulación uso una fuente variable de tensión y se que la LDR lo que cambia es resistencia y tengo que hacer un circuito del tipo divisor de tensión para poder recolectar los cambios de intensidad lumínica midiendo tensión. El circuito de para leer la LDR en el micro es el siguiente:


Y el LDR que uso es el siguiente:



De momento estoy interesado en hacer funcionar el OP07CP con el cual no he podido hacer nada aun =( otra cosa que no tengo muy claro es el valor de la resistencia que tiene que tener en serie el LDR para funcionar bien y sin offset, yo trabajo con 10K pero no se si sea mucho o poco.

Las pruebas en el proto-board las hago con una resistencia de precisión colocada a unos 0.10v para que a la salida del amplificador salgan por lo menos 1v no uso la LDR aun para no introducir errores de momento ni tensiones variables, de esa manera probare si el OP07CP esta trabajando bien o no.

El objetivo es hacer trabajar al OP07CP con tensión simple y con 5v. Según el datasheet se puede lograr pero no he tenido éxito.

Muchas gracias.

Saludos.
08/10/2011 #4


A ver vamos por partes, no se que tensiones pensas tener de ref, pero primeramente el AO esta alimentado con 5V, por ende en la salida no tendriamos mas de 3.5V, asi que viendo la ganancia de tu configuracion que esta en 10, no podriamos tener una tension de entrada mayor a 350mv.

Asi que vos estas simulando con tu fuente de alimentacion, entonces tenes que excursionar con la misma entre esos valores 0-350mv. Ojo que no cualquier fuente te los da esos valores, talvez necesites hacer un divisor resistivo para simularlo.

Si no te funciona respetando esos margenes de tensiones de entrada, tenes dos posibles errores, o tenes algo mal conectado o 5V es poco para ese AO. Asi que ahi vas a tener que probar.
En caso que sea poca la tension para el AO, la opciones son o cambiar de AO o bien cambiar la tension de alimentacion.

Bien, ahora la parte de que resistencia ponerle en serie, eso va a depender de las tensiones que vas a tener y de la corriente que le haras circular, que tiene que ser relativamente baja.
Vos pensa que la LDR tiene resistencia mayores a los 50k en ausencia de luz, y con una buena intensidad de luz, baja su resistencia a menos de 1k. Teniendo en cuenta eso vas a tener que elejir una R tal que la tension sobre la LDR no salga de los margenes que hacen saturar al AO o de tus tensiones de ref y que la corriente que la circule no exceda 1mA, yo no le haria circular mas que eso. Tambien podrias poner en vez de una R, una fuente de corriente.
13/10/2011 #5


Buenas, olvidando un poco lo que en primera instancia necesitaba resolver...

¿Es posible hacer trabajar al OP07 con una fuente simple? Me refiero a que en la pata 7 se coloque +5v y en la pata 4 0v y que con una configuracion (creo que deberia ser esa) amplificador no inversor, pueda funcionar? No logro hacerlo trabajar y necesariamente tiene que ser con una fuente simple, no se por que no funciona, si alguien sabe como puedo hacer por favor postee un esquema o algo que me oriente.

Muchas gracias.

Saludos.

Segun esto (http://www.analog.com/static/importe...037AN573_a.pdf) al parecer el OP07 NO puede ser alimentado con una fuente simple... ¿Que saben al respecto?, que otro amplificador de precision o instrumentacion que sea rail-to-rail, y que se pueda alimentar con una fuente simple me recomiendan? necesito que sea bastante comercial o por lo menos algo comun por que en mi pais es dificil encontrar componentes muy rebuscados =S

Gracias.
15/10/2011 #6


¿Alguien puede ayudarme con esta duda?
15/10/2011 #7

Avatar de pandacba

Cual es tu aplicación? porque una LDR y un AO de precisión no es la mejor combinación, y cual es tu real necesidad de que sea rail to ralil? porque visto lo que has posteado no es necesario ninguna de las dos premisas. Cualquier AO de buena calidad cumple perfectamente tus requerimientos, tales como los TL071.
Se utilza un AO RtR solo se utiliza en muy contados casos que no es el tuyo precisamente,
Algo que no has contemplado es como limitar la excursión de tensión para que no supere la máxima admitida por el pic que es de 5V.
Porque no elegiste un pic que ya trae incorporado un AO interno?

Para ampliar tus horizontes busca en el sitio de National y en el de Texas Instruments
15/10/2011 #8


Hola pandacba, gracias por tu respuesta, elegí estos componentes por que es lo que se puede encontrar en mi país sin muchos problemas, no puedo importar componentes de otros países con facilidad, y estos componentes son los que tenia a la mano.

Lo de la saturación todavía no lo he pensado (sera colocar un zener de 5v a la salida del amplificador, no lo he pensado bien aun) y quiero hacerlo de esta manera (ldr + amplificador) por que las variaciones que veo son muy pequeñas (todas alrededor de 1 voltio, todas variando en centecimas de voltios) y quiero tener una mejor resolucion cuando hago la lectura en el micro.

¿Que arreglo me recomiendas? uso una LDR por que es lo unico que tengo para medir la intensidad luminica.

Gracias. Saludos.
16/10/2011 #9

Avatar de pandacba

Tu problema, tiene una larga y triste tradición en muchos pueblos de latinoamerica, que por cuestiones de sus ideales prohiben, el traer materiales, que lo unico que causan, es un atraso, y deja a los pueblos en desventaja no solo tecnologica, si no tambièn de la idoneidad de sus tècnicos que no tienen la posibilidad de crear y experimentar por faltas de recursos.

Averiguate que otro AO se consigue y comentalo y te digo si te sirve.

En lugar de una LDR puedes utilzar un fotodio, o un fototransistor, tendrias que ver cual se adecua mejor a tus propositos
16/10/2011 #10


Gracias por tu respuesta, si amigo aqui en mi pais hacer diseños es muy dificil, los componentes se pueden importar pero son costosos y conseguir la divisas para adquirirlos (dolares) es muy complicado por el control de cambio actual.

Con respecto a lo que me preguntas, puedo conseguir el LM358 (este segun puede trabajar con fuente sencilla) no se si sea bueno para mi aplicación, necesito que sea de instrumentación o por lo menos un buen amplificador.

Solo hay 2 tiendas de consulta electrónica en mi país (que sirvan, otras son realmente malas) www.electronica.com.ve y www.ditel.com.ve si tienes un chance busca los amplificadores que conozcas y me dices a ver si los compro y empiezo a probar =)

Otra cosita (no perdamos el horizonte de buscar un amplificador que pueda trabajar con fuente sencilla, esto que comento a continuación es solo para que me puedas orientar en otras cosas), estoy trabajando con el OP07, lo puede arrancar usando una fuente de 24V y un arreglo de 2 resistencias en serie de 10K cada uno, haciendo un divisor de tensión, teniendo una tensión dual de +12v y -12v referidos al común de las dos resistencias (tierra virtual). El amplificador trabaja bien y todo el cuento pero NO hay regulación en la carga y cuando por ejemplo coloco unas resistencias entre +12V y la tierra virtual para generar una tensión de 0.060v (es para probar si realmente amplifica el circuito) a la salida del amplificador tengo 0.660v (la configuración que tengo montada es de amplificador NO inversor), la tensión de alimentación cae, esto es, lo que antes era +12V cae a unos 7V u 8V.

Intente colocando reguladores 7805 y 7905 y pasa exactamente los mismo cuando coloco las resistencias para tener una tensión de 0.060v ya no tengo +5V sino que tengo +4V y algo (del lado de la entrada del 7805, la tensión cae a 5V y algo cuando debería ser +12V). Creo que obtener tensiones duales con ese arreglo de divisor de tensión no sirve para hacer trabajar de manera confiable al amplificador.

Saludos.

Gracias por tu ayuda.
16/10/2011 #11


JoYcEr182 dijo: Ver Mensaje
Gracias por tu respuesta, si amigo aqui en mi pais hacer diseños es muy dificil, los componentes se pueden importar pero son costosos y conseguir la divisas para adquirirlos (dolares) es muy complicado por el control de cambio actual.

Con respecto a lo que me preguntas, puedo conseguir el LM358 (este segun puede trabajar con fuente sencilla) no se si sea bueno para mi aplicación, necesito que sea de instrumentación o por lo menos un buen amplificador.

Solo hay 2 tiendas de consulta electrónica en mi país (que sirvan, otras son realmente malas) www.electronica.com.ve y www.ditel.com.ve si tienes un chance busca los amplificadores que conozcas y me dices a ver si los compro y empiezo a probar =)

Otra cosita (no perdamos el horizonte de buscar un amplificador que pueda trabajar con fuente sencilla, esto que comento a continuación es solo para que me puedas orientar en otras cosas), estoy trabajando con el OP07, lo puede arrancar usando una fuente de 24V y un arreglo de 2 resistencias en serie de 10K cada uno, haciendo un divisor de tensión, teniendo una tensión dual de +12v y -12v referidos al común de las dos resistencias (tierra virtual). El amplificador trabaja bien y todo el cuento pero NO hay regulación en la carga y cuando por ejemplo coloco unas resistencias entre +12V y la tierra virtual para generar una tensión de 0.060v (es para probar si realmente amplifica el circuito) a la salida del amplificador tengo 0.660v (la configuración que tengo montada es de amplificador NO inversor), la tensión de alimentación cae, esto es, lo que antes era +12V cae a unos 7V u 8V.

Intente colocando reguladores 7805 y 7905 y pasa exactamente los mismo cuando coloco las resistencias para tener una tensión de 0.060v ya no tengo +5V sino que tengo +4V y algo (del lado de la entrada del 7805, la tensión cae a 5V y algo cuando debería ser +12V). Creo que obtener tensiones duales con ese arreglo de divisor de tensión no sirve para hacer trabajar de manera confiable al amplificador.

Saludos.

Gracias por tu ayuda.
Disculpa a ver si entendi bien,
Vos estas haciendo un divisor resistivo para alimentarlo y admes desde el mismo divisor resistivo haces otro para obtener esa tension de 0.06v?
Si es asi vas a tener que revisar algo mas de conceptos de corrientes y tensiones, porque no es tan asi el echo de montar un divisor resistivo y cuelgues lo que cuelges poder tener aprox lo que suposiste, eso solo lo podes hacer cuando lo planteas bien el divisor, y es algo aproximado tambien.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.