Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

31/05/2013 #1

Avatar de Ugy

Oscilador. Algo se me escapa, falla, esta mal o falta. ¿alguien me da una pista?
Hola:

La historia es larga, pero la resumire todo lo posible.

Para probar un frecuencimetro que he montado, necesitaba de un circuito oscilador, de aprox. 100MHZ.
En principio, elijo el copitts, pero luego de mucho probar, cambiar, medir, en fin todo lo que se me pudo pasar por la cabeza no consigo mas alla de 4-5 MHZ. En un juego con la bobina(estirar-encoger) consigo 7-8 MHZ y lo maximo que consigo son 12-13 MHZ
OJO AQUI -> ¡conectando la toma de tierra del edificio al negativo del circuito!.

Luego de varios dias sin mejoras, decido montar este oscilador
URL del circuito

con cristal para usar unos que tengo de hasta 20 MHZ. De entrada no paso de 1-2 MHZ(con cristal), por probar, le quito el condensador de base-emisor y lo mismo, lo convierto en colpitts y lo mismo, pruebo con la toma de tierra y consigo 5-6 MHZ tanto con cristal de 10 MHZ como con el de 20 MHZ.

Como piezas principales he usado:
3 => 2N2369A
2 => 2N3904
pensando que pudieran fallar.

En principio el frecuencimetro lo he descartado como fallo porque comprueba el cristal que lleva y me da un valor entre 9.9xx.xxx y 10 MHZ por lo tanto la posible variacion o error (1%), a mi entender, es minimo.

Sinceramente, con todo lo que he leido y probado, me veo totalmente incapaz de encontrar el fallo o la causa del por que no consigo los MHZ, ni si quiera en los cristales.
Y lo de la toma de tierra, eso si que no se donde ponerlo.


¿Alguno me puede ayudar?

Gracias.

Ugy
31/05/2013 #2

Avatar de SKYFALL

Por que es tan imperativo que la tierra del edificio este conectado a la tierra de tu circuito? Has intentado con variar los valores de los componentes pasivos asociados a la red osciladora, antes de solo cambiar el valor de los cristales?

Aunque la base del tiempo la da generalmente el calculo realizado con los componentes asociados tomando como referencia el valor en MHz del cristal, tienen mucho que ver los componentes pasivos al rededor del circuito.
31/05/2013 #3

Avatar de locodelafonola

hola..aver si te sirve esto.... ami me funciono... con un cristal de 8MhZ.......
Imágenes Adjuntas
Tipo de Archivo: png Sin título.png (88,3 KB (Kilobytes), 171 visitas)
31/05/2013 #4

Avatar de SKYFALL

locodelafonola sabes que frecuencia se obtiene a la salida de este oscilador? tratan de obtener 100 MHz.
31/05/2013 #5

Avatar de Rigeliano

Bueno yo hice el mismo circuito, probe con cristales de 4, 8 y 20MHZ y dieron el valor correcto pero cambie los condensadores con 330pF y 100pF ademas probé con 2N3904, BC548 y 2N2222 y funcionan bien, intenta que los cables de coneccion sean lo mas cortos posibles.
01/06/2013 #6

Avatar de Ugy

Fernando Arias dijo: Ver Mensaje
Por que es tan imperativo que la tierra del edificio este conectado a la tierra de tu circuito? Has intentado con variar los valores de los componentes pasivos asociados a la red osciladora, antes de solo cambiar el valor de los cristales?

Aunque la base del tiempo la da generalmente el calculo realizado con los componentes asociados tomando como referencia el valor en MHz del cristal, tienen mucho que ver los componentes pasivos al rededor del circuito.
Gracias por responder Fernando.

Te comento que, lo de la toma de tierra no es imperativo, sino "algo" que hice, para ver que pasaba, y la verdad me ha desmontado todo (mentalmente), no lo esperaba.
Por lo de variar, he cambiado resistencias y condensadores en el circuito a cristales. Y en el circuito LC a 100MHZ cambie, quite y añadi de todo, incluida la bobina, un choque al inicio del circuito y el condensador, me parece que se llama "de desacople" al inicio del circuito entre positivo y negativo.

Estoy de acuerdo contigo en que todo influye, incluso un oscilador en "vacio" da un resultado y luego conectado al resto del circuito da otro totalmente diferente.

Matizo que mi objetivo inicial era el de 100MHZ pero al ver los resultados, decidi hacer pruebas en algo "mas controlable" como son los cristales.

Gracias Fernando.

Un saludo.
Ugy

---------- Actualizado después de 3 minutos ----------

locodelafonola dijo: Ver Mensaje
hola..aver si te sirve esto.... ami me funciono... con un cristal de 8MhZ....... http://www.forosdeelectronica.com/at...1&d=1370054074
Gracias locodelafonola.

Servirme, si me sirve, para las pruebas, pero no se si conseguire "encontrar" pistas de que es lo que falla en los circuitos con los que me he metido (10 y 20 a cristales, y 100 LC)

Gracias.

Un saludo,

Ugy

---------- Actualizado después de 6 minutos ----------

Rigeliano dijo: Ver Mensaje
Bueno yo hice el mismo circuito, probe con cristales de 4, 8 y 20MHZ y dieron el valor correcto pero cambie los condensadores con 330pF y 100pF ademas probé con 2N3904, BC548 y 2N2222 y funcionan bien, intenta que los cables de coneccion sean lo mas cortos posibles.
Gracias por responder Rigeliano.

El circuito que pongo, lo he probado hasta con condensadores de 47p y 15p y resistencia(colector-base) de 10k.
Las conexiones como mucho son de 2 cm, a excepcion de la alimentacion, que pueden tener un total de 8 cm por lado. Se que se pueden hacer mas cortas, pero como eran pruebas he preferido tener margen para los cambios.

Gracias.

Un saludo,
Ugy
01/06/2013 #7


Hola Ugy , mirando con mui atencciõn en el esquematico del frequencimetro veras que el IC1 es uno 7490 y lo maximo que ese CI anda es unos 40Mhz de clock , si queres medir centenas de Mhz tente el CI : SP8629 del Plessey que es un prescaler divisor por 100 y opera hasta 150Mhz garantizado.
! Fuerte abraço y buena suerte en tu desahollos !
Att.
Daniel Lopes.
01/06/2013 #8

Avatar de locodelafonola

hola ..yo lo que entendi... es que necesitas un ocilador para generar un frecuencia patron para tu proyecto en mi caso.. remplaze el cristal....por 8 mhz... y es muy estable... gracias a las compuertas... y se puede alimentar desde 5v a 15v....cambia la amplitud de la señal....pero su relacion sige siendo 1;1..que creo que es lo que buscas....con cambiar el cristal ...juan
01/06/2013 #9

Avatar de Ugy

daniel lopes dijo: Ver Mensaje
Hola Ugy , mirando con mui atencciõn en el esquematico del frequencimetro veras que el IC1 es uno 7490 y lo maximo que ese CI anda es unos 40Mhz de clock , si queres medir centenas de Mhz tente el CI : SP8629 del Plessey que es un prescaler divisor por 100 y opera hasta 150Mhz garantizado.
! Fuerte abraço y buena suerte en tu desahollos !
Att.
Daniel Lopes.
Hola Daniel, gracias por responder.

Si ya se que el 7490 va hasta 40 MHZ, tambien has visto que antes esta el 4017 que divide por 10 y si los combinamos los dos (10*10) tenemos una division por 100.

Desconocia el SP8629, he mirado la hoja(datasheet) y seguro que me ira bien para lo que quiero hacer cuando salga de este atasco.

Gracias, y como decis en vuestro pais, muito obrigado.

Un abrazo,
Ugy

---------- Actualizado después de 12 minutos ----------

locodelafonola dijo: Ver Mensaje
hola ..yo lo que entendi... es que necesitas un ocilador para generar un frecuencia patron para tu proyecto en mi caso.. remplaze el cristal....por 8 mhz... y es muy estable... gracias a las compuertas... y se puede alimentar desde 5v a 15v....cambia la amplitud de la señal....pero su relacion sige siendo 1;1..que creo que es lo que buscas....con cambiar el cristal ...juan
Hola locodelafonola, gracias por tu tiempo.

Estas en lo cierto inicialmente necesito "probar" el frecuencimetro y para eso hice el circuito 100 MHZ LC, pero dados los malos y para mi inexplicables resultados, opte por hacer otro circuito, simple, con cristal, donde (supuestamente) los resultados serian mejores. y es en ese momento donde me encuentro con lo mismo en el circuito de cristal que en el de LC. Y eso es lo que me tiene atascado.
Tu propuesta me gusta, pero esta condicionada al cristal que ponga, que para pruebas ya vale, pero no coincide con la base del circuito inicial. Puede reproducir otros problemas (si es que falla) y dar otros datos pero seran diferentes a os que daba el circuito original.

Lo que he pretendido con el circuito a cristal es eliminar condensadores y bobina (LC) y descartar que el fallo este en ese punto, pero me he encontrado con los mismos fallos, incluso con componentes diferentes.

Gracias Juan.

Un saludo,

Ugy - Jose Luis
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.