Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

18/08/2010 #1

Avatar de seaarg

Oscilador a cristal, no funciona al cambiar integrado
Construi el siguiente oscilador a cristal. Utilice el integrado CD40106 con varios cristales, 4mhz, 8mhz, 12mhz y 20mhz. (a mas grande el cristal, menor los capacitores, con 20mhz use 10pico)

http://www.forosdeelectronica.com/at...9&d=1280510331

Mi frecuencimetro tiene un limite de 5mhz y la lectura era super estable con todos los cristales.

Cuando recorde que el inversor utilizado es lento, mire el datasheet y me di cuenta que no deberia funcionar bien con un cristal mayor a 4mhz (quiza hasta menos) entonces lo cambie por:

HD74HC14P

Grande fue mi sorpresa al ver que el mismo oscila totalmente erratico y a baja frecuencias. (con saltos enormes entre cada lectura).

Cambie por SN74HC04 y oscilaba a frecuencias "cercanas" al cristal pero tambien erratico.

¿En que le estoy errando? Desde ya el 40106 no deberia funcionar, o al menos no ser estable ya que estaria excediendo su velocidad por mucho. ¿Y a que se debe que el 74HC14 no oscile o lo haga tan mal?
18/08/2010 #2
Moderador

Avatar de elaficionado

Respuesta: Oscilador a cristal, no funciona al cambiar integrado
Hola.
Haz puestos los terminales de las entradas nos usadas a tierra, se hace esto generalmente para evitar oscilaciones o perturbaciones.

Sí no lo haz hecho, prueba hacerlo.

Chao.
elaficionado.
18/08/2010 #3
Moderador general

Avatar de Cacho

Respuesta: Oscilador a cristal, no funciona al cambiar integrado
Y otra chanchada que me han hecho los circuitos digitales (no los quiero ni ellos a mí) es ponerse tontos cuando les quito la señal.

Deduje (ojo, que lo que sigue es suposición) que el problema era la capacidad de cada entrada, se quedaba cargada y eso hacía que se portaran como completas idiotas las compuertas y hacían cualquier cosa. Las no usadas las mandé a masa (como decía EA) y aún en las usadas puse unas resistencias a masa de 1M (probé con más grandes y andaba igual, pero tenía muchas de 1M ).
Santo remedio.

No sé si acerté con la causa, pero la solución anduvo (y sigue andando) perfecto.

Saludos
19/08/2010 #4

Avatar de seaarg

Respuesta: Oscilador a cristal, no funciona al cambiar integrado
Excelente, esta noche pruebo ambas cosas para empezar a ver que pasa.

Vere si le pongo 10M a la entrada ya que ahi va un capacitor de valor indefinido y una resistencia quiza me varie la oscilacion segun la temperatura, para los mismos pF del cap.

Si esto fuera el problema, es evidente que el 40106 no es tan sensible a este factor, y la capacitancia de su entrada se descarga rapidamente.

Por otro lado, ¿a que puede deberse que el 40106 oscile bien y estable, siendo este un integrado muy lento para un cristal de 4 u 8 mhz?
19/08/2010 #5
Moderador general

Avatar de Cacho

Respuesta: Oscilador a cristal, no funciona al cambiar integrado
seaarg dijo: Ver Mensaje
Por otro lado, ¿a que puede deberse que el 40106 oscile bien y estable, siendo este un integrado muy lento para un cristal de 4 u 8 mhz?
Y me hiciste mirar los datasheets... Qué mal tipo que sos, ¿eh?

¿Por qué decís que el 40106 es lento para esas frecuencias??
(No tengo calculadora a mano, así que si le pifio en alguna cuenta, avisá).
En 5MHz tenés que cada ciclo dura 0,2us (200ns) y asumiendo 5V de alimentación la velocidad típica de subida y bajada es de 100ns. Si sube la tensión ese tiempo baja, así que la cosa sólo puede mejorar desde ahí.
En el peor de los casos le da como para hacer una triangular, no está tan mal. Y al darle más rosca a la frecuencia yo esperaría que se le cayera un poco la tensión a la salida, pero no que se le acabe el mundo.
A mí se me hace que debería funcionar (al límite, pero funcionar al fin).

Ahora... El 40106 y el 7414 tienen histéresis. Eso debería hacerlos más inmunes a las parásitas y esas cosas feas que hay por el aire.
El 7404 no, es simplemente un inversor y nada más. Ahí sí esperaría que se le piantaran un poco los tantos por esto de las entradas temperamentales... Pero tiene unos tiempos de transición mucho más lindos (menos de 10ns).


No sé... Probá y después contá cómo salió todo esto...

Saludos
19/08/2010 #6

Avatar de seaarg

Respuesta: Oscilador a cristal, no funciona al cambiar integrado
Correcto Cacho! a 4MHZ deberia funcionar casi al limite segun tu planteo.

Lo estoy alimentando a 9V, con divisor de tension a la salida al pic, asi que mejor aun... ahora, segun tabla de datasheet del 40106:
Propagation Delay Time: 70ns hasta 140ns, tomemos 105ns
Transition time: 50ns hasta 100ns, tomemos 75ns

¿Cual es el que vale? entiendo por propagacion desde que cambio un estado en la entrada hasta que se ve reflejado en la salida. ¿Que seria transicion aqui?

El efecto que busco con todo esto (y que logré) es tener un oscilador muy estable, que varie la frecuencia unos pocos hz, segun varie en pF el capacitor de la entrada. Encontre que esta variacion es mas apreciable con un cristal de 20mhz que con uno de 4mhz. Logico, a mi entender, ya que hay mas pulsos de menos o de mas para el pic que los cuenta durante un T fijo de 65.5ms.

Entonces, a 20Mhz, el ciclo seria de 50ns (si no me falla el calculo) con lo cual ahi se me cruzaba que no deberia funcionar. Pero tenes razon creo en tu planteo de que la salida deberia ser una triangular de menor amplitud.

Sin embargo, lo que mas me rompe la cabeza es que el 7414 tambien es schmitt trigger solo que mas rapido aun y no anda "ni pa' atra'"

El 7404 si "funciona" pero es inestable en F, aun con capacitores fijos de 10pico, probablemente por lo expresado por elaficionado.

Esta noche tratare de ponerle mi osciloscopio trucho a ver al menos como es la forma de onda que hace.

El frecuencimetro se vuelve loco con el 7414 con todos los cristales. (frecuencimetro con pic, limite 5mhz)

Ah! para agregar, en el esquematico en la resistencia RF utilize 100k y tambien 1M, mismo resultado. En ningun caso utilizo Rs de carga para el cristal. (¿deberia?)

------------------------------------------------------------------------------------------------
Agregando dudas al post: ¿Saben la formula para calcular los C asociados entre gnd y el cristal para esta topologia, para una determinada F? Hasta ahora yo estoy poniendo C segun sea estable o no la salida, no calculados.

La formula que encuentro es:
CL = [(C1 * C2) / (C1 + C2)] + Cs

Donde Cs es la capacidad parasita del circuito. Sin embargo, ¿Como relaciona CL a la frecuencia del cristal?
19/08/2010 #7
Moderador general

Avatar de Cacho

Respuesta: Oscilador a cristal, no funciona al cambiar integrado
seaarg dijo: Ver Mensaje
Propagation Delay Time: 70ns hasta 140ns, tomemos 105ns
Transition time: 50ns hasta 100ns, tomemos 75ns
¿Cual es el que vale?
Decime vos...
El grafiquito (está lindo) me lo robé de este datasheet.


El de transición es el que tarda en pasar de un estado al otro, están representados en la onda de abajo (la de salida).
seaarg dijo: Ver Mensaje
¿Saben la formula para calcular los C asociados entre gnd y el cristal para esta topologia, para una determinada F?
Ni la más pálida idea. Esa te la debo.

Saludos
Imágenes Adjuntas
Tipo de Archivo: jpg Tiempos.jpg (19,7 KB (Kilobytes), 103 visitas)
19/08/2010 #8

Avatar de seaarg

Respuesta: Oscilador a cristal, no funciona al cambiar integrado
Doh, estas en lo cierto chaparron... hay que mirar mejor el datasheet.

Lo que interpreto de ese grafico es que el tiempo de propagacion es el que vale y que esta formado por 50% de tiempo de transicion de entrada + otro 50% en la salida + un tiempo x.

O sea, tenemos 50ns + 20ns de... digamosle "transferencia interna" del estado. En total: 70ns. tipicos para el 40106

De todos modos, sigue la incognita de porque ese 7414 no anda, si hasta la capacitancia de la entrada es igual al 40106 (5pf) Espero que no sea todo cosa de que no esta andando ESE integrado en concreto, para colmo es el unico de estos en mi stock.

Para no abundar mas el thread, voy a probar esta noche con poner a masa las entradas no usadas y una R grande el la entrada del inversor del cristal. Luego de eso podriamos teorizar mas en firme.
19/08/2010 #9

Avatar de seaarg

Respuesta: Oscilador a cristal, no funciona al cambiar integrado
Bueno, probado el asunto. Con ambos integrados 7414 y 7404 funciona al poner una resistencia de 1M a masa en la entrada y las entradas no usadas a masa directo.

Ahora, lo frustrante: Oscila erraticamente con cualquier cristal, inclusive el 40106 tambien es erratico ahora, a pesar que funcionaba de pelos. A mas grande el cristal, mas erratico (logico).

La cuestion es que la duda del integrado y de este thread en si ha sido resuelta. Muchas gracias a ambos.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.