Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

18/01/2012 #1


Problema al alimentar servo
Buenas tardes.

Os comento..
Estoy realizando un circuito para controlar un servo. Por una parte uso LabJack, con el que me comunico con el PC para la programacion y cambiar las entradas respectivas desde ahi.
Necesito obtener un PWM, pero como no me quedan terminales en el LabJack, lo hago a traves de un integrado (ahora mismo no recuerdo el nombre, manda ...). El tema es que hasta aqui bien. Obtengo el PWM y puedo variar el ancho de pulso a mi antojo desde el PC.

El problema viene cuando alimento un servo con esta señal. La señal se distorsiona mucho, y el nivel máximo del PWM, no para de subir y bajar, haciendo que el servo no este completamente quieto en la posicion deseada, sino que se mueve constantemente adelante y atras(el movimiento no es siquiera visible, se escucha..). Entonces mi duda es porque ocurre esto.

Mi teoria es que el integrado puede que no le inyecte la suficiente corriente, aunque me parece algo raro, ya que el servo lo tengo alimentado externamente con una fuente independiente. Y en el caso de que si fuera ese el problema, ¿como podria aumentarla sin que se viera modificado mi pulso PWM? ¿Transistor? ¿Amplificador operacional?

Ayuda..!!
18/01/2012 #2

Avatar de Gudino Roberto duberlin

Hola Amigo, sube algun esquema lo mas completo posible de tu proyecto. Parece haber problemas relacionado con realimentacion o posicionamiento.
18/01/2012 #3


Te subo un dibujo, ahora mismo no dispongo del esquema, no lo tengo en este ordenador, asi que a ver si te resulta útil.
Te comento:

La comunicación PC-LJ se realiza por USB, con el que alimento el hardware.

Del LJ al conversor a PWM, simplemente envío un voltaje, y el integrado lo convierte. Hasta aquí todo bien. De hecho cuando mido el PWM sin el servo conectado, la señal es correcta.

Del conversor al servo, paso una línea por la que envío la señal PWM. El servo es alimentado externamente. Además tengo conectadas las tierras de la fuente, conversor y LabJack, ya que así sufría menos distorsión.

A ver si con esto puedes ayudarme!
Imágenes Adjuntas
Tipo de Archivo: png Untitled.png (23,5 KB (Kilobytes), 7 visitas)
19/01/2012 #4

Avatar de Gudino Roberto duberlin

Hola Amigo, ahora bien, como el PC se entera si el servo se posiciono de forma correcta?. O el sistema trabaja en lazo abierto?.
20/01/2012 #5

Avatar de jaimepsantos

Saludos!
Alimenta el servo con 6V te dara mejores resultados, igual checa el modelo te daran consejos para un mejor desempeño del mismo, con 6V por lo menos para un Futaba no recuerdo el modelo pero era de tamaño medio eso hacia que reaccionara mas rapido y tuviera mas torque
20/01/2012 #6


Finalmente lo he resuelto poniendo un Mosfet a la salida del convertidor PWM. Una resistencia en el terminal Drain, y de ahi saco la PWM (Yo creia que esto invertia, pero no es asi???)

Gudino, de momento esta en lazo abierto, aunque si que voy a incluir un sensor que me indique la posicion alcanzada, conectado al PC.

Y Jaime, nada, con el Mosfet ha qeudado solucionado ese tema!
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.