Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

11/12/2012 #1


Problema con circuito oscilador para luces (con 555)
Buenas. Hice un circuito que, en teoría, debería encender y apagar luces cada cierto intervalo de tiempo. El problema es que una parte del circuito funciona correctamente (enciende y apaga perfectamente según configuré el NE555), pero la otra etapa (que sería la parte inversora de la salida del NE555) queda siempre prendida, como si el CI no funcionara para esa parte. Probé dando vuelta el transistor BC557 pero ni siquiera encendió el LED. Acá les dejo el circuito:




¿Tienen idea de cuál puede ser el problema?

PD: Si tienen alguna duda acerca del circuito preguntenme.

Medí la tensión de la R7 del diagrama de arriba y cambia según la salida del NE555, pero cuando medí la de R6 no cambiaba, era siempre la misma (aproximadamente 11v).
11/12/2012 #2
Moderador general

Avatar de DOSMETROS

Te falta una resistencia desde el colector de Q3 a masa ( 10 , 15 , 22K Ohms )

También pudiste poner la lámpara entre colector de Q3 y masa y eliminar Q4

Saludos !
11/12/2012 #3

Avatar de blanko001

Ya el Sr. Dosmetros lo dijo todo:
También pudiste poner la lámpara entre colector de Q3 y masa y eliminar Q4
Ahora, debes saber de cuantos Watt son las lamparas que vas a poner, porque si consumen una cantidad a considerar de corriente te recalentarán mucho los transistores (sino los quema), para eso puedes poner otro transistor seguido a cada transistor ya instalado en configuración Darlington. Es de mencionar que los transistores que agregues deben poder controlar la corriente que necesitas. Ej: BD139 y BD140 (lampara de poco consumo), TIP31 y TIP32 (lampara un poquitin más comelona)... y así.
11/12/2012 #4


DOSMETROS dijo: Ver Mensaje
Te falta una resistencia desde el colector de Q3 a masa ( 10 , 15 , 22K Ohms )

También pudiste poner la lámpara entre colector de Q3 y masa y eliminar Q4

Saludos !
Agregué una resistencia de 10k entre el colector del BC557 y el emisor del BC548 (que está a conectado a masa) y la cosa sigue igual.
Si, es cierto que el transistor sobra, no se por qué razón lo use asi, pero de todas formas hice puente anulando el NPN y usando solo PNP y la cosa funcionaba de la misma manera.

blanko001 dijo: Ver Mensaje
Ya el Sr. Dosmetros lo dijo todo:

Ahora, debes saber de cuantos Watt son las lamparas que vas a poner, porque si consumen una cantidad a considerar de corriente te recalentarán mucho los transistores (sino los quema), para eso puedes poner otro transistor seguido a cada transistor ya instalado en configuración Darlington. Es de mencionar que los transistores que agregues deben poder controlar la corriente que necesitas. Ej: BD139 y BD140 (lampara de poco consumo), TIP31 y TIP32 (lampara un poquitin más comelona)... y así.
Si, ya he tenido en cuenta eso. A la salida van a ir conectados un par de LEDs azules (para que se den una idea, son para una maqueta).

Muchas gracias a los dos.
11/12/2012 #5
Moderador

Avatar de elaficionado

Hola.

Sube el archivo del simulador del circuito (empácalo con Winzip o Winrar).

Chao.
elaficionado.
11/12/2012 #6


Acá se los dejo. Están los dos archivos, el .lvw y el .pcb
Archivos Adjuntos
Tipo de Archivo: rar Luces.rar (3,9 KB (Kilobytes), 16 visitas)
11/12/2012 #7
Moderador general

Avatar de DOSMETROS

DOSMETROS dijo: Ver Mensaje
Te falta una resistencia desde el colector de Q3 a masa ( 10 , 15 , 22K Ohms )



MFaroppa dijo: Ver Mensaje
Agregué una resistencia de 10k entre el colector del BC557 y el emisor del BC548 (que está a conectado a masa) y la cosa sigue igual.
11/12/2012 #8


DOSMETROS dijo: Ver Mensaje
El emisor del BC548 está conectado a masa.
11/12/2012 #9
Moderador general

Avatar de DOSMETROS

Si ponés esa resistencia en el simulador que hace ?
11/12/2012 #10


En el simulador el circuito funciona correctamente, y si le agrego esa resistencia entre colector y masa sigue funcionando bien.
11/12/2012 #11
Moderador general

Avatar de DOSMETROS

Entonces te olvidaste de poner alguno de los puentes o alguna soldadura fria

O se te puso en corto el Q4
11/12/2012 #12


Ahora no se que le pasa, que la luz que quedaba prendida ahora titila (sin cargarse ni descargarse con el capacitor, es decir, haciendo de cuenta que ahi no hay nada) y la otra directamente no prende.

Estoy a punto de tirar todo por la ventana jajaja
11/12/2012 #13
Moderador general

Avatar de DOSMETROS

Levantale una punta a R7 y probá una luz sola !
11/12/2012 #14
Moderador

Avatar de elaficionado

Hola.

Desconecta los condensadores y mira si el circuito oscila.


No me gustan los tran. PNP.



Chao.
elaficionado.

Chao.
elaficionado.
Imágenes Adjuntas
Tipo de Archivo: png retra.PNG (19,6 KB (Kilobytes), 39 visitas)
11/12/2012 #15

Avatar de blanko001

Si vas a poner un par de leds no necesitas transistores... con una resistencia de 470 Ohm a cada led basta.
13/12/2012 #16


elaficionado dijo: Ver Mensaje
Hola.

Desconecta los condensadores y mira si el circuito oscila.


No me gustan los tran. PNP.

http://www.forosdeelectronica.com/at...1&d=1355276477

Chao.
elaficionado.

Chao.
elaficionado.
A la noche probaré que tal funciona sin los capacitores y les cuento.

blanko001 dijo: Ver Mensaje
Si vas a poner un par de leds no necesitas transistores... con una resistencia de 470 Ohm a cada led basta.
Me preocupaba el hecho de que serían 24 LEDs en total (armando series y paralelos) de alto consumo y quise asegurarme. Además era la forma más fácil para "negar" la salida del NE555.
13/12/2012 #17

Avatar de blanko001

Me preocupaba el hecho de que serían 24 LEDs en total (armando series y paralelos) de alto consumo y quise asegurarme. Además era la forma más fácil para "negar" la salida del NE555.
Ok, supuse que en verdad eran un par de LEDs Exito!
13/12/2012 #18
Moderador

Avatar de elaficionado

Hola.

¿Qué tipo de LEDs y de qué color?

Chao.
elaficionado.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.