Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

03/07/2012 #1


Problema de corte en transistor
Les cuento,

Debo encender 16 led rojos o verdes con el control de una plataforma arduino con pines digitales de 0v a 5v con max 40mA para ello coloque un transistor 2n2222 como lo ven y sus resistencias

Mi problema surge cuando lo necesito en corte es decir con 0v logico, los leds se encienden un poco lo que es un problema

Todos los datos entregados son medidos cuando estan en estado logico 0.

Ademas coloque la base del transistor al aire y aun estaban un poco encendido los leds con esos datos de corriente. Que yo sepa sin corriente en base esta en completo corte...

De ante mano gracias
03/07/2012 #2
Moderador general

Avatar de DOSMETROS

Los leds mas su resistencia van en colector.

Podrias poner una resistencia de 100 k de base a masa.

Saludos !
03/07/2012 #3


Y por que al dejar base al aire igual sigue un poco encendido???
03/07/2012 #4
Moderador general

Avatar de DOSMETROS

Probá :

DOSMETROS dijo: Ver Mensaje
Podrias poner una resistencia de 100 k de base a masa.
50k o 22 k seria mas o menos lo mismo

Ese es el problema de dejar los transistores mal polarizados o al aire , el ruido eléctrico y demás yerbas.
03/07/2012 #5


OK encontes saco una hacia masa. Tambien queria colocar un diodo en base ? o un condensador a masa ? Que tal ?
03/07/2012 #6
Moderador general

Avatar de DOSMETROS

Si , también un plato de tallarines . . .
03/07/2012 #7


Nono, me refiero a posibles soluciones no que todo en una
03/07/2012 #8

Avatar de Scooter

Pon la carga en el colector como es lógico y ya está.
03/07/2012 #9
Moderador general

Avatar de DOSMETROS

Un capacitor y/o díodo serían para otra cosa , vos necesitás saturar-encender un transistor NPN polarizando su base positivamente y llevarlo al corte-apagado con la base referida a 0 V, aqui va la resistencia pull-down a masa.

Ya somos dos que te decimos lo mismo :

DOSMETROS dijo: Ver Mensaje
Los leds mas su resistencia van en colector.
03/07/2012 #10


Dosmetros, gracias lo he solucionado la resistencia a masa era aprox 50 k

---------- Actualizado después de 33 minutos ----------

Me ha salido otro problema... casualmente cuando acerco algo al fototransistor se me caen los voltajes ... es decir si tal cual le aplico 5 volt a los transsitores se enciencienden pero si acerco algo al fototransistor y trato de encender los leds ... no llega voltaje suficiente... por que sera?
03/07/2012 #11
Moderador general

Avatar de DOSMETROS

Poné un diagrama actualizado de tu montaje por favor.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.