Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

28/10/2008 #1


Problema de temperatura con operacionales
Hola amigos,
Vereis, tengo un problema con un operacional que se trata del L272D cuyo datasheet os lo adjunto aquí:
http://www.datasheetcatalog.org/data...onics/1320.pdf

He diseñado una placa que utiliza 14 chips como este. Trabajan en modo seguidor-emisor. La cosa es que estando en vacío (unicamente alimentados), la temperatura de todos ellos se dispara, calentando escesivamente el pcb y llegando hasta los 50 grados. ¿Tenéis alguna idea de a qué se debe tal calentamiento? Cualquier idea sera bienvenida.
Muchas gracias.
28/10/2008 #2

Avatar de Ardogan

Nunca, nunca, pero NUNCA , se debe alimentar un operacional teniendo las entradas al aire, la salida no es problema, pero las entradas no, sino pasa eso que decís.
Si no usas alguna entrada mandala a GND o a Vcc, o a cualquier otra señal, lo que te quede más cómodo. Pero no sin conectar.
28/10/2008 #3


Bueno, quizas no me haya expresado bien. Uno de los 14 circuitos iguales que tengo implementada en la placa es este:



Las patas las tengo ocupadas todas.[/img]
29/10/2008 #4


¿No tiene alguien alguna sugerencia?¿Puede ser hasta normal ese calentamiento teniendo en cuenta los datos que se muestran el en datasheet?
29/10/2008 #5

Avatar de Ardogan

No creo que sea normal, ya que ese circuito no demanda casi corriente a la salida (la salida en el esquema se usa solo para realimentar).
Si la salida estuviera manejando corriente bueno, sería normal que se caliente, y puede ser necesario usar disipadores.
Pero lo que me extraña es que caliente con la salida manejando tan poca corriente. ¿La salida oscila o permanece estable?.
Acordate de poner un capacitor cerámico entre alimentación y GND del integrado:

- a 100nF capacitor corrected between supply pins and ground ;
- boucherot cell (0.1 to 0.2 µF + 1 Ω series) between
En la última línea le faltaría aclarar que es entre las salidas y GND (que serían los resistores de 1 ohm en serie con los capacitores de 0.22 uF que se ven en la figura 12).

Bueno, me temo que no te puedo ayudar más que con eso.
Saludos
29/10/2008 #6


Gracias Ardogan por responder.
Lo raro de este asunto es que el operacional esta sin carga. Por tanto, el calor que están disipando tiene que ser a la fuerza a causa de la quiescent current o corriente de inactividad que absorbe de la fuente de alimentación.

Para hacer una prueba, he cogido un chip y solo lo he alimentado con la salida realimentada con el (-). He colocado una Rshunt de 0,5 Ohm y el polimetro me marcaba una tensión en ella de 10mV. En consecuencia, el operacional absorbe 20mA de la fuente de alimentacion. ¿Demasiado verdad?
¿me sugieres entonces que ponga esa rama a la salida compuesta de 0.2 µF + 1 Ω?

Este problema lo tengo que solucionar ya que mi placa en standby solo con los operacionales consume casi 9W. Cantidad desproporcionada.

Y lo que mas me fastidia es que tengo que utilizar el L272D obligatoriamente. :(

Muchas gracias por la ayuda.
29/10/2008 #7
Moderador general

Avatar de Fogonazo

En tu esquema figura que la alimentación es por la pata 5 y en ningún encapsulado de ese IC la pata 5 es la alimentación ¿?
29/10/2008 #8

Avatar de Ardogan

En tu esquema figura que la alimentación es por la pata 5 y en ningún encapsulado de ese IC la pata 5 es la alimentación ¿?
Mmmmmm, muy cierto. No le presté la más mínima atención. Que buen ojo crítico Fogonazo.
29/10/2008 #9


Ups, perdón. El pineado que tiene el op en el dibujo no coincide con el datasheet. El dibujo lo he hecho a todo correr para enseñaros el circuito que he diseñado. No obstante, tanto las conexiones en la placa como el test que he mencionado anteriormente estan correctamente conectadas :(
29/10/2008 #10
Moderador general

Avatar de Fogonazo

Con el consumo en reposo que tiene no debería calentar, si podría ser que se ponga tibio (Solo algunos grados por sobre la temperatura ambiente).

Si tienes osciloscopio mira que no existan oscilaciones.

Intenta montar 1 IC sin nada externo, solo la alimentación y alguna polarización en las entradas a ver si de esta forma también calienta.
03/11/2008 #11


Hola de nuevo.
Acabo de realizar un descubrimiento y es el siguiente:
En el circuito que he mostrado anteriormente, he quitado la R5 en todos los ICs, y el calor se ha disminuido drásticamente. La corriente total que absorbe la placa ahora (con los 14 ICs) es de 160 mA.
Mi deducción es que parece ser que por la pata (+) se introducía corriente y ahora, como he suprimido la R5, no la hay.
¿Qué opinais?
Saludos.
03/11/2008 #12
Moderador general

Avatar de Cacho

Hola Laprast.

Me parece que tu problema viene de usar el operacional con una fuente simple (+V/gnd) y no poner un divisor de voltaje en la entrada (el famoso bias).
El operacional interpreta como 0 al punto medio entre +V y -V. En tu caso -V es 0, entonces el 0 del operacional es +V/2.
Implementalo como te sea mejor y probá. Ahí sí (creo) vas a poder poner la R de 28k7 sin problemas.
No te olvides de poner un par de capacitores (1 y 0,1 uf) a masa lo más cerca del pin de alimentación para evitar que oscile.

Saludos y espero que esto resuelva tu problema.
Cacho
03/11/2008 #13


Hola San_Cacho,
En el circuito que he implementado, no puedo poner un divisor de tension porque se me altera el funcionamiento. De todas maneras, ¿dónde me propones colocarlo?
Muchas gracias.
03/11/2008 #14
Moderador general

Avatar de Cacho

Sí, veo que no va a funcionar igual tu circuito. Tenés que adaptarle la salida (o la entrada de la etapa siguiente) para poder usar un divisor.
Éste debería fijar el voltaje de continua de la entrada positiva del operacional en +V/2, idealmente después de la resistencia de 28k7.

La otra opción es que con la corriente de reposo del BC847 hagas que la caída en R4 sea de +V/2. Con eso, en reposo el operacional "ve" una entrada de 0V. La salida va a variar entonces entre +V/2 y 0V.

Otra es poner una resistencia entre la entrada positiva y tierra. También te va a cambiar la salida, pero va a ayudar a que la entrada esté más cerca del 0 del L272.

¿Con qué voltajes estás trabajando (+V y VCL)? ¿Cuáles son los requerimientos de la etapa siguiente?
03/11/2008 #15


Pues aqui te pongo las tensiones:
VCL = 5V;
+V = 24V;

El BCD actua de chopper. En el punto 5 hay una tension cuadrada de 24v de amplitud. Esa tension es filtrada por el filtro pasabajos formado por R4, R5 y C1 reduciendola en una tension continua. Despues el OP "traslada" esa tension a la carga directamente.
03/11/2008 #16
Moderador general

Avatar de Cacho

Ah, no es un seguidor de emisor, sino de colector el circuito.
Si lo transformadorrmás en seguidor de emisor y hacés VCL=+V/2+X, donde X es la caída en el BC847 y todo lo previo, tenés +V/2 en la entrada del operacional en reposo.
03/11/2008 #17


Ya pero en reposo a mi me interesa que el operacional saque 0V, no V+/2.
03/11/2008 #18
Moderador general

Avatar de Cacho

R4 limita la corriente del BC847, el pasabajos lo forman R5 y C1 y la f0 es 5,5Hz.
Por lo que veo, ahora tenés +V en la salida del L272 en reposo (o un valor cercano), ¿o no?

A mi entender, tenés dos opciones para lograr 0V en reposo:

1) Usar un PNP, con el emisor en donde ahora está el colector del 847, y el colector en el emisor y deberías conectar la base del PNP al emisor del primer transistor y de ahí una resistencia a tierra. Ahí sí vas a tener 0V en la entrada positiva en reposo. Habrá que recalcular todo. No es muy conveniente.

2) Dejar el circuito como está y usar la entrada negativa, con la realimentación correspondiente, conectada al pasabajos y la positiva a masa. La onda cuadrada no va a pasar de cierto valor (no sé de cuánto, habrá que calcularlo), así que podés corregir eso con la ganancia del L272. Esta es la más simple.

Creo que es así nomás el asunto. Fijate si coincidís conmigo.
Un saludo

Edit:
Corrijo el voltaje en reposo: Debe estar cerca de VCL-1V.
03/11/2008 #19
Moderador general

Avatar de Cacho

Perdón! Madrugar hoy me hizo muy mal. :(
No caí hasta recién (qué bien que hace bañarse) en que al principio el HCPL2630 te invería la señal. La llevé al revés todo el camino.
Perdón de nuevo...

La única opción que se me ocurre es el divisor de voltajes original para la entrada positiva... O agregar una alimentación negativa en el circuito.
03/11/2008 #20

Avatar de Ardogan

Mmmm, eso de que por R5 se mete corriente no creo que sea así, la pata + del operacional no toma corriente (más que la de polarización -> micro-amperes cuando mucho), tiene impedancia de entrada muy alta.

¿Estás seguro de que el diagrama que subiste es tal cual el que estás probando?. Disculpá que insista, pero realmente no me cierra por qué al quitar R5 el operacional maneja menos corriente.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.