Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

29/11/2010 #1

Avatar de michelvellve

Problema con TSOP1738
Que hay colegas!?

Dejenme decirles un problema que me ocurrio con un circuito que le implemetamos a un robot...

El robot es un semi-automata que deseamos controlar por medio de un control remoto de television , un puente H (L293D - SN754410) y el pic 16F628A. Lo que sucedio es que nos ehco la mano un profesor puesto que aun somos tecnicos unicamente, en lo que a la programacion del PIC respecta, de tal manera que modifico un programa que ya tnia con anterioridad para adaptarlo a nuestras necesidades.
De tal manera, nuestro circuito se compone de:

TSOP1738
PIC 16F628A
Puente H (ya sea con el L293D o el SN754410)
2 Motores de C.D de 3 Volts cada uno
Regulador de Voltaje 7805
8 baterias de 1.2 Volts c/d conectadas en conjuntos de 4 (2) conectadas en paralelo a cada motor
1 Bateria de 9 Volts para alimentar el sistema de control

Por lo que ya al tener montado el cto en tabla fenolica y tenerlo soldado, lo alimentamos y madamos una señal al TSOP mediante un control remoto marca Sony y lo que notamos es que el dispositivo se habia quemado

Antes que continue debo decirles que para la alimentacion de los integrados usamos 4 baterias AA de 1.2 Volts c/u de 120 mA de corriente, conectadas en serie a un 7805 para conseguir un voltaje optimo, por lo que tambien, descartamos que pudiera haberse quemado el TSOP por cuestion de alimentarlo con mas voltaje que el que soporta (6.0 Volts) por lo que optamos por el lado de introducirle mayor corriente mayor que la que soporta que es un max. de 1.5 mA, que considero que es lo que hizo que se quemara.

Mi pregunta es:

Como puedo hacer para que el TSOP aguante y no se queme sin siquiera hacer prueba alguna siendo que el voltaje que alimentara el circuito sera proveniente ya no de 4 baterias AA sino de una bateria de 9V con quiza mayor amperaje al que soporta este dipositivo?

O quiza nos recomiendan optar por adaptar otro sistema a nuestro robot? De tal forma que aun se pueda controlar por medio de un control remoto o por RF como los juguetes que se venden...?

Gracias por tomar un rato para leer colegas!

Que esten muy bien

P.D:Anexo una parte de la datasheet del TSOP1738 que incluye el voltaje de alimentacion y la corriente que maneja

30/11/2010 #2


Hola, que tal?

En el mismo datasheet viene el sistema mínimo del sensor con las protecciones correspondientes.

Te recomiendo probarlo primero en protoboard para confirmar que no hay error en el circuito impreso.

Saludos!
30/11/2010 #3

Avatar de thenot

De que al tsop le administres mas corriente que la que necesita no es problema para se haya quemado. Si el datasheet dice que consume 1.5 mA entonces la cantidad minina de corriente que debes tenerle es esa, si le pones 2, 5 o 10 Amperes no debe por que quemarte tu tsop, dado que solo le estas dando energía de mas que el no necesita, el tsop solo consumira sus 1.5 mA, el resto no es aprovechado, si es una batería (pila o bateria) hará que tu circuito dure mas tiempo funcionando, ahora cosa muy distinta es con el voltaje, si dice que max es 5.5 V entonces no te puedes pasar de ese valor.

Ahora estas seguro que esta quemado?? por que sacas aquella conclusión?? es a simple vista, o sacaste aquella conclusión por que no funciono??
Te pregunto por:
Dices que usaste 4 pilas en serie para alimentarlo, si supusiéramos que las pilas tienen los 1,2 Volts de carga, en las 4 en serie tendrías 4.8 Volts y ademas dices que lo pasas por un 7805??? el 7805 para que regule bien debe estar por lo menos con 2 volts mas de lo que regula, o sea si usas un 7805 necesitas por lo menos 7 volts para que el regulador trabaje correctamente. Por lo tanto suponiendo que las pilas están a su 100% y como ya dije tendrías 4.8 Volts con lo cual el regulador no esta trabajando para nada correctamente, de partida ni siquiera estas llegando a los 5 que entrega el regulador (no creo que estés esperando que el regulador invente esos volts que faltan) y dado que no regula bien quizás hasta te este quitando algunos volts de los 4.8 que tienes. Ahora imaginemos que las pilas no esta a su 100%, pongamosle que tienen 0.1 volts menos de carga, o sea que tienen 1,1 volts, si juntamos las 4 tendríamos 4,4 volts, o sea ni siquiera estas llegando al valor mínimo que necesita el tsop, que son 4,5 Volts.

Así que te recomiendo, ya sabiendo que si le pones mas amperes que el que necesitas no pasara absolutamente nada, primero medir el voltaje de las 4 pilas en serie y si esta esta cercano al 5 conectarlo directamente sin el 7805, o como dices poner la batería de 9 Volts pero regulados con el 7805. Si tienes un transformador o un eliminador de pilas, úsalo y haz tus pruebas con ello conectándolo al 7805, como ya sabes si es que su voltaje es mayor a 7 volts y tampoco excedas los 12 volts, ya que tendrás mucha disipación de energía en forma de calor y tendrás que ponerle al 7805 un disipador de aluminio. Te recomiendo usar un eliminador de pilas o un transformador ya que generalmente el problema que se tiene es con las pilas, si estas no están bien cargadas tendrás problemas, en cambio con el transformador tendrás un voltaje y amperaje estable, y luego que ya pruebas bien con el transformador y vez que todo funciona Ok, entonces pasa tu alimentación a pilas ya que es obvio que debe ser portable y saca tus propias conclusiones con respecto si esta bien las pilas que tienes o necesitas mas, o alguna con mayor amperaje.

Así que ya sabes, si dices que esta quemado por que no funciono, haz lo que te digo y prueba, y si todo estaba bien en lo que te dije y el tsop si realmente se quemó, entonces ya sabes que el problema no es por la alimentación, sino que deberás hacer lo que te dice mcpiebot, comprobar si es que hay errores en el circuito impreso.

Veo que es tu primer mensaje, por lo cual te felicito ya que hiciste una muy buena pregunta, exponiendo todo lo que hiciste, solo falto el circuito, esquema o fotos de lo que hiciste, pero como lo explicaste se entiendio muy bien y eso es algo que muchos de los que postean en FE debiesen aprender o hacer.

Saludos!!!
30/11/2010 #4

Avatar de michelvellve

Gracias por sus respuestas mcpiebot y thenot.

En cuanto a lo del eliminador de baterias, contamos con 2 adaptadores, cada uno para conjuntar 4 baterias y asi conseguir los supuestos 4.8V de salida de cada adaptador.

Retomando lo que dices thenot, es extraño como con 4 baterias se consigue un voltaje mayor a 4.8V, de hecho se consigue un voltaje por cada 4 baterias de 5.5V aproximadamente por lo que se me hace extraño de igual manera...

Por otro lado, ese no es tanto el problema puesto que para alimentar el "sistema de control" del robot que lo conforman los CI´S y regulador de voltaje, usaremos para comodidad una bateria de 9V para alcanzar el voltaje y corriente necesarios para su buen funcionamiento.
Lo que restaria unicamente seria ver en que parte del circuito impreso podemos adaptarle las 8 baterias de 1.2V para alimentar cada uno de los 2 motores que el robot tiene...

Dejenme decirles tambien, que apenas realice una prueba precisamente para comprobar si el STOP estaba "quemado" y en efecto lo estaba puesto que como habia leido anteriormente en el foro, si este dispositivo se encontrara quemado, su salida siempre estaría en "1" lógico aun cuando se le mandara algun pulso distinto o incluso sin mandarle pulso alguno mediante un control remoto...
Esto lo comprobe conectado el dispositivo en un protoboard y a su salida (Vout) a una resistencia de 330ohms conectada a un LED, viendo como resultado que sin mandar pulso alguno por el control remoto de TV el LED se mantenia encendido...

La otra prueba que realizamos fue checar si habiamos cometido errores al diseñar el cto. en placa fenolica, lo cual hicimos auxiliandonos de otro TSOP1738 de otro compañero y conectandolo por medio de 3 caimanes a las terminales de alimentacion de la placa del cto. del robot y su salida del 1738 al pin 17 del PIC16F628A, pulsando los diferentes botones que asignamos para la direccion del robot con un control remoto y observando que el robot finalmente funcionaba como debia con el TSOP que nos habian prestado, por lo que como conclusion verificamos que definitivamente estaba dañado por lo que decidimos cambiar el dipositivo quemado por uno nuevo para ver como nos funcionaba ya...

Sin mas por el momento los mantere al tanto de lo que pasa con este cto.

Saludos

Michel
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.