Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/11/2011 #1


Problemas de programacion de lcd en flowcode y simulacion en proteus
amigos necesito ayuda para mostrar un mensaje en el lcd. estoy usando el PIC16F870, el programa lo diseñe en FLOWCODE, lo compilo y lo cargo al micro en proteus y al momento de simularlo no sucede nada, me pueden orientar un poco?
saludos...........
02/11/2011 #2
Moderador general

Avatar de Fogonazo

vimato dijo: Ver Mensaje
amigos necesito ayuda para mostrar un mensaje en el lcd. estoy usando el PIC16F870, el programa lo diseñe en FLOWCODE, lo compilo y lo cargo al micro en proteus y al momento de simularlo no sucede nada, me pueden orientar un poco?
saludos...........
Si, siempre y cuando publique el programa que llevas echo.
02/11/2011 #3


ok, aqui lo muestro. anexo imagen del programa en flowcode, imagen del programa en proteus y por ultimo el programa en C y en ASM
Imágenes Adjuntas
Tipo de Archivo: jpg imagen flowcode.JPG (116,5 KB (Kilobytes), 169 visitas)
Tipo de Archivo: jpg imagen proteus.JPG (69,8 KB (Kilobytes), 133 visitas)
Archivos Adjuntos
Tipo de Archivo: txt hola asm.txt (13,3 KB (Kilobytes), 49 visitas)
Tipo de Archivo: txt hola c.txt (10,9 KB (Kilobytes), 54 visitas)
02/11/2011 #4


realizaste la configuracion del chip con las palabras de configuracion adecuadas?
la velocidad de reloj seleccionada es la correcta en el programa?
regularmente esos son los problemas que se presentan.
por otro lado, si es compatible FC con proteus?
03/11/2011 #5

Avatar de Saint_

Hola vimato
"craneando..."


" ¿que nos pasa...?
"cableaste" mal al LCD....
Archivos Adjuntos
Tipo de Archivo: rar pic.rar (32,2 KB (Kilobytes), 249 visitas)
03/11/2011 #6


muchas gracias amigo, ya lo probé y me funciono a la perfección..........

saludos
12/11/2011 #7


problemas con el flowcode y la lcd
amigos en un tema anterior me ayudaron en la configuración del proteus con un programa simple en el flowcode usando el modulo lcd, ahora lo quiere probar en físico, al momento de probarlo el diseño inicie la lcd pero todos los caracteres de la pantalla se ponen en negro, ya chequee el contraste y no es esa la falla, sera que me pueden ayudar?
13/11/2011 #8


bueno donde estaba el error de conexión no puedo abrir el archivo de proteus por que es una version antigua la que tengo
13/11/2011 #9


tenia invertido RS y E, y R/W me faltaba conectarlo a la tierra
Imágenes Adjuntas
Tipo de Archivo: jpg Dibujo1.JPG (70,4 KB (Kilobytes), 84 visitas)
13/11/2011 #10

Avatar de deluxmigue

vimato, aun te hace falta unas conexiones en la lcd el pin 1 y 3 van a tierra y el 2 alimentacion
13/11/2011 #11


tienes razón, pero para simularlo en proteus no es obligatorio el uso de estos pines, ya lo probé y corre a la perfección...... de todas maneras muchas gracias por la acotación......
13/11/2011 #12

Avatar de DANDY

bueno y han probado el parsic? es parecido al flowcode pero mas sencillo
13/11/2011 #13


La verdad no, primera ves que lo oigo, ya lo voy a buscar a ver que tal....
Tienes algÚn link donde pueda encontrar informaciÓn de el?........
05/12/2011 #15


hola perdona me pasa lo mismo
vimato dijo: Ver Mensaje
amigos en un tema anterior me ayudaron en la configuración del proteus con un programa simple en el flowcode usando el modulo lcd, ahora lo quiere probar en físico, al momento de probarlo el diseño inicie la lcd pero todos los caracteres de la pantalla se ponen en negro, ya chequee el contraste y no es esa la falla, sera que me pueden ayudar?
hola mira yo e puesto todo cuanto la coneccion, en el puerto b y pongo "Hola Mundo" y solo me salen los caracteres en negro la primera fila es el el mismo problema que el tuyo, dime si lo as podido solucionar porfa gracias
12/12/2011 #16


hola de nuevo
pregunta a que frecuencia o velosidad tienen que ir los LCD yo sigo teniendo el mismo problema y ya e cambiado 4 lcd solo sale una fila negra y estoi usando un cristal de 40000 y a esa frecuencia
lo estoy haciendo mal ????? gracias
03/05/2012 #17


problema con flowcode
Hola amigos he realizado un programa en flowcode al simularlo en proteus funciona pero al hacerlo fisico no, al medir voltaje en las salidas del pic este marca 2,5V, lo que significa que esta en loop (0m y1), me podrían ayudar, me queda claro que es un problema de programación

Juan Carlos
03/05/2012 #18


jucaceledon dijo: Ver Mensaje
Hola amigos he realizado un programa en flowcode al simularlo en proteus funciona pero al hacerlo fisico no, al medir voltaje en las salidas del pic este marca 2,5V, lo que significa que esta en loop (0m y1), me podrían ayudar, me queda claro que es un problema de programación

Juan Carlos
¿y tu programa apá?, como te ayudamos???
sube el flowcode y le hechamos un vistazo!
05/05/2012 #19


ayuda
Primero pedirles disculpas por que por desconocimiento mio escribí en dos partes de este mismo foro.

Ahora les envío el programa, la filosofía es la siguiente:

1.- Debo setear t° max y mínima con pulsadores que suban y bajen el seteo.
2.- De acuerdo a la temperatura actual debo encender o apagar un calefactor
3.- En manual debo mover un motor derecha o izquierda según requerimiento
4.- En automático mover el motor un par de segundos luego esperar un tiempo y de ahy mover nuevamente el motor pero en sentido contrario

Espero su ayuda

Juan Carlos
06/05/2012 #20


sigo con mi problema
Hola por mitivos de salud deje de lado los pic pero e regresado jajaja sigo con mi problema de el lcd lo he echo en flow code lo he probado en proteus lo conectado como por defecto biene en el flow code y funciona bien en ambos programas pero cuando lo hago fisicamente no me ba, del pic 16f84a que es el que uso si salen los pulsos porque lo leo con una punta logica las señales que salen de proteus en fisico tambien estan estoy usando un lcd de 2x16 que es el 1602q de 14 pines sera que este lcd necesite alguna configuracion, es el segundo que pruevo, de verdad no se que hacer ayudaaaaa gracias:confused :
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.