Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/03/2015 #1


Problemas con servo al momento de conectar
Buenas a todos, tengo un arduino uno y 2 servos. Estos servos ya estan conectados al arduino y que al momento de conectar el arduino a mi pc los servos se mueven por ejemplo unos 30 grados.. no se porque ocurre eso y ademas he leido en algunas paginas que le ponen unos condesadores. Quisiera saber si alguien tiene un circuito o que componentes electronicos debo usar para corregir este tipo de problema, les agradezco mucho por su ayuda de antemano... Saludos. ...
07/03/2015 #2

Avatar de pandacba

Habria que ver como has implementado tu hardware, podrias subir los esquemas? para una evaluación?
08/03/2015 #3

Avatar de TRILO-BYTE

normalmente esto es por errores de software.

los capacitores que ponen en internet o los taingazos les ponen hasta transistores.

pero cuando los servos se mueven uno puede pensar que es el circuito pero habria que ver que esta pasando con la forma de onda del PWM. puede que no lo este quenerando de manera correcta.
ami me paso eso.

el micro no estaba haciendo bien la interrupcion.
08/03/2015 #4

Avatar de Scooter

Si cuando apagas el arduino el servo se queda en X° y arrancas el programa siempre a 0° por ejemplo, es normal que se mueva de X a 0.
Revisa si el programa envía datos erróneos al empezar.
08/03/2015 #5


HOla a todos muchas gracias por sus respuestas.. no hay ningun circuito entre el arduino y el servo, mas bien tal ves alquien tenga uno para que me pueda ayudar en eso.. he hecho una prueba grabandole al arduino un programa sin ninguna instruccion, solo el setup y el loop.. y el servo aun gira un poco al momento de conectar el arduino a mi pc.. yo pienso que el arduino al momento de inicar genera una señal que el servo no entiende y por ende este gira..
Scooter en el ejemplo que das yo dejo el servo en 0 grados y al momento de inicar el servo gira a X grados y regresa a 0 grados.. Gracias a todos
08/03/2015 #6

Avatar de locodelafonola

hola
acuariuns dijo: Ver Mensaje
HOla a todos muchas gracias por sus respuestas.. no hay ningun circuito entre el arduino y el servo, mas bien tal ves alquien tenga uno para que me pueda ayudar en eso.. he hecho una prueba grabandole al arduino un programa sin ninguna instruccion, solo el setup y el loop.. y el servo aun gira un poco al momento de conectar el arduino a mi pc.. yo pienso que el arduino al momento de inicar genera una señal que el servo no entiende y por ende este gira..
Scooter en el ejemplo que das yo dejo el servo en 0 grados y al momento de inicar el servo gira a X grados y regresa a 0 grados.. Gracias a todos
es corecto lo que hace., busca el punto de control
o sea iguala la pocicion mecnica ., con la unidad de control electronica
la logica de control trabaja a 5V ., no hace falta ninguna interfaz entre el pin del atmega y la entrada de control del servo (el servo tiene alimentacion separada)
09/03/2015 #7

Avatar de TRILO-BYTE

eso es cierto.
cuando vez circuitos no mas bien ROÑAS pura roña taringuera es por que:

1.- no saben electronica.
2.- copiaron un circuito de otra pagina.
3.- el micro que usan el pin de salida soporta muy poca corriente por ende usan un transistor auxiliar.
4.- un amigo les dijo pon esto les funciono y lo publican.
5.- usan una fuente de alimentacion con muchisimo ruido que no se le llamaria fuente de alimentacion si no generador de ruido
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.