Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

06/11/2014 #1


Puente H mosfet, no funciona
Hola buenas noches,
me llamo fede, y tengo un proyecto bastante importante en el cual estoy construyendo una silla de ruedas eléctrica.
Les comento que estoy armando un puente H con mosfet canal N (IRF540) y canal P (IRF9540) para controlar por ahora uno de los motorreductores de 24v/6A, el circuito lo probé en una protoboard y funcionaba correctamente con un motor de 24v 1A, pero luego traslade el circuito a un pcb y este no funciono.
Con un tester comprobé que cuando lo activaba hacia un lado la tensión en la bornera del motor era de 24v y cuando lo activaba hacia el otro me figuraba -24v, por lo que la inversión de giro la hacia correctamente, todo esto sin conectar el motor, pero cuando conectaba el motor este no se movía y la tensión caía a 0v en la bornera, no tuve ningún tipo de cortocircuito ni sobre calentamiento sobre los componentes.
Volví otra vez al circuito en la protoboar y testie todas las tensiones en diferentes puntos y coinciden con las mismas mediciones que obtuve en el pcb.
Supongo que puede ser un error de diseño, por eso dejo el esquema y el pcb, trate de simularlo en proteus pero siempre obtuve errores.
Desde ya muchas gracias.
saludos.
06/11/2014 #2

Avatar de papirrin

Me parecio bastante chistoso el circuito, ¿de donde lo sacaste?

yo creo que le estas limitando la corriente con la R20 de 330R
06/11/2014 #3

Avatar de TRILO-BYTE

esta un poco grande el puente H creo que podria ser mas sencillo en lugar del OPAM yo usaria un buffer de 3 estados para usar PWM y asi la proteccion de los diodos no me parece muy adecuada hay que trabajar mas en eso.

si como dice el colega se ve chistoso
07/11/2014 #4


TRILO-BYTE dijo: Ver Mensaje
esta un poco grande el puente H creo que podria ser mas sencillo en lugar del OPAM yo usaria un buffer de 3 estados para usar PWM y asi la proteccion de los diodos no me parece muy adecuada hay que trabajar mas en eso.

si como dice el colega se ve chistoso
Hola, decis que tendria que cambiar el lm339 por un biffer de tres estados?
Y con respecto a los diodo serian los zener?
07/11/2014 #5


Hola a todos , yo de plenissimo acuerdo con Don papirrin miro que "R20" (330 Ohmios) es un valor por demasiado alto , asi no hay curriente para funcionar lo motor , portanto te recomendo que baje ese resistor para 0,33 ohmios de modo el aun hacer su función( monitoreo de la curriente del motor, eso creo yo).
!Fuerte abrazo y buena suerte en tu desahollo!
Att.
Daniel Lopes.
07/11/2014 #6

Avatar de TRILO-BYTE

no había visto la R20 si esta muy alta se supone que el papel de la resistencia lo hace el motor para que el transistor este bien saturado.

y no son diodos Zener, debes poner diodos schottky para la parte del motor.
el papel de estos diodos es que cuando el motor se mueva de manera externa no destruya el circuito por que el motor genera corriente.

los diodos se encargan de mandar a tierra el voltaje externo, y en el diagrama le faltan diodos bueno en la parte de la salida para el motor.
07/11/2014 #7


Saludos, podrian decirme por favor donde ver el circuito?
07/11/2014 #8


Hola gracias por responder,
Definitivamente era la resistencia R20, ya la cambie por una de 0.1R, y el circuito salio andando,
Los diodos que tiene ahora son los byv 28, que están para proteger el circuito, tratare de cambiarlos por unos schottky.
Gracias
07/11/2014 #9

Avatar de papirrin

Como sugerencia y si gustas hacer la prueba, quita y puentea la resistencia R20 y deja el fusible como esta, este puede funcionar como resistencia shunt quizas solo tienes que aumentar la ganancia del operacional.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.