Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

10/12/2012 #41


Hola amigo Thenot, siento el tiempo que ha pasado desde tu última consulta. He estado de viaje y se me ha pasado este hilo.

Código:
el puente H esta al revez, los pnp van arriba y los npn abajo.
En respuesta a tu incidencia, te diré que el esquemático está bien, aunque te parezca que los transistores NPN y PNP están invertidos. En muchos de los esquemas se muestran como tu indicas, sin embargo te aseguro que, para este montaje, deben estar como los he dispuesto, arriba los NPN y abajo los PNP.

Cuando he leído tu mensaje, me ha sorprendido y he pensado, lo estuve simulando y todo iba bien. Me has hecho dudar, hasta el punto de revisar el circuito y su simulación. Para mayor seguridad, he realizado un nuevo circuito (ya que en muchos circuitos, sí están los NPN abajo y los PNP arriba) y el resultado ha sido un fracaso, no he podido mover el motor en la simulación.

De modo que, insisto, a menos que alguien demuestre lo contrario, el esquema esta bien. Fíjate bien en, cómo se activan los mencionados transistores y verás que, no puede funcionar este circuito si no es tal cual lo presenté.

Espero tu respuesta y gracias por seguir el hilo.

Saludos a todos.
10/12/2012 #42

Avatar de thenot

kagiva dijo: Ver Mensaje
Hola amigo Thenot, siento el tiempo que ha pasado desde tu última consulta. He estado de viaje y se me ha pasado este hilo.

Código:
el puente H esta al revez, los pnp van arriba y los npn abajo.
En respuesta a tu incidencia, te diré que el esquemático está bien, aunque te parezca que los transistores NPN y PNP están invertidos. En muchos de los esquemas se muestran como tu indicas, sin embargo te aseguro que, para este montaje, deben estar como los he dispuesto, arriba los NPN y abajo los PNP.

Cuando he leído tu mensaje, me ha sorprendido y he pensado, lo estuve simulando y todo iba bien. Me has hecho dudar, hasta el punto de revisar el circuito y su simulación. Para mayor seguridad, he realizado un nuevo circuito (ya que en muchos circuitos, sí están los NPN abajo y los PNP arriba) y el resultado ha sido un fracaso, no he podido mover el motor en la simulación.

De modo que, insisto, a menos que alguien demuestre lo contrario, el esquema esta bien. Fíjate bien en, cómo se activan los mencionados transistores y verás que, no puede funcionar este circuito si no es tal cual lo presenté.

Espero tu respuesta y gracias por seguir el hilo.

Saludos a todos.
Hola,
usas el mismo voltaje para alimentar todo?? si es así creo no habría problema para como lo tienes, en cambio si usas un voltaje distinto para la lógica y para los motores deberías tener problemas.. lo se ya que tiempo atrás hice muchas pruebas de transistores, puentes H y motores y mis conclusiones fueron esas (conclusiones teóricas y practicas). Si tienes la simulación subela en un rar. Lo antes posible te la revisaría y te hago el cambio para que veas (aunque quizás me demore unos días en responderte). Si deseas saber el porque de la configuracion del puente H como te digo te lo respondo en la proxima por que ahora ando medio liado y escribi esto a lo rapido.

Saludos!!
11/12/2012 #43

Avatar de Scooter

Sin duda yo los pondría al revés; en seguidor de emisor no creo que saturen y por lo tanto se calentarán mucho mas en esta configuración que en la contraria.

Por ejemplo, respecto del positivo la tensión mínima que habrá en el emisor de Q4 será:
Vce(Q2)+Vr6+Vd3+Vbe(Q4)=0,2+?+0,6+0,6=1,4V como mínmo de Vce del Q4. (Mas bien habrán 1,5V o mas)
Osea que ni por asomo está saturado. La potencia de Q4 en saturación sería P=0,2·Ic (aprox), ahora la potencia es de P=1,4·Ic "solamente" se pierde SIETE veces mas potencia.

Además si en el transistor "del positivo" se pierden 1,5V ye en el "del negativo" otro tanto, el motor en lugar de estar alimentado a 9V estará alimentado a 6V.

Osea que, yo personalmente, sin duda haría el puente al contrario de como está en el esquema.
Que así funciona, no lo niego, se tira a la basura el 33% o mas de la potencia pero funciona, si es para motores de juguete no pasa gran cosa, si es para algo mas potente si que pasa.
11/12/2012 #44


Esta bien, entiendo lo que me comentáis los dos, el caso es que al simularlo no funciona, al menos en el simulador, ??

De todos modos adjunto el circuito, utilizo el 'Circuit Wizard', no se si es lo más adecuado.

Espero que dispongáis de este programa para poder simularlo y me deis una opinión de porqué funciona según el esquemático que adjunto y en cambio no consigo que funcione al cambiar los NPN y PNP.

Gracias por vuestro tiempo.
Archivos Adjuntos
Tipo de Archivo: zip pwm_puente-h.zip (7,3 KB (Kilobytes), 21 visitas)
11/12/2012 #45

Avatar de Scooter

Es que no se pueden cambiar sin mas, la cosa lleva mas ciencia.

Para empezar yo aplicaría el pwm del 555 directamente a las bases de los npn "de abajo", y con un conmutador de dos circuittos por un lado seleccionaría que transistor pnp "de arriba" funciona por un circuito y por el otro a que pnp le llega el pwm.
Algo así, es solo un croquis:

Los valores están a bulto, faltarían además diodos volantes etc.
28/02/2013 #46


Hola a todos, creo que esta pagina ayudara un poco en este tema.

http://www.hispavila.com/3ds/atmega/hpuente.html
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.