Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/07/2015 #1


PWM y Optoacoplador
Hola a todos

Tengo el siguiente caso: con un Arduino controlo a través de una señal PWM un motor DC. Como uso dos alimentaciones con las masas separadas, tengo que utilizar un optoacoplador. Necesito que la señal PWM de la salida del Arduino este igual de clara y perfecta en el "otro" lado del optoacoplador.

Tal como se ve en la imagen adjunta he usado el 4N35 que tiene un CTR del 100%. La resistencia del led es de 330 ohmios para proporcionar una If=10mA. En el transistor del optoacoplador lo he polarizado en colector común con una resistencia del emisor a masa. En la base del transistor he colocado una resistencia de 2M2 para mejorar la velocidad de conmutación. En la salida he colocado dos inversores HFC4069 para mejorar el señal saliente del optoacoplador y también para volver a invertir el señal.

A parte de hacer los cálculos también lo he comprobado midiendo con un osciloscopio para ver el señal PWM saliente como respondía. El problema es que si ponía la R del emisor alta (10K, 4K7 o 1K) obtengo una señal PWM mal. Es decir, con los inversores conseguía una onda cuadrada perfecta pero tanto el inicio como el final del PWM se lo "comía". Por ejemplo cuando el señal PWM directo del Arduino estaba al 25%, en la salida del optoacoplador aún estaba a 0. Y cuando en la salida del optoacoplador el PWM estava al 100% en realidad el PWM original del Arduino estava al 80%.
Haciendo varias pruebas, he comprobado que la R del emisor tiene que ser muy baja (220 ohmios en este caso) para que el señal PWM sea lo más perfecto posible al PWM original del Arduino. El problema es que la Ic es bastante elevada (32mA), aunque el 4N35 puede aguantar hasta 100mA.

Mi duda es si hay alguna otra alternativa de configuración o polarización del optoacoplador para poder transmitir a la perfección un PWM.

Gracias
25/07/2015 #2

Avatar de chclau

Lo que se me ocurre es tomar la salida por colector. Emisor del opto a tierra sin resistencia de carga, resistencia de pull-up en colector y tomar la salida del colector.
25/07/2015 #3


Si también lo he probado y nada, el señal PWM está también imperfecto.
25/07/2015 #4

Avatar de chclau

Cual es el periodo de tu PWM? Yo hice pruebas teoricas (simulaciones con LTSpice) con 1kHz, con un 4n25 con resistencia de LED de 270 Ohm, tension de excitacion de 5V en el PWM , resistencia de base de 200K con capacitor en paralelo de 47pF, y resistencia de colector de 2K y los resultados son buenos.
25/07/2015 #5


La frecuencia del PWM es de 15KHz. En las simulaciones es normal que la señal este bien, a mi también me sale bien. Pero a la practica, comprobando con el osciloscopio la señal es mala. Solo con resistencia de muy bajo valor en la salida se consigue la señal perfecta. No sé si en este caso se tendría que usar algún otro modelo de optoacoplador.
25/07/2015 #6

Avatar de chclau

Es realmente necesaria una frecuencia tan alta?
25/07/2015 #7


Si, para no escuchar el ruido sonoro procedente del motor causado por la frecuencia
25/07/2015 #8

Avatar de juanma2468

Igual con 15Khz se puede llegar a escuchar el tipico chillido de la conmutación. Por otro lado ten en cuenta que al aumentar la frecuencia de conmutación sobre las bobinas del motor acarrea una sobre elevación de tensión mayor que a una frecuencia más baja, lo cual driver tendra que ser capaz de soportar esos picos de tensión.
26/07/2015 #9


He probado con esta frecuencia i no se escucha nada. Con frecuencias más bajas si que se escucha. El tema del driver ja lo tengo controlado el tema de la conmutación.
09/08/2015 #10


Lo que no entiendo es que si el 4N35 tiene un CTR de 100% cuando If=10mA, ¿porque tengo Ic=32mA?¿No tendría que ser la relación 1:1 o es que la resistencia de base a masa de 2M2 lo provoca?
10/08/2015 #11

Avatar de chclau

y como resolviste los problemas que tenias?

La resistencia de base no mejora el CTR, al contrario, lo empeora porque "roba" parte de la corriente de base. Los numeros que decis son un poco raros, como estas midiendo?
10/08/2015 #12

Avatar de juanma2468

Yo armaria el circuito de la siguiente manera. Inclusive haste se podria evitar de colocar un CD4049 reemplazando la compuerta por un simple transistor BC548 para usarlo como inversor.
Imágenes Adjuntas
Tipo de Archivo: jpg opto.jpg (77,0 KB (Kilobytes), 63 visitas)
10/08/2015 #13


Si ya lo he probado de esta manera, pero el problema que tengo es que el PWM no se transmite exactamente como sale del pin Arduino como he expuesto antes. La única manera es con el circuito que he adjuntado en el primer mensaje, o sea, con una resistencia en el emisor de 220 ohmios. De esta manera consigo una señal PWM perfecta, al contrario que otros diseños como por ejemplo el tuyo (cosa que no entiendo porque en teoría tendría que ir bien también, pero a la practica no).

Pero mi duda esta en porque teniendo una If=10mA con un CTR de 100%, tengo una Ic=32mA. Esto lo he medido con un amperimetro en la practica. Claro que lo que provoca este alto consumo es sobretodo la resistencia de 220 ohmios del emisor que polariza el transistor. Pero no entiendo el dato del CTR.

Si alguien lo entiende por favor que me lo explique.
10/08/2015 #14

Avatar de juanma2468

Pues, segun la hoja de datos las curvas son para If vs Ic, y tu estas saliendo por la pata de emisor. Prueba de cambiar el arreglo de manera de obtener una salida por colector y no por emisor, y verifica nuevamente la corriente. Si persiste la diferencia, prueba de cambiarlo y probar con otro.
10/08/2015 #15


Pero la corriente de colector es la misma que la de emisor. También lo he probado polarizando a emisor común y lo mismo.
10/08/2015 #16

Avatar de juanma2468

Es raro lo que te ocurre, probaste de cambiarlo por otro?
10/08/2015 #17


¿Otro modelo de Optoacoplador?
10/08/2015 #18

Avatar de juanma2468

Otro modelo u otro del mismo tipo. Otro modelo puede ser el PC817 que no necesita R de base
10/08/2015 #19


Del mismo tipo si y lo mismo. Otro modelo diferente no. La R de base en teoría ayuda a la velocidad de conmutación.

Si en realidad este circuito me va perfecto para lo que quiero, es simplemente que no acabo de entender lo del CTR del datasheet, ya que no me coincide nada.

Otro dato que he medido con el tester es la caída de voltaje entre colector-emisor del transistor del opto, que de es 5V. Y la Ic=32mA cuando el PWM está al 100%.
10/08/2015 #20

Avatar de juanma2468

El CTR cuando se encuentra al 100% significa que la corriente del diodo debe ser igual a la del colector, por lo que si tienes If=10mA, deberias tener lo mismo a la salida
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.