Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

26/06/2008 #1


Rebajar picos de corriente
Buenas a todos,
Ando trabajando con un motor paso a paso bipolar, y tengo problemas con los picos de corriente.
Para controlar los picos que me daban los pulsos del motor, he chopeado el enable (pata de habilitación) del driver (L298) a 20Khz.
Pero ahora, tengo picos de corriente, cuando habilito el enable.
Para rebajar estos picos, estoy pensando en poner un bobinón que me deribe mejor esos picos. Ando alimentando con una fuente variable.
De que valor pondrías la bobina, y como?
Afectará mucho al motor esos picos que se me crean chopeando el enable, ya que es por un tiempo muy muy limitado, pero a mucha frecuencia se repite.

Un saludo y gracias.
26/06/2008 #2

Avatar de Ardogan

Y si ponés un buen capacitor electrolítico entre la pata de alimentación del puente H y tierra; y además un capacitor cerámico para que los picos no se propaguen?.
Por ahí ya lo hiciste, sería útil que pongas un esquema del circuito (la parte del L298) para no decirte de poner cosas que quizás ya tenés incorporadas al circuito.
Saludos
27/06/2008 #3


Captura de picos, y esquematico
Gracias Ardogan,

Pues tengo puesto un condensador de desacoplo de 100nF alimentando los 24V del integrado (L298).

Captura de la corriente (canal azul)



El canal azul del osciloscopio, corresponde a la corriente de una bobina.
El primer dibujo, respecto a la señal de chopeado de enable a 20kHz(amarillo).
Y el siguiente dibujo, la corriente de una bobina (azul), respecto a los pulsos del motor paso a paso(amaarillo), a 200Hz
Como se puede apreciar en el segundo dibujo, tenemos picos de corriente, y no se a que se deben, y como puedo evitarlos.

Si alguien me podría ayudar.

Tambiés os muestro el diseño del protipo que he montado.


27/06/2008 #4

Avatar de Ardogan

Yo no dejaría de meterle un buen electrolítico en la pata de alimentación de Vs del L298 (en la figura 8 de su hoja de datos usa uno de 470 uF).
Chopeando el enable hay instantes en que la corriente del motor vuelve a la fuente, por ahí eso te trae problemas. Te pasa lo mismo chopeando alguna de las entradas in?
30/06/2008 #5


Buenas de nuevo.
No me había fijado en ese detalle del condensador.
Acabo de meterle el condensador, como en la figura 8. La masa del L298 a el negativo del condensador de 470uF, y la pata mas a la alimentación de 24V.
He consegido que la corriente quizas oszile menos, pero como podéis apreciar en la captura de osciloscopio que os adjunto, continua el problema de los picos.
En el dibujo aparte de la corriente en azul, se puede ver la IN que le entra al L298, chopeado con una frecuencia de 250Hz, y no tengo ningun tipo de oscilación.
También os adjunto la captura, de la tensión de una de las bobinas, entre sus extremos, respecto al pulso de una de las entradas del L298. Chopeando a 15KHZ el enable.
Haber si alguien me puede excplicar a que se deben los picos de corriente en la captura1, canal azul. Un SAludo.




30/06/2008 #6


Prueba con unos choques de ferrita de 10 Micro henrios aprox. en los hilos del motor
30/06/2008 #7


Buenas
Buenas de nuevo
Pues suena interesante, pero ni idea de que producto es el que te refieres.
Sería ponerle una bobina, en serie a la que tengo, de 10 uH.
Por tanto habría que poner 2, una para cada bobina? Eso se conseguiría en farnell por ejemplo?
Los diodos que utilizo para descargar las bobinas habría que modificar algo?

Y si me podrías explicar que consegimos con la ferrita de 10micro henrios por favor.

He encontrado esto en farneell pero nose exactamente cual pedir.
http://es.farnell.com/jsp/search/bro...questid=391774

Un saludos y gracias
30/06/2008 #8


Veras la bobina como ya sabes se opone a toda variación brusca de la corriente que circula por ella, con lo cual te ayuda a limitar esos picos que tienes, lo de la ferrita es para hacerlas mas pequeñas ya que ese núcleo aumenta la inductancia de las mismas, con unos anillos toroidales y bobinando un mínimo vueltas tendrás una inductancia apropiada, el valor de 10 te lo he dado de referencia, pues habría que hacer el calculo exacto según la frecuencia a eliminar, pero en esto la experiencia me dice que cuanto mas alta la inductancia se consiguen mejores resultados, los diodos no tienes que variarlos, los choques es conveniente ponerlos en el propio motor, evitando así que los cables propaguen la interferencia, y no seria nada malo poner otro condensador pegado al motor de 100 nf cerámico, las perturbaciones que producen los motores son " terroríficas " para los circuitos TTL, hay que evitarlas en todos los modos, incluso el uso de cable apantallado para los motores es aconsejable.

Un saludo
30/06/2008 #9
Moderador general

Avatar de Fogonazo

De que valor de corriente hablamos ?

Podrias armar un filtro mas complejo con 2 chokes y 3 capacitores
30/06/2008 #10


Buenas
Pues estoy trabajando con L298 que aguanta 2A por canal.
Y el motor tiene una resistencia de bobina de 3,5ohms. Y consumirá alrededor de un amperio por canal.
Ando chopeando el enable, para reducir cosumos.
El probema que tengo, lo que habeis podido comprobar en las capturas de corriente. Que tengo picos de 5A.
Me podrias explicar un poco lo del diseño de un filtro para el motor paso a paso bipolar?
Haber si pido a farnell los componentes que me indiques, y para mañana ya lo puedo motar y te cuento.

GRACIAs a todos,
01/07/2008 #11


Buenas
Asunto solucionado, con el problema de los picos de corriente.
Simplemente no existían! era un problema de aliasing, al convertir las muestras de digital a analogico. Probe con un osciloscopio analogico, y no existian picos

Ahora voy a empezar a reducir consumos chopeando la señal de enable.
Pero se me ha planteado un problema.
Tengo ya diseñado la PCB, y los enable de cada canal, los puentee. Y ahora resulta que los necesito independientes, para actuar en la corriente de cada bobina, sin que afecte ala otra.

Os pongo unas capturas de las corriente. Esque son preciosisimas

[img=http://img140.imagevenue.com/loc861/th_05775_corrien_2chanels_122_861lo.jpg][img=http://img227.imagevenue.com/loc251/th_05776_corriente_122_251lo.jpg][img=http://img209.imagevenue.com/loc576/th_05777_corrienteVsenable_122_576lo.jpg][img=http://img171.imagevenue.com/loc873/th_05778_corrienteVspulso_122_873lo.jpg]

La primera. Son la corrientes de las 2 bobinas. Azul=CHANNEL1; Rosa=CHANNEL2
La segunda. LA corriente de una bobina, bajando los tiempos. Se ve como chopea el enable.
La tercera. LA corriente, respecto al chopeo del enable. Se siguen bajando los tiempos.
LA cuarta. LA forma de la corriente. Respecto al pulso que le entraá al motor por un polo.


Si alguien puede ayudarme en reducir consumos..,,,


Saludos y gracias
01/07/2008 #12

Avatar de Ardogan

Qué bueno!, voy a tener en cuenta lo de chequear la velocidad de muestreo del osciloscopio el día que me aparezcan cosas raras.
Ahora en realidad me surge una duda, estaba viendo las formas de onda y la verdad no sé por qué tienen ese tramo de crecimiento exponencial. A ver si me explico mejor, en las figuras 1,2 y 4 las ondas de corriente están formadas por un tramo en que la corriente tiende a un valor estable (una respuesta amortiguada), en el tramo que va desde el flanco del pulso de control, hasta aproximadamente la mitad (o un poco menos) del tiempo en bajo o en alto. Pero después la corriente empieza a crecer desde ese momento hasta el final del tiempo en bajo/alto.
La pregunta es, ¿a qué se debe ese crecimiento de la corriente?, ¿no sería una respuesta inestable? (no tiende a un valor estacionario sino que crece sin límite).
En la figura 3 no pasa eso.
Bidaiaria ¿usaste la misma carga mecánica para el motor en los 4 casos?, ¿se supone que la corriente tenga esa forma de onda?, de ser así ¿por qué?.
Saludos
01/07/2008 #13


Figuras
Buenas ardogan.
La figura 3, corresponde, a un tiempo pequeñisimo, en la que chopeo la pata del enable.
que es el canal amarillo que aparece. 20kHz
Y todas esas corrientes en poco tiempo de la figura 3, se ven reflajadas en la figura 2. Que sería todas esas onda de corriente, que van creciendo con el pulso de 200Hz de la figura 4.
Nose si me explico. Uno es respecto al enable que es de muy alta frecuencia. La amortiguada.
Y la que parece inestable, la de respecto al pulso. Que pasa a 0, al invertir la polaridad.

Me exxplico? sino lo intento de nuevo

Lo de respuesta inestable, cuando pasa al segundo pulso ni idea. Crees que no deberia responder asi?

Saludos
01/07/2008 #14

Avatar de Ardogan

Claro, entiendo lo que significa cada forma de onda.
Lo que no me cierra (por desconocimiento puede ser, ojo!) es que la forma de onda de corriente crezca de esa forma.
Lo que se aplica al motor son pulsos de tensión, estamos de acuerdo hasta ahí. Y la parte eléctrica del motor es básicamente una resistencia en serie con una inductancia. Acá por un momento dudé de si no había que incluir una fem como en el motor de corriente continua, pero creo que no porque sería parecido al bobinado estatórico de un motor de CC y no al rotórico (que si incluye una fem) (el rotor de un PAP es un manojo de imanes).

Entonces, aplico un pulso de tensión a un RL, la corriente responde con exponenciales a esa entrada de tensión, que tienden a un valor máximo o a uno mínimo, pero no crece sin límite.
Para ser más preciso, del tipo Imax (1 - e^-t/Tau) cuando la tensión sube de 0 a Vfuente y del tipo e^-t/Tau cuando viene el flanco de Vfuente a 0. Tau = L/R y Imax = Vfuente/R.

Entonces es eso, no tengo seguridad plena de que esté mal, pero sí me genera dudas ver un comportamiento de ese tipo. Es como si hubiera alguna realimentación positiva en vez de negativa.

En un momento pensé en que podía ser por la carga mecánica haciendo analogía con un motor de corriente contínua (a mayor carga mecánica, preciso más cupla, por lo tanto más corriente) pero ni estoy seguro de que eso se aplique a un PAP. Ahora que lo pienso están todas esas definiciones de cupla para motores PAP, y en la medida en que uno no pida más cupla de la que puede dar no debería haber problema.

Pero después de escribir lo de arriba, me puse a repasar un poco como son las formas de onda de corriente en PAP, y bueno, ahora creo que metí la pata. Estás haciendo microstepping con el chopeo del enable no?, y las formas de ondas de corriente para microstepping son fragmentos de sinusoides mezclado con corriente constante...
O sea, algo así (ver figuras) (las saqué de las notas de aplicación de motores pap del sitio de microchip).
Entonces lo que a mí me parecía una corriente que crece sin límite aparente es en realidad el fragmento de la sinusoide, ¿es eso?.

Que matete me hice (trad matete = quilombo = lío = enredo), quién me salva? (de mí mismo jajaja)
Imágenes Adjuntas
Tipo de Archivo: gif corriente_pap_bipolar_microstep_140.gif (10,7 KB (Kilobytes), 19 visitas)
Tipo de Archivo: gif corriente_pap_bipolar_microstep__otra_390.gif (10,1 KB (Kilobytes), 18 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.